Fedora Linux Support Community & Resources Center
  #1  
Old 15th April 2012, 08:40 PM
KevinDrums Offline
Registered User
 
Join Date: Apr 2010
Location: USA
Posts: 43
linuxfirefox
Exclamation F16 Updates Stopped Working

My system has been OK since I installed it about 10 days ago. I update the machine daily like this:

'sudo yum update'

That always worked, until today. Now I get the usual stuff, except at the end where it complains about GPG keys not being right in the repository. See below:

Code:
Loaded plugins: fastestmirror, langpacks, presto, refresh-packagekit
Loading mirror speeds from cached hostfile
 * fedora: linux.mirrors.es.net
 * rpmfusion-free: mirror.hiwaay.net
 * rpmfusion-free-updates: mirror.hiwaay.net
 * rpmfusion-nonfree: mirror.hiwaay.net
 * rpmfusion-nonfree-updates: mirror.hiwaay.net
 * updates: linux.mirrors.es.net
Resolving Dependencies
--> Running transaction check
---> Package AdobeReader_enu.i486 0:9.4.7-1 will be updated
---> Package AdobeReader_enu.i486 0:9.5.1-1 will be an update
---> Package coreutils.x86_64 0:8.12-6.fc16 will be updated
---> Package coreutils.x86_64 0:8.12-7.fc16 will be an update
---> Package coreutils-libs.x86_64 0:8.12-6.fc16 will be updated
---> Package coreutils-libs.x86_64 0:8.12-7.fc16 will be an update
---> Package cups.x86_64 1:1.5.2-6.fc16 will be updated
---> Package cups.x86_64 1:1.5.2-8.1.fc16 will be an update
---> Package cups-ipptool.x86_64 1:1.5.2-6.fc16 will be updated
---> Package cups-ipptool.x86_64 1:1.5.2-8.1.fc16 will be an update
---> Package cups-libs.i686 1:1.5.2-6.fc16 will be updated
---> Package cups-libs.x86_64 1:1.5.2-6.fc16 will be updated
---> Package cups-libs.i686 1:1.5.2-8.1.fc16 will be an update
---> Package cups-libs.x86_64 1:1.5.2-8.1.fc16 will be an update
---> Package dvb-apps.x86_64 0:1.1.2-0.1457.bec11f78be51.fc16 will be updated
---> Package dvb-apps.x86_64 0:1.1.2-0.1479.37781d27a444.fc16 will be an update
---> Package flash-plugin.x86_64 0:11.2.202.228-release will be updated
---> Package flash-plugin.x86_64 0:11.2.202.233-release will be an update
---> Package google-chrome-stable.x86_64 0:18.0.1025.151-130497 will be updated
---> Package google-chrome-stable.x86_64 0:18.0.1025.162-131933 will be an update
---> Package kernel.x86_64 0:3.3.1-5.fc16 will be installed
---> Package kernel-devel.x86_64 0:3.3.1-5.fc16 will be installed
---> Package kernel-headers.x86_64 0:3.3.1-3.fc16 will be updated
---> Package kernel-headers.x86_64 0:3.3.1-5.fc16 will be an update
---> Package libsmbclient.x86_64 1:3.6.3-78.fc16 will be updated
---> Package libsmbclient.x86_64 1:3.6.4-82.fc16 will be an update
---> Package llvm-libs.i686 0:2.9-9.fc16 will be updated
---> Package llvm-libs.x86_64 0:2.9-9.fc16 will be updated
---> Package llvm-libs.i686 0:2.9-10.fc16 will be an update
---> Package llvm-libs.x86_64 0:2.9-10.fc16 will be an update
---> Package mysql.x86_64 0:5.5.21-1.fc16 will be updated
---> Package mysql.x86_64 0:5.5.22-1.fc16 will be an update
---> Package mysql-embedded.x86_64 0:5.5.21-1.fc16 will be updated
---> Package mysql-embedded.x86_64 0:5.5.22-1.fc16 will be an update
---> Package mysql-libs.x86_64 0:5.5.21-1.fc16 will be updated
---> Package mysql-libs.x86_64 0:5.5.22-1.fc16 will be an update
---> Package mysql-server.x86_64 0:5.5.21-1.fc16 will be updated
---> Package mysql-server.x86_64 0:5.5.22-1.fc16 will be an update
---> Package perl-DateTime-TimeZone.noarch 0:1.44-1.fc16 will be updated
---> Package perl-DateTime-TimeZone.noarch 0:1.46-1.fc16 will be an update
---> Package raptor2.x86_64 0:2.0.4-2.fc16 will be updated
---> Package raptor2.x86_64 0:2.0.7-1.fc16 will be an update
---> Package samba.x86_64 1:3.6.3-78.fc16 will be updated
---> Package samba.x86_64 1:3.6.4-82.fc16 will be an update
---> Package samba-client.x86_64 1:3.6.3-78.fc16 will be updated
---> Package samba-client.x86_64 1:3.6.4-82.fc16 will be an update
---> Package samba-common.x86_64 1:3.6.3-78.fc16 will be updated
---> Package samba-common.x86_64 1:3.6.4-82.fc16 will be an update
---> Package samba-winbind-clients.x86_64 1:3.6.3-78.fc16 will be updated
--> Processing Dependency: libwbclient.so.0()(64bit) for package: 1:samba-common-3.6.4-82.fc16.x86_64
--> Processing Dependency: libwbclient.so.0()(64bit) for package: cifs-utils-5.3-2.fc16.x86_64
--> Processing Dependency: libwbclient.so.0()(64bit) for package: 1:samba-3.6.4-82.fc16.x86_64
--> Processing Dependency: libwbclient.so.0()(64bit) for package: 1:samba-client-3.6.4-82.fc16.x86_64
--> Processing Dependency: libwbclient.so.0()(64bit) for package: 1:libsmbclient-3.6.4-82.fc16.x86_64
--> Processing Dependency: libwbclient.so.0()(64bit) for package: 1:samba-winbind-clients-3.6.4-82.fc16.x86_64
---> Package samba-winbind-clients.x86_64 1:3.6.4-82.fc16 will be an update
---> Package tzdata.noarch 0:2012b-3.fc16 will be updated
---> Package tzdata.noarch 0:2012c-1.fc16 will be an update
---> Package tzdata-java.noarch 0:2012b-3.fc16 will be updated
---> Package tzdata-java.noarch 0:2012c-1.fc16 will be an update
---> Package ypbind.x86_64 3:1.33-11.fc16 will be updated
---> Package ypbind.x86_64 3:1.35-1.fc16 will be an update
--> Running transaction check
---> Package libwbclient.x86_64 1:3.6.4-82.fc16 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

==============================================================================================================================================
 Package                             Arch                Version                                        Repository                       Size
==============================================================================================================================================
Installing:
 kernel                              x86_64              3.3.1-5.fc16                                   updates                          26 M
 kernel-devel                        x86_64              3.3.1-5.fc16                                   updates                         7.4 M
Updating:
 AdobeReader_enu                     i486                9.5.1-1                                        adobe-linux-i386                 57 M
 coreutils                           x86_64              8.12-7.fc16                                    updates                         2.9 M
 coreutils-libs                      x86_64              8.12-7.fc16                                    updates                          49 k
 cups                                x86_64              1:1.5.2-8.1.fc16                               updates                         2.0 M
 cups-ipptool                        x86_64              1:1.5.2-8.1.fc16                               updates                         5.7 M
 cups-libs                           i686                1:1.5.2-8.1.fc16                               updates                         360 k
 cups-libs                           x86_64              1:1.5.2-8.1.fc16                               updates                         353 k
 dvb-apps                            x86_64              1.1.2-0.1479.37781d27a444.fc16                 updates                         345 k
[snip to appease forum 10000 character limit]
 ypbind                              x86_64              3:1.35-1.fc16                                  updates                          58 k
Installing for dependencies:
 libwbclient                         x86_64              1:3.6.4-82.fc16                                updates                          68 k

Transaction Summary
==============================================================================================================================================
Install   2 Packages (+1 Dependent package)
Upgrade  27 Packages

Total size: 198 M
Is this ok [y/N]: y
Downloading Packages:
warning: rpmts_HdrFromFdno: Header V3 RSA/SHA256 Signature, key ID a82ba4b7: NOKEY
Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-x86_64


The GPG keys listed for the "Fedora 16 - x86_64 - Updates" repository are already installed but they are not correct for this package.
Check that the correct key URLs are configured for this repository.


 Failing package is: 1:cups-libs-1.5.2-8.1.fc16.i686
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-x86_64
How can I get my system to update again?

Thanks....
Reply With Quote
  #2  
Old 15th April 2012, 09:05 PM
PabloTwo Offline
"Registered User" T-Shirt Winner
 
Join Date: Mar 2007
Location: Seville, FL
Posts: 5,854
linuxchrome
Re: F16 Updates Stopped Working

For the time being, you could exclude the problem package:
Code:
yum --exclude=cups* update


---------- Post added at 04:05 PM ---------- Previous post was at 04:01 PM ----------

Right after posting, I did a "yum check-update", followed by a "yum update". It included the cups packages. I had no problems at all with gpg signing.
Code:
Updated:
  coreutils.x86_64 0:8.12-7.fc16        coreutils-libs.x86_64 0:8.12-7.fc16     cups.x86_64 1:1.5.2-8.1.fc16     cups-libs.i686 1:1.5.2-8.1.fc16      
  cups-libs.x86_64 1:1.5.2-8.1.fc16     mysql-libs.x86_64 0:5.5.22-1.fc16       tzdata.noarch 0:2012c-1.fc16     tzdata-java.noarch 0:2012c-1.fc16    

Complete!

Last edited by PabloTwo; 15th April 2012 at 09:07 PM.
Reply With Quote
  #3  
Old 15th April 2012, 09:15 PM
KevinDrums Offline
Registered User
 
Join Date: Apr 2010
Location: USA
Posts: 43
linuxfirefox
Re: F16 Updates Stopped Working

Ok, I figured out what I did to break the GPG check in my yum updates.

I put my own GPG keys into /var/lib/rpm/pubkeys I did this because 'rpm --import mygpg.key' wasn't enough for RPM to find my GPG key. But, putting my key into /var/lib/rpm/pubkeys got 'rpm --checksig mySignedPackage-1-1.i686.rpm' to verify.

See this link: http://forums.fedoraforum.org/showpo...46&postcount=3

Ugh. I wish I could get 'rpm --checksig' with my own key and 'yum update' to work at the same time.

Any ideas?

Thanks....
Reply With Quote
Reply

Tags
f16, stopped, updates, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fingerprint reader mysteriously stopped working (hardware detected, but not working) THEcreationist Hardware & Laptops 0 16th November 2010 01:58 PM
Latest updates have stopped my dual boot working aboulien Using Fedora 1 26th July 2010 03:04 AM
Installing Updates stopped display driver? tlsimon Installation, Upgrades and Live Media 5 17th November 2008 10:30 PM
logwatch stopped to run after some updates Volhv Using Fedora 0 14th February 2006 02:02 AM
USB Hub stopped working hedgert Hardware & Laptops 0 30th November 2005 09:21 PM


Current GMT-time: 17:04 (Saturday, 19-04-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat