Fedora Linux Support Community & Resources Center
  #1  
Old 1st April 2012, 07:24 AM
madjtorr Offline
Registered User
 
Join Date: Apr 2012
Location: Canada
Posts: 17
macoschrome
yum problems

http://pastie.org/private/o0awvdiohjng0akz0dafa
Reply With Quote
  #2  
Old 1st April 2012, 07:34 AM
nonamedotc Offline
Community Manager
 
Join Date: Mar 2011
Location: USA
Posts: 3,757
linuxfirefox
Re: yum problems

Amongst other things, do you even have the CentOS-Base.repo file in /etc/yum.repos.d folder? In the code you have pasted, you have moved the file to *.bak.

It also seems like you might have modified the repo file somehow. Please post the contents.
Reply With Quote
  #3  
Old 1st April 2012, 08:00 AM
madjtorr Offline
Registered User
 
Join Date: Apr 2012
Location: Canada
Posts: 17
macoschrome
Re: yum problems

fixed it but now when i try to update it says

CentOS-Base.repo restored it back and deleted the CentOS-Base.repo.bak

now


[root@amir ~]# yum update
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* epel: ftp.osuosl.org
* epel-testing: mirror01.th.ifl.net
addons | 1.9 kB 00:00
addons/primary_db | 1.1 kB 00:00
base | 1.1 kB 00:00
Not using downloaded repomd.xml because it is older than what we have:
Current : Sun Mar 4 21:06:23 2012
Downloaded: Sun Mar 4 21:06:14 2012
extras | 2.1 kB 00:00
extras/primary_db | 166 kB 00:00
linuxtech/primary | 160 kB 00:00
http://pkgrepo.linuxtech.net/el6/rel...rimary.xml.gz: [Errno -3] Error performing checksum
Trying other mirror.
Error: failure: repodata/primary.xml.gz from linuxtech: [Errno 256] No more mirrors to try.
[root@amir ~]# yum update
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* epel: ftp.osuosl.org
* epel-testing: mirror01.th.ifl.net
linuxtech/primary | 160 kB 00:00
http://pkgrepo.linuxtech.net/el6/rel...rimary.xml.gz: [Errno -3] Error performing checksum
Trying other mirror.
Error: failure: repodata/primary.xml.gz from linuxtech: [Errno 256] No more mirrors to try.

---------- Post added at 06:46 AM ---------- Previous post was at 06:39 AM ----------

i also tried to do yum clean metadata and yum clean all

---------- Post added at 06:47 AM ---------- Previous post was at 06:46 AM ----------

keeps giving me


linuxtech/primary | 160 kB 00:00
http://pkgrepo.linuxtech.net/el6/rel...rimary.xml.gz: [Errno -3] Error performing checksum
Trying other mirror.
linuxtech/primary | 160 kB 00:00
http://pkgrepo.linuxtech.net/el6/rel...rimary.xml.gz: [Errno -3] Error performing checksum
Trying other mirror.
Error: failure: repodata/primary.xml.gz from linuxtech: [Errno 256] No more mirrors to try.

---------- Post added at 07:00 AM ---------- Previous post was at 06:47 AM ----------

o just removed yum with yum -y remove yum-fastestmirror

Last edited by madjtorr; 1st April 2012 at 07:41 AM.
Reply With Quote
  #4  
Old 1st April 2012, 08:07 AM
nonamedotc Offline
Community Manager
 
Join Date: Mar 2011
Location: USA
Posts: 3,757
linuxfirefox
Re: yum problems

Try updating with that linuxtech repo disabled unless you are trying to update some package specifically installed from that repository.
Reply With Quote
  #5  
Old 1st April 2012, 08:09 AM
madjtorr Offline
Registered User
 
Join Date: Apr 2012
Location: Canada
Posts: 17
macoschrome
Re: yum problems

same error

Last edited by madjtorr; 1st April 2012 at 09:31 AM.
Reply With Quote
  #6  
Old 1st April 2012, 02:33 PM
nonamedotc Offline
Community Manager
 
Join Date: Mar 2011
Location: USA
Posts: 3,757
linuxfirefox
Re: yum problems

Well, the only other suggestion I have is this

Code:
su -
[root password]
cd /var/lib/rpm
rm -f __db*
rpm --rebuilddb
Reply With Quote
  #7  
Old 1st April 2012, 05:10 PM
madjtorr Offline
Registered User
 
Join Date: Apr 2012
Location: Canada
Posts: 17
macoschrome
Re: yum problems

fixed, thanks, it was a file i created

Create the repository config file /etc/yum.repos.d/linuxtech.repo:
[linuxtech]
name=LinuxTECH
baseurl=http://pkgrepo.linuxtech.net/el6/release/
enabled=1
gpgcheck=1
gpgkey=http://pkgrepo.linuxtech.net/el6/release/RPM-GPG-KEY-LinuxTECH.NET
Install agrep rpm package:
# yum install agrep

because of that
Reply With Quote
  #8  
Old 1st April 2012, 08:07 PM
nonamedotc Offline
Community Manager
 
Join Date: Mar 2011
Location: USA
Posts: 3,757
linuxfirefox
Re: yum problems

You could perhaps mark this thread solved then. Cheers.
Reply With Quote
  #9  
Old 1st April 2012, 08:46 PM
marko Offline
Registered User
 
Join Date: Jun 2004
Location: Laurel, MD USA
Posts: 6,030
linuxfirefox
Re: yum problems

isn't it also a bad idea to have epel and epel-testing activated at the same time, I'd think there'd be version clashes
Reply With Quote
  #10  
Old 1st April 2012, 09:47 PM
madjtorr Offline
Registered User
 
Join Date: Apr 2012
Location: Canada
Posts: 17
macoschrome
Re: yum problems

sum1 close this, its solved
Reply With Quote
  #11  
Old 1st April 2012, 10:17 PM
nonamedotc Offline
Community Manager
 
Join Date: Mar 2011
Location: USA
Posts: 3,757
linuxfirefox
Re: yum problems

Click on the "Thread Tools" menu on the top of first post and select "Mark as SOLVED" option. Also, if you want, you can also unsubscribe from the thread from the user control panel.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Wifi Problems, BCM4312. Connection problems jackbrennan7757 Hardware & Laptops 4 18th January 2008 08:32 PM
ldap, boot problems, login problems slidgey Servers & Networking 4 16th August 2007 10:42 PM
Stupid nOOb with boot up problems, internet problems...the works. phearthepenguin Servers & Networking 30 23rd August 2006 05:33 PM
Firefox problems and problems with Laptop sound card. j_villa1983 Hardware & Laptops 3 22nd August 2006 05:54 AM
How to debug suspend problems? Buggy kernel option parsing? SATA problems? chrismon Using Fedora 0 11th August 2006 04:31 PM


Current GMT-time: 10:14 (Saturday, 30-08-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat