Fedora Linux Support Community & Resources Center
  #31  
Old 26th March 2012, 09:49 PM
Delayline Offline
Registered User
 
Join Date: Mar 2012
Location: Tehran
Posts: 3
linuxfirefox
Re: akmod-nvidia fails me on 3.3.0-4fc16.x86_64

Quote:
Originally Posted by leepaul View Post
Remove the lot and start again

Code:
su
yum erase *\nvidia\*
yum install akmod-nvidia xorg-x11-drv-nvidia-libs.i686
wait a minute or two then reboot.
Am I correct? I must install the xorg-x11-drv-nvidia-libs.i686 on x86_64 architecture?
Reply With Quote
  #32  
Old 26th March 2012, 10:01 PM
GillesC Offline
Registered User
 
Join Date: Mar 2012
Location: Paris, France
Posts: 2
linuxfirefox
Re: akmod-nvidia fails me on 3.3.0-4fc16.x86_64

Quote:
Originally Posted by Delayline View Post
Am I correct? I must install the xorg-x11-drv-nvidia-libs.i686 on x86_64 architecture?
It worked for me.
Reply With Quote
  #33  
Old 26th March 2012, 10:04 PM
bob Online
Administrator (yeah, back again)
 
Join Date: Jul 2004
Location: Colton, NY; Junction of Heaven & Earth (also Routes 56 & 68).
Age: 69
Posts: 22,141
linuxfirefox
Re: akmod-nvidia fails me on 3.3.0-4fc16.x86_64

Yes, it's even called for on the Guide: http://forums.fedoraforum.org/showthread.php?t=204752
__________________
Linux & Beer - That TOTALLY Computes!
Registered Linux User #362651


Don't use any of my solutions on working computers or near small children.
Reply With Quote
  #34  
Old 26th March 2012, 11:36 PM
leepaul
Guest
 
Posts: n/a
linuxfirefox
Re: akmod-nvidia fails me on 3.3.0-4fc16.x86_64

Quote:
Originally Posted by Delayline View Post
Am I correct? I must install the xorg-x11-drv-nvidia-libs.i686 on x86_64 architecture?
You only need the i686 libs if you intend to run 32 bit applications.
Reply With Quote
  #35  
Old 27th March 2012, 03:53 AM
Magickman Offline
Registered User
 
Join Date: Oct 2008
Posts: 326
linuxfirefox
Re: akmod-nvidia fails me on 3.3.0-4fc16.x86_64

Quote:
Originally Posted by esau999 View Post
Yes, you're right - I know I'm getting old when I say it's getting late...and, you're definitely right: it's getting late.
So....for the morning:
you did this, right:
Code:
su 
yum remove akmod-nvidia
And then did this:
Code:
su
yum erase xorg-x11-drv-nouveau
mv  /lib/modules/$(uname -r)/kernel/drivers/gpu/drm/nouveau/nouveau.ko        /lib/modules/$(uname -r)/kernel/drivers/gpu/drm/nouveau/nouveau.txt
mv /boot/initramfs-$(uname -r).img /boot/initramfs-$(uname -r)-nouveau.img
dracut /boot/initramfs-$(uname -r).img $(uname -r)
And then did this:
Code:
su -
sed -i '/root=/s|$| rdblacklist=nouveau nouveau.modeset=0|' /boot/grub/grub.conf
mv /boot/initramfs-$(uname -r).img /boot/initramfs-$(uname -r)-nouveau.img
dracut /boot/initramfs-$(uname -r).img $(uname -r)
And then followed leigh123linux's instructions to the letter for F16?

This is what I did, and it fixed me.
I tried that, un-inststalled akmod, then installed it again, and tried "akmod --force," and it said, "command not found." Still won't start, either.
Reply With Quote
  #36  
Old 7th June 2012, 10:18 AM
TrickyHarry Offline
Registered User
 
Join Date: Feb 2012
Location: South England
Posts: 39
linuxfirefox
Re: akmod-nvidia fails me on 3.3.0-4fc16.x86_64 - it is fixed in FC17

Dear Folks,

I had had this akmods service not start in Fedora 16 for all of its life. I have just tested the same sequence of tasks in Fedora 17 and the akmods service does not fail, the service works !!.

# rpm -qa |grep akmod
akmod-nvidia-295.53-1.fc17.1.x86_64
akmods-0.4.0.4.fc17.noarch

How can we use this fact in Fedora 16 ???
-- this now outside of my Linux knowledge

Thanks in advance.

Quote:
Originally Posted by StephenH View Post
Have you tried going to http://rpmfusion.org/ and downloading the kmod-nvidia directly? That's what I did to get my system going when it failed for me. Also, try uninstalling and reinstalling akmods. That may help.# rpm -qa | grep nvidia
xorg-x11-drv-nvidia-libs-290.10-1.fc16.x86_64
kmod-nvidia-3.3.0-4.fc16.x86_64-290.10-2.fc16.2.x86_64
kmod-nvidia-290.10-2.fc16.2.x86_64
nvidia-xconfig-1.0-11.fc16.x86_64
xorg-x11-drv-nvidia-libs-290.10-1.fc16.i686
akmod-nvidia-290.10-2.fc16.2.x86_64
xorg-x11-drv-nvidia-290.10-1.fc16.x86_64
nvidia-settings-1.0-13.fc16.x86_64
# rpm -qa |grep akmod
akmod-nvidia-290.10-2.fc16.2.x86_64
akmods-0.3.8-3.fc16.noarch

These are the latest under RPM Fusion (Fedora - nonfree) 16 (x86_64)updates listing:
2012-03-22: akmod-nvidia-290.10-2.fc16.2
2012-03-22: kmod-nvidia-290.10-2.fc16.2
2012-03-22: kmod-nvidia-3.3.0-4.fc16.x86_64-290.10-2.fc16.2


Edit: Congratulations Bob. Unfortunately, I can't help you with the catalytic converter. My sympathies.
Reply With Quote
Reply

Tags
4fc16x8664, akmodnvidia, fails

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia Driver (kmod-nvidia or akmod-nvidia) not working on GT555M soumen Hardware & Laptops 3 29th January 2012 12:28 PM
Kernel 2.6.41.1-1.fc15.x86_64 akmod-nvidia.x86_64 No graphical display Doug Hutcheson Using Fedora 11 19th December 2011 01:46 AM
FC14: Nvidia Quadro FX 1700 troubles with akmod-nvidia Greken Hardware & Laptops 1 11th August 2011 02:24 PM
No support for nVidia Geforce4 (akmod-nvidia-96xx) on Fedora15 ? xenotrax Hardware & Laptops 7 6th June 2011 06:55 PM
kernel-2.6.32.2-15.fc13.x86_64 and akmod-nvidia-190.53-1.fc13.x86_64 chepioq Fedora 13 Development Branch 12 9th January 2010 04:45 PM


Current GMT-time: 02:12 (Monday, 22-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat