Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora 19/20 > Using Fedora
FedoraForum Search

Forgot Password? Join Us!

Using Fedora General support for current versions. Ask questions about Fedora that do not belong in any other forum.

Reply
 
Thread Tools Search this Thread Display Modes
  #16  
Old 25th March 2012, 06:59 AM
leepaul
Guest
 
Posts: n/a
linuxfirefox
Re: akmod-nvidia fails me on 3.3.0-4fc16.x86_64

Quote:
Originally Posted by bob View Post
And Greg, no. It's akmod-nvidia-290.10-2.fc16.2.x86_64

Edit: Just tried 'yum clean all' and then 'yum update' and still no newer version of akmod-nvidia available. Where's that one from? RPMFusion non-free shows just what I've got.

The output you posted seems to indicate that your using the old kernel (3.2.10-3.fc16.x86_64), try booting the newer 3.3.0 kernel.

also post
Code:
modinfo nvidia
Reply With Quote
  #17  
Old 25th March 2012, 10:54 AM
bob Online
Administrator (yeah, back again)
 
Join Date: Jul 2004
Location: Colton, NY; Junction of Heaven & Earth (also Routes 56 & 68).
Age: 69
Posts: 22,172
linuxfirefox
Re: akmod-nvidia fails me on 3.3.0-4fc16.x86_64

Leepaul, yes I'm currently using the older kernel because the new one won't boot to a gui, so that's the issue (akmod-nvidia failed). Therefore 'modinfo nvidia' will only show the current, working kernel.

Easu999, I'm awake (4 hours later, which is a sign of getting even OLDER ) so let's give your last post a fresh attempt. If I'm next posting from Mint, you'll know that wasn't it. Here we go....

---------- Post added at 05:54 AM ---------- Previous post was at 05:41 AM ----------

Well, the GOOD news is that I'm still in Fedora. The bad news is that it didn't work. Reinstalled akmod-nvidia and at least got back into the previous kernel with working graphics.
__________________
Linux & Beer - That TOTALLY Computes!
Registered Linux User #362651


Don't use any of my solutions on working computers or near small children.

Last edited by bob; 25th March 2012 at 10:46 AM.
Reply With Quote
  #18  
Old 25th March 2012, 10:59 AM
tox
Guest
 
Posts: n/a
windows_7firefox
Re: akmod-nvidia fails me on 3.3.0-4fc16.x86_64

give up on Fedora i'd remove the 3.3.0 kernel untill akmod-nvidia 295.33 is released as an update in RPMFusion bob
Reply With Quote
  #19  
Old 25th March 2012, 11:02 AM
Pitfall Offline
Registered User
 
Join Date: Nov 2011
Location: the Netherlands
Posts: 67
linuxfirefox
Re: akmod-nvidia fails me on 3.3.0-4fc16.x86_64

After an akmod-nvidia update I was able to build the kmod for 3.3.0-4.

If you need info I would be happy to give them to you.
__________________
Desktop: i3 540, GT430, Fedora 17 x86_64 KDE
Netbook: E-450, HD 6230, Fedora 17 x86_64 KDE
Reply With Quote
  #20  
Old 25th March 2012, 11:31 AM
bob Online
Administrator (yeah, back again)
 
Join Date: Jul 2004
Location: Colton, NY; Junction of Heaven & Earth (also Routes 56 & 68).
Age: 69
Posts: 22,172
linuxfirefox
Re: akmod-nvidia fails me on 3.3.0-4fc16.x86_64

Actually the 3.2.10-3 kernel is working just fine for now and this exercise is more about curiosity and frustration rather than need. The akmod-nvidia 295.33 may be a solution of course.

Gave it one more Good Ol' College Try at the 3.3.0-4 kernel and ended up in CLI once again. Confirmed the weird status with:

modprobe nvidia
FATAL: Module nvidia not found

rpm -qa | grep nvidia
nvidia-settings-1.0-13.fc16.x86_64
kmod-nvidia-3.2.10-3.fc16.x86_64_290.10-2.fc16.2.x86_64
kmod-nvidia-3.2.9-2.fc16.x86_64_290.10-1.fc16.18.x86_64
akmod-nvidia-290.10-2.fc16.2.x86_64
nvidia-xconfig-1.0-11.fc16.x86_64
kmod-nvidia-290.10-2.fc16.2.x86_64
xorg-x11-drv-nvidia-290.10-1-fc16.x86_64
xorg-x11-drv-nvidia-libs-290.10-1.fc.i686
kmod-nvidia-3.3.0-4.fc16.x86_64-290.10-2.fc16.2.x86_64
xorg-x11-drv-nvidia-libs-290.10-1.fc16.x86_64

(Hey there computer: it's THERE! See it? No? Ah well.....)

And, Pitfall, are you talking the mystery 295.33 akmod-nvidia? Where's everyone getting that??? Hmmm...looks like f17's got it.
__________________
Linux & Beer - That TOTALLY Computes!
Registered Linux User #362651


Don't use any of my solutions on working computers or near small children.

Last edited by bob; 25th March 2012 at 11:38 AM.
Reply With Quote
  #21  
Old 25th March 2012, 11:40 AM
Pitfall Offline
Registered User
 
Join Date: Nov 2011
Location: the Netherlands
Posts: 67
linuxfirefox
Re: akmod-nvidia fails me on 3.3.0-4fc16.x86_64

Code:
[bas@fedoraPC ~]$ rpm -qa | grep nvidia
kmod-nvidia-3.2.9-2.fc16.x86_64-290.10-1.fc16.18.x86_64
akmod-nvidia-290.10-2.fc16.2.x86_64
xorg-x11-drv-nvidia-290.10-1.fc16.x86_64
nvidia-xconfig-1.0-11.fc16.x86_64
kmod-nvidia-3.3.0-4.fc16.x86_64-290.10-2.fc16.2.x86_64
kmod-nvidia-3.2.10-3.fc16.x86_64-290.10-1.fc16.20.x86_64
nvidia-settings-1.0-13.fc16.x86_64
xorg-x11-drv-nvidia-libs-290.10-1.fc16.x86_64
Code:
[bas@fedoraPC ~]$ uname -a
Linux fedoraPC 3.3.0-4.fc16.x86_64 #1 SMP Tue Mar 20 18:05:40 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
Code:
[bas@fedoraPC ~]$ lsmod | grep nvidia
nvidia              12124066  30 
i2c_core               37991  2 nvidia,i2c_i801
Nope, I am just running the 290.10. It has been working since yesterday (that is when the update came out). I guess I am a lucky guy...
__________________
Desktop: i3 540, GT430, Fedora 17 x86_64 KDE
Netbook: E-450, HD 6230, Fedora 17 x86_64 KDE
Reply With Quote
  #22  
Old 25th March 2012, 11:57 AM
bob Online
Administrator (yeah, back again)
 
Join Date: Jul 2004
Location: Colton, NY; Junction of Heaven & Earth (also Routes 56 & 68).
Age: 69
Posts: 22,172
linuxfirefox
Re: akmod-nvidia fails me on 3.3.0-4fc16.x86_64

Looks like there's a whole bunch of lucky guys...and then there's me.

Of course, yesterday was also the day I had to order a catalytic converter for my wife's car to fix a problem that I caused two years ago by running 1 gallon of bad ethanol in a 20 gal. tank for a total of 5 miles. Cost on that one's topping $2000 total (includes full carb rebuild, car rentals, 0-2 sensors, converter and a full tank of gas being dumped).
__________________
Linux & Beer - That TOTALLY Computes!
Registered Linux User #362651


Don't use any of my solutions on working computers or near small children.
Reply With Quote
  #23  
Old 25th March 2012, 12:04 PM
leepaul
Guest
 
Posts: n/a
linuxfirefox
Re: akmod-nvidia fails me on 3.3.0-4fc16.x86_64

Remove the lot and start again

Code:
su
yum erase *\nvidia\*
yum install akmod-nvidia xorg-x11-drv-nvidia-libs.i686
wait a minute or two then reboot.
Reply With Quote
  #24  
Old 25th March 2012, 12:10 PM
bob Online
Administrator (yeah, back again)
 
Join Date: Jul 2004
Location: Colton, NY; Junction of Heaven & Earth (also Routes 56 & 68).
Age: 69
Posts: 22,172
linuxfirefox
Re: akmod-nvidia fails me on 3.3.0-4fc16.x86_64

Sure, why not. Mint's still working (at least I THINK it is). Let's go for it.
Attached Files
File Type: txt reinstallkmod.txt (8.3 KB, 125 views)
__________________
Linux & Beer - That TOTALLY Computes!
Registered Linux User #362651


Don't use any of my solutions on working computers or near small children.

Last edited by bob; 25th March 2012 at 12:13 PM.
Reply With Quote
  #25  
Old 25th March 2012, 12:20 PM
bob Online
Administrator (yeah, back again)
 
Join Date: Jul 2004
Location: Colton, NY; Junction of Heaven & Earth (also Routes 56 & 68).
Age: 69
Posts: 22,172
linuxfirefox
Re: akmod-nvidia fails me on 3.3.0-4fc16.x86_64

....and no joy, once again. Thanks for the try though, Leepaul, it was worth a shot I suppose and no harm done since the old kernel's kmod built just fine again.
__________________
Linux & Beer - That TOTALLY Computes!
Registered Linux User #362651


Don't use any of my solutions on working computers or near small children.
Reply With Quote
  #26  
Old 25th March 2012, 12:24 PM
leepaul
Guest
 
Posts: n/a
linuxfirefox
Re: akmod-nvidia fails me on 3.3.0-4fc16.x86_64

Now run

Code:
su
akmods --kernels 3.3.0-4.fc16.x86_64
Reply With Quote
  #27  
Old 25th March 2012, 12:27 PM
bob Online
Administrator (yeah, back again)
 
Join Date: Jul 2004
Location: Colton, NY; Junction of Heaven & Earth (also Routes 56 & 68).
Age: 69
Posts: 22,172
linuxfirefox
Re: akmod-nvidia fails me on 3.3.0-4fc16.x86_64

Quote:
[root@localhost bob]# akmods --kernels 3.3.0-4.fc16.x86_64
Checking kmods exist for 3.3.0-4.fc16.x86_64 [ OK ]
Yup, it's there! .. sitting there, doing nothing.


Waitaminnit!!!!!! Rebooted once more and.... TA DA!
Quote:
[bob@localhost ~]$ uname -a
Linux localhost.localdomain 3.3.0-4.fc16.x86_64 #1 SMP Tue Mar 20 18:05:40 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
Thanks to all. The cleansing worked! I'm back current on kernels with a functional kmod. (now, anyone know a cure for catalytic converter problems? )
__________________
Linux & Beer - That TOTALLY Computes!
Registered Linux User #362651


Don't use any of my solutions on working computers or near small children.

Last edited by bob; 25th March 2012 at 12:33 PM.
Reply With Quote
  #28  
Old 25th March 2012, 12:53 PM
StephenH Offline
Registered User
 
Join Date: Jul 2004
Location: Wake Forest, NC
Age: 60
Posts: 1,385
linuxfirefox
Re: akmod-nvidia fails me on 3.3.0-4fc16.x86_64

Have you tried going to http://rpmfusion.org/ and downloading the kmod-nvidia directly? That's what I did to get my system going when it failed for me. Also, try uninstalling and reinstalling akmods. That may help.# rpm -qa | grep nvidia
xorg-x11-drv-nvidia-libs-290.10-1.fc16.x86_64
kmod-nvidia-3.3.0-4.fc16.x86_64-290.10-2.fc16.2.x86_64
kmod-nvidia-290.10-2.fc16.2.x86_64
nvidia-xconfig-1.0-11.fc16.x86_64
xorg-x11-drv-nvidia-libs-290.10-1.fc16.i686
akmod-nvidia-290.10-2.fc16.2.x86_64
xorg-x11-drv-nvidia-290.10-1.fc16.x86_64
nvidia-settings-1.0-13.fc16.x86_64
# rpm -qa |grep akmod
akmod-nvidia-290.10-2.fc16.2.x86_64
akmods-0.3.8-3.fc16.noarch

These are the latest under RPM Fusion (Fedora - nonfree) 16 (x86_64)updates listing:
2012-03-22: akmod-nvidia-290.10-2.fc16.2
2012-03-22: kmod-nvidia-290.10-2.fc16.2
2012-03-22: kmod-nvidia-3.3.0-4.fc16.x86_64-290.10-2.fc16.2


Edit: Congratulations Bob. Unfortunately, I can't help you with the catalytic converter. My sympathies.
__________________
StephenH

"We must understand the reality that just because our culture claims certain things are true it does not mean they are!" --M. Liederbach

http://pilgrim-wanderings.blogspot.com

Last edited by StephenH; 25th March 2012 at 01:06 PM. Reason: Saw update from Bob
Reply With Quote
  #29  
Old 25th March 2012, 12:58 PM
bob Online
Administrator (yeah, back again)
 
Join Date: Jul 2004
Location: Colton, NY; Junction of Heaven & Earth (also Routes 56 & 68).
Age: 69
Posts: 22,172
linuxfirefox
Re: akmod-nvidia fails me on 3.3.0-4fc16.x86_64

StephenH, I'm fixed (at least for now), however thanks for posting that. I'm sure it's something that could help others.
__________________
Linux & Beer - That TOTALLY Computes!
Registered Linux User #362651


Don't use any of my solutions on working computers or near small children.
Reply With Quote
  #30  
Old 25th March 2012, 10:15 PM
GillesC Offline
Registered User
 
Join Date: Mar 2012
Location: Paris, France
Posts: 2
linuxfirefox
Re: akmod-nvidia fails me on 3.3.0-4fc16.x86_64

I am new to Fedora (installed less than a week ago...), and therefore have encountered a few difficulties ^^

Thank you very much Leepaul for having solved this one!
Reply With Quote
Reply

Tags
4fc16x8664, akmodnvidia, fails

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia Driver (kmod-nvidia or akmod-nvidia) not working on GT555M soumen Hardware & Laptops 3 29th January 2012 12:28 PM
Kernel 2.6.41.1-1.fc15.x86_64 akmod-nvidia.x86_64 No graphical display Doug Hutcheson Using Fedora 11 19th December 2011 01:46 AM
FC14: Nvidia Quadro FX 1700 troubles with akmod-nvidia Greken Hardware & Laptops 1 11th August 2011 02:24 PM
No support for nVidia Geforce4 (akmod-nvidia-96xx) on Fedora15 ? xenotrax Hardware & Laptops 7 6th June 2011 06:55 PM
kernel-2.6.32.2-15.fc13.x86_64 and akmod-nvidia-190.53-1.fc13.x86_64 chepioq Fedora 13 Development Branch 12 9th January 2010 04:45 PM


Current GMT-time: 17:11 (Thursday, 23-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Fasa - Lucknow Instagram Photos - Bogotol Travel Photos on Instagram