Fedora Linux Support Community & Resources Center
  #1  
Old 25th February 2012, 08:33 AM
newladkg Offline
Registered User
 
Join Date: Nov 2011
Posts: 11
linuxchrome
Exclamation Unable to update some softwares

I am unable to upgrade some softwares,while other upgrades are successful.
I am currently under(My desktop Fedora 16 System) Kernel-3.2.7-1.fc16.x86_64

This is the problem:

[root@localhost kgtaban]# yum upgrade
Loaded plugins: aliases, auto-update-debuginfo, changelog, dellsysid, downloadonly, etckeeper,
: fastestmirror, filter-data, fs-snapshot, fusioninventory-agent, keys, langpacks,
: list-data, local, merge-conf, post-transaction-actions, presto, priorities,
: protectbase, ps, puppetverify, refresh-packagekit, refresh-updatesd, remove-with-
: leaves, rpm-warm-cache, security, show-leaves, tmprepo, tsflags, upgrade-helper,
: verify, versionlock
Loading mirror speeds from cached hostfile
* fedora: mirror.neu.edu.cn
* fedora-debuginfo: ftp.isu.edu.tw
* fedora-source: mirror.neu.edu.cn
* rpmfusion-free: mirror.cse.iitk.ac.in
* rpmfusion-free-debuginfo: lnx.apollo-hw.ro
* rpmfusion-free-source: lnx.apollo-hw.ro
* rpmfusion-free-updates: lnx.apollo-hw.ro
* rpmfusion-free-updates-debuginfo: lnx.apollo-hw.ro
* rpmfusion-free-updates-source: lnx.apollo-hw.ro
* rpmfusion-nonfree: lnx.apollo-hw.ro
* rpmfusion-nonfree-debuginfo: lnx.apollo-hw.ro
* rpmfusion-nonfree-source: lnx.apollo-hw.ro
* rpmfusion-nonfree-updates: lnx.apollo-hw.ro
* rpmfusion-nonfree-updates-debuginfo: lnx.apollo-hw.ro
* rpmfusion-nonfree-updates-source: lnx.apollo-hw.ro
* updates: www.ftp.ne.jp
* updates-debuginfo: www.ftp.ne.jp
* updates-source: www.ftp.ne.jp
_local | 2.9 kB 00:00 ...
Skipping filters plugin, no data
0 packages excluded due to repository protections
Setting up Upgrade Process
Resolving Dependencies
Skipping filters plugin, no data
--> Running transaction check
---> Package firefox.x86_64 0:9.0.1-1.fc16 will be updated
---> Package firefox.x86_64 0:10.0.1-1.fc16 will be an update
---> Package gstreamer-plugins-bad-free.x86_64 0:0.10.22-2.fc16.1 will be updated
---> Package gstreamer-plugins-bad-free.x86_64 0:0.10.22-2.fc16.2 will be an update
---> Package libvpx.i686 0:0.9.7.1-1.fc16 will be updated
---> Package libvpx.x86_64 0:0.9.7.1-1.fc16 will be updated
--> Processing Dependency: libvpx.so.0()(64bit) for package: libavcodec53-0.9-52.fc16.x86_64
---> Package libvpx.i686 0:1.0.0-1.fc16 will be an update
---> Package libvpx.x86_64 0:1.0.0-1.fc16 will be an update
---> Package xulrunner.x86_64 0:9.0.1-1.fc16 will be updated
---> Package xulrunner.x86_64 0:10.0.1-3.fc16 will be an update
--> Running transaction check
---> Package libvpx.i686 0:0.9.7.1-1.fc16 will be updated
---> Package libvpx.x86_64 0:0.9.7.1-1.fc16 will be updated
---> Package libvpx.i686 0:1.0.0-1.fc16 will be an update
---> Package libvpx.x86_64 0:1.0.0-1.fc16 will be an update
--> Processing Dependency: libvpx.so.1()(64bit) for package: gstreamer-plugins-bad-free-0.10.22-2.fc16.2.x86_64
--> Processing Dependency: libvpx.so.1()(64bit) for package: xulrunner-10.0.1-3.fc16.x86_64
--> Running transaction check
---> Package firefox.x86_64 0:9.0.1-1.fc16 will be updated

Packages skipped because of dependency problems:
firefox-10.0.1-1.fc16.x86_64 from updates
gstreamer-plugins-bad-free-0.10.22-2.fc16.2.x86_64 from updates
libvpx-1.0.0-1.fc16.i686 from updates
libvpx-1.0.0-1.fc16.x86_64 from updates
xulrunner-10.0.1-3.fc16.x86_64 from updates

[root@localhost kgtaban]#

Please,help me out of this situation.
Reply With Quote
  #2  
Old 25th February 2012, 09:42 AM
EvilRedHorse Offline
Registered User
 
Join Date: Feb 2012
Location: London, Ontario, Canada
Posts: 32
windows_7firefox
Re: Unable to update some softwares

I had this problem because of ffmpeg dependencies on libvpx
yum update --skip-broken # didn't help
yum update --enablerepo=* # didn't help
# remove ffmpeg
yum remove ffmpeg
# get past update
yum update
# reinstall ffmpeg from rpmfusion-free-rawhide repo
yum localinstall --nogpgcheck http://download1.rpmfusion.org/free/...ble.noarch.rpm
yum update rpmfusion-free-release
yum install ffmpeg --enablerepo=*

Hope That Helps

P.S. firefox/xulrunner doesn't update because html5 video tags support embedded (vp80/vorbis) and vp80 requires libvpx
Reply With Quote
  #3  
Old 25th February 2012, 09:49 AM
leigh123linux
Guest
 
Posts: n/a
linuxfirefox
Re: Unable to update some softwares

Delete libavcodec53-0.9-52.fc16.x86_64 (where did you get this from?) as it's stopping the update
Code:
su
yum erase libavcodec53-0.9-52.fc16.x86_64
yum update
Reply With Quote
  #4  
Old 25th February 2012, 02:36 PM
newladkg Offline
Registered User
 
Join Date: Nov 2011
Posts: 11
linuxchrome
Re: Unable to update some softwares

Quote:
Originally Posted by PabloTwo View Post
The atrpms and rpmfusion repos are incompatible with each other. You will have nothing but endless grief having both of them installed and enabled at the same time. The rpmfusion repos are designed to be specifically compatible with Fedora.

I would suggest that you uninstall every package you installed from atrpms and then disable the atrmps repo.Tthen re-install the packages from rpmfusion. You can then temporarily enable the atrms repo to grab any packages that aren't available either from Fedora or rpmfusion.

You can quickly identify which atrpms packages you have installed with this code:
Code:
rpm -qa --qf "%{name}-%{version}.%{arch}\t%{vendor}\n" | grep ATrpms
^^I am really Thankful to PabloTwo for his instruction.
This solved my issue.

If possible please help me with this,Friends:-

[root@localhost kgtaban]# yum install smplayer
Loaded plugins: aliases, auto-update-debuginfo, changelog, dellsysid, downloadonly, etckeeper,
: fastestmirror, filter-data, fs-snapshot, fusioninventory-agent, keys, langpacks,
: list-data, local, merge-conf, post-transaction-actions, presto, priorities,
: protectbase, ps, puppetverify, refresh-packagekit, refresh-updatesd, remove-with-
: leaves, rpm-warm-cache, security, show-leaves, tmprepo, tsflags, upgrade-helper,
: verify, versionlock
Loading mirror speeds from cached hostfile
* fedora: ftp.isu.edu.tw
* fedora-debuginfo: ftp.isu.edu.tw
* fedora-source: ftp.isu.edu.tw
* rpmfusion-free: mirror.cse.iitk.ac.in
* rpmfusion-free-debuginfo: lnx.apollo-hw.ro
* rpmfusion-free-source: lnx.apollo-hw.ro
* rpmfusion-free-updates: lnx.apollo-hw.ro
* rpmfusion-free-updates-debuginfo: lnx.apollo-hw.ro
* rpmfusion-free-updates-source: lnx.apollo-hw.ro
* rpmfusion-nonfree: lnx.apollo-hw.ro
* rpmfusion-nonfree-debuginfo: lnx.apollo-hw.ro
* rpmfusion-nonfree-source: lnx.apollo-hw.ro
* rpmfusion-nonfree-updates: lnx.apollo-hw.ro
* rpmfusion-nonfree-updates-debuginfo: lnx.apollo-hw.ro
* rpmfusion-nonfree-updates-source: lnx.apollo-hw.ro
* updates: ftp.cuhk.edu.hk
* updates-debuginfo: ftp.nluug.nl
* updates-source: ftp.cuhk.edu.hk
Skipping filters plugin, no data
0 packages excluded due to repository protections
Setting up Install Process
Resolving Dependencies
Skipping filters plugin, no data
--> Running transaction check
---> Package smplayer.x86_64 0:0.7.0-1.fc16 will be installed
--> Processing Dependency: mplayer for package: smplayer-0.7.0-1.fc16.x86_64
--> Running transaction check
---> Package mplayer.x86_64 0:1.0-0.128.20110816svn.fc16 will be installed
--> Processing Dependency: libswscale.so.2(LIBSWSCALE_2)(64bit) for package: mplayer-1.0-0.128.20110816svn.fc16.x86_64
--> Processing Dependency: libavutil.so.51(LIBAVUTIL_51)(64bit) for package: mplayer-1.0-0.128.20110816svn.fc16.x86_64
--> Processing Dependency: libavformat.so.53(LIBAVFORMAT_53)(64bit) for package: mplayer-1.0-0.128.20110816svn.fc16.x86_64
Package ffmpeg-libs is obsoleted by ffmpeg, but obsoleting package does not provide for requirements
--> Processing Dependency: libavcodec.so.53(LIBAVCODEC_53)(64bit) for package: mplayer-1.0-0.128.20110816svn.fc16.x86_64
Package ffmpeg-libs is obsoleted by ffmpeg, but obsoleting package does not provide for requirements
--> Processing Dependency: libpostproc.so.51(LIBPOSTPROC_51)(64bit) for package: mplayer-1.0-0.128.20110816svn.fc16.x86_64
--> Processing Dependency: libswscale.so.2()(64bit) for package: mplayer-1.0-0.128.20110816svn.fc16.x86_64
--> Processing Dependency: libavformat.so.53()(64bit) for package: mplayer-1.0-0.128.20110816svn.fc16.x86_64
Package ffmpeg-libs is obsoleted by ffmpeg, but obsoleting package does not provide for requirements
--> Processing Dependency: libmp3lame.so.0()(64bit) for package: mplayer-1.0-0.128.20110816svn.fc16.x86_64
Package lame-libs is obsoleted by lame, but obsoleting package does not provide for requirements
--> Processing Dependency: libavutil.so.51()(64bit) for package: mplayer-1.0-0.128.20110816svn.fc16.x86_64
--> Processing Dependency: libavcodec.so.53()(64bit) for package: mplayer-1.0-0.128.20110816svn.fc16.x86_64
Package ffmpeg-libs is obsoleted by ffmpeg, but obsoleting package does not provide for requirements
--> Processing Dependency: libpostproc.so.51()(64bit) for package: mplayer-1.0-0.128.20110816svn.fc16.x86_64
--> Running transaction check
---> Package libavutil51.x86_64 0:0.9-52.fc16 will be installed
---> Package libpostproc51.x86_64 0:0.9-52.fc16 will be installed
---> Package libswscale2.x86_64 0:0.9-52.fc16 will be installed
---> Package mplayer.x86_64 0:1.0-0.128.20110816svn.fc16 will be installed
--> Processing Dependency: libavformat.so.53(LIBAVFORMAT_53)(64bit) for package: mplayer-1.0-0.128.20110816svn.fc16.x86_64
Package ffmpeg-libs is obsoleted by ffmpeg, but obsoleting package does not provide for requirements
--> Processing Dependency: libavcodec.so.53(LIBAVCODEC_53)(64bit) for package: mplayer-1.0-0.128.20110816svn.fc16.x86_64
Package ffmpeg-libs is obsoleted by ffmpeg, but obsoleting package does not provide for requirements
--> Processing Dependency: libavformat.so.53()(64bit) for package: mplayer-1.0-0.128.20110816svn.fc16.x86_64
Package ffmpeg-libs is obsoleted by ffmpeg, but obsoleting package does not provide for requirements
--> Processing Dependency: libmp3lame.so.0()(64bit) for package: mplayer-1.0-0.128.20110816svn.fc16.x86_64
Package lame-libs is obsoleted by lame, but obsoleting package does not provide for requirements
--> Processing Dependency: libavcodec.so.53()(64bit) for package: mplayer-1.0-0.128.20110816svn.fc16.x86_64
Package ffmpeg-libs is obsoleted by ffmpeg, but obsoleting package does not provide for requirements

Packages skipped because of dependency problems:
libavutil51-0.9-52.fc16.x86_64 from _local
libpostproc51-0.9-52.fc16.x86_64 from _local
libswscale2-0.9-52.fc16.x86_64 from _local
mplayer-1.0-0.128.20110816svn.fc16.x86_64 from _local
smplayer-0.7.0-1.fc16.x86_64 from _local
[root@localhost kgtaban]#

Awaiting for help,Friends...
Reply With Quote
  #5  
Old 25th February 2012, 06:21 PM
EvilRedHorse Offline
Registered User
 
Join Date: Feb 2012
Location: London, Ontario, Canada
Posts: 32
windows_7firefox
Re: Unable to update some softwares

# Since you are now using the rpmfusion-free-rawhide repo for ffmpeg
# You should also do this for ffmpeg-libs
# they should both be at version 0.8.9-1.fc17
yum -y update ffmpeg-libs --enablerepo=*
# I have no problem running:
yum -y install swplayer
# you might need to enable rawhide then update ffmpeg ffmpeg-libs
yum -y install fedora-release-rawhide
# what do you get for:
yum repolist
Reply With Quote
  #6  
Old 25th February 2012, 06:32 PM
leigh123linux
Guest
 
Posts: n/a
linuxfirefox
Re: Unable to update some softwares

Quote:
Originally Posted by EvilRedHorse View Post
# Since you are now using the rpmfusion-free-rawhide repo for ffmpeg
# You should also do this for ffmpeg-libs
# they should both be at version 0.8.9-1.fc17
yum -y update ffmpeg-libs --enablerepo=*
# I have no problem running:
yum -y install swplayer
# you might need to enable rawhide then update ffmpeg ffmpeg-libs
yum -y install fedora-release-rawhide
# what do you get for:
yum repolist

Your post is complete rubbish!!, the only mention here of fc17 and rawhide are your worthless posts.
Reply With Quote
  #7  
Old 25th February 2012, 06:55 PM
EvilRedHorse Offline
Registered User
 
Join Date: Feb 2012
Location: London, Ontario, Canada
Posts: 32
windows_7firefox
Re: Unable to update some softwares

Are you serious you should read this thread properly

ffmpeg and ffmpeg-libs were updated so that a system update could be completed

The current ffmpeg and ffmpeg-libs is 0.8.9-1.f17 within the rpmfusion-free-rawhide repo
That is where the words f17 and rawhide are coming from, newladkg is running Fedora 16.

We are now onto a second issue: installing swplayer.

Do you have advice on why this is failing, have you tried to recreate this situation within Fedora 16 like I have, no, then why don't you go complain somewhere else.

FYI libavcodec53 is a shared object file part of the ffmpeg library it's not something you can just uninstall.

Lets see how newladkg turns out.

I can't believe you are an Administrator.
Reply With Quote
  #8  
Old 25th February 2012, 07:09 PM
leigh123linux
Guest
 
Posts: n/a
linuxfirefox
Re: Unable to update some softwares

Quote:
Originally Posted by EvilRedHorse View Post
Are you serious you should read this thread properly

ffmpeg and ffmpeg-libs were updated so that a system update could be completed

The current ffmpeg and ffmpeg-libs is 0.8.9-1.f17 within the rpmfusion-free-rawhide repo
That is where the words f17 and rawhide are coming from, newladkg is running Fedora 16.

We are now onto a second issue: installing swplayer.

Do you have advice on why this is failing, have you tried to recreate this situation within Fedora 16 like I have, no, then why don't you go complain somewhere else.

FYI libavcodec53 is a shared object file part of the ffmpeg library it's not something you can just uninstall.

Lets see how newladkg turns out.

I can't believe you are an Administrator
.

More worthless crap

Quote:
FYI libavcodec53 is a shared object file part of the ffmpeg library it's not something you can just uninstall.
http://packages.atrpms.net/dist/f16/ffmpeg/


If you value your membership here read the rules as any disrespect shown to the staff here will result in a ban.

Posting Rules

Quote:
Do you have advice on why this is failing, have you tried to recreate this situation within Fedora 16 like I have, no, then why don't you go complain somewhere else.
It's my turf so if you don't like it you can go elsewhere!


I also suggest you reread the post as you are confused.
The issue here is mixed repos ie rpmfusion clash with atrpms.
Reply With Quote
  #9  
Old 25th February 2012, 07:17 PM
leigh123linux
Guest
 
Posts: n/a
linuxfirefox
Re: Unable to update some softwares

Quote:
Originally Posted by newladkg View Post
^^I am really Thankful to PabloTwo for his instruction.
This solved my issue.

If possible please help me with this,Friends:-

[root@localhost kgtaban]# yum install smplayer
Loaded plugins: aliases, auto-update-debuginfo, changelog, dellsysid, downloadonly, etckeeper,
: fastestmirror, filter-data, fs-snapshot, fusioninventory-agent, keys, langpacks,
: list-data, local, merge-conf, post-transaction-actions, presto, priorities,
: protectbase, ps, puppetverify, refresh-packagekit, refresh-updatesd, remove-with-
: leaves, rpm-warm-cache, security, show-leaves, tmprepo, tsflags, upgrade-helper,
: verify, versionlock
Loading mirror speeds from cached hostfile
* fedora: ftp.isu.edu.tw
* fedora-debuginfo: ftp.isu.edu.tw
* fedora-source: ftp.isu.edu.tw
* rpmfusion-free: mirror.cse.iitk.ac.in
* rpmfusion-free-debuginfo: lnx.apollo-hw.ro
* rpmfusion-free-source: lnx.apollo-hw.ro
* rpmfusion-free-updates: lnx.apollo-hw.ro
* rpmfusion-free-updates-debuginfo: lnx.apollo-hw.ro
* rpmfusion-free-updates-source: lnx.apollo-hw.ro
* rpmfusion-nonfree: lnx.apollo-hw.ro
* rpmfusion-nonfree-debuginfo: lnx.apollo-hw.ro
* rpmfusion-nonfree-source: lnx.apollo-hw.ro
* rpmfusion-nonfree-updates: lnx.apollo-hw.ro
* rpmfusion-nonfree-updates-debuginfo: lnx.apollo-hw.ro
* rpmfusion-nonfree-updates-source: lnx.apollo-hw.ro
* updates: ftp.cuhk.edu.hk
* updates-debuginfo: ftp.nluug.nl
* updates-source: ftp.cuhk.edu.hk
Skipping filters plugin, no data
0 packages excluded due to repository protections
Setting up Install Process
Resolving Dependencies
Skipping filters plugin, no data
--> Running transaction check
---> Package smplayer.x86_64 0:0.7.0-1.fc16 will be installed
--> Processing Dependency: mplayer for package: smplayer-0.7.0-1.fc16.x86_64
--> Running transaction check
---> Package mplayer.x86_64 0:1.0-0.128.20110816svn.fc16 will be installed
--> Processing Dependency: libswscale.so.2(LIBSWSCALE_2)(64bit) for package: mplayer-1.0-0.128.20110816svn.fc16.x86_64
--> Processing Dependency: libavutil.so.51(LIBAVUTIL_51)(64bit) for package: mplayer-1.0-0.128.20110816svn.fc16.x86_64
--> Processing Dependency: libavformat.so.53(LIBAVFORMAT_53)(64bit) for package: mplayer-1.0-0.128.20110816svn.fc16.x86_64
Package ffmpeg-libs is obsoleted by ffmpeg, but obsoleting package does not provide for requirements
--> Processing Dependency: libavcodec.so.53(LIBAVCODEC_53)(64bit) for package: mplayer-1.0-0.128.20110816svn.fc16.x86_64
Package ffmpeg-libs is obsoleted by ffmpeg, but obsoleting package does not provide for requirements
--> Processing Dependency: libpostproc.so.51(LIBPOSTPROC_51)(64bit) for package: mplayer-1.0-0.128.20110816svn.fc16.x86_64
--> Processing Dependency: libswscale.so.2()(64bit) for package: mplayer-1.0-0.128.20110816svn.fc16.x86_64
--> Processing Dependency: libavformat.so.53()(64bit) for package: mplayer-1.0-0.128.20110816svn.fc16.x86_64
Package ffmpeg-libs is obsoleted by ffmpeg, but obsoleting package does not provide for requirements
--> Processing Dependency: libmp3lame.so.0()(64bit) for package: mplayer-1.0-0.128.20110816svn.fc16.x86_64
Package lame-libs is obsoleted by lame, but obsoleting package does not provide for requirements
--> Processing Dependency: libavutil.so.51()(64bit) for package: mplayer-1.0-0.128.20110816svn.fc16.x86_64
--> Processing Dependency: libavcodec.so.53()(64bit) for package: mplayer-1.0-0.128.20110816svn.fc16.x86_64
Package ffmpeg-libs is obsoleted by ffmpeg, but obsoleting package does not provide for requirements
--> Processing Dependency: libpostproc.so.51()(64bit) for package: mplayer-1.0-0.128.20110816svn.fc16.x86_64
--> Running transaction check
---> Package libavutil51.x86_64 0:0.9-52.fc16 will be installed
---> Package libpostproc51.x86_64 0:0.9-52.fc16 will be installed
---> Package libswscale2.x86_64 0:0.9-52.fc16 will be installed
---> Package mplayer.x86_64 0:1.0-0.128.20110816svn.fc16 will be installed
--> Processing Dependency: libavformat.so.53(LIBAVFORMAT_53)(64bit) for package: mplayer-1.0-0.128.20110816svn.fc16.x86_64
Package ffmpeg-libs is obsoleted by ffmpeg, but obsoleting package does not provide for requirements
--> Processing Dependency: libavcodec.so.53(LIBAVCODEC_53)(64bit) for package: mplayer-1.0-0.128.20110816svn.fc16.x86_64
Package ffmpeg-libs is obsoleted by ffmpeg, but obsoleting package does not provide for requirements
--> Processing Dependency: libavformat.so.53()(64bit) for package: mplayer-1.0-0.128.20110816svn.fc16.x86_64
Package ffmpeg-libs is obsoleted by ffmpeg, but obsoleting package does not provide for requirements
--> Processing Dependency: libmp3lame.so.0()(64bit) for package: mplayer-1.0-0.128.20110816svn.fc16.x86_64
Package lame-libs is obsoleted by lame, but obsoleting package does not provide for requirements
--> Processing Dependency: libavcodec.so.53()(64bit) for package: mplayer-1.0-0.128.20110816svn.fc16.x86_64
Package ffmpeg-libs is obsoleted by ffmpeg, but obsoleting package does not provide for requirements

Packages skipped because of dependency problems:
libavutil51-0.9-52.fc16.x86_64 from _local
libpostproc51-0.9-52.fc16.x86_64 from _local
libswscale2-0.9-52.fc16.x86_64 from _local
mplayer-1.0-0.128.20110816svn.fc16.x86_64 from _local
smplayer-0.7.0-1.fc16.x86_64 from _local
[root@localhost kgtaban]#

Awaiting for help,Friends...

It looks like you still have atrpms versions installed, post


Code:
rpm -qa --qf "%{name}-%{version}.%{arch}\t%{vendor}\n" | grep ATrpms
and


Code:
rpm -qa *\ffmpeg\*
Reply With Quote
  #10  
Old 26th February 2012, 07:50 AM
newladkg Offline
Registered User
 
Join Date: Nov 2011
Posts: 11
linuxfirefox
Re: Unable to update some softwares

Quote:
Originally Posted by leigh123linux View Post
It looks like you still have atrpms versions installed, post


Code:
rpm -qa --qf "%{name}-%{version}.%{arch}\t%{vendor}\n" | grep ATrpms
and


Code:
rpm -qa *\ffmpeg\*
^^According to instructions provided,I did this:-

[kgtaban@localhost ~]$ su
Password:
[root@localhost kgtaban]# rpm -qa --qf "%{name}-%{version}.%{arch}\t%{vendor}\n" | grep ATrpms
[root@localhost kgtaban]#
[root@localhost kgtaban]# rpm -qa *\ffmpeg\*
[root@localhost kgtaban]#
[root@localhost kgtaban]#

The screenshot at Konsole.

It seems no atrpms versions are present in my system.

I can't run any video players/tools onto my system.
Please,Help me out.
Reply With Quote
  #11  
Old 26th February 2012, 08:28 AM
leigh123linux
Guest
 
Posts: n/a
linuxfirefox
Re: Unable to update some softwares

Post the full output for


Code:
su
rm -f /etc/yum.repos.d/*atrpms*repo
ls /etc/yum.repos.d/
yum install ffmpeg-libs
Reply With Quote
  #12  
Old 26th February 2012, 09:58 AM
newladkg Offline
Registered User
 
Join Date: Nov 2011
Posts: 11
linuxchrome
Re: Unable to update some softwares

^^Well,here we are,Sir.

[kgtaban@localhost ~]$ su
Password:
[root@localhost kgtaban]# rm -f /etc/yum.repos.d/*atrpms*repo

[root@localhost kgtaban]# ls /etc/yum.repos.d/
adobe-linux-i386.repo rpmfusion-free.repo
fedora.repo rpmfusion-free-updates.repo
fedora-updates.repo rpmfusion-free-updates-testing.repo
fedora-updates-testing.repo rpmfusion-nonfree-rawhide.repo
google-chrome.repo rpmfusion-nonfree.repo
_local.repo rpmfusion-nonfree-updates.repo
rpmfusion-free-rawhide.repo rpmfusion-nonfree-updates-testing.repo

[root@localhost kgtaban]# yum install ffmpeg-libs
Loaded plugins: aliases, auto-update-debuginfo, changelog, dellsysid, downloadonly, etckeeper,
: fastestmirror, filter-data, fs-snapshot, fusioninventory-agent, keys, langpacks,
: list-data, local, merge-conf, post-transaction-actions, presto, priorities,
: protectbase, ps, puppetverify, refresh-packagekit, refresh-updatesd, remove-with-
: leaves, rpm-warm-cache, security, show-leaves, tmprepo, tsflags, upgrade-helper,
: verify, versionlock
Loading mirror speeds from cached hostfile
* fedora: mirrors.ispros.com.bd
* fedora-debuginfo: ftp.isu.edu.tw
* fedora-source: mirrors.ispros.com.bd
* rpmfusion-free: mirror.cse.iitk.ac.in
* rpmfusion-free-debuginfo: lnx.apollo-hw.ro
* rpmfusion-free-source: lnx.apollo-hw.ro
* rpmfusion-free-updates: mirror.cse.iitk.ac.in
* rpmfusion-free-updates-debuginfo: lnx.apollo-hw.ro
* rpmfusion-free-updates-source: lnx.apollo-hw.ro
* rpmfusion-nonfree: lnx.apollo-hw.ro
* rpmfusion-nonfree-debuginfo: lnx.apollo-hw.ro
* rpmfusion-nonfree-source: lnx.apollo-hw.ro
* rpmfusion-nonfree-updates: lnx.apollo-hw.ro
* rpmfusion-nonfree-updates-debuginfo: lnx.apollo-hw.ro
* rpmfusion-nonfree-updates-source: lnx.apollo-hw.ro
* updates: ftp.riken.jp
* updates-debuginfo: ftp.riken.jp
* updates-source: ftp.riken.jp
_local | 2.9 kB 00:00 ...
_local/primary_db | 2.8 MB 00:00 ...
Skipping filters plugin, no data
0 packages excluded due to repository protections
Setting up Install Process
Package ffmpeg-libs is obsoleted by ffmpeg, trying to install ffmpeg-0.9-52.fc16.x86_64 instead
Resolving Dependencies
Skipping filters plugin, no data
--> Running transaction check
---> Package ffmpeg.x86_64 0:0.9-52.fc16 will be installed
--> Processing Dependency: libavdevice53 = 0.9-52.fc16 for package: ffmpeg-0.9-52.fc16.x86_64
--> Processing Dependency: libavcodec53 = 0.9-52.fc16 for package: ffmpeg-0.9-52.fc16.x86_64
--> Processing Dependency: libpostproc51 = 0.9-52.fc16 for package: ffmpeg-0.9-52.fc16.x86_64
--> Processing Dependency: libswresample0 = 0.9-52.fc16 for package: ffmpeg-0.9-52.fc16.x86_64
--> Processing Dependency: libavformat53 = 0.9-52.fc16 for package: ffmpeg-0.9-52.fc16.x86_64
--> Processing Dependency: libavfilter2 = 0.9-52.fc16 for package: ffmpeg-0.9-52.fc16.x86_64
--> Processing Dependency: libavutil51 = 0.9-52.fc16 for package: ffmpeg-0.9-52.fc16.x86_64
--> Processing Dependency: libswscale2 = 0.9-52.fc16 for package: ffmpeg-0.9-52.fc16.x86_64
--> Processing Dependency: libpostproc.so.51(LIBPOSTPROC_51)(64bit) for package: ffmpeg-0.9-52.fc16.x86_64
--> Processing Dependency: libavutil.so.51(LIBAVUTIL_51)(64bit) for package: ffmpeg-0.9-52.fc16.x86_64
--> Processing Dependency: libswresample.so.0(LIBSWRESAMPLE_0)(64bit) for package: ffmpeg-0.9-52.fc16.x86_64
--> Processing Dependency: libavformat.so.53(LIBAVFORMAT_53)(64bit) for package: ffmpeg-0.9-52.fc16.x86_64
--> Processing Dependency: libswscale.so.2(LIBSWSCALE_2)(64bit) for package: ffmpeg-0.9-52.fc16.x86_64
--> Processing Dependency: libavdevice.so.53(LIBAVDEVICE_53)(64bit) for package: ffmpeg-0.9-52.fc16.x86_64
--> Processing Dependency: libavcodec.so.53(LIBAVCODEC_53)(64bit) for package: ffmpeg-0.9-52.fc16.x86_64
--> Processing Dependency: libavfilter.so.2(LIBAVFILTER_2)(64bit) for package: ffmpeg-0.9-52.fc16.x86_64
--> Processing Dependency: libpostproc.so.51()(64bit) for package: ffmpeg-0.9-52.fc16.x86_64
--> Processing Dependency: libavdevice.so.53()(64bit) for package: ffmpeg-0.9-52.fc16.x86_64
--> Processing Dependency: libavcodec.so.53()(64bit) for package: ffmpeg-0.9-52.fc16.x86_64
--> Processing Dependency: libswresample.so.0()(64bit) for package: ffmpeg-0.9-52.fc16.x86_64
--> Processing Dependency: libavutil.so.51()(64bit) for package: ffmpeg-0.9-52.fc16.x86_64
--> Processing Dependency: libavformat.so.53()(64bit) for package: ffmpeg-0.9-52.fc16.x86_64
--> Processing Dependency: libswscale.so.2()(64bit) for package: ffmpeg-0.9-52.fc16.x86_64
--> Processing Dependency: libavfilter.so.2()(64bit) for package: ffmpeg-0.9-52.fc16.x86_64
--> Running transaction check
---> Package libavcodec53.x86_64 0:0.9-52.fc16 will be installed
--> Processing Dependency: libx264.so.118()(64bit) for package: libavcodec53-0.9-52.fc16.x86_64
--> Processing Dependency: libmp3lame.so.0()(64bit) for package: libavcodec53-0.9-52.fc16.x86_64
--> Processing Dependency: libva.so.1()(64bit) for package: libavcodec53-0.9-52.fc16.x86_64
--> Processing Dependency: libopencore-amrnb.so.0()(64bit) for package: libavcodec53-0.9-52.fc16.x86_64
--> Processing Dependency: libvpx.so.0()(64bit) for package: libavcodec53-0.9-52.fc16.x86_64
--> Processing Dependency: libopencore-amrwb.so.0()(64bit) for package: libavcodec53-0.9-52.fc16.x86_64
--> Processing Dependency: libxavs.so.1()(64bit) for package: libavcodec53-0.9-52.fc16.x86_64
---> Package libavdevice53.x86_64 0:0.9-52.fc16 will be installed
---> Package libavfilter2.x86_64 0:0.9-52.fc16 will be installed
---> Package libavformat53.x86_64 0:0.9-52.fc16 will be installed
---> Package libavutil51.x86_64 0:0.9-52.fc16 will be installed
---> Package libpostproc51.x86_64 0:0.9-52.fc16 will be installed
---> Package libswresample0.x86_64 0:0.9-52.fc16 will be installed
---> Package libswscale2.x86_64 0:0.9-52.fc16 will be installed
--> Running transaction check
---> Package libavcodec53.x86_64 0:0.9-52.fc16 will be installed
--> Processing Dependency: libvpx.so.0()(64bit) for package: libavcodec53-0.9-52.fc16.x86_64
---> Package libmp3lame0.x86_64 0:3.99.3-23.fc16 will be installed
---> Package libopencore-amrnb0.x86_64 0:0.1.2-2.fc16 will be installed
---> Package libopencore-amrwb0.x86_64 0:0.1.2-2.fc16 will be installed
---> Package libva1.x86_64 0:1.0.15-7.fc16 will be installed
---> Package libx264_118.x86_64 0:0.118-17_20111111.2245.fc16 will be installed
---> Package libxavs1.x86_64 0:0.1.51-2.fc16 will be installed
_local/filelists_db | 5.0 MB 00:00 ...

Packages skipped because of dependency problems:
ffmpeg-0.9-52.fc16.x86_64 from _local
libavcodec53-0.9-52.fc16.x86_64 from _local
libavdevice53-0.9-52.fc16.x86_64 from _local
libavfilter2-0.9-52.fc16.x86_64 from _local
libavformat53-0.9-52.fc16.x86_64 from _local
libavutil51-0.9-52.fc16.x86_64 from _local
libmp3lame0-3.99.3-23.fc16.x86_64 from _local
libopencore-amrnb0-0.1.2-2.fc16.x86_64 from _local
libopencore-amrwb0-0.1.2-2.fc16.x86_64 from _local
libpostproc51-0.9-52.fc16.x86_64 from _local
libswresample0-0.9-52.fc16.x86_64 from _local
libswscale2-0.9-52.fc16.x86_64 from _local
libva1-1.0.15-7.fc16.x86_64 from _local
libx264_118-0.118-17_20111111.2245.fc16.x86_64 from _local
libxavs1-0.1.51-2.fc16.x86_64 from _local
[root@localhost kgtaban]#


Is that for the rawhide repos which are creating the problem?

Last edited by newladkg; 26th February 2012 at 10:03 AM.
Reply With Quote
  #13  
Old 26th February 2012, 10:20 AM
leigh123linux
Guest
 
Posts: n/a
linuxfirefox
Re: Unable to update some softwares

This repo is breaking the transaction

Quote:
_local.repo
You will need to delete it and all the packages installed from it.
Reply With Quote
  #14  
Old 26th February 2012, 04:45 PM
newladkg Offline
Registered User
 
Join Date: Nov 2011
Posts: 11
linuxchrome
Re: Unable to update some softwares

^^Thank you leigh123linux.
Hats Off to you Administrator.
My issues are solved,and I can play video files under 'vlc" and "smplayer" at ease.
Thank's again for resolving the issues...

[solved]
Reply With Quote
Reply

Tags
softwares, unable, update

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to Update / Power Loss During Update ivinod Using Fedora 11 3rd October 2010 04:38 PM
unable to update ivinod Installation, Upgrades and Live Media 2 8th August 2010 09:29 PM
necessary to update softwares? Kelly Using Fedora 3 1st October 2006 05:21 PM


Current GMT-time: 04:44 (Sunday, 21-12-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
...Los frailes - White Beach Station 3, Boracay Instagram Photos - Bundi Travel Photos - Rodovia Dos Bandeirantes Photos on Instagram - Puerto Deportivo La Marina De Torrevieja Instagram Photos