Fedora Linux Support Community & Resources Center
  #1  
Old 9th October 2011, 08:32 AM
JohnJasonJordan Offline
Registered User
 
Join Date: Mar 2007
Location: Portland USA left coast
Posts: 254
linuxfedorafirefox
SD cards always mount read-only

Fedora 14, x86_64 on Lenovo Thinkpad T61.

About six months ago I bought a Transcend 32 GB SD card for my (then) new Android phone. Foolishly I bought the mini size, not the micro size. Before returning it I tried it in my laptop, only to discover that it mounted read-only. I tried various things (now forgotten), but failed to get it to mount read-write. Since it was the wrong size for the phone I returned it to Amazon.

Then I bought a Transcend 32 GB micro SD card that came with an adapter. Again, I tried to mount it in the laptop, but it also mounted read-only. But when I put it in the phone I had no problems - Android happily mounted it read-write. I continue to use it in the phone.

The other day I found a deal on a Sandisk 32 GB micro SD card, so I bought it. Like the Transcend, it came with an adapter. My plan was to use it as additional storage on the laptop. However, like its predecessors, it mounts read-only.

To troubleshoot I started with Palimpsest. When I launched Palimpsest at first it did not see the SD card. But after I popped the card out and reinserted it Palimpsest automatically added it to the list of devices. And Nautilus automatically opened a file browser window (although still read-only).

Palimpsest reported the following potentially useful information:

DRIVE:
  • Model: SU32G
  • Firmware version: 12/2010
  • Capacity: 32 GB
  • Partitioning: Master boot record
  • Serial number: 0c38530e
  • Device: /dev/mmcblk0
  • Rotation rate: Solid state disk
  • Connection: SDIO
  • Smart status Not supported

In the DRIVE section Palimpsest offers buttons for Format Drive, and
for Benchmark.

VOLUMES:
  • Usage: Filesystem
  • Partition type W95 FAT32 (LBA) (0x0c)
  • Partition flags Bootable
  • Type: FAT (32 bit version)
  • Device: /dev/mmcblk0p1
  • Partition label: -
  • Capacity: 32 GB
  • Available: -
  • Mount point: Mounted at /media/2535-1DF9

In the VOLUME section Palimpsest offers buttons for Unmount Volume, Check Filesystem, Delete Partition, Format Volume, and Edit Partition.

The only button I tried was Edit Partition, which popped up a little window with Partition Label (grayed out), Type (drop-down, currently at "W95 FAT32 (LBA) (0x0c), and offering many other filesystem types), plus a check box for "Bootable," which is checked. I exited the window without changing anything.

I created a mount point at /media/SD, then I tried adding it to /etc/fstab. My first attempt in fstab was:

/dev/mmcblk0 /media/SD vfat noauto,users,rw 0 0

But that always generated error messages that /dev/mmcblk0 did not exist. So, armed with the information from Palimpsest I changed it to:

/dev/mmcblk0p1 /media/SD vfat noauto,users,rw 0 0

However, that generates error messages that /dev/mmcblk0p1 does not exist.

Some questions:

Do I need this thing to be bootable? I will use it just for additional storage. Would removing the Bootable flag do anything to resolve the problem? (Probably not.)

The partition type is W95 VFAT (LBA) (0x0c). What do "LBA" and "0x0c" mean? Is the "vfat" in my fstab line the correct way to tell fstab what filesystem it is? I might want to use the card to transfer files to other people's computers, so VFAT is probably the best choice, but there are other VFAT options in the Palimpsest drop-down. Should I reformat it to a different filesystem?

Any other suggestions are also welcome.
__________________
I like things that start with "lin*," so I use Linux and my major is linguistics.
Reply With Quote
  #2  
Old 9th October 2011, 11:30 AM
tgreaser Offline
Registered User
 
Join Date: Dec 2004
Posts: 6
linuxfirefox
Re: SD cards always mount read-only

The boot-able option can be disabled but i dont think it really matters.
This means that if this is the primary hard drive then this is the partition that the OS or boot-loader is expected to be found on.

what dose your dmesg and /var/log/messages show when you have the disk in and boot up the system with your fstab configured to use the sd card ?
Reply With Quote
  #3  
Old 9th October 2011, 01:33 PM
stevea Offline
Registered User
 
Join Date: Apr 2006
Location: Ohio, USA
Posts: 8,837
linuxfedorafirefox
Re: SD cards always mount read-only

I'm using ...
/dev/mmcblk0p1 /media/stuff ext4 noauto,user 0 0
but of course that's not vfat.


Are you sure the device is mounted 'ro' or is it one of those silly problems with VFAT's overly simplistic permissions.
What does
mount
report on the device ?
__________________
None are more hopelessly enslaved than those who falsely believe they are free.
Johann Wolfgang von Goethe
Reply With Quote
  #4  
Old 9th October 2011, 05:33 PM
JohnJasonJordan Offline
Registered User
 
Join Date: Mar 2007
Location: Portland USA left coast
Posts: 254
linuxfedorafirefox
Re: SD cards always mount read-only

Quote:
Originally Posted by stevea View Post
I'm using ...
/dev/mmcblk0p1 /media/stuff ext4 noauto,user 0 0
but of course that's not vfat.
Are you sure the device is mounted 'ro' or is it one of those silly problems with VFAT's overly simplistic permissions.
What does
mount
report on the device ?
I finally decided to restart the computer, leaving my line in fstab:

/dev/mmcblk0p1 /media/SD vfat noauto,users,rw 0 0

When the computer restarted Nautilus displayed "SD" as a partition, and clicking on it opened a window displaying the contents. But it's still read-only. Strangely, Fedora did use my line in fstab to mount it at /media/SD; but ignored the rest of the line. Here is what mount says:

[jjj@Devil8 ~]$ mount
<snipped>
/dev/mmcblk0p1 on /media/SD type vfat (ro,noexec,nosuid,nodev)

Then I decided to use Palimpsest to reformat it. Unfortunately, Palimpsest refused, with the error message: Error creating file system: helper exited with exit code 1: cannot open /dev/mmcblk0p1: Read-only file system. Palimpsest does not require root to open, so I launched Gparted and tried to format it there (Gparted does require root to open). Unfortunately, Gparted refused as well, with the same error - that the filesystem is read only.

Finally, I tried from the command line as root:

[root@Devil8 jjj]# mkfs.vfat /dev/mmcblk0p1
mkfs.vfat 3.0.9 (31 Jan 2010)
mkfs.vfat: unable to open /dev/mmcblk0p1

(And yes, it was unmounted when I tried to format it.)

The strange thing is that in my Android phone it automatically opens read-write. Hence, the problem is not in the SD card - and bear in mind that this is the third SD card that I have tried and Fedora 14 refused to mount any of them read-write. The problem must be in Fedora or in the Lenovo laptop. Unfortunately, I don't have any other computers with an SD card slot where I can try it.

Need more suggestions!
__________________
I like things that start with "lin*," so I use Linux and my major is linguistics.
Reply With Quote
  #5  
Old 10th October 2011, 08:48 AM
JohnJasonJordan Offline
Registered User
 
Join Date: Mar 2007
Location: Portland USA left coast
Posts: 254
linuxfedorafirefox
Re: SD cards always mount read-only

Since my last post I have tried parted and Gparted, and mkfs. Nothing will touch it. I have Windows 2000 installed in Virtualbox, and it sees the card, but also as read-only. Just now I booted to a Lucid live CD and had the same experience as with Fedora - it mounts fine, but always read-only, and nothing can touch it. That doesn't mean that the problem is not in Fedora; just that if it's a problem in Fedora then Ubuntu has the same problem.

The weird part is that it mounts read-write in Android. How come the little brother can do things that the big brother cannot?
__________________
I like things that start with "lin*," so I use Linux and my major is linguistics.
Reply With Quote
  #6  
Old 10th October 2011, 04:18 PM
Dutchy Offline
Registered User
 
Join Date: Aug 2011
Posts: 1,010
linuxfirefox
Re: SD cards always mount read-only

Google "linux fstab mount options".
I think the better approach would be to first manually mount it via the command line until you've got the right mount parameters.
Reply With Quote
  #7  
Old 24th February 2012, 04:17 PM
kh71 Offline
Registered User
 
Join Date: Nov 2005
Posts: 16
linuxfirefox
Re: SD cards always mount read-only

I have similar kind problem. Bought SD card to extend my laptop storage space. The grazy thing is that I'm able to mount is as r/w and everything works when I use command line or Dolphin file manager. If I access files with Nautilus it looks like it re-mounts something and I have read-only also on command line after that. I mount it in fstab with line:

/dev/mmcblk0p1 /home/myhome/Documents vfat rw,defaults,utf8=1,uid=500,gid=500 0 0

My user id is 500. I also have slightly older FED on this machine. If I leave utf8=1 out certain scandinavian characters show up as (?).
Reply With Quote
  #8  
Old 17th February 2013, 11:37 AM
kh71 Offline
Registered User
 
Join Date: Nov 2005
Posts: 16
linuxfirefox
Re: SD cards always mount read-only

The problem was that SD card has some corrupted files. I umounted the disk, checked it and after that it mounts rw back again. So:

umount /dev/mmcblk0p1
dosfsck -a -w -v /dev/mmcblk0p1
mount -a

And it mounts normally rw.
Reply With Quote
  #9  
Old 17th February 2013, 12:28 PM
george_toolan Offline
Registered User
 
Join Date: Dec 2006
Posts: 2,077
linuxfirefox
Re: SD cards always mount read-only

This is a feature and not a bug. When an error occurs the file system is re-mounted read-only to prevent further damage.

Check /var/log/messages for errors.
Reply With Quote
  #10  
Old 5th April 2013, 03:37 AM
buddhistpalm Offline
Registered User
 
Join Date: Dec 2010
Location: Texas
Posts: 19
linuxfirefox
Re: SD cards always mount read-only

I am having a similar issue with a 32gb micro SDHC card in Fedora 18 running MATE (with native file manager Caja). Every time I try to copy a file over, I get a "destination is read-only."

It does not happen in Thunar file manager; everything copies fine. I only downloaded a second file manager after a file transfer went through on another laptop running F17 LXDE.

I've tried
"umount /dev/mmcblk0p1
dosfsck -a -w -v /dev/mmcblk0p1
mount -a"

but I get the same results.

I tried totally reformatting through the command line, but get the same results again.

Anyone have a clue?
Reply With Quote
  #11  
Old 17th August 2013, 12:21 PM
grdryn Offline
Registered User
 
Join Date: Apr 2011
Location: Galway, Ireland
Posts: 3
linuxfirefox
Re: SD cards always mount read-only

I was having a similar problem today with a micro SDHC card in an SD card adapter. The solution to my problem was that there's a 'lock' switch on the left side of the adapter (I have 2 different ones, and the lock is the same on both). Basically that lock should be off rather than on.
Reply With Quote
Reply

Tags
mount, read only, sd card, vfat

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Atheros Chipset Based Cards + MadWifi Installation & Usage (T60 and Z60t MUST read) Tuxic Guides & Solutions (No Questions) 94 26th July 2008 05:49 PM
Atheros Chipset Based Cards and Madwifi helpful read Tuxic Servers & Networking 0 8th October 2006 06:38 PM


Current GMT-time: 08:07 (Sunday, 21-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat