Fedora Linux Support Community & Resources Center
  #1  
Old 23rd February 2012, 04:51 AM
skgiit Offline
Registered User
 
Join Date: Feb 2012
Location: India
Posts: 8
linuxfirefox
ATI radeon graphic card heats up

Hi..I am new to fedora. Recently I installed fedora 16 on my dell studio 1555 with the ATI radeon hd 4500 graphic card. As soon as fedora boots up, the GPU temperature reaches 74 degree celcius and the fan runs really fast....How can i solve this problem??...I there any way I could run the ATI GPU in powersave mode..

Pllzz some one help!!!
Reply With Quote
  #2  
Old 23rd February 2012, 04:44 PM
Fenrin Offline
Registered User
 
Join Date: Apr 2010
Location: Earth
Posts: 891
linuxopera
Re: ATI radeon graphic card heats up

you can try that:
Code:
su
echo dynpm > /sys/class/drm/card0/device/power_method
or:
Code:
su
echo profile > /sys/class/drm/card0/device/power_method
echo low > /sys/class/drm/card0/device/power_profile
(you can read about this here)

it could also help a little to update your kernel to a version >=3.2.5, because version 3.2.5 fixed a power regression bug.
Code:
yum update kernel
if this doesn't help much, you could try the AMD/ATI proprietary graphics driver. But this driver has some issues with the xorg-version of Fedora 16.
Reply With Quote
  #3  
Old 24th February 2012, 06:40 AM
skgiit Offline
Registered User
 
Join Date: Feb 2012
Location: India
Posts: 8
linuxfirefox
Re: ATI radeon graphic card heats up

Hi Fenrin,
Thank you so much, it works ...but as soon as i restart my laptop, it again starts to heat up, and i have to follow these steps again..Isn't there a permanent solution??
Reply With Quote
  #4  
Old 24th February 2012, 09:24 AM
Fenrin Offline
Registered User
 
Join Date: Apr 2010
Location: Earth
Posts: 891
linuxopera
Re: ATI radeon graphic card heats up

you're welcome
I thought you have to do this only one time. The proprietary AMD/ATI driver is a bit better with power saving.

you can install it via:
Code:
su
rpm -Uvh   http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm     http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm
and then either:
Code:
yum install kmod-catalyst xorg-x11-drv-catalyst xorg-x11-drv-catalyst-libs.i686
This works only with the 3.2.7-1 kernel (not PAE kernel).

or:
Code:
yum install akmod-catalyst xorg-x11-drv-catalyst  xorg-x11-drv-catalyst-libs.i686
this is supposed to built the driver kernel module for every kernel (except PAE), but in my experience this is more likely to fail than the kmod driver with 3.2.7-1 kernel.

if you use a PAE kernel:
Code:
yum install kmod-catalyst-PAE xorg-x11-drv-catalyst-libs.i686  xorg-x11-drv-catalyst
to check the kernel version, you can use "uname -r"

If applications use xv video output, the xorg-server will restart. That's a issue of this driver with the xorg version Fedora 16 uses. In mplayer, gnome-mplayer and vlc you can change the video output driver to OpenGL (gl). If you want to remove the driver, you can do it via "yum remove *catalyst*".
Reply With Quote
  #5  
Old 24th February 2012, 12:19 PM
skgiit Offline
Registered User
 
Join Date: Feb 2012
Location: India
Posts: 8
linuxchrome
Re: ATI radeon graphic card heats up

Hi fenrin,
I tried the first driver, but gnome crashed on restart and did not load....then I went back to recovery mode and unistalled it ...

I also tried the second driver, but gnome 3 could not load and it revert back to gnome 2....

Cant we write a script...and put the earlier codes which you gave, so that the codes will be run every time i would start fedora?

Thanks
Reply With Quote
  #6  
Old 25th February 2012, 02:35 AM
Fenrin Offline
Registered User
 
Join Date: Apr 2010
Location: Earth
Posts: 891
linuxopera
Re: ATI radeon graphic card heats up

yes there is surely a place where you can put the lines which works for you in, so that it is executed at startup automatically. Before systemd times (which was introduce in Fedora 15), there was the file rc.d or rc.conf (but the later I think not in Fedora distros). But now with systemd I have no idea where to put in these lines.

I also used the forum search a bit, but it's not so easy to find...

I'm also not a very experienced Linux user, probably someone else can help you better with this startup script.
Reply With Quote
  #7  
Old 25th February 2012, 03:12 AM
dd_wizard Offline
Registered User
 
Join Date: Sep 2009
Posts: 1,409
linuxfirefox
Re: ATI radeon graphic card heats up

This thread should help you. You need to create the file /etc/rc.d/rc.local as shown in comment 2. The path in comment 2 is incorrect, it needs to include rc.d as shown here. Then add the lines shown in comment 4 of that thread to it and the lines posted by fenrin here that worked for you. They'll be executed at each boot. I believe it needs to be owned by root, so you'll need to create it as root or with sudo. Also, it needs to be executable. Look at the permissions of the files in /etc/rc.d/init.d to see what they should be for /etc/rc.d/rc.local. Oh, and don't forget to enable the rc.local service as shown in comment 2 of the other thread.

dd_wizard

Last edited by dd_wizard; 25th February 2012 at 03:19 AM.
Reply With Quote
  #8  
Old 25th February 2012, 06:04 AM
skgiit Offline
Registered User
 
Join Date: Feb 2012
Location: India
Posts: 8
linuxchrome
Re: ATI radeon graphic card heats up

hey thanks
it worked ...than you soo much...
Reply With Quote
  #9  
Old 8th March 2012, 04:23 PM
skgiit Offline
Registered User
 
Join Date: Feb 2012
Location: India
Posts: 8
linuxchrome
Re: ATI radeon graphic card heats up

Hey,
Recently I updated my kernel to 3.2.9-1.fc16.i686...so I thought of installing the catalyst proprietary drivers..and this time it worked for my laptop with the new kernel. But it has again started to heat up, and when I try to use the command


>>echo profile > /sys/class/drm/card0/device/power_method
>>echo low > /sys/class/drm/card0/device/power_profile

it says, the file does not exist.

How can i run my ati gpu in powersaver mode after installing the ATI catlayst drivers?
Reply With Quote
  #10  
Old 8th March 2012, 06:00 PM
Fenrin Offline
Registered User
 
Join Date: Apr 2010
Location: Earth
Posts: 891
linuxopera
Re: ATI radeon graphic card heats up

power-saving of the Catalyst driver should work like intended after a successful installation.

This:
Code:
echo profile > /sys/class/drm/card0/device/power_method
echo low > /sys/class/drm/card0/device/power_profile
works only with the default Radeon driver, but not with Catalyst.

if you add pcie_aspm=force to the kernel boot line, it can maybe help a little bit with power consumption and heat.
If there are possibilities to underclock your card further, it's probably listed with the command "aticonfig --help".

To check if the CPU frequency scaling works correctly, you can install kernel-tools and then use this command:
Code:
cpupower -c all frequency-info
I'm not sure if the current kernel version is supported though. Here describes a F16 user that he has problems with kernel 3.2.9-2 and this driver, but kernel 3.2.9-1 is probably supported.

Last edited by Fenrin; 8th March 2012 at 08:57 PM.
Reply With Quote
  #11  
Old 27th March 2012, 03:20 PM
skgiit Offline
Registered User
 
Join Date: Feb 2012
Location: India
Posts: 8
linuxfirefox
Re: ATI radeon graphic card heats up

HI friends,
I am still facing the ATI radeon graphic card heat up problem.
Firstly, I would like to say that...I have used many linux distros...and this problem is occuring with each and every distro...may it be..ubuntu...suse...fedora...every one. But when I tried PClinuxOS the ATI proprietary driver were already installed and my GPU was very cool..(47 degrees Celcius)

So, what is the problemn, is it the problem with my laptop or something else.

Whenever a new kernel upgrade comes, I try installing the AMD proprietary drivers..hoping this time they would work better...they work nicely..but my lkaptop heats as hell (78 degrees celcius)...so I have to again uninstall them and used the default drivers provided my fedora and that too in the powersaver mode. Even the defualt drivers heat my GPU if not run in the powersave mode. I have even tried powersave mode with the proprietary drivers..but it seems that there powersave mode doesnot work at all. Even with powersave mode, the proprietary drivers heat up my GPU.

I am using dell studio 1555 laptop with 1 gb ATI radeon HD 4500 series graphic card. They work fine in windows and temperature is also very low. But there is some problem with thw linux distros.

I would be really happy, if someone could come out with a solution or enlighten me with the basic problem that is causing this...

Thanks
Reply With Quote
  #12  
Old 26th April 2012, 02:07 AM
roberco Offline
Registered User
 
Join Date: Feb 2011
Posts: 21
windows_7ie
Re: ATI radeon graphic card heats up

Gnome and KDE are loaded with features and thus they are power hogs. You may want to try LXDE Spin version which requires a lot less power and is suitable for laptops. Download the iso file, burn it and pop the CD in and see how hot the video card gets.
Reply With Quote
  #13  
Old 26th April 2012, 06:31 AM
skgiit Offline
Registered User
 
Join Date: Feb 2012
Location: India
Posts: 8
windows_7chrome
Re: ATI radeon graphic card heats up

Hi friends,
The problem got solved with the new kernel 3.3.2.1....
I think it was problem of the kernel. Now my laptop runs cooler as ever
Reply With Quote
  #14  
Old 31st May 2012, 04:05 PM
Sigsev Offline
Registered User
 
Join Date: Mar 2012
Location: Spain
Posts: 10
linuxfirefox
Re: ATI radeon graphic card heats up

Quote:
Originally Posted by skgiit View Post
Hi friends,
The problem got solved with the new kernel 3.3.2.1....
I think it was problem of the kernel. Now my laptop runs cooler as ever
Hi skgiit.. Is it running collerwith the propietary driver or with the free one? Did you tried it with both?
Thank you
Reply With Quote
  #15  
Old 31st May 2012, 04:12 PM
skgiit Offline
Registered User
 
Join Date: Feb 2012
Location: India
Posts: 8
windows_7chrome
Re: ATI radeon graphic card heats up

It worked well with both the default and also the proprietary driver and I haven't faced any issues since then, even with the newest fedora kernel..
Reply With Quote
Reply

Tags
ati, card, graphic, heats, radeon

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Best Graphic VGA Card Kursat.Unlukara Hardware & Laptops 3 12th April 2008 05:00 AM
Graphic card svenkatesan Hardware & Laptops 11 29th March 2006 09:35 AM
Compatibile with Fedora Core 4: PowerColor Radeon X800GT 256MB graphic card? x800gt Hardware & Laptops 0 8th September 2005 01:59 AM
Ill buy a new graphic card comrade Hardware & Laptops 5 25th August 2005 12:18 AM
OS wars heats up Berticus Linux Chat 13 27th June 2005 04:25 AM


Current GMT-time: 09:17 (Tuesday, 22-07-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat