Fedora Linux Support Community & Resources Center
  #1  
Old 26th November 2008, 07:16 AM
igla Offline
Registered User
 
Join Date: Aug 2007
Posts: 28
no fonts in xmms menus

After installing F10 there are no fonts in xmms menus
I'd be glad for a hint.
Reply With Quote
  #2  
Old 26th November 2008, 02:31 PM
igla Offline
Registered User
 
Join Date: Aug 2007
Posts: 28
Problem solved with
http://admdenis.narod.ru/files/gtk1_utf8_patch.tar.bz2
Reply With Quote
  #3  
Old 3rd December 2008, 03:45 PM
Camberwell Offline
Registered User
 
Join Date: Mar 2006
Location: Wallingford, Oxfordshire, UK
Age: 35
Posts: 295
hi there,

i'v got this problem with my xmms fonts too, and i've tried this fix posted here, but it doesn't work me

do i need a certain fonts rpm installed for this fix??

Reply With Quote
  #4  
Old 3rd December 2008, 05:35 PM
Camberwell Offline
Registered User
 
Join Date: Mar 2006
Location: Wallingford, Oxfordshire, UK
Age: 35
Posts: 295
according to the xmms config file it wants -adobe-helvetica-medium-r-*-*-8-*

which rpm provides this font?
Reply With Quote
  #5  
Old 3rd December 2008, 06:29 PM
PabloTwo Offline
"Registered User" T-Shirt Winner
 
Join Date: Mar 2007
Location: Seville, FL
Posts: 5,855
Chances are good that you already have the adobe-helvetica font installed, but it's not available in a "pxlsz" of "8". At least, that's what I find on my system, and that the smallest pxlsz available, as revealed by xfontsel, is "11".

Perhaps if you change the "8" to "11" for the point size in it's configuration file, it might work. xfontsel is a command line program, which when entered, brings up a window that lets you see/select all of your installed fonts. If you don't have xfontsel, then install the package xorg-x11-utils to get it. In the xfontsel window, bigin by clicking on "fndry", then select adobe from the drop down list (you can only choose items that are shown in bold), then click on the next item, "fmly", and click on helvetica, if it is in bold... etc, on across to see what you have available.

You could also just enter some new font into the XMMS config file, one that you do have.

I don't know what package would/might give you the -adobe-helvetica-medium-r-*-*-8-*.... in that point size. I don't use XMMS, but I do use audacious, which is a fork of BEEP, which was a completely rewritten clone of XMMS. Audacious adds a lot more functionality, and can use all of the old, and newer, XMMS skins. It also doesn't suffer from missing font problems.
Reply With Quote
  #6  
Old 3rd December 2008, 07:16 PM
Camberwell Offline
Registered User
 
Join Date: Mar 2006
Location: Wallingford, Oxfordshire, UK
Age: 35
Posts: 295
thanks for the reply

according to xfontsel i do have that font, alltho when i start xmms in a konsole it says...

** WARNING **: Failed to open font: "-adobe-helvetica-medium-r-*-*.8-*".

i would love to use audacious instead but i seem to get..

illegal instruction

when i start audacious, i did a bit of googling on audacious and aparently its been compiled with some option that my computer doesn't do

i might try and compile audacious from source unless anyone has a solution for that one too

at the moment i'm playing mp3's with mplayer or xine or totem (xine backend)

edit: oh yeah sorry, i've tried all sorts of fonts in there and none work, but it does change the font in the xmms main window and the playlist, but not the menu's

but i would like to get audacious or xmms working eventualy

Last edited by Camberwell; 3rd December 2008 at 07:20 PM. Reason: forgot to mention
Reply With Quote
  #7  
Old 3rd December 2008, 07:39 PM
PabloTwo Offline
"Registered User" T-Shirt Winner
 
Join Date: Mar 2007
Location: Seville, FL
Posts: 5,855
Sorry to hear that my suggestions didn't work out for you. Then I suppose that there was nothing in the XMMS config file that had a line specific to the "menu" font selection (?). Perhaps that's hard coded into the binary. I'm sure that if you used xfontsel to setup your font as requested by XMMS for the menu, you'd see it's not available with a pxlsz of 8, just like mine, and that's the problem.

Sometimes when a package won't work for me (not very often, but it happens), I download the SRPM of that package using yumdownloader, uninstall the package that was installed from the regular repos, and use rpmbuild and the rpmdevtools to build the rpm package locally. That might be a possible choice for you to get audacious working on your system.
Reply With Quote
  #8  
Old 3rd December 2008, 08:34 PM
Camberwell Offline
Registered User
 
Join Date: Mar 2006
Location: Wallingford, Oxfordshire, UK
Age: 35
Posts: 295
thanks for your responses

in xfontsel pixel size 8 is available, I tried other sizes anyway and it still didn't work, and other font types but no joy.

in ~/.xmms/config theres is a line...

mainwin_font=-bitstream-charter-medium-r-normal-*-*-10.*

and this line does affect the font in the xmms main window, and the playlist window fine, it just seems to be the gtk side of things thats broken. (see screenshot above)

I've downloaded the audacious and audacious-plugins source aswell, then yum installed enough -devel files to get a usable set of plugins compiled and it still fails to start with "illegal instruction"

oh well it might sort its self out with some future yum updates

for now i'll carry on with mplayer and xine

thanks again for your input

Martin
Reply With Quote
  #9  
Old 3rd December 2008, 11:57 PM
Camberwell Offline
Registered User
 
Join Date: Mar 2006
Location: Wallingford, Oxfordshire, UK
Age: 35
Posts: 295
Goode evenin all,

I seem to have fixed my little problem

what i've done is made a $HOME/.gtkrc file and in it i've put...

Code:
style "default-text" {
       fontset = "-bitsream-bitstream charter-medium-r-normal-*-12-*-*-*-*-*-*-*"

}

class "GtkWidget" style "default-text"
this seems to work for me anyway, cant garantee anyone else tho

Reply With Quote
  #10  
Old 4th December 2008, 12:10 AM
PabloTwo Offline
"Registered User" T-Shirt Winner
 
Join Date: Mar 2007
Location: Seville, FL
Posts: 5,855
Nice fix Martin. I'm sure others might benefit from your above post.
Reply With Quote
  #11  
Old 5th December 2008, 05:34 AM
Louisda16th Offline
Registered User
 
Join Date: Jan 2008
Location: Bangalore
Posts: 133
I have the same problem. Unfortunately none of the above fixes work for me. Any suggestions?
Reply With Quote
  #12  
Old 13th January 2009, 03:58 PM
creeping death Offline
Registered User
 
Join Date: Feb 2008
Posts: 656
[solution]

you need to update your xorg-x11-fonts...

Code:
yum install xorg-x11-font*
that solved the problem for me...

before...


after....



Last edited by creeping death; 13th January 2009 at 04:03 PM.
Reply With Quote
  #13  
Old 13th May 2009, 06:50 PM
joekrahn Offline
Registered User
 
Join Date: Jun 2004
Posts: 40
The .gtkrc fix worked for me, except that I had to put it into "~/.gtkrc.mine".

Running strace, I found that the file "~/.gtkrc-1.2-gnome2" was getting read. It says "Autowritten by gnome-settings-daemon. Do not edit", but includes "~/.gtkrc.mine". This could be an obsolete file; I have not changed settings in a while. The point is to be aware that you may need to check other ~/.gtkrc-* files.
Reply With Quote
  #14  
Old 24th July 2010, 03:21 PM
Fejj Offline
Registered User
 
Join Date: Sep 2009
Posts: 1
linuxfedorafirefox
Re: no fonts in xmms menus

If this helps anyone :

I had same thing - menu and file browse dialogue produced boxes instead of text.

After reading this thread, and not wanting to do the yum command line to install all fonts, I looked through the GUI for adding programs, in the font section.

I saw one for "A set of 100dpi Central European language fonts for X."

Installed that and problem fixed.

I don't know if it really was something with that font package, or just installing a new font fixed it. (Or seems to have, hope it doesn't do this again after a few days.)

Interestingly after Fedora 13 was installed, xmms worked, and the font was normal. At some point (probably after installing software - I'm thinking particularly games) I got the boxes problem.

I also have a wide screen laptop (1440 x 900), that might be a factor. (I am guessing that is a factor in a couple of probably unrelated intermittent bugs in gnome panel (graphics not fonts).)

Hope this helps if someone wants to fix the problem without installing a whole bunch of fonts.

(I chose the font above based on seeing that 100dpi fonts are installed, and that I am in Europe. Fedora was installed though as US English based (but with deadkeys).)
Reply With Quote
  #15  
Old 10th December 2011, 09:58 AM
jamesthorpe Offline
Registered User
 
Join Date: Dec 2011
Location: Pietermaritzburg South Africa
Posts: 1
linuxfedorafirefox
Re: no fonts in xmms menus

I'm using LTSP to run diskless terminals throughout the house for playing media, browsing the web etc. Running it off my FC13 box.

Anyway, XMMS plays really nicely on the terminals but I had this same issue with the squares instead of fonts in the gtk menus. What was weird was that XMMS menus are fine on the host machine but only the terminals have the problem. What a scene to get that sorted out- thanks to the tips above.

I tried modifying my $HOME/.gtkrc file to the settings shown by Camberwell - no dice, then tried re-installing X fonts but neither seemed to do the trick.What worked in the end (possibly in combination) was running the strace on xmms and looking for references to gtkrc- in my case, it was trying to read /home/james/.gtkrc-1.2-gnome2.en at one point so I just created a symbolic link from my gtkrc file to that one and all is sorted.

Thanks to all the contributors.
Reply With Quote
Reply

Tags
fonts, menus, xmms

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
OOO fonts proble in sub menus surprie Using Fedora 4 26th November 2008 04:31 PM
The new xmms-libs breaks compatability with xmms-mp3 uncholowapo Linux Chat 1 23rd November 2008 11:47 PM
fonts, buttons, and Menus missed up after Nvidia drivers ramy.m Using Fedora 4 14th August 2008 04:09 AM
Mp3's on xmms: xmms-mp3 decoder install error. driftwood Using Fedora 4 22nd February 2006 01:47 AM
Windows fonts guide(Including my .fonts.conf) liraz Guides & Solutions (No Questions) 1 25th June 2005 05:24 AM


Current GMT-time: 06:32 (Thursday, 24-04-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat