Fedora Linux Support Community & Resources Center
  #1  
Old 21st November 2011, 02:14 PM
tuxor Offline
Registered User
 
Join Date: Mar 2011
Posts: 179
linuxfirefox
[Fedora 16] xev ignores mic-mute-key

My ThinkPad T400s has a "microphone mute"-key, which I used with Fedora 15 quite flawlessly. Since I installed (fresh install!) Fedora 16, I can't use this key in X any more.

On Fedora 15
  • "showkey -s" showed nothing on keypress, the following warning appeared in dmesg instead: "keyboard: can't emulate rawmode for keycode 240"
  • "showkey -k" showed Keycode 240 on keypress
  • "xev" showed Keycode 248 (sic!) and I was able to use this key with xmodmap.

On Fedora 16
  • "showkey -s" shows nothing on keypress, the following warning appears in dmesg instead: "keyboard: can't emulate rawmode for keycode 248"
  • "showkey -k" shows Keycode 248 on keypress
  • "xev" shows no reaction at all on keypress.

Using "acpi_osi=!Linux" doesn't affect the behaviour described above.

Any hints what I could do about this? It's quite nice to use this key e.g. with skype, and I would love to have it with Fedora 16 as well. Why did the keycode (with showkey -k) change from Fedora 15 to 16?

---------- Post added at 02:14 PM ---------- Previous post was at 01:59 PM ----------

This is, what xev returns on Fedora 15 (tested from x86_64 LiveCD):
Code:
KeyRelease event, serial 33, synthetic NO, window 0x2200001,
    root 0xb0, subw 0x0, time 40990, (994,120), root:(1081,184),
    state 0x0, keycode 248 (keysym 0x0, NoSymbol), same_screen YES,
    XLookupString gives 0 bytes:
    XFilterEvent returns: False
Please note, that there is really no reaction at all using xev on Fedora 16 (x86_64).

The micmute-key's signals are emitted via /dev/input/event6 (the input-device of thinkpad_acpi). Another key whose signal is emitted via this device is the touchpad-on/off-key. But that key works out of the box.

Can somebody tell me at least, which part of the operating system is responsible for this problem? I could file a bug then But at the moment I wouldn't know where to file the bug...
__________________
Fedora on Lenovo ThinkPad T400s

Last edited by tuxor; 21st November 2011 at 02:37 PM.
Reply With Quote
  #2  
Old 24th November 2011, 04:55 PM
tuxor Offline
Registered User
 
Join Date: Mar 2011
Posts: 179
linuxfirefox
Re: [Fedora 16] xev ignores mic-mute-key

Tried "getscancodes" from http://keytouch.sourceforge.net/dl-getscancodes.html

When listening to /dev/input/event6, I'm getting:

Code:
# ./getscancodes /dev/input/event6
Input driver version is 1.0.1
Input device ID: bus 0x19 vendor 0x17aa product 0x5054 version 0x4101
Input device name: "ThinkPad Extra Buttons"
26 (0x1a)
26 (0x1a)
So my micmute-key has scancode 26 or 0x1a. Remember, that "showkey -s" doesn't display anything and "showkey -k" displays "Keycode 248". Wtf?
__________________
Fedora on Lenovo ThinkPad T400s
Reply With Quote
  #3  
Old 26th November 2011, 06:40 PM
tuxor Offline
Registered User
 
Join Date: Mar 2011
Posts: 179
linuxfirefox
Re: [Fedora 16] xev ignores mic-mute-key

I filed a bug about this here: https://bugzilla.redhat.com/show_bug.cgi?id=757365

Please note that the button works in Ubuntu 11.10 and Linux Mint 12 (Linux 3.0.0) just like it used to work in Fedora 15.
__________________
Fedora on Lenovo ThinkPad T400s
Reply With Quote
  #4  
Old 29th November 2011, 08:08 AM
tuxor Offline
Registered User
 
Join Date: Mar 2011
Posts: 179
linuxfirefox
Re: [Fedora 16] xev ignores mic-mute-key

Indeed the keycode has been changed on kernel side, now the kernel emits keycode 248 and that is out of range of X11-evdev: https://bugs.freedesktop.org/show_bug.cgi?id=11227

That's not a solution, but at least an explanation, thanks to Peter Hutterer.
__________________
Fedora on Lenovo ThinkPad T400s
Reply With Quote
  #5  
Old 29th November 2011, 12:03 PM
stevea Offline
Registered User
 
Join Date: Apr 2006
Location: Ohio, USA
Posts: 8,994
linuxfedorafirefox
Re: [Fedora 16] xev ignores mic-mute-key

The mute key is managed by the thinkpad_acpi module which should be loaded.
Documented in thinkpad_acpi.txt of the kernel documentation (yum package 'kernel-doc').
/usr/share/doc/kernel-doc-*/Documentation/laptops/thinkpad-acpi.txt

It's *possible* that kernel module changed, or that you don't have it loaded.

FWIW I've got a vanilla 3.2.0-rc2+ kernel on a Tpad T510 and the mute key works as expected.
__________________
None are more hopelessly enslaved than those who falsely believe they are free.
Johann Wolfgang von Goethe
Reply With Quote
  #6  
Old 30th November 2011, 01:06 AM
tuxor Offline
Registered User
 
Join Date: Mar 2011
Posts: 179
linuxsafari
Re: [Fedora 16] xev ignores mic-mute-key

1. I don't know whether T400s and T510 are identical in this respect.

2. This issue is about the key that mutes the microphone, not the "usual" mute key - that one is working fine and is _not_ managed by /dev/input/event6!

3. Which OS are you testing this on?

---------- Post added 30th November 2011 at 01:06 AM ---------- Previous post was 29th November 2011 at 02:02 PM ----------

I can't find anything about thinkpad_acpi managing the micmute key - I doubt this is the case. By the way, the microphone-mute-key does not emit any acpi-signal (tested with acpi_listen).

This is lame. They are discussing about the micmute-led days and days here: http://comments.gmane.org/gmane.linu...cpi.devel/2753 But nobody seems to care that the whole functionality of this key has been killed by the most recent kernel developments...
__________________
Fedora on Lenovo ThinkPad T400s
Reply With Quote
  #7  
Old 4th December 2011, 04:52 PM
tuxor Offline
Registered User
 
Join Date: Mar 2011
Posts: 179
linuxfirefox
Re: [Fedora 16] xev ignores mic-mute-key

I found a workaround:
Now my /lib/udev/keymaps/module-lenovo looks as follows:
Code:
0x1 screenlock # Fn+F2
0x2 battery # Fn+F3
0x3 sleep # Fn+F4
0x4 wlan # Fn+F5
0x6 switchvideomode # Fn+F7
0x7 f21 # Fn+F8 touchpadtoggle
0x8 f24 # Fn+F9 undock
0xB suspend # Fn+F12
0xF brightnessup # Fn+Home
0x10 brightnessdown # Fn+End
0x11 kbdillumtoggle # Fn+PgUp - ThinkLight
0x13 zoom # Fn+Space
0x14 volumeup
0x15 volumedown
0x16 mute
0x17 prog1 # ThinkPad/ThinkVantage button (high keycode: "vendor")
0x1A prog2 # Microphone mute
And my /usr/share/X11/XKeysymDB:
Code:
XF86MicMute             :1008FFAA
And my ~/.Xmodmap:
Code:
keycode 157 = XF86MicMute NoSymbol XF86MicMute
Via gnome-control-center I added a new shortcut for this command:
Code:
/usr/bin/amixer sset Capture toggle
__________________
Fedora on Lenovo ThinkPad T400s

Last edited by tuxor; 4th December 2011 at 05:06 PM.
Reply With Quote
  #8  
Old 23rd January 2012, 07:48 AM
gcbfedora Offline
Registered User
 
Join Date: Jan 2012
Location: la
Posts: 4
linuxiceweasel
Re: [Fedora 16] xev ignores mic-mute-key

Quote:
Originally Posted by tuxor View Post
I filed a bug about this here: https://bugzilla.redhat.com/show_bug.cgi?id=757365

Please note that the button works in Ubuntu 11.10 and Linux Mint 12 (Linux 3.0.0) just like it used to work in Fedora 15.
So, does the 1A key code works under X or will it never will?

my T410 does not produce the 1A keycode, and my distro (debian sid) already has all the changes in the files you mention at the end of this thread

i'm not that into the X protocol to understand the upstream bug that bug mentions
Reply With Quote
  #9  
Old 28th July 2012, 06:07 PM
camdecoster Offline
Registered User
 
Join Date: Nov 2007
Posts: 3
linuxchrome
Re: [Fedora 16] xev ignores mic-mute-key

Quote:
Originally Posted by tuxor View Post
I found a workaround:
Via gnome-control-center I added a new shortcut for this command:
Code:
/usr/bin/amixer sset Capture toggle
What did you add as the keyboard key (accelerator)? If the mic mute key isn't recognized when you press it, what do you press?

I'm having this same issue on Debian Testing at the moment.
Reply With Quote
  #10  
Old 26th December 2013, 05:11 PM
tuxor Offline
Registered User
 
Join Date: Mar 2011
Posts: 179
linuxfirefox
Resolved in Fedora 20

By the way, this issue has been completely resolved with Fedora 20. We even have a nice GNOME OSD for the micmute status now!

The howto in this thread doesn't work anymore due to the change in udev's keymap handling: https://ask.fedoraproject.org/questi...eymap-is-gone/
__________________
Fedora on Lenovo ThinkPad T400s
Reply With Quote
Reply

Tags
fedora, ignores, micmutekey, xev

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
kpackagekit ignores proxy settings in Fedora 14? yaconsult Using Fedora 0 4th January 2011 01:27 AM
[SOLVED] fedora 12 xorg ignores Virtual directive ardya Using Fedora 0 12th March 2010 01:17 AM
Fedora Core 9: VIM ignores .vimrc ThorHammer Using Fedora 7 26th July 2008 09:54 PM
rpmbuild in Fedora 9 ignores ~/.rpmrc daneel971 Using Fedora 0 3rd June 2008 04:44 PM
Need help installing MUTE p2p on Fedora 3 westone Using Fedora 2 10th January 2005 06:18 AM


Current GMT-time: 14:38 (Friday, 28-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Torekov Hamn Photos - Area de Servicio Exito Medinaceli Photos - Beaverdam Flats Travel Photos