Fedora Linux Support Community & Resources Center
  #1  
Old 5th November 2011, 12:41 PM
Bazu135 Offline
Registered User
 
Join Date: Aug 2011
Location: Luton, UK
Age: 29
Posts: 291
linuxfirefox
Clementine crashing on launch

I've got a problem attempting to run Clementine. It previously ran without errors, but now it crashes every time I try to start it. When I try to run it through the terminal, I get the following message:

Code:
db error:  QSqlError(1, "Unable to execute statement", "unsupported file format") 
faulty query:  "CREATE TABLE directories (
  path TEXT NOT NULL,
  subdirs INTEGER NOT NULL
)" 
bound values:  QMap() 
Unable to update music library database
Aborted (core dumped)
Last time I successfully ran Clementine, it was attempting to update a library, and threw an error message about being unable to do so (I can't remember anything more specific than that; sorry!). Since then, no luck.

I honestly have no idea how to fix this. I thought that maybe a restart, or a reinstall, or an uninstall-restart-install would clear whatever it was attempting to carry out, but these have all failed. I'd guess there's a file I'd need to delete, or a line somewhere that needs to be removed, or maybe an option while launching from the command line, but I have no idea what.

Any ideas?
Reply With Quote
  #2  
Old 5th November 2011, 07:54 PM
Keldorn Offline
Registered User
 
Join Date: Jun 2008
Location: Russia
Age: 26
Posts: 517
linuxchrome
Re: Clementine crashing on launch

Try to delete (or just rename it) clementine preference folder, it is hidden somewhere in your home folder.
Reply With Quote
  #3  
Old 5th November 2011, 08:08 PM
PiElle Offline
Registered User
 
Join Date: Jun 2011
Location: Italy
Posts: 360
windows_7firefox
Re: Clementine crashing on launch

No problems running Clementine here ...
Reply With Quote
  #4  
Old 6th November 2011, 10:21 AM
Bazu135 Offline
Registered User
 
Join Date: Aug 2011
Location: Luton, UK
Age: 29
Posts: 291
linuxfirefox
Re: Clementine crashing on launch

Quote:
Originally Posted by Keldorn View Post
Try to delete (or just rename it) clementine preference folder, it is hidden somewhere in your home folder.
This fixed it - thank you

For future people stumbling by, I had to delete ~/.config/Clementine - problem immediately resolved
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Gstreamer plugin issue with Clementine dragonbite Using Fedora 3 23rd November 2013 11:56 PM
Gnome 3/clementine oddities radicaledward Using Fedora 0 14th October 2011 11:31 PM
Fedora 13 x64 LXDE crashing crashing crashing joutlan Using Fedora 3 31st May 2010 07:44 AM
OOo won't launch JohnJasonJordan Using Fedora 4 19th January 2010 10:59 PM
Tribal Trouble crashing while attempting to launch thx11384eb Gamers' Lounge 2 14th October 2007 01:12 AM


Current GMT-time: 03:13 (Wednesday, 22-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Terlizzi - Bururi - Kuala Terengganu Photos