Fedora Linux Support Community & Resources Center
Prev Previous Post   Next Post Next
  #1  
Old 11th August 2011, 04:21 PM
jmgmad Offline
Registered User
 
Join Date: Aug 2011
Posts: 1
windows_xp_2003firefox
Script running error when I tried to start a service

Hello guys, this is my first post here in FedoraForum.

Iīm writing this because I need some tips and support in way to understand why and where is my mistake in a script writing that I want to running in my Fedora (v.14) x32bits.

Iīm doing a configuration of a SAP service which called SAP Router! For this, in opensource operation systems, we need to run this particulary service through a script! This script start this SAP Router service. The bizarre thing here is I already configure this service with exactly the same script in Red Hat (RHEL) and there I didnīt have any problem...

The script is to start the saprourter service and in this script file I put the following statement:

Code:
#
# Start saprouter
# You can automatically start SAProuter when you start the system. In UNIX for example, you would change file /etc/rc.
# saprouter CN=saprouter, OU=0001214237, OU=SAProuter, O=SAP, C=DE sapserv2
#
#
SRDIR=/usr/sap/saprouter
LOGFILE="usr/sap/saprouter/saprouter_log"
if [ -f $SRDIR/saprouter ] ; then
        echo "Starting SAP Router" | tee -a $LOGFILE
$SRDIR/saprouter -r -R $SRDIR/saprouttab -G $LOGFILE -W 60000 -K "p:CN=saprouter, OU=0001209837, OU=SAProuter, O=SAP, C=DE" \
        | tee -a $LOGFILE &
fi

When I run this script the output is this:

Code:
[root@saprouter sap]# pwd
/usr/sap/saprouter
[root@saprouter saprouter]# ./saprouter_start 
/usr/sap/saprouter/saprouter_start: line 12: syntax error near unexpected token `|'
'usr/sap/saprouter/saprouter_start: line 12: `        | tee -a $LOGFILE &

So... can you check the script and if you donīt mind help me in way to understand where is the error... if this error is related to specific syntax Fedora or not...!



Can you help me please?


Thank you,
Kind regards,
jmgmad
Reply With Quote
 

Tags
error, running, script, service, start

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] A init.d service script works with `service XX start` but not `systemctl start XX` lovetide Using Fedora 1 13th February 2014 02:28 PM
help running script on start up itsbrad212 Using Fedora 4 25th November 2009 03:38 AM
IOError: <urlopen error (-2, 'Name or service not known')> iwhile running yum update nagaraju1024 Using Fedora 2 1st July 2009 11:22 AM
Running mldonkey as a service, service does not startup Dhana Servers & Networking 2 14th August 2006 04:43 AM
Script not running due to syntax error - please help code_astronomer Programming & Packaging 8 19th December 2005 06:39 PM


Current GMT-time: 11:19 (Friday, 24-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletinŪ Copyright Đ2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Morar - Artemivsk Photos on Instagram - Ris-Orangis Photos on Instagram