Fedora Linux Support Community & Resources Center
  #1  
Old 23rd June 2011, 04:58 PM
TrotskyIcepick Offline
Registered User
 
Join Date: Jun 2011
Posts: 5
windows_vistachrome
[SOLVED] : FED15 and VBox4.0.8 Guest Additions Problem

I've just installed clean copies of both VirtualBox v4.0.8 and Fedora 15. Now I have followed the instructions here : http://www.sysprobs.com/install-fedo...ions-fedora-15 to install the latest VBox guest additions.

Each time I try I get the following message:

The headers for the current running kernel were not found. If the following module compilation fails then this could be the reason. The missing package can be installed with
yum install kernel-devel-2.6.38.8-32.fc15.i686.PAE.

However, if I run that command I am told there is no such package available. The guest addition installer continues seemingly OK, but after a restart they are not loaded.

I desperately need help, I've just moved to Fedora from Ubuntu due to major issues with its new version.

Thanks In Advance.

Last edited by TrotskyIcepick; 24th June 2011 at 01:28 AM. Reason: problem was solved by DBelton
Reply With Quote
  #2  
Old 24th June 2011, 12:15 AM
DBelton Offline
Administrator
 
Join Date: Aug 2009
Posts: 7,318
linuxfirefox
Re: FED15 and VBox4.0.8 Guest Additions Problem

try this:

Code:
su -
(root password)

yum update kernel

yum install kernel-PAE-devel kernel-headers
I assume you are running the PAE kernel since you specified it in your command above.

from the command line, run uname -r anbd be certain that you are indeed running the PAE kernel. If you are running the standard I686 the install kernel-devel instead of kernel-PAE-devel above.
Reply With Quote
  #3  
Old 24th June 2011, 01:27 AM
TrotskyIcepick Offline
Registered User
 
Join Date: Jun 2011
Posts: 5
windows_vistachrome
Re: FED15 and VBox4.0.8 Guest Additions Problem

DBelton......you are a "STAR", I was indeed using the PAE version of the kernel, so it would seem that I needed the devel version too. I'm not a Linux power user so would never have figured that out.

Now I have all the juicy goodness of Gnome3 and can't believe that Ubuntu chose the buggy and unthemeable Unity after seeing this in action.

Now I just need to spend much more time in the Linux community so that in future I might be able to figure stuff like this myself.

Many, many thanks for your help.
Reply With Quote
  #4  
Old 24th June 2011, 01:38 AM
DBelton Offline
Administrator
 
Join Date: Aug 2009
Posts: 7,318
linuxfirefox
Re: FED15 and VBox4.0.8 Guest Additions Problem

Glad that you have it working now..

And Welcome to Fedora

Edit:

Oh, and in Fedora, yum is your friend.. (or your worst enemy, all depends on what mood it's in) There is a little learning curve coming from Ubuntu, but you should be able to get by that in no time.

One thing.... Fedora has a policy of not including packages that have patent/copyright restrictions or aren't open source... So a lot of the extras are over in the rpmfusion repos, like just about all of the audio/video codecs, nvidia drivers, etc...

I have found one of the easiest ways to get a lot of that stuff installed is by using a nice little application written by dangermouse (a moderator on here) called AutoPlus.

http://www.dnmouse.org/autoten/

If you select the "Install Most Codecs" option that will give you just about all the audio/video codecs you will need to play just about anything. You can also use it to install the flash plugin for you.

Last edited by DBelton; 24th June 2011 at 01:44 AM.
Reply With Quote
  #5  
Old 24th June 2011, 06:20 AM
TrotskyIcepick Offline
Registered User
 
Join Date: Jun 2011
Posts: 5
windows_vistachrome
Re: FED15 and VBox4.0.8 Guest Additions Problem

Great information, the only reason I still use Windoze now is for MS SQL Server, IIS and of course.....World of Warcraft Although I still find it a bit of a thrill being able to run one OS inside of another.

Just one last small question.....where are all the theme/appearance settings hiding? Used to be under System | Preferences | Appearance in Ubuntu. Or is all that now hidden as console command stuff?

Cheers.
Reply With Quote
  #6  
Old 24th June 2011, 06:49 AM
DBelton Offline
Administrator
 
Join Date: Aug 2009
Posts: 7,318
linuxfirefox
Re: FED15 and VBox4.0.8 Guest Additions Problem

well, For the time being, there really isn't much in the way of theme/appearance settings that's easily changed in the new Gnome 3 shell.

With it being a new release and really a complete re-write, there are quite a few things that haven't been put back in.. Hopefully those things will make it in by way of some updates really soon, but for the time being, you have to hunt around and change things the hard way. There are several thread on it in here, if you look around and find them.

About the biggest complaint I have had with the Gnome 3 shell is the lack of configurability, but it is slowly getting better.
Reply With Quote
  #7  
Old 24th June 2011, 08:07 PM
TrotskyIcepick Offline
Registered User
 
Join Date: Jun 2011
Posts: 5
windows_vistachrome
Re: FED15 and VBox4.0.8 Guest Additions Problem

Tbh I find it quite refreshing that Fedora / Gnome3 pretty much worked out of the box so to speak, yes I had a couple of issues with vbox guest adds etc, but other than that it just works. And it has to be said, given the graphical nature of Gnome 3 it doesn't hog resources like Ubuntu always has.

Why Ubuntu chose to go with the Unity desktop is beyond me when at the end of the day (and I was surprised by this) it is remarkably similar in appearance and functionality to Gnome 3 (Ubuntu imho have messed up on this and are going to lose a lot of those users who chose it for it's ease of use and friendliness, even running it in Ubuntu Classic mode you lose all your theme settings and there is no way to get them back....RIP Ubuntu as ar as I'm concerned ).

And as I'm finding, there are it seems more intelligent and workable solutions out there on the net for Fedora issues.....and a friendly community to boot.

Regards
Andrew
Reply With Quote
  #8  
Old 27th June 2011, 05:13 PM
Ora82 Offline
Registered User
 
Join Date: Jun 2011
Posts: 1
windows_7firefox
Re: FED15 and VBox4.0.8 Guest Additions Problem

I have also installed VBox 4.0.8 and Fedora 15. I have taken a look on several Forum pages to do the trick, to get GNOME 3 running.

I managed to install Guest Additions (VBOXADDITIONS_4.0.8_71778 appears in 'Places'.

Though running VBoxLinuxAdditions.run, it failed(=red) to install kernel-devel-2.6.38.8.32.fc32.i686.PAE (not available)

vboxadd-install.log tells me: '*** Error: unable to find the source of your current Linux kernel. Specify KERN_DIR=<directory> and run Make again.. Stop. Creating user for the Guest Additions. Creating udev rule for the Guest Additions kernel module.'

I tried yum update kernel. Terminal advices me 'kernel available, but not installed.'

How can i update the kernel?
Reply With Quote
  #9  
Old 27th June 2011, 06:33 PM
DBelton Offline
Administrator
 
Join Date: Aug 2009
Posts: 7,318
linuxfirefox
Re: FED15 and VBox4.0.8 Guest Additions Problem

please refer to the instructions in post #2 above. They apply to your situation too.
Reply With Quote
  #10  
Old 2nd July 2011, 02:03 AM
clb92 Offline
Registered User
 
Join Date: Jul 2011
Posts: 1
linuxfirefox
Re: FED15 and VBox4.0.8 Guest Additions Problem

Quote:
Originally Posted by DBelton View Post
try this:

Code:
su -
(root password)

yum update kernel

yum install kernel-PAE-devel kernel-headers
I assume you are running the PAE kernel since you specified it in your command above.

from the command line, run uname -r anbd be certain that you are indeed running the PAE kernel. If you are running the standard I686 the install kernel-devel instead of kernel-PAE-devel above.
After doing what you said I just got the error:

The gcc utility was not found. If the following module compilation fails then
this could be the reason and you should try installing it.
[FAILED]
Your system does not seem to be set up to build kernel modules.


I'm very new to Linux and totally new to Fedora.

EDIT: I use VirtualBox 4.0.10
Reply With Quote
  #11  
Old 24th July 2011, 09:23 PM
coder543 Offline
Registered User
 
Join Date: Jul 2011
Posts: 1
linuxchrome
Re: FED15 and VBox4.0.8 Guest Additions Problem

I really don't think you need to continue using windows for SQL and IIS, you could easily install Apache and SQL on Fedora or Ubuntu or any other Linux. And as a side note, Gnome 3 took about three whole years to develop, where as Canonical recognized that they didn't want to use Gnome Shell so they developed Unity in roughly six months. That's insanely fast. Admittedly they had a little groundwork done by the netbook addition, but they rewrote it all from scratch essentially. The first release was going to be slightly rough, but 11.10 will fix almost all the gripes about it.

I, however, strongly respect Fedora for using LVM by default. That is awesome.
Reply With Quote
  #12  
Old 25th July 2011, 09:30 PM
rayde Offline
Registered User
 
Join Date: Jul 2011
Posts: 1
linuxchrome
Re: FED15 and VBox4.0.8 Guest Additions Problem

Quote:
Originally Posted by clb92 View Post
After doing what you said I just got the error:

The gcc utility was not found. If the following module compilation fails then
this could be the reason and you should try installing it.
[FAILED]
Your system does not seem to be set up to build kernel modules.


I'm very new to Linux and totally new to Fedora.

EDIT: I use VirtualBox 4.0.10
I get this same error in Virtualbox! On:
Quote:
Linux fedora 2.6.38.8-35.fc15.x86_64 #1 SMP Wed Jul 6 13:58:54 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
when I attempt to install gcc I receive the following error:

Quote:
sudo yum install gcc


Loaded plugins: langpacks, presto, refresh-packagekit
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package gcc.x86_64 0:4.6.0-9.fc15 will be installed
--> Processing Dependency: libgomp = 4.6.0-9.fc15 for package: gcc-4.6.0-9.fc15.x86_64
--> Processing Dependency: cpp = 4.6.0-9.fc15 for package: gcc-4.6.0-9.fc15.x86_64
--> Processing Dependency: cloog-ppl >= 0.15 for package: gcc-4.6.0-9.fc15.x86_64
--> Processing Dependency: glibc-devel >= 2.2.90-12 for package: gcc-4.6.0-9.fc15.x86_64
--> Processing Dependency: libmpc.so.2()(64bit) for package: gcc-4.6.0-9.fc15.x86_64
--> Running transaction check
---> Package cloog-ppl.x86_64 0:0.15.9-3.fc15 will be installed
--> Processing Dependency: libppl.so.9()(64bit) for package: cloog-ppl-0.15.9-3.fc15.x86_64
--> Processing Dependency: libppl_c.so.4()(64bit) for package: cloog-ppl-0.15.9-3.fc15.x86_64
---> Package cpp.x86_64 0:4.6.0-9.fc15 will be installed
---> Package glibc-devel.x86_64 0:2.14-4 will be installed
--> Processing Dependency: glibc-headers = 2.14-4 for package: glibc-devel-2.14-4.x86_64
--> Processing Dependency: glibc-headers for package: glibc-devel-2.14-4.x86_64
---> Package libgomp.i686 0:4.6.0-9.fc15 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: libgomp-4.6.0-9.fc15.i686
--> Processing Dependency: libc.so.6(GLIBC_2.0) for package: libgomp-4.6.0-9.fc15.i686
--> Processing Dependency: libc.so.6(GLIBC_2.1.3) for package: libgomp-4.6.0-9.fc15.i686
--> Processing Dependency: libc.so.6(GLIBC_2.2) for package: libgomp-4.6.0-9.fc15.i686
--> Processing Dependency: libc.so.6 for package: libgomp-4.6.0-9.fc15.i686
--> Processing Dependency: libpthread.so.0(GLIBC_2.0) for package: libgomp-4.6.0-9.fc15.i686
--> Processing Dependency: libgcc_s.so.1(GCC_3.0) for package: libgomp-4.6.0-9.fc15.i686
--> Processing Dependency: libpthread.so.0 for package: libgomp-4.6.0-9.fc15.i686
--> Processing Dependency: libc.so.6(GLIBC_2.3) for package: libgomp-4.6.0-9.fc15.i686
--> Processing Dependency: librt.so.1(GLIBC_2.2) for package: libgomp-4.6.0-9.fc15.i686
--> Processing Dependency: libpthread.so.0(GLIBC_2.3.4) for package: libgomp-4.6.0-9.fc15.i686
--> Processing Dependency: librt.so.1 for package: libgomp-4.6.0-9.fc15.i686
--> Processing Dependency: libgcc_s.so.1 for package: libgomp-4.6.0-9.fc15.i686
--> Processing Dependency: libpthread.so.0(GLIBC_2.1) for package: libgomp-4.6.0-9.fc15.i686
--> Processing Dependency: libc.so.6(GLIBC_2.6) for package: libgomp-4.6.0-9.fc15.i686
--> Processing Dependency: libgcc_s.so.1(GCC_3.3.1) for package: libgomp-4.6.0-9.fc15.i686
---> Package libmpc.x86_64 0:0.8.3-0.3.svn855.fc15 will be installed
--> Running transaction check
---> Package glibc.i686 0:2.14-4 will be installed
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.14-4.i686
--> Processing Dependency: libfreebl3.so for package: glibc-2.14-4.i686
---> Package glibc-headers.x86_64 0:2.14-4 will be installed
---> Package libgcc.i686 0:4.6.0-9.fc15 will be installed
---> Package ppl.x86_64 0:0.11.2-1.fc15 will be installed
--> Processing Dependency: libpwl.so.5()(64bit) for package: ppl-0.11.2-1.fc15.x86_64
--> Running transaction check
---> Package nss-softokn-freebl.i686 0:3.12.10-2.fc15 will be installed
---> Package ppl-pwl.x86_64 0:0.11.2-1.fc15 will be installed
--> Finished Dependency Resolution
Error: Protected multilib versions: libgcc-4.6.0-9.fc15.i686 != libgcc-4.6.0-10.fc15.x86_64
Error: Protected multilib versions: nss-softokn-freebl-3.12.10-2.fc15.i686 != nss-softokn-freebl-3.12.10-4.fc15.x86_64
Error: Protected multilib versions: libgomp-4.6.0-9.fc15.i686 != libgomp-4.6.0-10.fc15.x86_64
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
I've tried running those two suggested commands with no luck.

I cannot install the "various compilers" via the Add/Remove Software gui either. I get:
Quote:
Protected multilib versions: libgcc-4.6.0-9.fc15.i686 != libgcc-4.6.0-10.fc15.x86_64
Protected multilib versions: nss-softokn-freebl-3.12.10-2.fc15.i686 != nss-softokn-freebl-3.12.10-4.fc15.x86_64
Protected multilib versions: libgomp-4.6.0-9.fc15.i686 != libgomp-4.6.0-10.fc15.x86_64

Any suggestions?

---------- Post added at 04:30 PM ---------- Previous post was at 02:46 PM ----------

I think I've found the solution. During the install of Fedora I had selected to have "test updates" installed. However, this repo was not selected anymore in my software sources, and therefore there was a version mismatch. I went into the software sources in Add/Remove Programs and checked the same repos that were selected during my install, and it let me proceed through installing gcc... which let me then install the VirtualBox additions.
Reply With Quote
  #13  
Old 27th July 2011, 03:14 PM
SomeDamFool Offline
Registered User
 
Join Date: Sep 2006
Location: Groom Lake Nevada
Posts: 491
linuxfirefox
Re: FED15 and VBox4.0.8 Guest Additions Problem

Quote:
Originally Posted by TrotskyIcepick View Post
where are all the theme/appearance settings hiding? Used to be under System | Preferences | Appearance in Ubuntu. Or is all that now hidden as console command stuff?

Cheers.
There are 5 additional themes available for G3. Do a search:

Code:
[root@localhost ~]# yum search gnome-shell-theme
Loaded plugins: allowdowngrade, presto, protectbase, refresh-packagekit
0 packages excluded due to repository protections
updates/pkgtags                                          |  37 kB     00:00     
======================== N/S Matched: gnome-shell-theme ========================
gnome-shell-theme-atolm.noarch : The Atolm gnome-shell theme
gnome-shell-theme-dark-glass.noarch : The Dark-Glass gnome-shell theme
gnome-shell-theme-gaia.noarch : The Gaia gnome-shell theme
gnome-shell-theme-orta.noarch : The Orta gnome-shell theme
gnome-shell-theme-smooth-inset.noarch : The Smooth-Inset gnome-shell theme
If you also search gnome-shell-extension there is one that puts another button on the activities page and you can change themes by clicking on the preview.
Mike
__________________
su -
I am root the great and powerful
Pay no attention to the man behind the curtain

Last edited by SomeDamFool; 27th July 2011 at 03:14 PM. Reason: f
Reply With Quote
  #14  
Old 5th January 2013, 09:10 AM
dniko Offline
Registered User
 
Join Date: Jul 2008
Posts: 10
windows_7firefox
Re: FED15 and VBox4.0.8 Guest Additions Problem

This solution worked for me in a Windows7 host system "guesting" Fedora 15. It indeed helped a lot.

In windows XP hosts, the command was yum install kernel-devel kernel-headers.

Kind regards.

Quote:
Originally Posted by DBelton View Post
try this:

Code:
su -
(root password)

yum update kernel

yum install kernel-PAE-devel kernel-headers
I assume you are running the PAE kernel since you specified it in your command above.

from the command line, run uname -r anbd be certain that you are indeed running the PAE kernel. If you are running the standard I686 the install kernel-devel instead of kernel-PAE-devel above.
Reply With Quote
Reply

Tags
additions, fed15, guest, problem, vbox

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Guest Additions Fedora Guest/Windows Host pythagorean Guides & Solutions (No Questions) 0 17th October 2010 08:06 PM
Installing guest additions Virtualbox Fedora 13 guest heffo_j Guides & Solutions (No Questions) 5 16th August 2010 08:44 PM
Guest Additions Problem After Upgrade ponic Using Fedora 9 7th March 2010 10:12 AM
F12 Guest Additions Problem (Windows 7 Host) Nordic Installation, Upgrades and Live Media 8 7th March 2010 05:55 AM
F11 32bit as guest on F11 64bit: guest additions? kto Using Fedora 1 26th July 2009 04:48 PM


Current GMT-time: 10:36 (Wednesday, 23-04-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat