Fedora Linux Support Community & Resources Center
  #1  
Old 26th July 2011, 07:55 AM
danithq Offline
Registered User
 
Join Date: Jul 2011
Posts: 3
linuxfedorafirefox
Canon Pixmar MG5150 problems

I have been trying to add the Canon Pixmar MG5150 printer to my Fedora 13 setup.
I downloaded the drivers and installed them but I keep getting an error saying the pstocanonij failed.
I have searched online and been unable to locate any help for this issue.
Anyone have any suggestions ?
Reply With Quote
  #2  
Old 26th July 2011, 08:24 AM
flyingfsck Offline
Registered User
 
Join Date: Aug 2010
Location: Al Ain, UAE
Posts: 1,864
linuxfirefox
Re: Canon Pixmar MG5150 problems

No idea, but here is what i would try:
# lsmod
See whether driver is loaded. If not, use modprobe to load it and watch for error messages - google them.

Restart CUPS:
# service cups restart
and watch for errors.

Print something manually:
# lpr -H hostname -P printername test.pdf

and try the default settings as well:
$ lpr -H 127.0.0.1 test.pdf

The idea is to try simple things and see what the system tells you.

Hope that helps!

Cheers,

F
Reply With Quote
  #3  
Old 26th July 2011, 10:54 AM
David Batson Offline
Registered User
 
Join Date: Jul 2009
Posts: 1,234
linuxopera
Re: Canon Pixmar MG5150 problems

Did you install the following (not the source files)? Do you get any SELinux alerts?

I always install the drivers, then add the printer in CUPS. Try deleting you Canon Printer from CUPS, then add it back in from CUPS. Make sure you use the driver you downloaded (there may be more than one available). The driver you downloaded should mention 3.40 in the description.

MG5100 series IJ Printer Driver Ver. 3.40 for Linux (rpm ...

MG5100 series ScanGear MP Ver. 1.60 for Linux (rpm Packagearchive)
__________________
Fedora 19 Gnome on a ThinkPad X220, i5-2540M CPU, Intel HD Graphics 3000, Intel N 6205 wireless, and Sierra Wireless 754S Mobile Hotspot (AT&T)
Reply With Quote
  #4  
Old 26th July 2011, 05:38 PM
danithq Offline
Registered User
 
Join Date: Jul 2011
Posts: 3
linuxfedorafirefox
Re: Canon Pixmar MG5150 problems

Hello Again,
Yep I have tried deleting it and reloading it same message.
I even deleted uninstalled Cups reinstalled cups reinstalled the drivers and still the same message.
I run Winxp in a vitual machine using virtual Box and I can print from there so at least I can print even if I do have to do it from windows.

I ran lsmod but don't see any mention of the driver files or any other file names I recognise.
Not sure of what lsmod does so may have to investigate that !!
tried the lpr -H 127.0.0.1 a pdf file
and lpr -H 10.1.1.17 my pdf file and received no error messages from the command line and can see the documents in the printer que but no print.
The printer que message says No connected?
But the virtual machine may have control at the moment I will try it again when I close the vm.

will have to also check out modprobe as I do not know it either.
I am a relative newbie!!

Thanks for the tips.
Will keep trying.
Reply With Quote
  #5  
Old 26th July 2011, 05:50 PM
David Batson Offline
Registered User
 
Join Date: Jul 2009
Posts: 1,234
linuxopera
Re: Canon Pixmar MG5150 problems

I've installled two canon multifunction printers successfully. The first post below is more detailed.

http://forum.mandriva.com/en/viewtop...87c6ca#p506242

http://forum.mandriva.com/en/viewtop...33655&p=839255

Quote:
Originally Posted by myself
have since replaced the Canon PIXMA MP600 with a Canon PIXMA MG8120 (the MP600 died). There are linux drivers for the MG8100 series that install fine. The printer works great. The scanner works fine in Linux, but only with Canon's scangearmp utility (a GUI app started from terminal). So far there are no SANE drivers for the scanner, but I expect that to change.
EDIT: See that you have the gutenprint and foomatic drivers installed from Fedora's repos. Could make a difference.
__________________
Fedora 19 Gnome on a ThinkPad X220, i5-2540M CPU, Intel HD Graphics 3000, Intel N 6205 wireless, and Sierra Wireless 754S Mobile Hotspot (AT&T)

Last edited by David Batson; 26th July 2011 at 06:44 PM.
Reply With Quote
  #6  
Old 27th July 2011, 07:32 AM
danithq Offline
Registered User
 
Join Date: Jul 2011
Posts: 3
linuxfedorafirefox
Re: Canon Pixmar MG5150 problems

Hello,
I have the printer connected to my PC via a USB cable not via ethernet to router.
It appears in the list of printers to install but when I get to select the model it does not show up in the list.
I select the correct ppd file and it seems to install but still get the message /usr/lib/cups/filter/pstocanonij failed
It did show up in the list at one stage but has now dissappeared from the model list.
Reply With Quote
Reply

Tags
canon, mg5150, pixmar, problems

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
problems with canon LBP2900 printer... :confused: kaimietiz Hardware & Laptops 4 10th October 2006 04:55 PM


Current GMT-time: 03:55 (Saturday, 20-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat