Fedora Linux Support Community & Resources Center
  #1  
Old 11th April 2011, 03:14 PM
remenic Offline
Registered User
 
Join Date: Apr 2011
Posts: 3
linuxchrome
sshd, remote deskop, all inaccessible?

Heya, I've configured remote desktop and sshd, but I'm unable to log in from any other machine. Connecting to localhost (from the same machine) works fine.

I've checked /etc/hosts.allow and /etc/hosts.deny but both didn't contain any rules. I added ALL: ALL to hosts.allow, but still no luck

As far as I can tell, the firewall doesn't contain any rules to block incoming connections either.

Any ideas?
  #2  
Old 11th April 2011, 03:34 PM
Miikka Offline
Registered User
 
Join Date: Apr 2011
Location: Finland
Posts: 293
linuxfedorafirefox
Re: sshd, remote deskop, all inaccessible?

Is your router configured properly? Does it forward the needed ports to your computer?
  #3  
Old 11th April 2011, 03:50 PM
remenic Offline
Registered User
 
Join Date: Apr 2011
Posts: 3
linuxchrome
Re: sshd, remote deskop, all inaccessible?

Quote:
Originally Posted by Miikka View Post
Is your router configured properly? Does it forward the needed ports to your computer?
I was trying to access my machine from another machine in the LAN. Both machines are connected via a switch. Both are in same IP range (192.168.1.0/24).
  #4  
Old 11th April 2011, 03:57 PM
motnahp00
Guest
 
Posts: n/a
windows_7ie
Re: sshd, remote deskop, all inaccessible?

In your sshd_config file, did you add the AllowUsers line?
  #5  
Old 11th April 2011, 08:46 PM
remenic Offline
Registered User
 
Join Date: Apr 2011
Posts: 3
linuxchrome
Re: sshd, remote deskop, all inaccessible?

Quote:
Originally Posted by motnahp00 View Post
In your sshd_config file, did you add the AllowUsers line?
I managed to fix the problem!! But AllowUsers wasn't the problem. The problem was me

I decided to check with wireshark to see what was going on, and I noticed that the machine was responding with ICMP "administratively prohibited". Prior to asking for help here, I had checked with iptables -L but didn't find anything out of the ordinary.

After I disabled the firewall with system-config-firewall, it worked. Will try to figure out how to enable firewall while allowing sshd (it was checked, so I'm guessing it *should* have worked). Most important right now, is that I can log in remotely :-)

Thanks to the both of you who tried to help!
 

Tags
deskop, inaccessible, remote, sshd

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting sshd: /etc/init.d/sshd: line 113: /usr/sbin/sshd: Permission denied sumanc Using Fedora 9 28th March 2008 06:37 AM
Uninstalled Deskop Effects the_j0k3r Using Fedora 4 12th February 2008 10:14 AM
remote deskop with nx Nu_ Using Fedora 2 16th January 2007 05:54 AM
Remote deskop options? hurl380 Using Fedora 2 3rd March 2006 12:55 AM


Current GMT-time: 06:23 (Wednesday, 22-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Tagbilaran City Photos - Eloi Mendes - Yinzhu Instagram Photos