Fedora Linux Support Community & Resources Center
  #1  
Old 28th November 2010, 04:32 PM
fouryu Offline
Registered User
 
Join Date: May 2008
Location: Hangzhou, China
Age: 31
Posts: 5
linuxfedorafirefox
Install VMware Player on 64bit FC14 Failed

I downloaded the VMware Player 3.1.2, the file is .bundle. I run it, installed vmplayer.

When run vmplayer, it noticed me that several modules not found, and it should be compiled into kernel. Then I installed the kernel-devel package(the same version as my runing kernel:2.6.35.6-48.fc14.x86_64 ). su, run the vmplayer to start the compile, but still failed.

The error log shows following information, is it can be solved? Thank you!
make[1]: Entering directory `/usr/src/kernels/2.6.35.6-48.fc14.x86_64'
CC [M] /tmp/vmware-root/modules/vmmon-only/linux/driver.o
CC [M] /tmp/vmware-root/modules/vmmon-only/linux/iommu.o
/tmp/vmware-root/modules/vmmon-only/linux/iommu.c: In function ‘IOMMU_SetupMMU’:
/tmp/vmware-root/modules/vmmon-only/linux/iommu.c:156:7: error: implicit declaration of function ‘iommu_map_range’
/tmp/vmware-root/modules/vmmon-only/linux/iommu.c: In function ‘IOMMU_VMCleanup’:
/tmp/vmware-root/modules/vmmon-only/linux/iommu.c:403:7: error: implicit declaration of function ‘iommu_unmap_range’
/tmp/vmware-root/modules/vmmon-only/linux/iommu.c: In function ‘IOMMUUnregisterDeviceInt’:
/tmp/vmware-root/modules/vmmon-only/linux/iommu.c:216:17: warning: ignoring return value of ‘device_attach’, declared with attribute warn_unused_result
make[2]: *** [/tmp/vmware-root/modules/vmmon-only/linux/iommu.o] Error 1
make[1]: *** [_module_/tmp/vmware-root/modules/vmmon-only] Error 2
Reply With Quote
Reply

Tags
64bit, fc14, install, kernel, vmware

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Cannot Start VMWare-player in FC14 choudharypranay Using Fedora 4 16th November 2010 02:58 AM
FC14 64bit Epsoinv350 photo no longer working g8jvm Hardware & Laptops 1 7th November 2010 05:07 PM
VMware Player won't install (or patch) garaden Using Fedora 4 6th August 2009 12:24 AM
Unable to install Fedora 9 via VMware on Windows Vista 64bit Host Assailant86 Installation, Upgrades and Live Media 1 22nd July 2008 02:57 AM
Help me install a mp3 player on Fedora Core 5 64bit aussie7 Installation, Upgrades and Live Media 5 27th May 2006 02:02 AM


Current GMT-time: 23:39 (Tuesday, 22-07-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat