Fedora Linux Support Community & Resources Center
  #1  
Old 14th August 2009, 01:25 PM
nite_man Offline
Registered User
 
Join Date: Aug 2007
Location: Limassol, Cyprus
Posts: 19
linuxfedorafirefox
Scrolling on touchpad doesn't work on Fedora 11

Hi,

After upgrading from Fedora 10 to 11 the scrolling on touchpad of the Compaq 6710b doesn't work. I saw a few posts about activating touchpad in the KDE control panel but I couldn't find any touchpad related tab.

Any help will be appreciated.

TIA
__________________
Cheers,
Michael
Fedora 15, KDE 4.4
Reply With Quote
  #2  
Old 14th August 2009, 02:31 PM
Dangermouse Offline
Administrator - (On Leave)
 
Join Date: Aug 2007
Location: London Postbox (the red one)
Age: 49
Posts: 3,864
linuxfedorafirefox
Hi,
in f11 the touchpad is disbled by default i think!, anyway not sure about kde, but in gnome there is a gui for enabling it, system>preferences>mouse, id assume kde has similar.
Reply With Quote
  #3  
Old 14th August 2009, 02:48 PM
David Batson Offline
Registered User
 
Join Date: Jul 2009
Posts: 1,234
linuxopera
Try Qsynaptics for KDE. For Gnome, Gsynaptics should work. I use Qsynaptics with Mandriva 2009.1 KDE and Gsynaptics with F11 Gnome. I only use the TrackPoint though. I use these apps to disable the Touchpad.
__________________
Fedora 19 Gnome on a ThinkPad X220, i5-2540M CPU, Intel HD Graphics 3000, Intel N 6205 wireless, and Sierra Wireless 754S Mobile Hotspot (AT&T)
Reply With Quote
  #4  
Old 14th August 2009, 06:27 PM
nite_man Offline
Registered User
 
Join Date: Aug 2007
Location: Limassol, Cyprus
Posts: 19
linuxfedorafirefox
Thanks for your replays, guys. I tried to use ksynaptics but it needs driver version 0.14.4 and the system has 0.14.6c. Touchpad works fine under GNOME and there is a tab with touchpad setting in the system configuration. But I cannot find anything similar for KDE.
__________________
Cheers,
Michael
Fedora 15, KDE 4.4
Reply With Quote
  #5  
Old 14th August 2009, 06:56 PM
David Batson Offline
Registered User
 
Join Date: Jul 2009
Posts: 1,234
linuxopera
Instead of Ksynaptics, try Qsynaptics.
__________________
Fedora 19 Gnome on a ThinkPad X220, i5-2540M CPU, Intel HD Graphics 3000, Intel N 6205 wireless, and Sierra Wireless 754S Mobile Hotspot (AT&T)
Reply With Quote
  #6  
Old 14th August 2009, 07:31 PM
ultra magnus Offline
Registered User
 
Join Date: Nov 2007
Location: Finland
Age: 32
Posts: 314
linuxfedorafirefox
try using two fingers to scroll, this is what I have to do. To enable tapping see http://satyajitranjeev.wordpress.com...-in-fedora-11/ :

Quote:
copy
/usr/share/hal/fdi/policy/20thirdparty/10-synaptics.fdi to /etc/hal/fdi/policy

and edit the file according to your needs.

Code:
<merge key="input.x11_options.TapButton1" type="string">1</merge>
 <merge key="input.x11_options.TapButton2" type="string">3</merge>
 <merge key="input.x11_options.TapButton3" type="string">2</merge>
Add the above lines if they are not present. This will enable tapping, two-finger tap for right click and three for middle click.
__________________
my blog
my forum
my "art"
my packages
IRC: Magnu5
Reply With Quote
  #7  
Old 14th August 2009, 07:31 PM
nite_man Offline
Registered User
 
Join Date: Aug 2007
Location: Limassol, Cyprus
Posts: 19
linuxfedorafirefox
It seems for Fedora the Qsynaptics package is called Ksynaptics. At least I saw it in the package definition - http://www.rpmfind.net/linux/RPM/fed...fc10.i386.html
__________________
Cheers,
Michael
Fedora 15, KDE 4.4
Reply With Quote
  #8  
Old 14th August 2009, 07:41 PM
Citizen Erased Offline
Registered User
 
Join Date: Jun 2008
Location: Éire
Posts: 9
linuxfedorafirefox
Ksynaptics doesn't seem to be in the f11 repo.
I have both Gnome and KDE installed so not sure if a KDE-only install will include the gnome mouse gui but I put this in my ~/.kde/Autostart folder and scroll works fine once it runs

Code:
#/bin/bash
############~Mouse scroll fix~##########
gnome-mouse-properties &
sleep 3
kill $(pidof gnome-mouse-properties)

exit
Once the I run the Gnome mouse gui the touchpad scroll works fine on KDE for me
Reply With Quote
  #9  
Old 15th August 2009, 01:21 AM
nite_man Offline
Registered User
 
Join Date: Aug 2007
Location: Limassol, Cyprus
Posts: 19
linuxfedorafirefox
Hi Citizen Erased. Your approach works for me. Thanks a lot. Just have reversed scrolling by some reason.
__________________
Cheers,
Michael
Fedora 15, KDE 4.4
Reply With Quote
  #10  
Old 15th August 2009, 06:55 PM
Citizen Erased Offline
Registered User
 
Join Date: Jun 2008
Location: Éire
Posts: 9
linuxfedorafirefox
In the KDE system settings, click on "Keyboard & Mouse"
In the mouse sub-menu there should be an option to reverse scroll direction, checking or unchecking that may solve problem
Reply With Quote
  #11  
Old 17th August 2009, 11:05 AM
nite_man Offline
Registered User
 
Join Date: Aug 2007
Location: Limassol, Cyprus
Posts: 19
linuxfedorafirefox
Thanks a lot, guys, for your help. The gnome-mouse-properties works fine under KDE but it's strange a bit for me that KDE doesn't have any its settings for the touchpad control.
__________________
Cheers,
Michael
Fedora 15, KDE 4.4
Reply With Quote
  #12  
Old 20th August 2009, 01:49 PM
nite_man Offline
Registered User
 
Join Date: Aug 2007
Location: Limassol, Cyprus
Posts: 19
linuxfedorafirefox
Well, Finally I found howto scroll using touchpad. It's done as in Mac OS X touching by two fingers It works fine and it's much better then using scrolling bar on the touchpad.
__________________
Cheers,
Michael
Fedora 15, KDE 4.4
Reply With Quote
  #13  
Old 12th November 2010, 02:38 PM
amir1990 Offline
Registered User
 
Join Date: Nov 2010
Posts: 1
linuxfedorafirefox
Question Re: Scrolling on touchpad doesn't work on Fedora 11

i have this problem too. i mean my touchpad dont work in KDE
but i found that whit using 10-synaptics fdi file i can solve it
cp /usr/share/hal/fdi/policy/20thirdparty/10-synaptics.fdi /etc/hal/fdi/policy
i typed it in bash but i got permission denied
can you help me
Reply With Quote
Reply

Tags
fedora, scrolling, touchpad, work

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Enable touchpad tapping and circular scrolling on F11 with XFCE STEELBAS Hardware & Laptops 2 17th June 2009 03:21 AM
Touchpad Scrolling, and update availability jbrown96 Using Fedora 3 12th June 2009 09:55 PM
touchpad tap click doesn't work Pacopag Hardware & Laptops 2 18th June 2008 02:49 AM
Scrolling with Alps touchpad on Sony Vaio no worky thies Hardware & Laptops 3 29th April 2005 06:24 PM
Touchpad Scrolling linedpaper Hardware & Laptops 5 12th October 2004 09:37 PM


Current GMT-time: 15:49 (Thursday, 23-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Talavera Photos - Bhera Travel Photos - Ras al-Khaimah Photos on Instagram