Fedora Linux Support Community & Resources Center
  #1  
Old 26th August 2010, 01:49 PM
muhammad ammar Offline
Registered User
 
Join Date: Feb 2010
Posts: 42
linuxfedorafirefox
Disable Shutdown Messages

Hi All,

How to disable logging to console in Fedora 13? To get rid of messages like

Stopping HAL daemon: [ OK ]

and all other messages during shutdown and restart.

Actually, earlier when i shutdown the system only a single shutdown message is showing on the screen, i don't know what happened, now it is showing lot of messages.

i tried the quiet parameter in kernel boot parmeters but no effect.

Anyone have any idea?

Regards,
Reply With Quote
  #2  
Old 27th August 2010, 03:02 AM
stoat Offline
Registered User
 
Join Date: Jun 2006
Posts: 7,550
linuxfedorafirefox
Re: Disable Shutdown Messages

Quote:
Originally Posted by muhammad ammar

How to disable logging to console in Fedora 13? To get rid of messages like

Stopping HAL daemon: [ OK ]

and all other messages during shutdown and restart.

Actually, earlier when i shutdown the system only a single shutdown message is showing on the screen, i don't know what happened, now it is showing lot of messages.
I don't understand the connection between logging into Fedora 13 and those messages that you want to hide. Sorry. But in my experience, the kernel parameter "quiet" suppresses kernel debug spew that flies by very early during booting. For most of us, it is of very little value, so the quiet kernel parameter is added to the kernel command in grub.conf by default. That kernel parameter (whether present or not) does nothing regarding shutdown messages in my experience.

The kernel parameter "rhgb" in Fedora 13 runs the Plymouth graphical boot which hides those classic lines of text with [ OK ] or [FAILED] that are related to init stuff and services startup. I have noticed that removing the rhgb kernel parameter to allow those startup messages to be displayed also results in some similar messages being displayed at shutdown.

So, do you have rhgb in your kernel commands in grub.conf? If not, then add it.
Reply With Quote
  #3  
Old 27th August 2010, 06:48 AM
muhammad ammar Offline
Registered User
 
Join Date: Feb 2010
Posts: 42
linuxfedorafirefox
Re: Disable Shutdown Messages

Quote:
Originally Posted by stoat View Post
I don't understand the connection between logging into Fedora 13 and those messages that you want to hide. Sorry. But in my experience, the kernel parameter "quiet" suppresses kernel debug spew that flies by very early during booting. For most of us, it is of very little value, so the quiet kernel parameter is added to the kernel command in grub.conf by default. That kernel parameter (whether present or not) does nothing regarding shutdown messages in my experience.

The kernel parameter "rhgb" in Fedora 13 runs the Plymouth graphical boot which hides those classic lines of text with [ OK ] or [FAILED] that are related to init stuff and services startup. I have noticed that removing the rhgb kernel parameter to allow those startup messages to be displayed also results in some similar messages being displayed at shutdown.

So, do you have rhgb in your kernel commands in grub.conf? If not, then add it.
Sorry for confusion.

What i meant to say is that earlier when i use the poweroff command to shutdown the system, there is only a single shutdown message showing on screen, no other message.

yes, rhgb is present. I didn't change any kernel boot parameter.

I don't know the cause of problem, may be due to updates or removal of some package.
Reply With Quote
  #4  
Old 27th August 2010, 11:01 AM
marriedto51 Offline
Registered User
 
Join Date: Jul 2009
Location: England, UK
Posts: 897
linuxfedorafirefox
Re: Disable Shutdown Messages

I have always seen similar behaviour to muhammad ammar (I'm using 12, but saw the same thing with 9, 10, and 11).

For me, using the `rhgb' boot option in the `kernel=' line in the grub entry always suppresses the messages when booting up, but only sometimes does it suppress the messages when shutting down: sometimes I get a simple "Shutting down..." centred on the screen, but more often I get the "Stopping squid ... [OK]" messages.

I have never been able to find out why the shutdown messages are sometimes hidden and sometimes not; it seems to be different every time I shut the machine down!
Reply With Quote
  #5  
Old 29th August 2010, 12:03 AM
stoat Offline
Registered User
 
Join Date: Jun 2006
Posts: 7,550
linuxfedorafirefox
Re: Disable Shutdown Messages

Quote:
Originally Posted by marriedto51

For me, using the `rhgb' boot option in the `kernel=' line in the grub entry always suppresses the messages when booting up, but only sometimes does it suppress the messages when shutting down: sometimes I get a simple "Shutting down..." centred on the screen, but more often I get the "Stopping squid ... [OK]" messages.
Yeah me, too. But you know what? I don't know why we fret so much over the startup (and, I guess, shutdown) messages and the graphics to hide them (or not). Red Hat Graphical Boot always seemed to work. Now there's Plymouth, and for me it works on some machines and not others. I used to torture myself doing all of the published tweaks and workarounds to make it work (sometimes, and sometimes not). Nowadays, I couldn't care any less about it. If it works, good. If I have to watch the little colored bars have their race across the bottom of the screen, then that's good, too. And when I boot good old Debian Lenny, I get reminded all over again how inoffensive the classic messages are and have always been IMO. All of this rhgb and Plymouth business seems to me to be a lot of effort and development for nothing, really.
Reply With Quote
  #6  
Old 29th August 2010, 02:17 AM
skolnick Offline
Registered User
 
Join Date: Nov 2007
Posts: 108
linuxchrome
Re: Disable Shutdown Messages

Funny, the first thing I always do after installing fedora, is removing "rhgb" and "quiet" from the kernel lines...it gives linux a "geeky feeling" with all the kernel lines appearing as it boots. I love it :P.

Regards.
Reply With Quote
  #7  
Old 29th August 2010, 02:52 AM
jpollard Offline
Registered User
 
Join Date: Aug 2009
Location: Waldorf, Maryland
Posts: 6,777
linuxfedorafirefox
Re: Disable Shutdown Messages

It also lets you know when something starts acting strange...
Reply With Quote
  #8  
Old 29th August 2010, 06:28 AM
stevea Offline
Registered User
 
Join Date: Apr 2006
Location: Ohio, USA
Posts: 8,696
linuxfedorafirefox
Re: Disable Shutdown Messages

Those messages come from the services shutdown scripts.
It's a very bad idea to bypass service shutdown.
It's similar to hitting the power switch when you use "powerdown -f"


The nondestructive way to do this is by editing the line n /etc/init/rc.conf from:
console output
to
# console output

This comments out the "console output" command, which is explained in "man 5 init".
So then all the messages will go to /dev/null , and you won't see any errors if they occur.

I don't think it's usually a smart idea (but maybe you have a special application), but this is how you do it.

INcidentally this disavles console messages for any runstate chage (like "telinit 3" for example).
The exception is that the startup services messages are started from /etc/init/rcS.conf which
has the same line (near the top).
__________________
None are more hopelessly enslaved than those who falsely believe they are free.
Johann Wolfgang von Goethe

Last edited by stevea; 29th August 2010 at 06:42 AM.
Reply With Quote
Reply

Tags
console, fedora-13, logging

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Where do shutdown log messages go? dd_wizard F14 Development 2 4th August 2010 08:19 PM
shutdown messages crossfire Using Fedora 1 27th February 2009 09:37 PM
How to hide FC6 shutdown messages or use shutdown spash renjoyhenry Using Fedora 0 5th November 2006 05:09 AM
Shutdown messages narasim_7 Using Fedora 14 9th August 2005 07:30 PM


Current GMT-time: 14:52 (Friday, 25-07-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat