Fedora Linux Support Community & Resources Center
  #1  
Old 3rd January 2010, 10:30 PM
That Lame Thing Offline
Registered User
 
Join Date: Jan 2010
Posts: 11
linuxfedorafirefox
A total newb... and pulseaudio problems

I posted a topic earlier, mostly about my wireless, but the sound problem I mentioned having on Ubuntu seems to have followed me to Fedora. From the information I've gathered, it appears to be due to Pulseaudio.

Basically, I'm not very adept with Linux info outside the ordinary terminal commands for yum, sudo, yast, etc and I need to be able to either completely remove pulseaudio or disable it entirely somehow. From my experience on Ubuntu, just muting or disabling sound won't fix a thing... This problem doesn't seem to exist for me on Windows (though it would take a lot more than this to make me bother with that again), so I'm guessing it isn't anything too critical to fix (like a hardware problem or whatever else).

So, anyone here think they can help me, a very inexperienced linux user, solve this little nightmare and remove or disable pulseaudio? Between the two sounds (a sort of buzzing for no real reason and a slight popping when some sound effects happen), I'm in a pretty annoying position.

Hoping for some help, or if you need more info I can try to provide that, as well.
Reply With Quote
  #2  
Old 3rd January 2010, 10:59 PM
scottro Offline
Retired Community Manager -- Banned from Texas by popular demand.
 
Join Date: Sep 2007
Location: NYC
Posts: 8,132
linuxopera
You can try

yum remove pulseaudio

That has fixed it for me at times. The trouble is, I always wind up doing this, that, and the other, and never keep close track of what works and what doesn't.

The other trouble with that solution is that sometimes it breaks what isn't broken, or will take necessary programs with it, however, you can always give it a try, or do it with rpm -e --nodeps pulseaudio and see what happens. (You can always put it back with yum install pulseaudio).

Unfortunately, pulseaudio is one of those things that may, one day, be good--indeed, some people who have researched it in more detail sing its praises--but at the moment, it's one of the many things contributing to the fact that Windows does many things better than Linux does.
__________________
--
http://home.roadrunner.com/~computertaijutsu

Do NOT PM forum members with requests for technical support. Ask your questions on the forum.


"I don't know why there is the constant push to break any semblance of compatibility" --anon
Reply With Quote
  #3  
Old 4th January 2010, 03:34 AM
That Lame Thing Offline
Registered User
 
Join Date: Jan 2010
Posts: 11
linuxfedorafirefox
Well, I used "rpm -e --nodeps pulseaudio" and now I have no sound, even the little volume setting speaker icon is gone. I've read of an EsounD thing or something, I think... I'm thinking that was an alternative to pulseaudio? Could this be of use to me, or is there another thing I could use in this situation?

Thanks, seriously!
Reply With Quote
  #4  
Old 4th January 2010, 03:46 AM
robert-e Offline
Registered User
 
Join Date: May 2008
Posts: 755
linuxfedorafirefox
Try OSSv4. Ther is a "how to" in a recent sticky. It works.
Bob
Reply With Quote
  #5  
Old 4th January 2010, 04:20 AM
scottro Offline
Retired Community Manager -- Banned from Texas by popular demand.
 
Join Date: Sep 2007
Location: NYC
Posts: 8,132
linuxopera
Yes, and if that doesn't work--as mentioned, you can always easily reinstall pulseaudio with


yum install pulseaudio.

Sorry it didn't fix your issue and put you in a worse place than before. That's one of the joys of pulseaudio, one dayk, or on one install, sound won't work with it and on another day, or another install, sound won't work with it.

I haven't yet tried the OSS4 tutorial, but plan to do so--it worked quite well for me on ArchLinux.
__________________
--
http://home.roadrunner.com/~computertaijutsu

Do NOT PM forum members with requests for technical support. Ask your questions on the forum.


"I don't know why there is the constant push to break any semblance of compatibility" --anon
Reply With Quote
  #6  
Old 4th January 2010, 04:24 AM
That Lame Thing Offline
Registered User
 
Join Date: Jan 2010
Posts: 11
linuxfedorafirefox
hmm... this should work for me as soon as I figure out how to properly use the cd command (assuming I'm on the right tutorial at http://forums.fedoraforum.org/showthread.php?p=1313960 ) and until then, I don't mind being without sound as much as I was bothered by the popping... lol
Reply With Quote
  #7  
Old 4th January 2010, 09:44 AM
glennzo Online
Un-Retired Administrator
 
Join Date: Mar 2004
Location: Salem, Mass USA
Age: 57
Posts: 14,875
linuxfirefox
If you're in the middle of re-installing PulseAudio have a look here when you're finished, https://fedoraproject.org/wiki/Commo...audio_adapters. Don't know for sure that it will apply to your situation but it only takes a few seconds to check.
__________________
Glenn
The Bassinator © ®

[SIGPIC][/SIGPIC]
Laptop: Just a couple of old single core units
Desktop: BioStar MCP6PB M2+ / AMD Phenom 9750 Quad Core / 4GB / Kingston HyperX 3K SSD 240GB SATA 3.0 / 1TB SATA / EVGA GeForce 8400 GS 1GB
Reply With Quote
  #8  
Old 4th January 2010, 10:40 AM
sonoran Offline
Registered User
 
Join Date: May 2005
Location: Sonoran Desert
Posts: 2,421
linuxmozilla
Hi That Lame Thing-
This is a good thread on your issue:

http://forums.fedoraforum.org/showthread.php?t=173478

Note AdamW's post #7 with the links to the wiki pages on debugging audio problems. As an end user you just want your sound to work, which is understandable. Fedora, and this forum, are community efforts, so you might want to consider pitching in and contributing by trying to debug your problem and filing a report.

On fedora PulseAudio works fine for me; on Arch Linux I use ossv4. When in Rome...
Reply With Quote
  #9  
Old 4th January 2010, 07:26 PM
That Lame Thing Offline
Registered User
 
Join Date: Jan 2010
Posts: 11
linuxfedorafirefox
Hey, thanks, Sonoran! I reinstalled PA and removed the alsa plugin thing and this appears to be an excellent workaround for now, at least until I figure out how to get sound effects in fedora working again (I might have disabled them myself for all I can remember, but it's still weird... no problem there, though).

Nice workaround until I can figure things out better.
Reply With Quote
  #10  
Old 4th January 2010, 11:55 PM
Aolean Offline
Registered User
 
Join Date: Jan 2010
Posts: 3
linuxfedorafirefox
pulseaudio memory leak

Hello,

Well, I too have problems with pulseaudio, but before deinstalling like explained in this post I would like to know if someone else had memory leak problems with it ?
The sound for me is just perfect, but I end with pulseaudio consuming more than 2Gb of RAM.
On Ubuntu forums, it seems that there was an incompatibility between udev and pulseaudio, a workaround was to downgrade to the previous version of udev. Has someone heard about this with Fedora ?

Thanks,

Seb
Reply With Quote
  #11  
Old 5th January 2010, 03:38 AM
jdayrutherford Offline
Registered User
 
Join Date: Jan 2010
Posts: 1
linuxfedorafirefox
pulesaudio memory leak

yes, I have this problem also. I have a system 76 laptop that came with ubuntu. when I
upgraded to the 9.10 version it started. After a short tme pulseaudio will consume all available
ram.

It is said to be a problem with udev on ubuntu forums but to date I have not seen a patch. I have even
run the next beta version of ubuntu and the problem is still there.

So....I thought I would give Fedora a try. Its been a while since I ran fedora, but it installed fine and
runs quite nicely, perhaps better than Ubuntu in some ways...but the issue with pulseaudio is
identical. Give it a couple of hours and all of my 4GB of ram are gone. Killall pulseaudio
fresets the counter but that is all.

John
Reply With Quote
  #12  
Old 5th January 2010, 03:52 AM
dd_wizard Offline
Registered User
 
Join Date: Sep 2009
Posts: 1,484
linuxfirefox
The memory leak deserves a bug report, imho. I'm on a Toshiba laptop, and don't see that issue. Be sure to include your hardware in the bug report. If you're adventerous, set up PA to not respawn and start it inside valgrind.

dd_wizard
Reply With Quote
  #13  
Old 9th January 2010, 07:35 PM
Aolean Offline
Registered User
 
Join Date: Jan 2010
Posts: 3
linuxfedorafirefox
done here :
https://bugzilla.redhat.com/show_bug.cgi?id=552932

Please come and help if you have the same problem !
Reply With Quote
Reply

Tags
buzzing, pulseaudio, sound, sounds

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I(total newb) increase my swap space ? Ry J Using Fedora 6 23rd January 2009 08:34 PM
Nvidia Driver Problems - Not total noob boxxa Using Fedora 5 16th May 2007 12:32 PM
Total newb. no GUI calavera Installation, Upgrades and Live Media 4 29th September 2006 02:44 AM
C++ Compiler total NEWB! rambone Installation, Upgrades and Live Media 7 30th January 2006 03:10 AM
Total Newb Question Nezmin2 Using Fedora 1 19th October 2005 10:33 PM


Current GMT-time: 17:17 (Sunday, 28-12-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
...Paradisus Palma Real In Punta Cana, Dominican Republic Travel Photos on Instagram - Zuma Istanbul Travel Photos - Balboa Candy Travel Photos