Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > The Dungeon > Archived (Click Header To See Sub-Forums) > Alpha, Beta & Snapshots Discussions (Fedora 11 Only)
FedoraForum Search

Forgot Password? Join Us!

Alpha, Beta & Snapshots Discussions (Fedora 11 Only) Post Development Version comments and questions that don't belong in Bugzilla here. These posts will be moved or deleted once the Final version is released

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 3rd June 2009, 11:01 AM
CraigWatson Offline
Registered User
 
Join Date: Jan 2008
Location: Witham, Essex, UK
Age: 27
Posts: 341
F11 - Yum Problems after PreUpgrade

Hey everyone,
Having some problems running yum after doing a preupgrade from F10 to Rawhide. Yum worked perfectly in F10, but now reports metalink.xml errors and timeouts depending on the config.

My setup is a local Squid proxy, authenticating to an MS ISA proxy. Squid is working file as I have Firefox and Pidgin running through it as well as a few external machines. Local proxy settings are all pointed to 127.0.0.1, port 8080, both in the GUI setup and terminal environment variables:

Code:
[root@khashoggi ~]# echo $http_proxy
http://127.0.0.1:8080
With no changes to the yum.conf file, yum hangs on "Determining fastest mirrors" (I have yum-fastestmirror installed). With "proxy=http://127.0.0.1:8080" in the yum.conf file, I get:

Code:
[root@khashoggi ~]# yum update
Loaded plugins: dellsysidplugin2, fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
fedora/metalink                                          |   15 B     00:00     
Could not parse metalink https://mirrors.fedoraproject.org/metalink?repo=fedora-11&arch=x86_64 error was 
No repomd file
Error: File /var/cache/yum/fedora/metalink.xml does not exist
Just wondering if it could be a bug with this version of yum and proxying? I can't even do a "yum repolist", as it times out there as well. Here are the repos I have installed:

Code:
[root@khashoggi ~]# ls -l /etc/yum.repos.d/*.repo
-rw-r--r--. 1 root root  179 2007-07-25 21:45 /etc/yum.repos.d/adobe-linux-i386.repo
-rw-r--r--. 1 root root 1785 2009-05-11 23:45 /etc/yum.repos.d/fedora-rawhide.repo
-rw-r--r--. 1 root root 1144 2009-05-11 23:45 /etc/yum.repos.d/fedora.repo
-rw-r--r--. 1 root root 1105 2009-05-11 23:45 /etc/yum.repos.d/fedora-updates.repo
-rw-r--r--. 1 root root 1163 2009-05-11 23:45 /etc/yum.repos.d/fedora-updates-testing.repo
-rw-r--r--. 1 root root 1301 2009-05-17 16:16 /etc/yum.repos.d/rpmfusion-free-rawhide.repo
-rw-r--r--. 1 root root 1076 2009-03-26 12:35 /etc/yum.repos.d/rpmfusion-free.repo
-rw-r--r--. 1 root root 1131 2009-03-26 12:34 /etc/yum.repos.d/rpmfusion-free-updates.repo
-rw-r--r--. 1 root root 1260 2009-05-17 16:16 /etc/yum.repos.d/rpmfusion-free-updates-testing.repo
-rw-r--r--. 1 root root 1355 2009-05-17 16:20 /etc/yum.repos.d/rpmfusion-nonfree-rawhide.repo
-rw-r--r--. 1 root root 1247 2009-05-17 16:20 /etc/yum.repos.d/rpmfusion-nonfree.repo
-rw-r--r--. 1 root root 1245 2009-05-17 16:20 /etc/yum.repos.d/rpmfusion-nonfree-updates.repo
-rw-r--r--. 1 root root 1305 2009-05-17 16:20 /etc/yum.repos.d/rpmfusion-nonfree-updates-testing.repo
Code:
[root@khashoggi ~]# grep enabled=1 /etc/yum.repos.d/*.repo
/etc/yum.repos.d/adobe-linux-i386.repo:enabled=1
/etc/yum.repos.d/fedora.repo:enabled=1
/etc/yum.repos.d/fedora-updates.repo:enabled=1
/etc/yum.repos.d/rpmfusion-free.repo:enabled=1
/etc/yum.repos.d/rpmfusion-free-updates.repo:enabled=1
/etc/yum.repos.d/rpmfusion-nonfree.repo:enabled=1
/etc/yum.repos.d/rpmfusion-nonfree-updates.repo:enabled=1
Apart from that, all working fine
__________________
Personal Website | Windows to Linux - Tips from Experience

Desktop - Galileo
Dual-Boot: Fedora 13 x64, Windows 7 x64
Intel Core2Quad Q6600 @3.6GHz, 8GB PC2-8500 DDR2, ATI HD4870, 23" @ 1920x1080 + 20" @ 1600x900 (both DVI-D), 2TB ICH10R RAID0 array, Custom Watercooling

Laptop - MacBook 5.1 ('08 Aluminium)
Dual-Boot: Fedora 13 x64, Apple OS X
Intel Core2Duo, 2GB 1066MHz DDR3, nVidia 9400M, 13" LCD @ 1280x800, 160GB SATA

Last edited by CraigWatson; 3rd June 2009 at 11:04 AM.
 

Tags
f11, proxy, rawhide, yum

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] F11 Problems with NVidia Driver After PreUpgrade sdlor Using Fedora 34 18th June 2009 05:15 AM
preupgrade from fc7 to fc9 Amrita Installation, Upgrades and Live Media 1 9th June 2009 10:16 AM
F9 to F10 using preupgrade ssam Alpha, Beta & Snapshots Discussions (Fedora 10 Only) 6 19th November 2008 08:42 PM
F8 -> F9 with preupgrade can i use kde 3.5 ejgutierrez Installation, Upgrades and Live Media 2 20th July 2008 04:33 AM
PreUpgrade Helker Installation, Upgrades and Live Media 2 24th June 2008 08:14 AM


Current GMT-time: 18:15 (Saturday, 30-08-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat