Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > The Dungeon > Archived (Click Header To See Sub-Forums) > Alpha, Beta & Snapshots Discussions (Fedora 10 Only)
FedoraForum Search

Forgot Password? Join Us!

Alpha, Beta & Snapshots Discussions (Fedora 10 Only) Post Development Version comments and questions that don't belong in Bugzilla here. These posts will be moved or deleted once the Final version is released

 
 
Thread Tools Search this Thread Display Modes
  #1  
Old 23rd November 2008, 04:44 PM
crainey69 Offline
Registered User
 
Join Date: Oct 2007
Location: Macon, MO
Age: 45
Posts: 330
hate to do this. mp3's in Amarok

Hello all!

Been a part of this forum since Fedora 7 and have watched tons of threads about mp3 playback that could have been simply answered with a search. I find myself in a problem though. I can't get mp3 playback in amarok working.

What am I missing. I have all of the rpmfusion repos active and even added livna back but, I can't seem to find the plugins?

Thanks

Cory
  #2  
Old 23rd November 2008, 04:54 PM
glennzo Offline
Un-Retired Administrator
 
Join Date: Mar 2004
Location: Salem, Mass USA
Age: 57
Posts: 14,768
Hey Crainey. I don't usually use Amarok. Mauriat Miranda's site says sudo yum install amarok amarok-extras-freeworld amarok-visualisation as part of the mp3 section. http://www.mjmwired.net/resources/mj...ra-f9.html#mp3 Wonder if this will help. Do mp3's play using other music players?
__________________
Glenn
The Bassinator © ®

[SIGPIC][/SIGPIC]
Laptop: Just a couple of old single core units
Desktop: BioStar MCP6PB M2+ / AMD Phenom 9750 Quad Core / 4GB / Kingston HyperX 3K SSD 240GB SATA 3.0 / 1TB SATA / EVGA GeForce 8400 GS 1GB
  #3  
Old 23rd November 2008, 10:11 PM
axel Offline
Registered User
 
Join Date: Apr 2005
Location: Thessaloniki, Greece
Posts: 290
With only rpmfusion enabled, livna disabled, try:

yum install amarok-extras-freeworld

Last edited by axel; 23rd November 2008 at 11:11 PM.
  #4  
Old 23rd November 2008, 10:42 PM
leigh123linux
Guest
 
Posts: n/a
amarok-extras-freeworld and amarok-extras-nonfree are meta packages i.e an empty package with deps .

Here's the doc from amarok-extras-freeworld

Quote:
Now that xine-lib is in Fedora, most additional functionalities are
provided by the libtunepimp-extras-freeworld (mp3 musicbrainz plugin)
and xine-lib-extras-freeworld (mp3 playback) packages.

Thus, this is only a virtual package which depends on
libtunepimp-extras-freeworld
xine-lib-extras-freeworld
to provide an upgrade path.

You can safely remove this package if you want to
.

To get mp3 working in amarok install xine-lib-extras-freeworld & libtunepimp-extras-freeworld


Code:
su
yum install xine-lib-extras-freeworld libtunepimp-extras-freeworld
  #5  
Old 24th November 2008, 02:31 PM
crainey69 Offline
Registered User
 
Join Date: Oct 2007
Location: Macon, MO
Age: 45
Posts: 330
Thanks guys!

Hated to even ask that question so I appreciate the help!

Cory
  #6  
Old 25th November 2008, 03:32 AM
crainey69 Offline
Registered User
 
Join Date: Oct 2007
Location: Macon, MO
Age: 45
Posts: 330
Other issues with Amarok I guess. I finally got VLC see to work but

Thanks for all of your help. I couldn't even get VLC running when I posted this do to errors. It is running now and playing all files but Amarok is having issues. I'll post the CLI output from Amarok below. Some of it makes sense to me (though I don't know how to fix it) and some of it looks like gibberish. Maybe one of the gurus can make sense of it. Also I'm getting some weird output in the CLI from time to time regarding to KDE issues (maybe related).

Output from Amarok below:

Quote:


WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
amarok: END__: void DatabaseUpdater::prepareTemporaryTables() - Took 0.45s
TagLib: MPEG::Header::parse() -- Invalid sample rate.
TagLib: MPEG::Header::parse() -- Invalid sample rate.
TagLib: MPEG::Header::parse() -- Invalid sample rate.
TagLib: MPEG::Header::parse() -- Invalid sample rate.
TagLib: MPEG::Header::parse() -- Invalid sample rate.
TagLib: MPEG::Header::parse() -- Invalid sample rate.
TagLib: MPEG::Header::parse() -- Invalid sample rate.
TagLib: MPEG::Header::parse() -- Invalid sample rate.
TagLib: ID3v2.4 no longer supports the frame type RVAD. It will be discarded from the tag.
TagLib: ID3v2.4 no longer supports the frame type RVAD. It will be discarded from the tag.
TagLib: ID3v2.4 no longer supports the frame type TDAT. It will be discarded from the tag.
TagLib: ID3v2.4 no longer supports the frame type TDAT. It will be discarded from the tag.
TagLib: MPEG::Header::parse() -- Invalid sample rate.
TagLib: MPEG::Header::parse() -- Invalid sample rate.
TagLib: MPEG::Header::parse() -- Invalid sample rate.
TagLib: MPEG::Header::parse() -- Invalid sample rate.
TagLib: MPEG::Header::parse() -- Invalid sample rate.
TagLib: MPEG::Header::parse() -- Invalid sample rate.
TagLib: MPEG::Header::parse() -- Invalid sample rate.
TagLib: MPEG::Header::parse() -- Invalid sample rate.
TagLib: MPEG::Header::parse() -- Invalid sample rate.
TagLib: MPEG::Header::parse() -- Invalid sample rate.
TagLib: ID3v2.4 no longer supports the frame type TDAT. It will be discarded from the tag.
TagLib: ID3v2.4 no longer supports the frame type TDAT. It will be discarded from the tag.
TagLib: ID3v2.4 no longer supports the frame type TDAT. It will be discarded from the tag.
TagLib: ID3v2.4 no longer supports the frame type TDAT. It will be discarded from the tag.
TagLib: ID3v2.4 no longer supports the frame type RVAD. It will be discarded from the tag.
TagLib: ID3v2.4 no longer supports the frame type RVAD. It will be discarded from the tag.
TagLib: ID3v2.4 no longer supports the frame type TDAT. It will be discarded from the tag.
TagLib: ID3v2.4 no longer supports the frame type TDAT. It will be discarded from the tag.
TagLib: ID3v2.4 no longer supports the frame type TDAT. It will be discarded from the tag.
TagLib: ID3v2.4 no longer supports the frame type TDAT. It will be discarded from the tag.
TagLib: MPEG::Header::parse() -- Invalid sample rate.
TagLib: MPEG::Header::parse() -- Invalid sample rate.
TagLib: ID3v2.4 no longer supports the frame type RVAD. It will be discarded from the tag.
TagLib: ID3v2.4 no longer supports the frame type RVAD. It will be discarded from the tag.
TagLib: ID3v2.4 no longer supports the frame type TDAT. It will be discarded from the tag.
TagLib: ID3v2.4 no longer supports the frame type TDAT. It will be discarded from the tag.
TagLib: ID3v2.4 no longer supports the frame type TDAT. It will be discarded from the tag.
TagLib: ID3v2.4 no longer supports the frame type TDAT. It will be discarded from the tag.
TagLib: ID3v2.4 no longer supports the frame type TDAT. It will be discarded from the tag.
TagLib: ID3v2.4 no longer supports the frame type TDAT. It will be discarded from the tag.
TagLib: ID3v2.4 no longer supports the frame type TDAT. It will be discarded from the tag.
TagLib: ID3v2.4 no longer supports the frame type TDAT. It will be discarded from the tag.
TagLib: ID3v2.4 no longer supports the frame type TDAT. It will be discarded from the tag.
TagLib: ID3v2.4 no longer supports the frame type TDAT. It will be discarded from the tag.
TagLib: MPEG::Header::parse() -- Invalid sample rate.
TagLib: MPEG::Header::parse() -- Invalid sample rate.
TagLib: MPEG::Header::parse() -- Invalid sample rate.
TagLib: MPEG::Header::parse() -- Invalid sample rate.
TagLib: MPEG::Header::parse() -- Invalid sample rate.
TagLib: MPEG::Header::parse() -- Invalid sample rate.
TagLib: ID3v2.4 no longer supports the frame type RVA. It will be discarded from the tag.
TagLib: ID3v2.4 no longer supports the frame type RVA. It will be discarded from the tag.
TagLib: MPEG::Header::parse() -- Invalid sample rate.
TagLib: MPEG::Header::parse() -- Invalid sample rate.
TagLib: ID3v2.4 no longer supports the frame type RVAD. It will be discarded from the tag.
TagLib: ID3v2.4 no longer supports the frame type RVAD. It will be discarded from the tag.
TagLib: MPEG::Header::parse() -- Invalid sample rate.
TagLib: MPEG::Header::parse() -- Invalid sample rate.
TagLib: ID3v2.4 no longer supports the frame type TDAT. It will be discarded from the tag.
TagLib: ID3v2.4 no longer supports the frame type TDAT. It will be discarded from the tag.
TagLib: ID3v2.4 no longer supports the frame type TDAT. It will be discarded from the tag.
TagLib: ID3v2.4 no longer supports the frame type TDAT. It will be discarded from the tag.
TagLib: MPEG::Header::parse() -- Invalid sample rate.
TagLib: MPEG::Header::parse() -- Invalid sample rate.
TagLib: MPEG::Header::parse() -- Invalid sample rate.
TagLib: MPEG::Header::parse() -- Invalid sample rate.
TagLib: MPEG::Header::parse() -- Invalid sample rate.
TagLib: MPEG::Header::parse() -- Invalid sample rate.
TagLib: MPEG::Header::parse() -- Invalid sample rate.
TagLib: MPEG::Header::parse() -- Invalid sample rate.
TagLib: MPEG::Header::parse() -- Invalid sample rate.
TagLib: MPEG::Header::parse() -- Invalid sample rate.

Snipit to get it to post

amarok: p after: QPoint(4,-6)
amarok: BEGIN: void ProgressBarNG::setDescription(const QString&)
amarok: END__: void ProgressBarNG::setDescription(const QString&) - Took 5.7e-05s
amarok: BEGIN: void StatusBar::hideProgress()
amarok: END__: void StatusBar::hideProgress() - Took 0.00012s
amarok: END__: void CompoundProgressBar::childBarComplete(ProgressBarN G*) - Took 0.00074s
amarok: END__: void Dynamic::BiasedPlaylist::solverFinished(ThreadWeav er::Job*) - Took 0.00086s

I had to trim some stuff off of the top down to some errors to get it to post. Continued in next post

Last edited by crainey69; 25th November 2008 at 03:34 AM. Reason: getting rid of smileys
  #7  
Old 25th November 2008, 03:33 AM
crainey69 Offline
Registered User
 
Join Date: Oct 2007
Location: Macon, MO
Age: 45
Posts: 330
Output when trying to play a mp3

As the title states:


Part of the output when trying to play a mp3:

Quote:

amarok: BEGIN: virtual void Context::ContextView::resizeEvent(QResizeEvent*)
amarok: BEGIN: void Context::ContextView::updateContainmentsGeometry()
amarok: cv rect: QRect(0,0 338x553)
amarok: width: 338
amarok: height: 553
amarok: newPos: 363 , 618
amarok: containment geometry: QRectF(363,618 358x613)
amarok: width: 338
amarok: height: 553
amarok: newPos: 0 , 618
amarok: containment geometry: QRectF(0,618 358x613)
amarok: width: 338
amarok: height: 553
amarok: newPos: 363 , 0
amarok: containment geometry: QRectF(363,0 358x613)
amarok: width: 338
amarok: height: 553
amarok: newPos: 0 , 0
amarok: containment geometry: QRectF(0,0 358x613)
amarok: END__: void Context::ContextView::updateContainmentsGeometry() - Took 0.0015s
amarok: END__: virtual void Context::ContextView::resizeEvent(QResizeEvent*) - Took 0.0016s
amarok: END__: virtual void Context::ContextView::resizeEvent(QResizeEvent*) - Took 0.0057s
QDir::exists: Empty or null file name
amarok: BEGIN: void Playlist::Actions::play(quint64, bool)
amarok: BEGIN: void EngineController::play(const Meta::TrackPtr&, uint)
amarok: BEGIN: void EngineController::playUrl(const KUrl&, uint)
amarok: BEGIN: void EngineController::slotStopFadeout()
amarok: END__: void EngineController::slotStopFadeout() - Took 7.9e-05s
amarok: [EngineController] URL: "file:///mnt/music/Jordin%20Sparks%20Ft.%20Chris%20Brown%20-%20No%20Air.mp3"
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
amarok: END__: void EngineController::playUrl(const KUrl&, uint) - Took 0.0011s
amarok: END__: void EngineController::play(const Meta::TrackPtr&, uint) - Took 0.0013s
amarok: END__: void Playlist::Actions::play(quint64, bool) - Took 0.0017s

Anybody have a clue?

Thanks
Cory
  #8  
Old 25th November 2008, 03:58 AM
crainey69 Offline
Registered User
 
Join Date: Oct 2007
Location: Macon, MO
Age: 45
Posts: 330
not sure if it is related or not but xine is getting a segmentation fault too.
  #9  
Old 25th November 2008, 04:12 AM
leigh123linux
Guest
 
Posts: n/a
Quote:
Originally Posted by crainey69 View Post
not sure if it is related or not but xine is getting a segmentation fault too.
https://bugzilla.redhat.com/show_bug.cgi?id=470686

http://bugzilla.rpmfusion.org/show_bug.cgi?id=125
  #10  
Old 25th November 2008, 04:24 AM
Pumpino Offline
Registered User
 
Join Date: Jun 2008
Location: Melbourne, Australia
Posts: 152
I can't play mp3s in Amarok either. I started another thread at http://forums.fedoraforum.org/showthread.php?t=205019. Just thought I'd post the link in case the issue is resolved in the future there rather than here.
  #11  
Old 25th November 2008, 04:54 AM
crainey69 Offline
Registered User
 
Join Date: Oct 2007
Location: Macon, MO
Age: 45
Posts: 330
Thanks Leigh

Still doesn't solve my Amarok problem but, I know it's not just me.
  #12  
Old 25th November 2008, 05:06 AM
crainey69 Offline
Registered User
 
Join Date: Oct 2007
Location: Macon, MO
Age: 45
Posts: 330
Firewing is here woohoo
  #13  
Old 25th November 2008, 11:15 AM
leigh123linux
Guest
 
Posts: n/a
Are you running selinux ? ( I don't and amarok works OK )

http://forums.fedoraforum.org/showthread.php?t=204979
  #14  
Old 25th November 2008, 11:40 AM
Pumpino Offline
Registered User
 
Join Date: Jun 2008
Location: Melbourne, Australia
Posts: 152
I'm not running SELinux.
  #15  
Old 28th November 2008, 09:54 PM
leigh123linux
Guest
 
Posts: n/a
Thread resurrected.


Quote:
Originally Posted by akaraivanov
Hi guys,

I got amarok running with F10.

Here is what i did (even though this might not be the shortest path)

* configured RPM fusion repository
* amarok uses phonon's engines to decode the audio. phonon has xine and gstreamer plugins in F10. xine did not work for me, so I installed gstreamer plugin for phonon. I have installed phonon-backend-gstreamer. that was not enough ...
* run totem with some mp3 files. It complains that it does not have decoders for mp3 and searches and installs more packages.
* at the and totem and amarok can play mp3

I have the following packages installed:
> rpm -qa |egrep 'phonon|gstream|amarok'
PackageKit-gstreamer-plugin-0.3.9-4.fc10.i386
phonon-4.2.0-7.fc10.i386
gstreamer-plugins-base-0.10.21-2.fc10.i386
gstreamer-plugins-flumpegdemux-0.10.15-4.fc10.i386
gstreamer-0.10.21-2.fc10.i386
amarok-1.94-2.fc10.i386
gstreamer-plugins-ugly-0.10.9-2.fc10.i386
gstreamer-tools-0.10.21-2.fc10.i386
gstreamer-python-0.10.12-1.fc10.i386
totem-gstreamer-2.24.3-1.fc10.i386
phonon-backend-xine-4.1.3-1.fc10.i386
gstreamer-plugins-good-0.10.11-1.fc10.i386
phonon-backend-gstreamer-4.2.0-7.fc10.i386

Hope that may help someone.
 

Tags
amarok, hate, mp3

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Amarok - Selectively playing m4a's/mp3's/ogg's rockytfox Using Fedora 2 4th March 2008 05:04 AM
MP3's in Amarok won't play Arodef5 Using Fedora 6 5th May 2006 03:32 PM
amaroK: no Xine engine available & cannot play mp3's AndyCooll Using Fedora 14 29th September 2005 06:02 PM
amarok no mp3's TranceDude Using Fedora 5 10th September 2005 09:28 AM
Amarok, Noatun only play some mp3's since upgrade from fc3 to fc4 schwedentod Using Fedora 7 15th August 2005 04:45 PM


Current GMT-time: 04:15 (Saturday, 25-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Novovolynsk - Sapele Photos - Gampola