Fedora Linux Support Community & Resources Center
  #1  
Old 28th November 2008, 03:48 PM
hinrich Offline
Registered User
 
Join Date: Nov 2008
Location: Cape Town - South Africa
Posts: 3
f9 kernel option CONFIG_IP_ROUTE_MULTIPATH_CACHED

Hi all

I just implemented a squid proxy running shorewall as firewall and load balancer under f9.

Kernel: 2.6.25-14.fc9.i686

The setup run fine except that shorewall doesn't seem to untilize the two ISP connections and favours one of them and I have the feeling that the balancing is not working properly:

If I just diconnect the defaultrouted ISP the internet connectivity for the proxy still persists via the default route.
If I disconnect the other 'non-defaultroute' ISP I have to restart the network service and shorewall before the proxy has connectivity again.

The shorewall documentation states that the kernel is caching the routes and will use the same ISP again and again.
Setting the Kernel Option CONFIG_IP_ROUTE_MULTIPATH_CACHED=n is supposed to solve this problem.

So I went to build a new Kernel with this option but can't find it. The only one comming close is: CONFIG_IP_ROUTE_MULTIPATH which is set to yes by default.

My question:

1) Am I barking up the wrong tree in trying to build a new Kernel?

a) if no: can I just add the Option CONFIG_IP_ROUTE_MULTIPATH_CACHED=n into the .config file before building the new kernel?

b) is the problem more likely based on the shorewall coniguration?


here my ifconfig:

eth0 Link encap:Ethernet HWaddr 00:0F:FE:1A:47:01
inet addr:172.16.2.4 Bcast:172.16.3.255 Mask:255.255.0.0

eth1 Link encap:Ethernet HWaddr 00:0A:5E:514:27
inet addr:192.168.0.2 Bcast:192.168.0.255 Mask:255.255.255.0

eth1:1 Link encap:Ethernet HWaddr 00:0A:5E:514:27
inet addr:192.168.0.11 Bcast:192.168.0.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Interrupt:22 Base address:0xcc00

eth1:2 Link encap:Ethernet HWaddr 00:0A:5E:514:27
inet addr:192.168.0.12 Bcast:192.168.0.255 Mask:255.255.255.0

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0

The virtual interfaces are configured by shorewall masq:

#INTERFACE SOURCE ADDRESS PROTO PORT(S) IPSEC MARK
eth1:1 eth0 192.168.0.11-192.168.0.12


Here my providers:

#NAME NUMBER MARK DUPLICATE INTERFACE GATEWAY OPTIONS COPY
ISP1 1 1 main eth1:1 192.168.0.101 balance
ISP2 2 2 main eth1:2 192.168.0.102 balance


192.168.0.101 and 102 are the two ISP router.


Would be great if somebody has some input for me!!

Thanks
Reply With Quote
Reply

Tags
balance, isp, kernel, multi, shorewall

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel option with Grub tkoco Using Fedora 3 15th February 2008 03:47 AM
Fedora 6 install kernel option leigh123linux Installation, Upgrades and Live Media 166 21st November 2007 12:38 PM
How to enable kernel option: REGPARM - Kernel: 2.6.14-1.1653_FC4 Camino Using Fedora 4 6th January 2006 07:48 PM
grub , local kernel option fire-fly Using Fedora 6 27th August 2005 09:32 AM
kernel 2.6, nvidia and the 4kstack option bazzoon Using Fedora 6 4th July 2004 04:30 AM


Current GMT-time: 15:46 (Wednesday, 23-04-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat