Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora Resources > Guides & Solutions (No Questions)
FedoraForum Search

Forgot Password? Join Us!

Guides & Solutions (No Questions) Post your guides here (No links to Blogs accepted). You can also append your comments/questions to a guide, but don't start a new thread to ask a question. Use another forum for that.

Closed Thread
 
Thread Tools Search this Thread Display Modes
  #1  
Old 21st November 2008, 11:06 PM
leigh123linux
Guest
 
Posts: n/a
F16,F15 & F14 Nvidia driver guides

Please note that I won't respond to any post's for help unless this basic information is included!


Code:
rpm -qa *\nvidia\*  *\kernel\*|sort;uname -r;lsmod |grep -e nvidia -e nouveau;cat /etc/X11/xorg.conf


__________________________________________________ _____________________________________

F16 Howto for the rpmfusion nvidia drivers



Click here for supported Nvidia cards list


This is a Four-Step Process. If you don't follow all three steps, your install will fail!



1. Update the kernel and reboot

Code:
su
yum update kernel\* selinux-policy\*
reboot
2. Install the nvidia driver.

For GeForce 6, 7, 8, 9, 200, 300, 400 & 500 series cards


Using akmod: This is the best option in my opinion as you don't get any problems when a new kernel is released.

__________________________________________________ __________________________________________________ __________
Extra step for PAE kernel only

Code:
su
yum install kernel-PAE-devel
__________________________________________________ __________________________________________________ ___________

Code:
su
yum --nogpgcheck install http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm
yum install akmod-nvidia xorg-x11-drv-nvidia-libs.i686




Or using kmod (which saves a bit of disk space but will have problems with every kernel update.)
( if you have 4Gb of RAM or more you will probably have a PAE kernel [32bit only] so follow the PAE part )

Code:
su
yum --nogpgcheck install http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm
yum install kmod-nvidia xorg-x11-drv-nvidia-libs.i686
If you use a PAE kernel

Code:
su
yum --nogpgcheck install http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm
yum install kmod-nvidia-PAE



3. Make sure nouveau is removed from initramfs



Code:
su
mv /boot/initramfs-$(uname -r).img /boot/initramfs-$(uname -r)-nouveau.img
dracut /boot/initramfs-$(uname -r).img $(uname -r)

4. Reboot

Last edited by leigh123linux; 22nd April 2011 at 06:22 PM. Reason: ....
  #2  
Old 21st November 2008, 11:30 PM
leigh123linux
Guest
 
Posts: n/a
F15 Nvidia driver guide

Please note that I won't respond to any post's for help unless this basic information is included!


Code:
rpm -qa *\nvidia\*  *\kernel\*|sort;uname -r;lsmod |grep -e nvidia -e nouveau;cat /etc/X11/xorg.conf


__________________________________________________ _____________________________________

F15 Howto for the rpmfusion nvidia drivers



Click here for supported Nvidia cards list


This is a Three-Step Process. If you don't follow all three steps, your install will fail!



1. Update the kernel and reboot

Code:
su
yum update kernel*
reboot
2. Install the nvidia driver.

For GeForce 6, 7, 8, 9, 200, 300, 400 & 500 series cards


Using akmod: This is the best option in my opinion as you don't get any problems when a new kernel is released.

__________________________________________________ __________________________________________________ __________
Extra step for PAE kernel only

Code:
su
yum install  kernel-PAE-devel
__________________________________________________ __________________________________________________ ___________

Code:
su
rpm -Uvh  http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm   http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm   
yum install akmod-nvidia  xorg-x11-drv-nvidia-libs.i686




Or using kmod (which saves a bit of disk space but will have problems with every kernel update.)
( if you have 4Gb of RAM or more you will probably have a PAE kernel [32bit only] so follow the PAE part )

Code:
su
rpm -Uvh   http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm     http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm    
yum install kmod-nvidia  xorg-x11-drv-nvidia-libs.i686
If you use a PAE kernel

Code:
su
rpm -Uvh   http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm     http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm    
yum install kmod-nvidia-PAE



For GeForce FX cards


Using akmod: This is the best option in my opinion as you don't get any problems when a new kernel is released.


Code:
su
rpm -Uvh   http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm     http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm   
yum install akmod-nvidia-173xx xorg-x11-drv-nvidia-173xx-libs.i686



Or using kmod (which saves a bit of disk space but will have problems with every kernel update.)

Code:
su
rpm -Uvh   http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm     http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm  
yum install kmod-nvidia-173xx xorg-x11-drv-nvidia-173xx-libs.i686
If you use a PAE kernel


Code:
su
rpm -Uvh   http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm     http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm
yum install kmod-nvidia-173xx-PAE



3. Reboot

4. If you would like plymouth as well
(optional)

Code:
su
yum install bootconf-gui
Then set you desired boot resolution from the menu launcher

Application / System / Boot configuration

There is a selinux issue that prevents gnomes-hell from starting (I hate it )



https://bugzilla.redhat.com/show_bug.cgi?id=694918

run

Code:
su
grep gnome-session-c /var/log/audit/audit.log | audit2allow -M nvidiaisbroken
semodule -i nvidiaisbroken.pp

__________________________________________________ __________________________________________________ _
If it fails to work check /boot/grub/grub.conf to see if nouveau is blacklisted, if not run.

1. Edit grub.conf


this command adds rdblacklist=nouveau option to /boot/grub/grub.conf



Code:
su -
sed -i '/root=/s|$| rdblacklist=nouveau nouveau.modeset=0|' /boot/grub/grub.conf
mv /boot/initramfs-$(uname -r).img /boot/initramfs-$(uname -r)-nouveau.img
dracut /boot/initramfs-$(uname -r).img $(uname -r)
2. Reboot



__________________________________________________ __________________________________________________ ______

If nouveau refuses to die try
Code:
su
yum erase xorg-x11-drv-nouveau
mv  /lib/modules/$(uname -r)/kernel/drivers/gpu/drm/nouveau/nouveau.ko        /lib/modules/$(uname -r)/kernel/drivers/gpu/drm/nouveau/nouveau.txt
mv /boot/initramfs-$(uname -r).img /boot/initramfs-$(uname -r)-nouveau.img
dracut /boot/initramfs-$(uname -r).img $(uname -r)

Last edited by leigh123linux; 3rd November 2010 at 09:19 AM. Reason: .
  #3  
Old 25th November 2008, 09:26 PM
leigh123linux
Guest
 
Posts: n/a
F14 Nvidia driver guide

F14 Howto for the rpmfusion nvidia drivers


Click here for supported Nvidia cards list


This is a Three-Step Process. If you don't follow all three steps, your install will fail!



1. Update the kernel and reboot

Code:
su
yum update kernel*
reboot
2. Install the nvidia driver. ( if you have 4Gb of RAM or more you will probably have a PAE kernel [32bit only] so follow the PAE part )

For GeForce 6, 7, 8, 9, 200, 300, 400 & 500 series cards


Using akmod: This is the best option in my opinion as you don't get any problems when a new kernel is released.

Code:
su
rpm -Uvh   http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm     http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm
yum install akmod-nvidia  xorg-x11-drv-nvidia-libs.i686




Or using kmod (which saves a bit of disk space but will have problems with every kernel update.)

Code:
su
rpm -Uvh   http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm     http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm
yum install kmod-nvidia  xorg-x11-drv-nvidia-libs.i686
If you use a PAE kernel

Code:
su
rpm -Uvh   http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm     http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm
yum install  kmod-nvidia-PAE




For GeForce FX cards



Using akmod: This is the best option in my opinion as you don't get any problems when a new kernel is released.

Code:
su
rpm -Uvh   http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm     http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm
yum install akmod-nvidia-173xx xorg-x11-drv-nvidia-173xx-libs.i686



Or using kmod (which saves a bit of disk space but will have problems with every kernel update.)

Code:
su
rpm -Uvh   http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm     http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm
yum install kmod-nvidia-173xx xorg-x11-drv-nvidia-173xx-libs.i686
If you use a PAE kernel


Code:
su
rpm -Uvh   http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm     http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm
yum install kmod-nvidia-173xx-PAE


For GeForce 4 and below

Using akmod: This is the best option in my opinion as you don't get any problems when a new kernel is released.

Code:
su
rpm -Uvh   http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm     http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm
yum install akmod-nvidia-96xx xorg-x11-drv-nvidia-96xx-libs.i686




Or using kmod (which saves a bit of disk space but will have problems with every kernel update.)

Code:
su
rpm -Uvh   http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm     http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm
yum install kmod-nvidia-96xx xorg-x11-drv-nvidia-96xx-libs.i686
If you use a PAE kernel


Code:
su
rpm -Uvh   http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm     http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm
yum install kmod-nvidia-96xx-PAE
3. Reboot

4. If you would like plymouth as well


Code:
su
yum install bootconf-gui
Then set you desired boot resolution from the menu launcher

Application / System / Boot configuration


__________________________________________________ __________________________________________________ _________________________

If it fails to work check /boot/grub/grub.conf to see if nouveau is blacklisted, if not run.

1. Edit grub.conf


this command adds rdblacklist=nouveau option to /boot/grub/grub.conf



Code:
su -
sed -i '/root=/s|$| rdblacklist=nouveau nouveau.modeset=0|' /boot/grub/grub.conf
mv /boot/initramfs-$(uname -r).img /boot/initramfs-$(uname   -r)-nouveau.img
dracut /boot/initramfs-$(uname -r).img $(uname -r)
2. Reboot

Last edited by leigh123linux; 3rd November 2010 at 09:19 AM. Reason: .
  #4  
Old 26th November 2008, 07:27 PM
slune Offline
Registered User
 
Join Date: Apr 2006
Posts: 36
hi i've installed nvidia driver to my new F10 x64 and i have one problem. When I try run system-config-display I get this error.
I used quide on this page.

Quote:
Traceback (most recent call last):
File "/usr/share/system-config-display/xconf.py", line 312, in <module>
hardware_state = XF86HardwareState(xconfig)
File "/usr/lib64/python2.5/site-packages/rhpxl/xhwstate.py", line 174, in __init__
self.init_from_xconfig(xconfig)
File "/usr/lib64/python2.5/site-packages/rhpxl/xhwstate.py", line 260, in init_from_xconfig
if screen.device:
AttributeError: 'NoneType' object has no attribute 'device'
and with wine

Quote:
fixme:win:EnumDisplayDevicesW ((null),0,0x39edbc,0x00000000), stub!
err:d3d:WineD3D_CreateFakeGLContext Can't find a suitable iPixelFormat
err:d3d:InitAdapters Failed to get a gl context for default adapter
err:d3d:WineDirect3DCreate Direct3D9 is not available without opengl
err:d3d:WineDirect3DCreate Direct3D9 is not available without opengl
I think that this is the same problem.
Thx for help.
  #5  
Old 26th November 2008, 07:36 PM
leigh123linux
Guest
 
Posts: n/a
Quote:
Originally Posted by slune View Post
hi i've installed nvidia driver to my new F10 x64 and i have one problem. When I try run system-config-display I get this error.
I used quide on this page.



and with wine



I think that this is the same problem.
Thx for help.

Post

Code:
glxinfo
Code:
rpm -qa |grep nvidia

and
Code:
cat /etc/X11/xorg.conf
  #6  
Old 26th November 2008, 07:52 PM
slune Offline
Registered User
 
Join Date: Apr 2006
Posts: 36
I tried upload files but there was error so i've used my dropbox sorry.

http://dl.getdropbox.com/u/123005/glxinfo.txt
http://dl.getdropbox.com/u/123005/rpm.txt
http://dl.getdropbox.com/u/123005/xorg.conf.txt
  #7  
Old 26th November 2008, 08:08 PM
leigh123linux
Guest
 
Posts: n/a
Quote:
Originally Posted by slune View Post

Ok edit xorg.conf to


Code:
# Xorg configuration created by livna-config-display

Section "Files"
	ModulePath   "/usr/lib64/xorg/modules/extensions/nvidia"
	ModulePath   "/usr/lib64/xorg/modules/drivers"
	ModulePath   "/usr/lib64/xorg/modules"
EndSection

Section "ServerFlags"
	Option	    "AIGLX" "on"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "nvidia"
	Option	    "AddARGBGLXVisuals" "True"
EndSection

Section "Extensions"
	Option	    "Composite" "Enable"
EndSection
Don't forget to restartX after editing.

and try reinstalling system-config-display & rhpxl

Code:
su
yum reinstall system-config-display rhpxl
as for the wine error I don't know , it should work as glxinfo says you have openGL .

Code:
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce 9800M GTS/PCI/SSE2
OpenGL version string: 2.1.2 NVIDIA 177.82
OpenGL shading language version string: 1.20 NVIDIA via Cg compiler
OpenGL extensions:
  #8  
Old 26th November 2008, 08:32 PM
slune Offline
Registered User
 
Join Date: Apr 2006
Posts: 36
I've changed my xorg, reboot(for sure ), reinstall and there is no change. I tried uninstall nvidia driver, delete xorg.conf and reboot everything works fine of course no compiz-fusion etc.. With nvidia driver i have still problem with system-config-display and wine.
  #9  
Old 26th November 2008, 09:01 PM
tux4me Offline
Registered User
 
Join Date: Nov 2008
Location: Denmark
Age: 47
Posts: 96
I downloaded http://rpm.livna.org/livna-release-9.rpm
Update
it then updates to livna-release-10
Update
it then installs RPM Fusion Repos.

Then its business as usual (for Livna users)

BUT !!!

My EVE-Online game, witch i run though Wine, ran perfect and smooth on F9 dist with Nvidia.
Now it dosent run smooth any more, and some options is gone in the games graphic config

I have no idea where the problem lies, but had i known this, i would have stayed on F9 and never updated

So if you are playing EVE-Online , my advise is to forget F10 ...... for now ... (big ALSA sound issues too, with Wine)
  #10  
Old 27th November 2008, 12:59 AM
Unlimited Offline
Registered User
 
Join Date: Jun 2005
Posts: 48
I followed the instructions to the letter, however I'm getting this dependency issue.

Quote:
--> Finished Dependency Resolution
livna-config-display-0.0.22-1.fc10.noarch from rpmfusion-nonfree has depsolving problems
--> Missing Dependency: system-config-display is needed by package livna-config-display-0.0.22-1.fc10.noarch (rpmfusion-nonfree)
Error: Missing Dependency: system-config-display is needed by package livna-config-display-0.0.22-1.fc10.noarch (rpmfusion-nonfree)
I'm not sure if this is a temporary issue with the repo or what. Any ideas?
  #11  
Old 27th November 2008, 07:26 AM
Unlimited Offline
Registered User
 
Join Date: Jun 2005
Posts: 48
Okay, I got things installed, but I have the sneaking suspicion I did way more work than I had too.

Just in case, here what I did.

1. Grabbed system-config-display source rpm: http://rpmfind.net//linux/RPM/fedora...10.noarch.html

2. Grabbed dependencies needed for rpmbuild: yum install gettext intltool rpm-build

3. rpmbuild --rebuild system-config-display-1.1.1-1.fc10.src.rpm

4. Grabbed dependencies to install the outputted binary RPM: http://rpm.pbone.net/index.php3/stat....i386.rpm.html

5. rpm -Uvh system-config-display-1.1.1-1.fc10.noarch.rpm

6. yum install kmod-nvidia-173xx xorg-x11-drv-nvidia-173xx-libs.i386

Everything went smoothly from there. Now, some side information here, I installed FC10 from the Live-CD, is this related to some of the missing dependencies?
Am I the only one to have experienced this problem (I can hardly imagine I am, though things seem to be working for everyone else in this thread :-/ )?
Am I simply missing another repo that contains system-config-display, or otherwise why isn't it showing up for me?
It's also worth noting that xorg-x11-drv-nvidia-173xx-libs.x86_64 does not appear to be in my repositories either.

I am running a fresh install of FC10 (from Live-CD) with an NVidia GeForce fx5500 for reference.
  #12  
Old 27th November 2008, 07:51 AM
Unlimited Offline
Registered User
 
Join Date: Jun 2005
Posts: 48
Apparently I spoke too soon.

I rebooted and hardware acceleration is working (as evidenced by glxgears), however system-config-display gives the following error:
Quote:
Traceback (most recent call last):
File "/usr/share/system-config-display/xconf.py", line 312, in <module>
hardware_state = XF86HardwareState(xconfig)
File "/usr/lib/python2.5/site-packages/rhpxl/xhwstate.py", line 175, in __init__
self.init_from_xconfig(xconfig)
File "/usr/lib/python2.5/site-packages/rhpxl/xhwstate.py", line 261, in init_from_xconfig
if screen.device:
AttributeError: 'NoneType' object has no attribute 'device'
I have little doubt this is related to the very roundabout way I had to go of finding and installing it.

Also, prior to the driver installation (and the primary reason I wanted it installed) I was only able to set a max resolution of 800x600. Now it seems my only options are 640x480 & 320x240. So things are actually worse in terms of usability. The irony here is not lost on me, and it would almost be funny if it wasn't so annoying.

Mind you, in prior versions of Fedora I have always used the binary drivers as provided direction from NVidia in .sh form. Of course, the current version of those don't even build at the moment. So what are my options here? I'm starting a torrent of the normal install media tonight, and hopefully reinstalling with that will fix these issues or a working solution will be available by the time the download is done. Otherwise, I guess it's Ubuntu for a month until Fedora sorts their stuff out. I guess I should have known better than to try and install a fresh Fedora release over the holiday when I need my desktop to work without me working on it. (Don't read me wrong here, I love Fedora, but this sort of thing always seems to happen with new releases right off the bat)
  #13  
Old 27th November 2008, 09:16 AM
leigh123linux
Guest
 
Posts: n/a
Quote:
Originally Posted by Unlimited View Post
Apparently I spoke too soon.

I rebooted and hardware acceleration is working (as evidenced by glxgears), however system-config-display gives the following error:


I have little doubt this is related to the very roundabout way I had to go of finding and installing it.

Also, prior to the driver installation (and the primary reason I wanted it installed) I was only able to set a max resolution of 800x600. Now it seems my only options are 640x480 & 320x240. So things are actually worse in terms of usability. The irony here is not lost on me, and it would almost be funny if it wasn't so annoying.

Mind you, in prior versions of Fedora I have always used the binary drivers as provided direction from NVidia in .sh form. Of course, the current version of those don't even build at the moment. So what are my options here? I'm starting a torrent of the normal install media tonight, and hopefully reinstalling with that will fix these issues or a working solution will be available by the time the download is done. Otherwise, I guess it's Ubuntu for a month until Fedora sorts their stuff out. I guess I should have known better than to try and install a fresh Fedora release over the holiday when I need my desktop to work without me working on it. (Don't read me wrong here, I love Fedora, but this sort of thing always seems to happen with new releases right off the bat)

Try using nvidia-settings


Code:
su -
nvidia-settings

Then use it to setup you monitor and save the changes to xorg.conf
  #14  
Old 27th November 2008, 03:30 PM
mpolo Offline
Registered User
 
Join Date: Jun 2005
Posts: 197
Quote:
You may need to edit xorg.conf for compiz to work.
Is there a particular reason that this doesn't get done automatically?

Thanks for the information, you saved me a whole lot of frustration on getting compiz back after the upgrade from 9 to 10 (which actually went pretty smoothly, though it still took several hours to get back to a productive mode...)
  #15  
Old 27th November 2008, 04:59 PM
Unlimited Offline
Registered User
 
Join Date: Jun 2005
Posts: 48
Quote:
Try using nvidia-settings

Then use it to setup you monitor and save the changes to xorg.conf
Hm, I guess I should have mentioned that nvidia-settings is where I see my only two resolution options. Hitting "Detect Displays" doesn't change anything. These drivers seem determined to believe my 20" CRT is a 640x480 screen. :-/ Is there a way to override this nonsense by editing the xorg.conf directly?
Closed Thread

Tags
drivers, fedora 14, fedora 15, fedora 16, guide, nvidia

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
rescue after failed nvidia driver install? restore nouveau or basic video driver? Icm76 Using Fedora 11 14th January 2012 03:23 AM
Nvidia set up guides. sepoto Using Fedora 2 5th March 2011 05:11 AM
nVidia Driver Guides & Autoten: Thanks! Hobashira Fedora Focus 0 12th November 2010 07:29 AM
msi n220gt series not working with Nvidia driver guides top of page davidvandoren Hardware & Laptops 0 7th September 2010 06:52 PM
FC11 nVidia No Sound After RPMFusion nVidia Driver Load basimmer Using Fedora 0 16th October 2009 12:46 AM


Current GMT-time: 18:04 (Friday, 24-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Rabigh Travel Photos on Instagram - Yao - Sig Travel Photos