Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > The Dungeon > Archived (Click Header To See Sub-Forums) > Alpha, Beta & Snapshots Discussions (Fedora 10 Only)
FedoraForum Search

Forgot Password? Join Us!

Alpha, Beta & Snapshots Discussions (Fedora 10 Only) Post Development Version comments and questions that don't belong in Bugzilla here. These posts will be moved or deleted once the Final version is released

 
 
Thread Tools Search this Thread Display Modes
  #16  
Old 21st October 2008, 10:36 PM
Quasar8000 Offline
Registered User
 
Join Date: Jun 2008
Posts: 111
A quick update: After some searching, I discovered that since the 2.6.27 kernel is supposed to take care of the wireless toggling, there's no need for the WLAN state switch in /sys/devices/platform/eeepc anymore. Instead, this functionality can now be accessed through /sys/class/rfkill/rfkill0/state, which can be used to turn the WLAN on (echo 1 > /sys/class/rfkill/rfkill0/state) or off (echo 0 > /sys/class/rfkill/rfkill0/state). The good news is that there's also a control for the bluetooth at /sys/class/rfkill/rfkill1/state, the bad news is that it doesn't seem to be working yet. All the other problems I mentioned above are still unchanged. I hope the coming kernel releases fix those issues.
  #17  
Old 30th October 2008, 01:58 AM
Duli Offline
Registered User
 
Join Date: Jul 2006
Location: Sao Paulo, SP - Brazil
Age: 35
Posts: 702
Quote:
Originally Posted by Quasar8000 View Post
A quick update: After some searching, I discovered that since the 2.6.27 kernel is supposed to take care of the wireless toggling, there's no need for the WLAN state switch in /sys/devices/platform/eeepc anymore. Instead, this functionality can now be accessed through /sys/class/rfkill/rfkill0/state, which can be used to turn the WLAN on (echo 1 > /sys/class/rfkill/rfkill0/state) or off (echo 0 > /sys/class/rfkill/rfkill0/state). The good news is that there's also a control for the bluetooth at /sys/class/rfkill/rfkill1/state, the bad news is that it doesn't seem to be working yet. All the other problems I mentioned above are still unchanged. I hope the coming kernel releases fix those issues.
Yep, I'm on 2.6.27.4-51.fc10.i686 here on Eee PC 701. The echo 0 turns wireless light off, but the antenna seems to be on and capturing surround wireless devices, altough I'm not able to connect to them anymore.

Then, if I issue echo 1 again, it doesn't get back again normally. I'm unable to connect to any network available.

Any other way of manually disabling and enabling wlan card?
  #18  
Old 1st November 2008, 11:34 PM
Quasar8000 Offline
Registered User
 
Join Date: Jun 2008
Posts: 111
Quote:
Originally Posted by Duli View Post
Yep, I'm on 2.6.27.4-51.fc10.i686 here on Eee PC 701. The echo 0 turns wireless light off, but the antenna seems to be on and capturing surround wireless devices, altough I'm not able to connect to them anymore.

Then, if I issue echo 1 again, it doesn't get back again normally. I'm unable to connect to any network available.

Any other way of manually disabling and enabling wlan card?
That could be due to the fact that the Eee PC 701 uses a MadWifi driver. I think the procedure to turn off MadWifi drivers is not the same as the procedure to turn off Ralink's drivers. Unfortunately I don't have a 701 so I can't help much there, but I can suggest a couple of things based on the script used to enable/disable WLAN using Fn+F2 under Fedora 9. To stop the WLAN completely try the following commands:
Code:
rmmod ath_pci
rmmod ath_rate_sample
rmmod wlan_scan_sta
rmmod wlan_tkip
rmmod wlan_wep
rmmod wlan
Then issue the echo 0 command. To enable WLAN reception again, try issuing echo 1 then
Code:
modprobe ath_pci
Hopefully this would work, please let us know if it does.
  #19  
Old 3rd November 2008, 10:51 PM
Duli Offline
Registered User
 
Join Date: Jul 2006
Location: Sao Paulo, SP - Brazil
Age: 35
Posts: 702
Hello, Quasar8000:

This is what has worked for Eee PC + F10:

Code:
service NetworkManager stop
modprobe pciehp pciehp_force=1
ifconfig wlan0 down
rmmod ath5k
echo 0 > /sys/class/rfkill/rfkill0/state
rmmod pciehp
service NetworkManager start
Then, to turn the wireless back on:

Code:
service NetworkManager stop
modprobe pciehp pciehp_force=1
echo 1 > /sys/class/rfkill/rfkill0/state
rmmod pciehp
service NetworkManager start
A bug has been reported by me: https://bugzilla.redhat.com/show_bug.cgi?id=461329

Thanks!

Thanks.
 

Tags
901, beta, eee, fedora

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Where can I get Fedora 10 beta? schmidty313 Alpha, Beta & Snapshots Discussions (Fedora 10 Only) 1 9th November 2008 08:40 PM
So if I get Fedora 10 beta Silpheed2K Alpha, Beta & Snapshots Discussions (Fedora 10 Only) 2 24th October 2008 12:41 PM
Fedora 10 - Beta djblack Alpha, Beta & Snapshots Discussions (Fedora 10 Only) 17 2nd October 2008 05:07 AM
Fedora 10 Alpha-Beta Upgrade from Fedora 9 issues alsa snostorm Alpha, Beta & Snapshots Discussions (Fedora 10 Only) 9 18th September 2008 05:13 AM
Fedora 9 Beta JKoder Alpha - Beta (Fedora 9 Only) 7 8th April 2008 01:44 PM


Current GMT-time: 00:19 (Friday, 28-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Rabong, Buddha Park Travel Photos on Instagram - Alter Schwede Travel Photos on Instagram