FedoraForum.org - Fedora Support Forums and Community
Page 1 of 4 123 ... LastLast
Results 1 to 15 of 51
  1. #1
    alphaindia Guest

    kernel-2.6.26.6-79.fc9.i686 boot issue

    Hi Guys,
    I'm using FC9 with kernel 2.6.26.5-45.fc9.i686. This morning I did yum update and there was a kernel update i.e kernel.i686 0:2.6.26.6-79.fc9 together with other updates. Though the new kernel is recognized in my grub, once it loaded, it freeze up to the line where it says failure to boot. Any idea what is wrong and how to correct it? I wish I could give the boot screen but I just don't know how to copy and paste it in here.

    Btw, I have tried thrice removing and updating the new kernel.i686 0:2.6.26.6-79.fc9 but cant seems to boot using it. Any help and guidance is appreciated.

  2. #2
    Join Date
    Jul 2008
    Posts
    378
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    can you show that error?

  3. #3
    alphaindia Guest
    Thx for the reply. This is some of the boot messages im getting when i tried to use the new kernel.

    ************************************************** ***
    Loading ext3 module
    Trying to resume from /dev/dm-a
    unable to access resume device (/dev/dm-1)
    Creating root device
    Monting root filesystem
    mount:error mounting /dev/root on /sysroot as ext3: No such file or directory
    Setting up other filesystems
    Setting up new root fs
    setuproot: moving /dev failed. No such file or directory
    no fstab.sys, mounting internal defaults
    setuproot: error mounting /proc: no such file or directory
    setuproot: error mounting /sys: no such file or directory
    Mount failed for selinuxfs on /selinux : no such file or directory
    Switching to new root and running init
    unmounting old /dev
    unmounting old /proc
    unmounting old /sys
    switchroot : mount failed: No such file or directory
    Booting has failed.
    ************************************************** *******************

  4. #4
    alphaindia Guest
    For your information, I am also using the latest kernel with my notebook and it works flawlessly. If I want to make a comparison, what should I look for?

  5. #5
    Join Date
    Jul 2008
    Posts
    378
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    from you log i can diagnose problem with software/hardware raid. i have no idea what is really problem it can be:
    - bad partition scheme
    - bad kernel modules for your raid
    - new GUID for partition
    - new partition NAME
    - hard disk crash

    can you diagnose those issues?

  6. #6
    alphaindia Guest
    MY FC 9 currently have 2 kernel installed. The previous version is kernel 2.6.26.5-46.fc9.i686. Booting FC9 via the previous kernel seems to be ok, no error message etc. I guess that eliminates the idea that there is something wrong with my hdd. Any other idea?

  7. #7
    Join Date
    Jul 2008
    Posts
    378
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    what do you have raid or lvm? or booth

  8. #8
    alphaindia Guest
    No raid. Just lvm. 3 IDE (80gb/40gb/40gb) and 1 Sata0(80gb).

  9. #9
    Join Date
    Jul 2008
    Posts
    378
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    check your /boot directory for initrd files. probably you miss one.

  10. #10
    alphaindia Guest
    Mind telling me how should i do the checking? I tried ls -a /boot moments ago and tried to gedit the initrd file and config file for the kernel but nothing comes up.

  11. #11
    Join Date
    Jul 2008
    Posts
    378
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    can you show /boot content

  12. #12
    alphaindia Guest
    ***************************/boot content
    [root@localhost ~]# ls -a /boot
    . initrd-2.6.26.6-79.fc9.i686.img
    .. lost+found
    config-2.6.26.5-45.fc9.i686 System.map-2.6.26.5-45.fc9.i686
    config-2.6.26.6-79.fc9.i686 System.map-2.6.26.6-79.fc9.i686
    efi vmlinuz-2.6.26.5-45.fc9.i686
    grub vmlinuz-2.6.26.6-79.fc9.i686
    initrd-2.6.26.5-45.fc9.i686.img
    [root@localhost ~]#

    *****************************grub.conf
    # grub.conf generated by anaconda
    #
    # Note that you do not have to rerun grub after making changes to this file
    # NOTICE: You have a /boot partition. This means that
    # all kernel and initrd paths are relative to /boot/, eg.
    # root (hd1,0)
    # kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00
    # initrd /initrd-version.img
    #boot=/dev/sda
    default=2
    timeout=9
    splashimage=(hd1,0)/grub/splash.xpm.gz
    hiddenmenu
    title Fedora (2.6.26.6-79.fc9.i686)
    root (hd1,0)
    kernel /vmlinuz-2.6.26.6-79.fc9.i686 ro root=/dev/dm-0
    initrd /initrd-2.6.26.6-79.fc9.i686.img
    title Fedora (2.6.26.5-45.fc9.i686)
    root (hd1,0)
    kernel /vmlinuz-2.6.26.5-45.fc9.i686 ro root=UUID=e781053a-2a74-49ec-bbc6-5ebc6a753d11
    initrd /initrd-2.6.26.5-45.fc9.i686.img
    title WinsXP
    rootnoverify (hd0,0)
    chainloader +1

  13. #13
    Join Date
    Jul 2008
    Posts
    378
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    as you can see you have only initrd-2.6.26.5-45.fc9.i686.img and here no initrd for current kernel (..27).

    and that happen because you got SEGFAULT when you upgrade kernel.

    to solve it reinstall last kernel with those patch:

    apply those patch on mkinitrd source:

    diff -ru mkinitrd-6.0.52/bdevid/scsi.c mkinitrd-6.0.52.new/bdevid/scsi.c
    --- mkinitrd-6.0.52/bdevid/scsi.c 2008-04-25 19:24:00.000000000 +0400
    +++ mkinitrd-6.0.52.new/bdevid/scsi.c 2008-10-05 02:48:35.000000000 +0400
    @@ -379,7 +379,7 @@
    if (priv->unique_id_83)
    return 0;

    - if (!(priv->unique_id_83 = calloc(page_83[3] + 1, sizeof (char))))
    + if (!(priv->unique_id_83 = calloc(2 * (page_83[3] + 1), sizeof (char))))
    return 1;

    #if 0



    https://bugzilla.redhat.com/show_bug.cgi?id=440661

  14. #14
    Join Date
    Jul 2008
    Posts
    378
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    uups wait a second

  15. #15
    alphaindia Guest
    bro,please reread my earlier post. I do have initrd for the new kernel in my /boot
    *****
    [root@localhost ~]# ls -a /boot
    . initrd-2.6.26.6-79.fc9.i686.img <<<<<<<i think u meant this?
    .. lost+found
    config-2.6.26.5-45.fc9.i686 System.map-2.6.26.5-45.fc9.i686
    config-2.6.26.6-79.fc9.i686 System.map-2.6.26.6-79.fc9.i686
    efi vmlinuz-2.6.26.5-45.fc9.i686
    grub vmlinuz-2.6.26.6-79.fc9.i686
    initrd-2.6.26.5-45.fc9.i686.img
    [root@localhost ~]#

Page 1 of 4 123 ... LastLast

Similar Threads

  1. Replies: 4
    Last Post: 21st November 2008, 07:00 PM
  2. Remove kernel.i686 and install kernel.i686
    By ikaruss in forum Using Fedora
    Replies: 2
    Last Post: 19th February 2007, 08:35 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •