Fedora Linux Support Community & Resources Center
  #1  
Old 16th September 2008, 09:28 PM
mcjoe Offline
Registered User
 
Join Date: Sep 2008
Posts: 8
Slave disk is read-only and doesn't want to unmount

Hi,

I an stuck with an issue on my new Fedora 8 installation. The computer has two disk, one 40Gb on /dev/sda1 (=master disk) and a slave 160 Gb disk on /dev/sdb3. They both mount fine at boot. But for some strange reason, the slave disk is read-only. For example, when the root wants to do a mkdir on the disk the response is canno create directory, Read-only File system.

I read about this mount /dev/sdb3 / -o remount r,w on these forums, but it doesn't help. The disks stays on the desktop as if nothing was happened.

Please help,

jo
Reply With Quote
  #2  
Old 17th September 2008, 03:10 AM
sidebrnz Online
Registered User
 
Join Date: Oct 2007
Location: Freedonia
Age: 64
Posts: 2,549
Add this line to /etc/fstab, using the appropriate mount point:

/dev/sdb3 /MOUNTPOINT ext3 auto,umask=0000 0 0

If this is the last line in fstab, make sure to hit Enter after you're done, or mount will complain and not mount the partition. Then remount the drive and it should work. If not, there may be a jumper issue that needs to be checked.
__________________
Registered Linux user #470359 and permanently recovered BOFH.

Any advice in this post is worth exactly what you paid for it.
Reply With Quote
  #3  
Old 17th September 2008, 03:23 AM
stevea Offline
Registered User
 
Join Date: Apr 2006
Location: Ohio, USA
Posts: 8,696
What does "mount" report ?
What does "ls -ld XXX" report in the directory where you tried the mkdir ? (Even root needs permissions).

Unlikely to be a jumper.
Reply With Quote
  #4  
Old 17th September 2008, 10:04 PM
mcjoe Offline
Registered User
 
Join Date: Sep 2008
Posts: 8
I added this to the fstab (after i su to root) as now this file contains this

/dev/VolGroup00/LogVol00 / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
tmpfs /dev/shm tmpfs defaults 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
sysfs /sys sysfs defaults 0 0
proc /proc proc defaults 0 0
/dev/VolGroup00/LogVol01 swap swap defaults 0 0
/dev/sb3 /media/BigO ext3 auto,umask=0000 0 0

then, I rebooted the system, just to be sure. The volume appears on the desktop and is reachable via the terminal, but the problem remains :
Whatever I do on that disk (mkdir, chmod), for example mkdir test on the topdirectory as root
mkdir :cannot create directory 'test' : Read-only file system

these are some ls -ld in /media/Big0
[root@localhost media]# ls -ld
drwxrwxr-x 3 root root 4096 2008-09-17 22:19 .
[root@localhost media]#
[root@localhost media]# cd BigO
[root@localhost BigO]# ls -ld
drwxrwxr-x 1 root 80 37 2008-07-12 11:14 .
[root@localhost BigO]# mkdir test
mkdir: cannot create directory `test': Read-only file system

Hope this clarifies a few things. Many thanks already Steve and sidebrnz
Reply With Quote
  #5  
Old 18th September 2008, 06:39 AM
sidebrnz Online
Registered User
 
Join Date: Oct 2007
Location: Freedonia
Age: 64
Posts: 2,549
Give us the result of this command:

ls -l /media/BigO

so that we can see the permissions. As Steve pointed out, even root can't write to a directory unless write permission is set.
__________________
Registered Linux user #470359 and permanently recovered BOFH.

Any advice in this post is worth exactly what you paid for it.
Reply With Quote
  #6  
Old 18th September 2008, 07:13 AM
mcjoe Offline
Registered User
 
Join Date: Sep 2008
Posts: 8
[jo@localhost ~]$ ls -l /media/BigO
total 4572
drwxr-xr-x 1 nobody nobody 6 2008-07-12 11:14 adobe
drwxr-xr-x 1 root root 35 2004-08-08 00:58 bin
drwxrwxr-t 1 root 80 2 2004-01-10 01:58 cores
-rw-r--r-- 1 root 501 27136 2008-03-02 06:50 Desktop DB
-rw-r--r-- 1 root 501 198402 2008-03-02 06:46 Desktop DF
dr-xr-xr-x 1 root root 2 1976-04-01 10:30 dev
lrwxr-xr-x 1 root 80 11 1976-04-01 10:48 etc -> private/etc
drwxr-xr-x 1 501 80 10 2008-03-11 22:21 hashdee
drwxr-xr-x 1 501 501 7 2008-01-05 14:47 Jonas filmkes
lrwxr-xr-x 1 root 80 9 2008-03-03 09:59 mach -> /mach.sym
-rw-r--r-- 1 root root 3859004 2004-08-06 04:26 mach_kernel
-r--r--r-- 1 root 80 569916 2008-03-03 09:59 mach.sym
drwxr-xr-x 1 nobody nobody 8 2008-03-15 14:52 muziek
drwxr-xr-x 1 root root 5 2004-01-10 01:58 Network
drwxr-xr-x 1 nobody nobody 17 2008-06-12 23:24 New Folder
drwxr-xr-x 1 501 501 17 2008-03-11 22:07 Photos
drwxr-xr-x 1 root root 5 2008-03-03 09:59 private
drwxr-xr-x 1 root root 61 2004-08-06 02:36 sbin
drwxrwxrwt 1 nobody nobody 4 2008-04-13 14:39 Temporary Items
lrwxr-xr-x 1 root 80 11 1976-04-01 10:48 tmp -> private/tmp
drwxr-xr-x 1 root root 9 1976-04-01 11:20 usr
lrwxr-xr-x 1 root 80 11 1976-04-01 10:49 var -> private/var
drwxrwxrwt 1 root 80 5 2008-03-03 10:08 Volumes
Reply With Quote
  #7  
Old 18th September 2008, 07:13 AM
stevea Offline
Registered User
 
Join Date: Apr 2006
Location: Ohio, USA
Posts: 8,696
To re-iterate post #3

What does "mount" report ?

You should see lines line:
/dev/sda1 on /media/BigO type ext3 (rw)
Reply With Quote
  #8  
Old 18th September 2008, 07:15 AM
mcjoe Offline
Registered User
 
Join Date: Sep 2008
Posts: 8
steve, what would be the full mount command after I unmount /dev/sdb3 ?
Reply With Quote
  #9  
Old 18th September 2008, 07:25 AM
mcjoe Offline
Registered User
 
Join Date: Sep 2008
Posts: 8
This is the output I got when I issued the mount command (Big0 is mounted)

[jo@localhost ~]$ mount
/dev/mapper/VolGroup00-LogVol00 on / type ext3 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
/dev/sda1 on /boot type ext3 (rw)
tmpfs on /dev/shm type tmpfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
/dev/sdb3 on /media/BigO type hfsplus (rw,nosuid,nodev,uhelper=hal)
[jo@localhost ~]$
Reply With Quote
  #10  
Old 18th September 2008, 07:38 AM
sidebrnz Online
Registered User
 
Join Date: Oct 2007
Location: Freedonia
Age: 64
Posts: 2,549
I see that the drive in question is hfsplus, a Mac format. That might be part of the problem here, but I don't know enough about it to say. I do know that for a long time Linux couldn't safely write to NTFS drives, and there might be something similar here. Have you mounted other hfsplus drives and written to them?
__________________
Registered Linux user #470359 and permanently recovered BOFH.

Any advice in this post is worth exactly what you paid for it.
Reply With Quote
  #11  
Old 18th September 2008, 08:23 AM
mcjoe Offline
Registered User
 
Join Date: Sep 2008
Posts: 8
No, this the first hfsplus. It comes out of a external casing which was conntected to my Mac running Mac OS X. My idea was that, because OS X is based on BSD, and the disk has been working fine with the Mac for a year, I would be giving issues when i would use it with Fedora. Looks like I was wrong?
Reply With Quote
  #12  
Old 18th September 2008, 09:00 AM
stevea Offline
Registered User
 
Join Date: Apr 2006
Location: Ohio, USA
Posts: 8,696
/dev/sdb3 on /media/BigO type hfsplus (rw,nosuid,nodev,uhelper=hal)

Yeah - it's mounted rw. So why no mkdir ?
less /usr/share/doc/kernel-doc-2.6.26/Documentation/filesystems/hfsplus.txt
Reply With Quote
  #13  
Old 18th September 2008, 11:08 AM
mcjoe Offline
Registered User
 
Join Date: Sep 2008
Posts: 8
Steve, shouldn't I try the the force option as described in the doc?
And how would i do that? Simple change the /etc/fstab to
/dev/sb3 /media/BigO ext3 auto,force,umask=0000 0 0
Would that be a solution?
Reply With Quote
  #14  
Old 18th September 2008, 11:51 AM
markkuk Offline
Registered User
 
Join Date: Apr 2005
Location: Finland
Posts: 5,075
Based on googled information, journaled hfsplus filesystems are mounted read-only. You should use MacOS to turn off journaling on the partition if you want to use it to transfer files between Linux and MacOS.
Reply With Quote
  #15  
Old 20th September 2008, 08:35 PM
mcjoe Offline
Registered User
 
Join Date: Sep 2008
Posts: 8
I resolved this the hard way. After googling on markuk answer, I decided to buy a new HD, format it as ext3 and copy the contents on it from the hfsplus. It isn't the cheapest solution, but now everything is fine. thanks all
Reply With Quote
Reply

Tags
disk, readonly, slave, unmount

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Slave Disk Jugler Hardware & Laptops 4 11th July 2005 04:31 PM


Current GMT-time: 20:02 (Thursday, 24-07-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat