Fedora Linux Support Community & Resources Center
  #1  
Old 12th June 2008, 05:12 PM
twilightomni Offline
Registered User
 
Join Date: Apr 2008
Posts: 70
Can't Get Good Hinting on Calibri (or other MS Cleartype fonts)

Hey there. Using Fedora 9, fresh install. When I add the Microsoft cleartype fonts -- calibri, cambria, consolas, etc. etc. -- only half of them look semi-decent.

Calibri in particular looks hideous. This applies to emails from Outlook-using friends that I read in Thunderbird (hideous), or Office documents in OpenOffice (hideous).

I'm not talking about trying to get subpixel rendering working. It seems like hinting itself is broken on Calibri, in particular. The font is completely aliased and jagged no matter what size I choose or what hinting type I select. Grayscale smoothing doesn't even apply to it.

If I disable hinting completely (None from the Gnome Font Properties), then the grayscale smoothing works, but after all with no hinting it's still rather hideous. Selecting any form of hinting not only DOESN'T hint the font, it breaks the smoothing.

Under OpenSUSE, the cleartype fonts, including Calibri, hint correctly (though not identical to Windows, given the territory of patented font-rendering here). But even when I install freetype-freeworld (livna), with its bytecode interpreter enabled, Calibri still looks like garbage under Fedora.

Does anyone else have this problem, and how can I fix it? It's a minor nitpick, I know, but it's driving me nuts that I can't figure this out.
Reply With Quote
  #2  
Old 12th June 2008, 06:37 PM
giulianobr Offline
Registered User
 
Join Date: Dec 2007
Age: 31
Posts: 31
hi! this issue is normal in Fedora. In last week I found this thread here in fedora forum: http://www.fedoraforum.org/forum/sho...d.php?t=186789
Install and see the diference. IS VERY BIG! and very good the see good looking fonts.
__________________
Giuliano Ribeiro
LG P430 i5
Fedora 16 64b
Win7 64b
Reply With Quote
  #3  
Old 12th June 2008, 07:24 PM
twilightomni Offline
Registered User
 
Join Date: Apr 2008
Posts: 70
Thanks. I appreciate it.

I'm a little disappointed to discover that I can't fix this using an rpmbuild with a special flag. I didn't realize I'd need completely altered packages. Thanks for the tip though.

But serious though! Why do I need to patch it just to HINT Calibri? Does the Freetype patent-free autohinter not work correctly on the Cleartype fonts at all?

Last edited by twilightomni; 12th June 2008 at 07:30 PM.
Reply With Quote
  #4  
Old 12th June 2008, 08:24 PM
giulianobr Offline
Registered User
 
Join Date: Dec 2007
Age: 31
Posts: 31
you don't need create the rpms, just get here: http://www.bevenhall.se/jim/fedora-cleartype/
fast and easy!
__________________
Giuliano Ribeiro
LG P430 i5
Fedora 16 64b
Win7 64b
Reply With Quote
  #5  
Old 12th June 2008, 09:18 PM
twilightomni Offline
Registered User
 
Join Date: Apr 2008
Posts: 70
That's awesome, and I'll give it a shot. I just wish I knew why hinting doesn't work poorly, but doesn't even work at all on those fonts in the first place.
Reply With Quote
  #6  
Old 12th June 2008, 10:08 PM
brebs Offline
Banned
 
Join Date: Apr 2008
Posts: 558
I've added x86_64 binaries for the Ubuntu fonts RPMs, to join the existing i386 ones.
Reply With Quote
  #7  
Old 14th June 2008, 08:53 PM
twilightomni Offline
Registered User
 
Join Date: Apr 2008
Posts: 70
Alright, I installed the binary i386 packages. (Downloaded the source ones too, but I didn't use them -- didn't think I was supposed to patch them with rpmbuild myself.)

And...the subpixel rendering looks nice. But, the Microsoft Cleartype fonts still look horribly pixelated and completely aliased ONLY when hinting (slight, medium, full) is enabled. Again, I have to turn hinting off to get, in particular Calibri, to look correct (especially at sizes 8, 10, 12, and 14).

So the cleartype fonts still don't hint correctly. Admittedly, Segoe UI, Tahoma, Arial -- many Microsoft fonts look much better when hinting is disabled. But I was certain that even with hinting, the Office Cleartype fonts looked decent under OpenSUSE. What is OpenSUSE doing that Fedora is not?

As a result, using Calibri, Candara, Cambria etc -- still looks ridiculously ugly in OpenOffice is well. I hear that's another story, since it uses a statically-linked freetype.

My two questions then, are...

1. Why does the hinter absolutely ruin the antialiasing of Cleartype fonts?
2. Since the hinter is going to ruin the fonts, how can I turn OpenOffice's built-in autohinter off? I'm not talking about the anti-aliasing from the Tools - Options - View, I'm talking about the font hinter. OpenOffice won't obey my system font hinting settings.

Thanks a lot for your help so far though. I'm very impressed with the fonts now, it's just this darn OpenOffice and hinting that's getting in my way.



PS. Did I need to toggle the patches in the spec files myself with those RPMs, or are they ready to go as is? I installed them straight from the command line with no extra options.

PPS. I hear there is way to tell OpenOffice to use your system Freetype library. It involves LD_PRELOAD, but I lost the howto, and my browser history is gone, so I can't find it. Has anybody heard about this method?

Last edited by twilightomni; 14th June 2008 at 08:57 PM.
Reply With Quote
  #8  
Old 14th June 2008, 09:13 PM
brebs Offline
Banned
 
Join Date: Apr 2008
Posts: 558
Quote:
Originally Posted by twilightomni
What is OpenSUSE doing that Fedora is not?
There is a ton of customizations possible in /etc/fonts/ and ~/.fonts.conf, which the major distros will be tweaking themselves. Such tweaks may affect the Calibri font family.

Quote:
Did I need to toggle the patches in the spec files myself with those RPMs, or are they ready to go as is?
Why would I bother to make available pre-compiled RPMs, if you had to recompile from the SRPMs yourself anyway? The pre-compiled RPMs are ready as-is.
Reply With Quote
  #9  
Old 15th June 2008, 01:59 AM
twilightomni Offline
Registered User
 
Join Date: Apr 2008
Posts: 70
That's a good point.

I'll check /etc/fonts and mess with some options, but really, I'm satisfied with Subpixel+No-hinting. Maybe some of those options could help me with the hinting.

Though, if only I could fix OpenOffice...does anybody using Fedora really bother recompiling it just to get nicer looking fonts?
Reply With Quote
  #10  
Old 13th July 2008, 01:06 AM
twilightomni Offline
Registered User
 
Join Date: Apr 2008
Posts: 70
I finally figured it out! I can get Calibri (and Cambria, and the other Cleartype fonts) to hint correctly now.

By mere chance, I found the thread here at Ubuntu forums:

http://ubuntuforums.org/showthread.p...hlight=calibri

It describes the need to disable embedded bitmaps within TrueType fonts. (When the bitmaps themselves are used, I imagine, since they are not vector-based, they cannot be algorithmically hinted). So disabling these allows the hinting and antialiasing to work like normal.

To do so, you add this block to your $HOME/.fonts.conf file:

Code:
    <match target="font" >
         <edit name="embeddedbitmap" mode="assign">
             <bool>false</bool>
         </edit>
    </match>
So now, finally, I have all my fonts under control.

It's funny, it had nothing to do with bytecode interpreters or antialiasing at all. Running around for freetype packages was like a gigantic red-herring.

I suppose OpenSUSE has this option by default, because the Office fonts work fine there. I have also tested this on Kubuntu, which has the same problem (despite the *buntu family having the bytecode interpreter built-in by default), and this fixes it.

Hope someone finds this useful.
Reply With Quote
  #11  
Old 23rd May 2014, 06:36 AM
Quicksand Offline
Registered User
 
Join Date: Jan 2013
Location: California
Posts: 11
linuxfirefox
Re: Can't Get Good Hinting on Calibri (or other MS Cleartype fonts)

I don't know if it's appropriate to dig up this old thread and reanimate it . . . but . . .

Six years later, that tip from twilightomni in the previous post is still good advice. I just had to make that change in my F20 installation go get Calibri to render properly in some point sizes.

It was weird because antialiasing and subpixel rendering worked fine at tiny sizes and also at large sizes. But normal text sizes were pixelated with no antialiasing at all.

This change to ~/.config/fontconfig/fonts.conf fixed it right up. BOOM.
Reply With Quote
Reply

Tags
calibri, cleartype, fonts, good, hinting

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting cleartype-like fonts on linux lmo Guides & Solutions (No Questions) 84 17th November 2011 03:01 PM
Installing Windows fonts: good or bad idea? av_lin Using Fedora 5 22nd June 2009 06:12 PM
How I made Windows fonts look good in Fedora 10 bugsrep Using Fedora 8 6th January 2009 06:29 PM
Why doesn't fedora gnome fonts look as good as Suse gnome fonts? jang Using Fedora 5 26th July 2005 08:01 PM
Can't turn off sub-pixel hinting in KDE stanmuffin Hardware & Laptops 7 29th May 2004 03:29 PM


Current GMT-time: 04:05 (Friday, 31-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Sardarshahr - Kasba - Dobryanka