Fedora Linux Support Community & Resources Center
  #1  
Old 26th April 2012, 11:47 AM
jatinderkaur Offline
Registered User
 
Join Date: Apr 2012
Location: India
Posts: 7
linuxfirefox
Exclamation GPU not supported

I have hp laptop having AMD Radeon HD 6470 GPU and Intel(R) Core(TM) i3-2330M CPU

I have installed fedora (3.3.2-6-fc16.x86_64) OS. But is is not detecting GPU in my system.

Anyone could help in this plz?
Reply With Quote
  #2  
Old 26th April 2012, 03:14 PM
Gareth Jones Offline
Official Gnome 3 Sales Rep. (and Adminstrator)
 
Join Date: Jul 2011
Location: Birmingham, UK
Age: 31
Posts: 2,771
linuxfirefox
Re: GPU not supported

When you say it's not detecting the GPU, what do you mean? Does it give you any error messages? Do you have any graphics at all, or is it just using an un-accelerated fall-back driver or mode?
Reply With Quote
  #3  
Old 26th April 2012, 05:17 PM
jatinderkaur Offline
Registered User
 
Join Date: Apr 2012
Location: India
Posts: 7
windows_7firefox
Re: GPU not supported

Yes I have.Windows is showing in Graphic Card in Display adapters.

Actually I have installed AMD APP SDK on fedora 16.It has detected only
one computing device i.e. intel i3 CPU and not showing GPU. It has prerequisite to install ATI
catalyst driver on fedora. But proprietary driver provided on AMD website is not working with fedora 16.

And yes I have installed fedora 16 in Basic Graphic Mode because otherwise it was not loading gnome and was showing black screen .


Quote:
Originally Posted by Gareth Jones View Post
When you say it's not detecting the GPU, what do you mean? Does it give you any error messages? Do you have any graphics at all, or is it just using an un-accelerated fall-back driver or mode?

Last edited by jatinderkaur; 26th April 2012 at 05:24 PM.
Reply With Quote
  #4  
Old 27th April 2012, 11:30 AM
george_toolan Offline
Registered User
 
Join Date: Dec 2006
Posts: 2,077
linuxfirefox
Re: GPU not supported

Enable rpmfusion repository then try

Code:
yum install kmod-catalyst
Reply With Quote
  #5  
Old 27th April 2012, 02:48 PM
jatinderkaur Offline
Registered User
 
Join Date: Apr 2012
Location: India
Posts: 7
linuxfirefox
Re: GPU not supported

Quote:
Originally Posted by george_toolan View Post
Enable rpmfusion repository then try

Code:
yum install kmod-catalyst
Thx.I am trying to enable rpm fusion.Eariler I was using proxy for updates. I have removed proxy setting made.But still get errors:

Quote:
Retrieving http://download1.rpmfusion.org/free/...ble.noarch.rpm
curl: (7) couldn't connect to host
Reply With Quote
  #6  
Old 28th April 2012, 06:30 AM
jatinderkaur Offline
Registered User
 
Join Date: Apr 2012
Location: India
Posts: 7
windows_7firefox
Question Re: GPU not supported

Quote:
Originally Posted by george_toolan View Post
Enable rpmfusion repository then try

Code:
yum install kmod-catalyst

Yep I have followed the instruction give over here: http://wiki.cchtml.com/index.php/Fed...from_RPMFusion

and have installed akmod-catalyst, xorg-x11-drv-catalyst and xorg-x11-drv-catalyst-libs

on my system. But after reboot system doesn't load GUI back. It is showing black screen with msgs:

Quote:
Started Avahi ,DNS/DS-SDL -------------------------- [ok]

------------------------------------------------------------- [ok]


"
"
"""""""""""""""

Failed to start LSB: Build and install new kmods from akmod packages\See
Systemctl status akmods Service" for detail [failed]

Send mail.............................................. ......................... [OK]
Reply With Quote
  #7  
Old 29th April 2012, 11:49 AM
george_toolan Offline
Registered User
 
Join Date: Dec 2006
Posts: 2,077
linuxfirefox
Re: GPU not supported

I didn't say anything about akmod ;-)
Reply With Quote
  #8  
Old 29th April 2012, 02:25 PM
jatinderkaur Offline
Registered User
 
Join Date: Apr 2012
Location: India
Posts: 7
windows_7firefox
Re: GPU not supported

Quote:
Originally Posted by george_toolan View Post
I didn't say anything about akmod ;-)
check out this link ------>

http://wiki.cchtml.com/index.php/Fed...from_RPMFusion

its not funny... i need to install catalyst driver properly.If anyone can help
Reply With Quote
  #9  
Old 30th April 2012, 11:39 AM
george_toolan Offline
Registered User
 
Join Date: Dec 2006
Posts: 2,077
linuxfirefox
Re: GPU not supported

Seriously. Read the error message you posted and try to make your own kmods if you don't believe me.

Code:
yum install kmod-catalyst
It doesn't get much easier than this and you won't need any akmods as long as rpmfusion keeps building kmods for each new kernel release.

Btw Catalyst 12.4 is available on rpmfusion now

Code:
yum --enablerepo=rpmfusion-nonfree-updates-testing update kmod-catalyst
Reply With Quote
  #10  
Old 30th April 2012, 12:51 PM
Fenrin Offline
Registered User
 
Join Date: Apr 2010
Location: Earth
Posts: 895
linuxopera
Re: GPU not supported

I agree akmod-catalyst is not as reliable as kmod-catalyst with the particular supported kernel version. Building the needed kernel module with akmod-catalyst fails sometimes.

Quote:
But after reboot system doesn't load GUI back. It is showing black screen with msgs:...
you can probably boot into console mode, if you add 3 in the bootline of the grub menu entry for fedora. The line where it says "linux /boot/vmlinuz.... rhgb quiet" is the line where you should add 3
When the grub menu appears, select the Fedora entry, press e and add 3 at the end of the line. Then press the F10 key to boot.

Last edited by Fenrin; 30th April 2012 at 01:48 PM.
Reply With Quote
  #11  
Old 30th April 2012, 04:10 PM
jatinderkaur Offline
Registered User
 
Join Date: Apr 2012
Location: India
Posts: 7
windows_7firefox
Re: GPU not supported

Quote:
Originally Posted by george_toolan View Post
Seriously. Read the error message you posted and try to make your own kmods if you don't believe me.

Code:
yum install kmod-catalyst
It doesn't get much easier than this and you won't need any akmods as long as rpmfusion keeps building kmods for each new kernel release.

Btw Catalyst 12.4 is available on rpmfusion now

Code:
yum --enablerepo=rpmfusion-nonfree-updates-testing update kmod-catalyst

yup I have already removed akmod-catalyst and installed kmod-catalyst. But problem still persists. System is not loading GUI.

---------- Post added at 03:10 PM ---------- Previous post was at 03:09 PM ----------

Quote:
Originally Posted by Fenrin View Post
I agree akmod-catalyst is not as reliable as kmod-catalyst with the particular supported kernel version. Building the needed kernel module with akmod-catalyst fails sometimes.



you can probably boot into console mode, if you add 3 in the bootline of the grub menu entry for fedora. The line where it says "linux /boot/vmlinuz.... rhgb quiet" is the line where you should add 3
When the grub menu appears, select the Fedora entry, press e and add 3 at the end of the line. Then press the F10 key to boot.

Ok I have tried it but didn't help.

This is parameters shown in grub:

linux /vmlinuz-3.3.2-6.fc16.x86_64 root=/dev/mapper/VolGroup-lv-rootro\
nomodeset rd.md=0 rd.dm=0 rd.lvm.lv=Volgroup/lv_swap KEYTABLE=US quie\
t SYSFONT=latarcyrheb-sub rhgb rd.lvm.lv= Volgroup/lv_root rd.luks=0 L\
AND=enUS.UTF-8 radeon.modeset=0


I think dark red parameters can help.Any further suggestions?

Last edited by jatinderkaur; 30th April 2012 at 04:46 PM.
Reply With Quote
  #12  
Old 1st May 2012, 09:01 AM
george_toolan Offline
Registered User
 
Join Date: Dec 2006
Posts: 2,077
linuxfirefox
Re: GPU not supported

Try to remove the quiet so you can see the error messages.
Reply With Quote
  #13  
Old 1st May 2012, 01:54 PM
jatinderkaur Offline
Registered User
 
Join Date: Apr 2012
Location: India
Posts: 7
windows_7firefox
Re: GPU not supported

Quote:
Originally Posted by george_toolan View Post
Try to remove the quiet so you can see the error messages.
i have removed quiet. But same black screen with same msgs i have already posted appears. I have also tried removing nomodeset. This resulted in black screen for infinite time.
Reply With Quote
Reply

Tags
gpu, supported

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Max RAM supported x86 FC9 Crimson Tide Using Fedora 2 23rd May 2008 09:28 PM
.rar is not supported in FC4? Stevenisme Using Fedora 6 25th September 2005 11:49 AM


Current GMT-time: 07:54 (Saturday, 20-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat