Fedora Linux Support Community & Resources Center
  #1  
Old 27th November 2011, 06:10 PM
bobriha Offline
Registered User
 
Join Date: Nov 2011
Posts: 2
linuxfirefox
problem installing Perl modules using CPAN

I'm getting an error when trying to reinstall DBI module using perl-cpan,

cpan[1]> install DBI
CPAN: Storable loaded ok (v2.27)
Going to read '/root/.cpan/Metadata'
Database was generated on Sat, 02 Jul 2011 18:27:42 GMT
CPAN: LWP::UserAgent loaded ok (v6.02)
perl: symbol lookup error: /usr/local/lib/perl5/auto/Time/HiRes/HiRes.so: undefined symbol: Perl_Istack_sp_ptr

In fact this happens for any other module as well.
Also, just searching for the module returns the same error:

cpan[2]> i /DBI/
CPAN: Storable loaded ok (v2.27)
Going to read '/root/.cpan/Metadata'
Database was generated on Sat, 02 Jul 2011 18:27:42 GMT
CPAN: LWP::UserAgent loaded ok (v6.02)
perl: symbol lookup error: /usr/local/lib/perl5/auto/Time/HiRes/HiRes.so: undefined symbol: Perl_Istack_sp_ptr

I've tried installing it manually from the source, with same result.

I've noticed things broke after I've upgraded to Fedora 16. All was working well in Fedora 15.

# uname -r
3.1.2-1.fc16.i686.PAE
# perl -v
This is perl 5, version 14, subversion 2 (v5.14.2) built for i386-linux-thread-multi

Any ideas please?
Reply With Quote
  #2  
Old 6th December 2011, 01:13 AM
bobriha Offline
Registered User
 
Join Date: Nov 2011
Posts: 2
linuxfirefox
Re: problem installing Perl modules using CPAN

after long searching the solution, I ended up reinstalling F16 from scratch ... as painful as it was.

after all my perl environment got messed up and seemed like i was getting versions incompatibility between my old modules and perl v5.14.2

my new F16 is working fine now.
Reply With Quote
Reply

Tags
cpan, installing, modules, perl, problem

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to install perl modules with CPAN vonedaddy Guides & Solutions (No Questions) 0 29th March 2011 12:45 AM
Perl CPAN trouble installing modules Jimls Using Fedora 1 21st January 2011 11:31 PM
perl CPAN and @INC problem siyverts Using Fedora 0 9th April 2009 05:47 PM
installing modules using cpan leemansvg Using Fedora 2 21st April 2005 05:50 AM


Current GMT-time: 21:16 (Wednesday, 30-07-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat