Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora 19/20 > Using Fedora
FedoraForum Search

Forgot Password? Join Us!

Using Fedora General support for current versions. Ask questions about Fedora that do not belong in any other forum.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 1st June 2011, 12:41 PM
ewasser Offline
Registered User
 
Join Date: Feb 2010
Posts: 14
linuxfirefox
[FC15]Messagebus problem: KNotification::slotReceivedIdError: Error while...

After a new installation with Fedora Core 15 KDE is starting slow. It's now giving me a lot of errors in $HOME/.xsession-errors:

Code:
kwin(5077)/kdeui (KNotification) KNotification::slotReceivedIdError: Error while contacting
notify daemon "Did not receive a reply. Possible causes include: the remote application did
not send a reply, the message bus security policy blocked the reply, the reply timeout
expired, or the network connection was broken."
The message repeats and repeats. Sometimes I start applications and they timeout with similar messages. To be more precise: I can't select a program from the "System settings" dialogue.

Code:
klauncher(5065)/kio (KLauncher): SlavePool: No communication with slave.
Selinux is off. Any ideas?
Reply With Quote
  #2  
Old 12th July 2011, 10:15 PM
emersonkfuri Offline
Registered User
 
Join Date: Jul 2008
Posts: 2
linuxchrome
Re: [FC15]Messagebus problem: KNotification::slotReceivedIdError: Error while...

It's a nvidia related problem. I fixed replacing my kmod-nvidia packages by kmod-nividia-173xx metapackage.

lspci output:
01:00.0 VGA compatible controller: nVidia Corporation G72 [GeForce 7300 SE/7200 GS] (rev a1)
Reply With Quote
  #3  
Old 13th July 2011, 11:27 AM
ewasser Offline
Registered User
 
Join Date: Feb 2010
Posts: 14
linuxfirefox
Re: [FC15]Messagebus problem: KNotification::slotReceivedIdError: Error while...

Quote:
Originally Posted by emersonkfuri View Post
It's a nvidia related problem. I fixed replacing my kmod-nvidia packages by kmod-nividia-173xx metapackage.
I don't think so. After some further investigation I found that sssd was trying to communicate with LDAP via SSL and the LDAP server doesn't support this mode. After I turned LDAP off (working with a local user) everything was fine.

So I don't think it a graphical/hardware issue.
Reply With Quote
  #4  
Old 26th July 2011, 08:06 AM
ewasser Offline
Registered User
 
Join Date: Feb 2010
Posts: 14
linuxfirefox
[Solved]Re: [FC15]Messagebus problem: KNotification::slotReceivedIdError: Error while

Quote:
Originally Posted by emersonkfuri View Post
It's a nvidia related problem. I fixed replacing my kmod-nvidia packages by kmod-nividia-173xx metapackage.
WTF? You're right. Thanks for the tip. How're these 2 things are related?
Reply With Quote
  #5  
Old 23rd November 2011, 12:51 PM
C64 Offline
Registered User
 
Join Date: Feb 2006
Posts: 32
linuxfedorafirefox
Re: [FC15]Messagebus problem: KNotification::slotReceivedIdError: Error while...

I am experiencing a similar symptom and it's really confusing. The bug seems to be there in F15 from the start but only appeared in F14 after my last update.

I have network login against an LDAP server (pam_ldap, no SSL or sssd). If I install kmod-nvidia I can no longer log in to KDE as an ldap user (login progress never advances from first icon). If I remove kmod-nvidia and all dependencies I can log in without problems.

The strange thing is that I can log in to a local account with kmod-nvidia enabled. This indicates that the driver and configuration is working, but for whatever reason newer drivers mess up when there is network activity required for login (user homes are also mounted remotely on an nfs share). SElinux is disabled.

This has never been a problem in F14 until recently. Does anybody know a fix other than deactivate or going legacy? Is there any easy way of installing the last known working kmod-nvidia?
Reply With Quote
  #6  
Old 23rd November 2011, 03:03 PM
ewasser Offline
Registered User
 
Join Date: Feb 2010
Posts: 14
linuxfirefox
Re: [FC15]Messagebus problem: KNotification::slotReceivedIdError: Error while...

Quote:
Originally Posted by C64 View Post
I am experiencing a similar symptom and it's really confusing. The bug seems to be there in F15 from the start but only appeared in F14 after my last update
The bug is in FC16 too. Same configuration: no selinux, $HOME on NFS, LDAP user, hanging during the KDE login, converting the LDAP user to /etc/{group,passwd,shadow} is a workaround.
Reply With Quote
  #7  
Old 24th November 2011, 03:22 PM
C64 Offline
Registered User
 
Join Date: Feb 2006
Posts: 32
linuxfedorafirefox
Re: [FC15]Messagebus problem: KNotification::slotReceivedIdError: Error while...

Quote:
Originally Posted by ewasser View Post
The bug is in FC16 too. Same configuration: no selinux, $HOME on NFS, LDAP user, hanging during the KDE login, converting the LDAP user to /etc/{group,passwd,shadow} is a workaround.
Are the local "passwd" accounts still mapped to an NFS $HOME-dir? That would narrow the problem down to only LDAP + kmod-nvidia.
Reply With Quote
Reply

Tags
fc15, kde, messagebus

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
fc15 vncserver error on start - INVALIDARGUMENT dan sawyer Using Fedora 14 24th April 2012 09:47 PM
Synaptics Pad Click problem FC15 Druid Guides & Solutions (No Questions) 1 24th October 2011 09:38 PM
[SOLVED] FC15 preupgrade failue on java-1.5.0-gcj-javadoc-1.5.0.0-35.fc15.i686 gkasica Installation, Upgrades and Live Media 1 29th May 2011 12:18 PM
Yum update error fc14 >fc15 Algognito Installation, Upgrades and Live Media 4 29th May 2011 02:48 AM
Messagebus has error and HalDaemon does not run at boot gigjee Using Fedora 0 18th September 2005 08:17 PM


Current GMT-time: 18:57 (Saturday, 25-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Kashiwazaki Travel Photos on Instagram - Tripoli Travel Photos - Torcy Photos