Fedora Linux Support Community & Resources Center
  #1  
Old 21st January 2010, 12:01 PM
leigh123linux
Guest
 
Posts: n/a
linuxfedorafirefox
New Xorg server ABI

They have bumped the Xorg server version to 1.7.99

http://koji.fedoraproject.org/koji/b...buildID=152218


This means that people using the nvidia driver will need to add this to xorg.conf


Code:
Section "ServerFlags" 
    Option "IgnoreABI" "true" 
EndSection
  #2  
Old 23rd January 2010, 11:27 AM
STEVE555 Offline
Registered User
 
Join Date: Nov 2004
Posts: 104
linuxopera
Hi leigh123linux,
I noticed the ABI problem after today's updates. I have put that option in my xorg.conf,but that doesn't seem to have an effect.I still have to issue
Code:
startx -- -ignoreABI
from init 3

I'll attach my xorg.conf to this reply.

Regards,
STEVE555
Attached Files
File Type: conf xorg.conf (1.9 KB, 131 views)
  #3  
Old 23rd January 2010, 12:25 PM
leigh123linux
Guest
 
Posts: n/a
linuxfedoramozilla
Quote:
Originally Posted by STEVE555 View Post
Hi leigh123linux,
I noticed the ABI problem after today's updates. I have put that option in my xorg.conf,but that doesn't seem to have an effect.I still have to issue
Code:
startx -- -ignoreABI
from init 3

I'll attach my xorg.conf to this reply.

Regards,
STEVE555

Update nouveau, you shouldn't need to add Option "IgnoreABI" "true" to xorg.conf


http://koji.fedoraproject.org/koji/b...buildID=152224
  #4  
Old 23rd January 2010, 12:59 PM
STEVE555 Offline
Registered User
 
Join Date: Nov 2004
Posts: 104
linuxfedoramozilla
Hi leigh123linux,
I solved my problem,I use the xf86-video-nouveau drivers from git.All I had to do was a re-compile and I've set Option "IgnoreABI" to "false" in my xorg.conf. and I get the new User Account Dialogue (it keeps sending me to the Gnome Desktop,but that is another story).

I would like to thank you very much for your help.

Regards,
STEVE555
  #5  
Old 23rd January 2010, 01:51 PM
leigh123linux
Guest
 
Posts: n/a
linuxfedorafirefox
Quote:
Originally Posted by STEVE555 View Post
Hi leigh123linux,
I solved my problem,I use the xf86-video-nouveau drivers from git.All I had to do was a re-compile and I've set Option "IgnoreABI" to "false" in my xorg.conf. and I get the new User Account Dialogue (it keeps sending me to the Gnome Desktop,but that is another story).

I would like to thank you very much for your help.

Regards,
STEVE555

The new nouveau driver works fine here.

Code:
[leigh@localhost ~]$ rpm -qa |grep -e nouveau -e Xorg |sort
xorg-x11-drv-nouveau-0.0.15-15.20091217gitbb19478.fc13.x86_64
xorg-x11-server-Xorg-1.7.99.3-1.20100120.fc13.x86_64
[leigh@localhost ~]$ uname -r
2.6.33-0.20.rc5.git0.fc13.x86_64
[leigh@localhost ~]$ cat /etc/X11/xorg.conf
cat: /etc/X11/xorg.conf: No such file or directory
[leigh@localhost ~]$ glxinfo |grep direct
direct rendering: Yes
[leigh@localhost ~]$ lsmod |grep nouveau
nouveau               331898  2 
ttm                    51499  1 nouveau
drm_kms_helper         24776  1 nouveau
drm                   174496  4 nouveau,ttm,drm_kms_helper
i2c_algo_bit            5037  1 nouveau
i2c_core               25736  5 i2c_nforce2,nouveau,drm_kms_helper,drm,i2c_algo_bit
[leigh@localhost ~]$
 

Tags
abi, server, xorg

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
xorg-x11-server-Xorg - 1.3.0.0-42.fc8.i386 broke my compiz-fusion (borders gone) Tine Using Fedora 16 22nd December 2008 06:35 PM
mesa-libGL conflicts xorg-x11-server-Xorg globalbmx Using Fedora 1 5th May 2008 08:29 PM
Updating xorg-x11-server-Xorg to 1.3.0 destroyed my X window wu_qso Using Fedora 0 10th March 2008 08:06 AM
How to check whether xorg-x11-server-Xorg again supports my VGA with composition? adrin Using Fedora 0 20th January 2008 05:05 PM
Beryl broken afteer xorg-x11-server-Xorg update bowens44 Using Fedora 5 10th June 2007 07:01 PM


Current GMT-time: 13:31 (Wednesday, 17-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat