Fedora Linux Support Community & Resources Center
  #1  
Old 21st August 2009, 07:43 AM
Silpheed2K Offline
Registered User
 
Join Date: Aug 2008
Posts: 585
linuxfedorafirefox
akmod-nvidia isn't working for me.

Since kmod is taking so long I've decided to try akmod-nvidia... but everytime my system starts up... I get a failed message for the akmod... I got kernel-devel installed.
Here's the output from my terminal

Code:
~]# service akmods restart
Checking kmods exist for 2.6.29.6-217.2.3.fc11.i586        [  OK  ]
Files needed for building modules against kernel
2.6.29.6-217.2.3.fc11.i586 could not be found as the following
directories are missing:
/usr/src/kernels/2.6.29.6-217.2.3.fc11.i586/
/lib/modules/2.6.29.6-217.2.3.fc11.i586/build/             [FAILED]
What do I need to have or do to make this mysterious thing work?

edit: I was on a previous kernel when I typed that in my terminal. I typed that to give you at least a clue of the problem it's giving me. When I boot on the newer kernel I disable desktop effects.
Also, is there any clean up that needs to be done after this whole rebuild process takes place?

Last edited by Silpheed2K; 21st August 2009 at 07:46 AM.
Reply With Quote
  #2  
Old 21st August 2009, 07:51 AM
ozjd Offline
Registered User
 
Join Date: Feb 2008
Location: Sydney Australia
Age: 59
Posts: 2,372
linuxfedorafirefox
Have a look at the nvidia thread in my signature. It has detailed instructions for installing akmod-nvidia.
Reply With Quote
  #3  
Old 21st August 2009, 08:19 AM
Silpheed2K Offline
Registered User
 
Join Date: Aug 2008
Posts: 585
linuxredhatfirefox
I accidentally turned on desktop effects from CCSM... does anybody know how to turn this off from a LiveCD? my desktop isn't even visible now.. just a blank white screen.

edit: nevermind, I got it.. I moved the startup file out of ~/.config/autostart/ to keep it from starting when I log in.

edit 2: I already have all of those packages installed and the nVidia thread didn't solve my problem. Does anybody know what the problem may be?

edit 3: solved it.. I didnt have the kernel-devel and kernel-headers packages. Last kernel-devel I had apparently was a Fedora 10 package
Code:
su -
yum install kernel-devel kernel-headers
I got that from this page http://www.kernelhardware.org/fedora...r-kmod-nvidia/ and installed those on top of some of the stuff I used from the nVidia thread ozjd referred me to.

Last edited by Silpheed2K; 21st August 2009 at 09:06 AM.
Reply With Quote
  #4  
Old 21st August 2009, 11:22 PM
ozjd Offline
Registered User
 
Join Date: Feb 2008
Location: Sydney Australia
Age: 59
Posts: 2,372
linuxfedorafirefox
I'm not sure how you installed akmod but it usually brings in the kernel headers etc as dependencies.
Reply With Quote
Reply

Tags
akmodnvidia, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
kmod-nvidia vs akmod-nvidia dth4h Using Fedora 35 4th September 2009 03:02 AM
F11: akmod-nvidia doesn't work dedded Installation, Upgrades and Live Media 4 15th June 2009 09:58 PM
nvidia driver does not work (akmod-nvidia) zuargo Hardware & Laptops 4 14th June 2009 07:11 AM
are akmod-nvidia and kmod-nvidia exclusive? marko Using Fedora 2 23rd February 2009 02:26 AM
What is akmod-nvidia for? thunderogg Hardware & Laptops 3 29th May 2008 04:41 PM


Current GMT-time: 11:57 (Tuesday, 21-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Maravatio Instagram Photos - Remire-Montjoly - Northfield Photos on Instagram