Fedora Linux Support Community & Resources Center
  #1  
Old 31st August 2004, 12:01 AM
paulec Offline
Registered User
 
Join Date: Aug 2004
Posts: 3
Keyboard mapping in FC2

When installing FC2 I selected my keyboard as US International by mistake now whenever I type ' I get `.

I have used the system setting tool in Gnome to change the keyboard to US English. This has fixed the problem for a text login but not for Gnome.

I have to set the keyboard to US English for each session. The curious thing is the system setting keybord tool indicates Gnome is set to US English. I simply have to open the tool and accept the existing setting.
Reply With Quote
  #2  
Old 31st August 2004, 03:05 PM
tashirosgt Offline
Registered User
 
Join Date: Aug 2004
Posts: 3,936
How did your /etc/X11/xorg.conf file end up - did it have two keyboards defined in it or just one?
__________________
"Never let the task you are trying to accomplish distract you from the study of computers."
Reply With Quote
  #3  
Old 31st August 2004, 11:05 PM
paulec Offline
Registered User
 
Join Date: Aug 2004
Posts: 3
There is only one keyboard in xorg.conf


# XFree86 4 configuration created by pyxf86config

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbModel" "pc102"
Option "XkbLayout" "us"
Option "XkbRules" "xorg"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "LCD Panel 1400x1050"
HorizSync 31.5 - 90.0
VertRefresh 59.0 - 75.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "radeon"
VendorName "Videocard vendor"
BoardName "ATI Radeon Mobility 7500"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 16
Modes "1400x1050" "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1400x1050" "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection
Reply With Quote
  #4  
Old 1st September 2004, 05:05 PM
tashirosgt Offline
Registered User
 
Join Date: Aug 2004
Posts: 3,936
Let me make sure I understand what you mean by a "text login". Do you mean you get the right keyboard mapping when you login with no desktop? Or does a text login refer to when you open a Gnome terminal? When the keyboard doesn't work in Gnome, does this mean it doesn't work in a Gnome terminal opened from the desktop or that it doesn't work in an application ( like OpenOffice writer ) that you run from the desktop (or both).

Thing to check:

Do you really have a 102 key keyboard (not counting the function keys) like the line:
Option "XkbModel" "pc102"
indicates? Or is it a 105 key keyboard?
I'm not sitting at an FC2 machine now, but I think there should be files "us" and "xorg" somewhere in a subdirectory of:
/usr/X11R6/lib/X11/xkb
that are reffered to in the lines:
Option "XkbLayout" "us"
Option "XkbRules" "xorg"
If these files are links, what do they link to?
__________________
"Never let the task you are trying to accomplish distract you from the study of computers."
Reply With Quote
  #5  
Old 1st September 2004, 05:31 PM
tashirosgt Offline
Registered User
 
Join Date: Aug 2004
Posts: 3,936
Another thiing to check is whether /etc/X11/Xmodmap looks right.
I think this is what the
xmodmap -pke
command prints out.
__________________
"Never let the task you are trying to accomplish distract you from the study of computers."
Reply With Quote
  #6  
Old 2nd September 2004, 12:27 AM
paulec Offline
Registered User
 
Join Date: Aug 2004
Posts: 3
By a "text terminal" I meant a none gnome session. The problem was occuring in all gnome editors, eclipse and gnome terminals. I did not try any of the Open Office apps.

I managed to fix the problem last night by using
gconf-editor
peripherals
keyboard
xkb

where the setting was still for "us_intl". Changed this to "us" and all is fine now.
Reply With Quote
Reply

Tags
fc2, keyboard, mapping

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Keyboard mapping eliashickman Using Fedora 3 8th September 2009 03:17 PM
Keyboard mapping P.o.D Using Fedora 4 4th September 2009 11:13 PM
Keyboard mapping plrsmith Hardware & Laptops 0 12th June 2009 10:26 AM
Problem with keyboard mapping brunoadm Using Fedora 0 28th November 2008 03:32 AM
mapping keyboard to ascii -rick- Using Fedora 0 18th April 2008 10:52 AM


Current GMT-time: 01:14 (Thursday, 24-04-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat