Fedora Linux Support Community & Resources Center
  #1  
Old 13th February 2009, 02:02 PM
Idongnz Offline
Registered User
 
Join Date: Nov 2006
Posts: 48
a problem with using "wget"

when I enter:
wget -r ftp://ftp.lfs-matrix.net/pub/lfs/lfs-packages/6.1.1/

I can only get some unusefull symlink like this:

Creating symlink ftp.lfs-matrix.net/pub/lfs/lfs-packages/6.1.1/util-linux-2.12q-umount_fix-1.patch -> ../../conglomeration/util-linux/util-linux-2.12q-umount_fix-1.patch

Creating symlink ftp.lfs-matrix.net/pub/lfs/lfs-packages/6.1.1/util-linux-2.12q.tar.bz2 -> ../conglomeration/util-linux/util-linux-2.12q.tar.bz2

Creating symlink ftp.lfs-matrix.net/pub/lfs/lfs-packages/6.1.1/vim-6.3-lang.tar.bz2 -> ../conglomeration/vim/vim-6.3-lang.tar.bz2

.........................................

but "wget ftp://ftp.lfs-matrix.net/pub/lfs/lfs-packages/6.1.1/autoconf-2.59.tar.bz2"
then I can get the software successfully.

what's wrong?
__________________
hello. :)
gelonx@qq.com
Reply With Quote
  #2  
Old 13th February 2009, 03:40 PM
Connor~ Offline
Registered User
 
Join Date: Feb 2009
Posts: 3
If I am correct wget is for individual files. Like you would put in each wget link individual link.
Reply With Quote
  #3  
Old 13th February 2009, 04:45 PM
vallimar Offline
Registered User
 
Join Date: Jul 2008
Posts: 1,066
Use mirror mode with wget to grab a whole directory.
Though I'm unsure how well that works with ftp.

If it doesn't work, then try a real ftp client and use mget.
Reply With Quote
Reply

Tags
problem, wget

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
"ls" and "cd" treat ".." differently inside symlinked directories bnorman Using Fedora 0 19th June 2008 04:49 PM
problem with "Package Manager" And "Add and remove programs & yum Dr.AMA Installation, Upgrades and Live Media 4 22nd March 2008 08:30 PM
HOW TO MOUNT "C" "D" "E" LOCAL HARDDISK PARTITION ketan_hk Using Fedora 6 6th September 2007 01:10 AM
Metacity and "Xlib: extension "SHAPE" missing on display ":0.0". debu_sagii Using Fedora 0 29th August 2007 05:53 PM
Error:visibility arg must be one of "default", "hidden", "protected" or "internal" wangfeng Using Fedora 0 23rd May 2005 04:59 AM


Current GMT-time: 20:11 (Saturday, 20-12-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
...Hayuelos Centro Comercial Photos - The Amphitheatre, Pula, Croatia Photos - Las Villas Pasaje City Travel Photos