Fedora Linux Support Community & Resources Center
  #1  
Old 3rd September 2007, 11:07 AM
glennzo Online
Un-Retired Administrator
 
Join Date: Mar 2004
Location: Salem, Mass USA
Age: 57
Posts: 14,698
Sftp

Two computers, named Dad and Toshiba, on my network. Both run Fedora 7. I thought that I'd try this 'SFTP' thing. I can connect to Dad from Toshiba using my username and password. Perfect. I cannot connect to Toshiba from Dad. Error message states 'Couldn't display "sftp://192.168.1.102:22/", because no host "192.168.1.102" could be found. Check that the spelling is correct and that your proxy settings are correct.' I can ping 192.168.1.102 (dad) from Toshiba.

[glenn@toshiba ~]$ ping 192.168.1.102
PING 192.168.1.102 (192.168.1.102) 56(84) bytes of data.
64 bytes from 192.168.1.102: icmp_seq=1 ttl=64 time=0.069 ms
64 bytes from 192.168.1.102: icmp_seq=2 ttl=64 time=0.070 ms
64 bytes from 192.168.1.102: icmp_seq=3 ttl=64 time=0.073 ms
64 bytes from 192.168.1.102: icmp_seq=4 ttl=64 time=0.101 ms
64 bytes from 192.168.1.102: icmp_seq=5 ttl=64 time=0.074 ms
64 bytes from 192.168.1.102: icmp_seq=6 ttl=64 time=0.073 ms
64 bytes from 192.168.1.102: icmp_seq=7 ttl=64 time=0.072 ms
64 bytes from 192.168.1.102: icmp_seq=8 ttl=64 time=0.075 ms
64 bytes from 192.168.1.102: icmp_seq=9 ttl=64 time=0.072 ms
64 bytes from 192.168.1.102: icmp_seq=10 ttl=64 time=0.073 ms

--- 192.168.1.102 ping statistics ---
10 packets transmitted, 10 received, 0% packet loss, time 8999ms
rtt min/avg/max/mdev = 0.069/0.075/0.101/0.010 ms
[glenn@toshiba ~]$

I believe that SSHD needs to be running on both computers. It is, and starts at boot on both. SELinux and Firewall are disabled on both computers also. Any thoughts?
__________________
Glenn
The Bassinator © ®

[SIGPIC][/SIGPIC]
Laptop: Toshiba Satellite / Intel Core 2 Duo 1.73 GHz / 2GB / 160GB / Intel Mobile 945GM/GMS/GME/943/940GML Integrated Graphics
Desktop: BioStar MCP6PB M2+ / AMD Phenom 9750 Quad Core / 4GB / 1TB SATA / 500GB SATA / EVGA GeForce 8400 GS 1GB
Reply With Quote
  #2  
Old 3rd September 2007, 04:35 PM
ryptyde Offline
Registered User
 
Join Date: May 2005
Location: Tragic City, Michigan USA
Posts: 1,647
I know this may not help but I have just checked 3 of my computers, a laptop with F7 a desktop with F7 and a desktop with FC6. They are all on a wireless network and can access each other via "sftp".

I do recall at one time that one of the setups couldn't access any other computers using sftp but somewhere in the process of setting up my network the computer now can access other computers.

I do have SELinux set as permissive,and firewall enabled. Maybe you need to check if a "trusted service" needs to be enabled in firewall setting? Sorry for the lack of a better answer as networking is a bit vague to me.
Reply With Quote
  #3  
Old 3rd September 2007, 09:51 PM
glennzo Online
Un-Retired Administrator
 
Join Date: Mar 2004
Location: Salem, Mass USA
Age: 57
Posts: 14,698
Thanks for taking the time to reply ryptyde. I'm sure that the solution lies in some obscure setting somewhere. I'll have to take the time to diagnose it, that's all. I have Fedora 7 and Fedora 8T1 on the laptop, and the same on the desktop. Also have another toy that is running Fedora 7. Trying the different combintions of computer to computer SFTP should yield some further insight. Think I'll actually note what computer can access what other computer while running which version of Fedora. I'll get there. It's just something that aroused my curiosity today and I thought that it may be a more convenient way to share files. I'll look at the firewall and SELinux on all boxes also. Thanks again.
__________________
Glenn
The Bassinator © ®

[SIGPIC][/SIGPIC]
Laptop: Toshiba Satellite / Intel Core 2 Duo 1.73 GHz / 2GB / 160GB / Intel Mobile 945GM/GMS/GME/943/940GML Integrated Graphics
Desktop: BioStar MCP6PB M2+ / AMD Phenom 9750 Quad Core / 4GB / 1TB SATA / 500GB SATA / EVGA GeForce 8400 GS 1GB
Reply With Quote
  #4  
Old 3rd September 2007, 10:04 PM
jcliburn Offline
Registered User
 
Join Date: Nov 2004
Location: Mississippi, USA
Posts: 1,180
In dad's sshd_config, do you have a "Subsystem" entry defined for sftp?

Can you ssh into dad from toshiba? (If so, you've verified that port 22 isn't blocked on dad.)

Verify that sshd_config and ssh_config on dad match those on toshiba.
Reply With Quote
  #5  
Old 3rd September 2007, 10:40 PM
glennzo Online
Un-Retired Administrator
 
Join Date: Mar 2004
Location: Salem, Mass USA
Age: 57
Posts: 14,698
I have no idea how to use ssh to log into another computer. sshd_config on Dad is an empty file. as is ssh_config. On Toshiba it's the same. Both empty files. I've configured nothing on either computer in terms of this SFTP thing. It's been staring at me every time I go to the network folder so I thought I see what it's all about.

I take that back. The location of the files is /etc/ssh/ and I opened /etc/sshd_config and /etc/ssh_config. No wonder they were empty files!
__________________
Glenn
The Bassinator © ®

[SIGPIC][/SIGPIC]
Laptop: Toshiba Satellite / Intel Core 2 Duo 1.73 GHz / 2GB / 160GB / Intel Mobile 945GM/GMS/GME/943/940GML Integrated Graphics
Desktop: BioStar MCP6PB M2+ / AMD Phenom 9750 Quad Core / 4GB / 1TB SATA / 500GB SATA / EVGA GeForce 8400 GS 1GB
Reply With Quote
  #6  
Old 3rd September 2007, 10:53 PM
marko Online
Registered User
 
Join Date: Jun 2004
Location: Laurel, MD USA
Posts: 6,032
Quote:
Originally Posted by glennzo
I have no idea how to use ssh to log into another computer.
ssh username@hostname


should do it. If you don't have private/public keys setup, it will ask for
your password.

Mark
Reply With Quote
  #7  
Old 4th September 2007, 01:05 AM
glennzo Online
Un-Retired Administrator
 
Join Date: Mar 2004
Location: Salem, Mass USA
Age: 57
Posts: 14,698
From toshiba
[glenn@toshiba ~]$ ssh glenn@dad
The authenticity of host 'dad (192.168.1.101)' can't be established.
RSA key fingerprint is 90:27:b0:83:8e:04:02:07:51:24:b5:2b:b5:c8:cb:34.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added 'dad' (RSA) to the list of known hosts.
glenn@dad's password:
That worked.

From Dad
[glenn@dad~]$ ssh glenn@toshiba
ssh: connect to host toshiba port 22: No route to host
[glenn@dad~]$
Does this mean that port 22 is closed on toshiba?
__________________
Glenn
The Bassinator © ®

[SIGPIC][/SIGPIC]
Laptop: Toshiba Satellite / Intel Core 2 Duo 1.73 GHz / 2GB / 160GB / Intel Mobile 945GM/GMS/GME/943/940GML Integrated Graphics
Desktop: BioStar MCP6PB M2+ / AMD Phenom 9750 Quad Core / 4GB / 1TB SATA / 500GB SATA / EVGA GeForce 8400 GS 1GB
Reply With Quote
  #8  
Old 4th September 2007, 01:51 AM
marko Online
Registered User
 
Join Date: Jun 2004
Location: Laurel, MD USA
Posts: 6,032
Quote:
ssh: connect to host toshiba port 22: No route to host
[glenn@dad~]$
Does this mean that port 22 is closed on toshiba?
I think I once got that error because one of my ssh hosts
didn't have eth0 (the network interface) as a trusted device.
I think you said you had your firewalls turned off so then that
wouldn't be it.

Mark
Reply With Quote
  #9  
Old 4th September 2007, 02:22 AM
jcliburn Offline
Registered User
 
Join Date: Nov 2004
Location: Mississippi, USA
Posts: 1,180
glennzo, most likely your firewall (iptables) on toshiba is blocking inbound access to port 22, thus preventing ssh/sftp from dad.

A quick test involves turning off iptables on toshiba.

$ su -c '/sbin/service iptables stop'

Then see if you can connect from dad to toshiba using ssh.

To turn the firewall back on, run

$ su -c '/sbin/service iptables start'
Reply With Quote
  #10  
Old 4th September 2007, 02:25 AM
glennzo Online
Un-Retired Administrator
 
Join Date: Mar 2004
Location: Salem, Mass USA
Age: 57
Posts: 14,698
Thanks. AS it happens I was reading a post by Firewing1, the 'every server setup imaginable' post. I ran system-config-securitylevel and found that the firewall and selinux were indeed on. I turned them off and ssh and sftp to toshiba now work.
__________________
Glenn
The Bassinator © ®

[SIGPIC][/SIGPIC]
Laptop: Toshiba Satellite / Intel Core 2 Duo 1.73 GHz / 2GB / 160GB / Intel Mobile 945GM/GMS/GME/943/940GML Integrated Graphics
Desktop: BioStar MCP6PB M2+ / AMD Phenom 9750 Quad Core / 4GB / 1TB SATA / 500GB SATA / EVGA GeForce 8400 GS 1GB
Reply With Quote
  #11  
Old 4th September 2007, 03:35 AM
marko Online
Registered User
 
Join Date: Jun 2004
Location: Laurel, MD USA
Posts: 6,032
just make sure to turn the firewall back on and instead allow the ssh to
work with the firewall by making holes in it at port 22

Mark
Reply With Quote
  #12  
Old 4th September 2007, 08:52 AM
glennzo Online
Un-Retired Administrator
 
Join Date: Mar 2004
Location: Salem, Mass USA
Age: 57
Posts: 14,698
This STFP, is this better than plain old networking in terms of ease, speed and security? If I use this it seems that there was / is no need for me to set up sabma for file sharing, which has always been tricky and finicky.
__________________
Glenn
The Bassinator © ®

[SIGPIC][/SIGPIC]
Laptop: Toshiba Satellite / Intel Core 2 Duo 1.73 GHz / 2GB / 160GB / Intel Mobile 945GM/GMS/GME/943/940GML Integrated Graphics
Desktop: BioStar MCP6PB M2+ / AMD Phenom 9750 Quad Core / 4GB / 1TB SATA / 500GB SATA / EVGA GeForce 8400 GS 1GB
Reply With Quote
  #13  
Old 4th September 2007, 02:55 PM
marko Online
Registered User
 
Join Date: Jun 2004
Location: Laurel, MD USA
Posts: 6,032
sftp is secure file transfer protocol it, it's just a very basic ftp client that runs thru a ssh connection,
it could replace samba if you only seldom send files around. But it's not as handy.
Another option is 'scp' which is secure copy. If you are sending a file from
your currrent host to host2 you just do:

Quote:
scp file username@host2:
or
scp /usr/local/filename username@host2:/usr/local
the colon ":" means the home directory of username.
If could also put the file below the home dir on host2 in
"/home/username/dir2/dir3"

scp file username@host2:dir2/dir3

To make it really convenient you'd want to setup the private /public keys
so it's not always bugging for your password.

Mark
Reply With Quote
  #14  
Old 4th September 2007, 05:01 PM
glennzo Online
Un-Retired Administrator
 
Join Date: Mar 2004
Location: Salem, Mass USA
Age: 57
Posts: 14,698
Linux gets more interesting every day. Fact of the matter is that I just don't explore it like I used to.
__________________
Glenn
The Bassinator © ®

[SIGPIC][/SIGPIC]
Laptop: Toshiba Satellite / Intel Core 2 Duo 1.73 GHz / 2GB / 160GB / Intel Mobile 945GM/GMS/GME/943/940GML Integrated Graphics
Desktop: BioStar MCP6PB M2+ / AMD Phenom 9750 Quad Core / 4GB / 1TB SATA / 500GB SATA / EVGA GeForce 8400 GS 1GB
Reply With Quote
Reply

Tags
sftp

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
F7 sftp High_Noonan Using Fedora 4 16th June 2007 07:29 PM
sftp creating restricted shell for sftp only 105547111 Using Fedora 3 29th May 2007 02:14 AM
sftp and ssh Wiles Servers & Networking 5 21st August 2006 09:46 AM
SSH yes...SFTP no... Error Using Fedora 9 23rd June 2004 12:32 PM


Current GMT-time: 21:09 (Monday, 01-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat