Fedora Linux Support Community & Resources Center
  #1  
Old 9th December 2006, 01:09 AM
pescobar
Guest
 
Posts: n/a
yum update problem

I am trying to run yum update on my freshly installed FC6 x86_64 box.

I have not changed any of the repository settings or anything. I am just trying to run yum update. I previously had a python problem which I fixed by doing:

rpm -e --nodeps python-2.4.4-1.fc6.x86_64

Apparently, two versions of python somehow ended up on my system. But now when I do yum update, I get the following:

Transaction Check Error: file /usr/share/gtk-doc/html/pango/PangoEngineLang.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
file /usr/share/gtk-doc/html/pango/PangoEngineShape.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
file /usr/share/gtk-doc/html/pango/PangoFcDecoder.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
file /usr/share/gtk-doc/html/pango/PangoFcFont.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
file /usr/share/gtk-doc/html/pango/PangoFcFontMap.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
file /usr/share/gtk-doc/html/pango/PangoMarkupFormat.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
file /usr/share/gtk-doc/html/pango/index.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
file /usr/share/gtk-doc/html/pango/index.sgml from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
file /usr/share/gtk-doc/html/pango/ix01.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
file /usr/share/gtk-doc/html/pango/ix02.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
file /usr/share/gtk-doc/html/pango/ix03.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
file /usr/share/gtk-doc/html/pango/ix04.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
file /usr/share/gtk-doc/html/pango/ix05.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
file /usr/share/gtk-doc/html/pango/ix06.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
file /usr/share/gtk-doc/html/pango/ix07.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
file /usr/share/gtk-doc/html/pango/ix08.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
file /usr/share/gtk-doc/html/pango/ix09.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
file /usr/share/gtk-doc/html/pango/lowlevel.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
file /usr/share/gtk-doc/html/pango/pango-ATSUI-Fonts.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
file /usr/share/gtk-doc/html/pango/pango-Cairo-Rendering.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
file /usr/share/gtk-doc/html/pango/pango-Coverage-Maps.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
file /usr/share/gtk-doc/html/pango/pango-Engines.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
file /usr/share/gtk-doc/html/pango/pango-Fonts.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
file /usr/share/gtk-doc/html/pango/pango-FreeType-Fonts-and-Rendering.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
file /usr/share/gtk-doc/html/pango/pango-Glyph-Storage.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
file /usr/share/gtk-doc/html/pango/pango-Layout-Objects.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
file /usr/share/gtk-doc/html/pango/pango-Miscellaneous-Utilities.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
file /usr/share/gtk-doc/html/pango/pango-Modules.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
file /usr/share/gtk-doc/html/pango/pango-OpenType-Font-Handling.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
file /usr/share/gtk-doc/html/pango/pango-Scripts.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
file /usr/share/gtk-doc/html/pango/pango-Tab-Stops.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
file /usr/share/gtk-doc/html/pango/pango-Text-Attributes.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
file /usr/share/gtk-doc/html/pango/pango-Text-Processing.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
file /usr/share/gtk-doc/html/pango/pango-Win32-Fonts-and-Rendering.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
file /usr/share/gtk-doc/html/pango/pango-X-Fonts-and-Rendering.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
file /usr/share/gtk-doc/html/pango/pango-Xft-Fonts-and-Rendering.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
file /usr/share/gtk-doc/html/pango/pango-querymodules.html from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
file /usr/share/gtk-doc/html/pango/pango.devhelp from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
file /usr/share/gtk-doc/html/pango/pango.devhelp2 from install of pango-devel-1.14.8-1.fc6 conflicts with file from package pango-devel-1.14.4-3.fc6
file /usr/share/gtk-doc/html/hal/ch01.html from install of hal-devel-0.5.8.1-5.fc6 conflicts with file from package hal-devel-0.5.8.1-5.fc6
file /usr/share/gtk-doc/html/hal/ch02.html from install of hal-devel-0.5.8.1-5.fc6 conflicts with file from package hal-devel-0.5.8.1-5.fc6
file /usr/share/gtk-doc/html/hal/hal-libhal-storage.html from install of hal-devel-0.5.8.1-5.fc6 conflicts with file from package hal-devel-0.5.8.1-5.fc6
file /usr/share/gtk-doc/html/hal/hal-libhal.html from install of hal-devel-0.5.8.1-5.fc6 conflicts with file from package hal-devel-0.5.8.1-5.fc6

Please help!
Reply With Quote
  #2  
Old 9th December 2006, 06:12 AM
hugbees Offline
Registered User
 
Join Date: Dec 2005
Posts: 46
my laptop too cant seem to yum update python and some other packages. isntalled fc6 couple of days ago
Reply With Quote
  #3  
Old 12th December 2006, 09:08 PM
bigfootnmd Offline
Registered User
 
Join Date: Sep 2004
Posts: 178
Ok I had a similar conflicts with problem.

Here is how I solved it. As root I typed yum remove "whatever the earlier version was"

This may remove more than one package. Next I ran yum update

So in this case I would try

yum remove pango-devel-1.14.4-3.fc6

Say yes to remove prompt

then run yum update

So, in effect by removing the offending earlier version of the package you remove the conflict.

Good luck
Reply With Quote
  #4  
Old 9th December 2006, 06:18 AM
u-noneinc-s Offline
Registered User
 
Join Date: Jul 2005
Location: Wine Country, California
Posts: 2,850
http://www.fedoraforum.org/forum/sho...d.php?t=140730 post 5 might help.

@ pescobar...I know you've been to this page but did you remove the older python or the newer one? (I know I would have removed the older one and evidently that's incorrect, in this case anyway).
__________________
Mark N.

Perpetual Newbie
--
I wanted to proclaim myself "The Typo King" but there's way too much competion. :p

411874 Get Counted
Reply With Quote
Reply

Tags
problem, update, yum

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
After 'yum update' problem wsinw Using Fedora 3 15th February 2009 03:56 PM
KDE Update Problem TheMixtureMedia Using Fedora 9 22nd December 2007 06:03 PM
yum update problem messner Using Fedora 0 15th June 2006 10:36 PM
Amarok Update Problem from yum -y update Raafi Using Fedora 6 26th August 2005 11:23 PM
FC3 update problem pengyou12345 EOL (End Of Life) Versions 4 14th July 2005 09:35 AM


Current GMT-time: 17:20 (Saturday, 23-08-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat