Oracle client and server (10g) fail to install on FC5. I worked around it by copying an Oracle installation directory from a FC4 box. Both sqlpus and libclntclsh.so work, but I really hope someone gets a fix for this...
Oracle client and server (10g) fail to install on FC5. I worked around it by copying an Oracle installation directory from a FC4 box. Both sqlpus and libclntclsh.so work, but I really hope someone gets a fix for this...
Last edited by giulix; 23rd March 2006 at 11:38 AM.
Asus K55VD, i5 3230M - Productivity/Programming (F28)
Asus M32CD - i7-6700, Asus STRIX-GTX970-DC2OC-4GD, 1x8 GB Sk Hynix 2133 MHz DDR4 - Gaming (W10)
There are two problems preventing Oracle from installing on FC5: one is that the platform is not (yet) supported, the other that the installer (both server and client) will hang while linking ntcontab.
The first problem is easily dealt with by appending the following option when starting the installer
The second one is trickier: there is a bug in the gennttab script that prevents the installer to execute a sed command; this bug is documented here (thanks to admjal). This is true for both the new version of the installer (10.2.0.1.0) as well as the previous one (10.2.0). See also here.Code:./runInstaller -ignoreSysPrereqs
The following instructions can be used to prepare an Oracle installation CD which will work on FC5, in case you need one to perform multiple installations (this is for the client installation):
1) Download the server or client .zip file for your platform from Oracle
2) Unzip it in a directory of your choice, say "Oracle"
3) cd to Oracle/client/stage/Components/oracle.network.rsf/10.2.0.1.0/1/DataFiles
4) Extract the files contained in the filegroup6.jar archive
change directory to bin and patch the gennttab script: change the linesCode:jar xf filegroup6.jar
with the linesCode:LIB=`$ECHO ${TtoLIB} | $SED 's/ /\\ /g' | $GREP "^${T}:" | $AWK -F: '{print $2}'` INI=`$ECHO ${TtoINI} | $SED 's/ /\\ /g' | $GREP "^${T}:" | $AWK -F: '{print $2}'` BAS=`$ECHO ${TtoBAS} | $SED 's/ /\\ /g' | $GREP "^${T}:" | $AWK -F: '{print $2}'`
5) Recreate the archive with the patched file and delete the bin directoryCode:LIB=`$ECHO ${TtoLIB} | $SED 's/ /\n/g' | $GREP "^${T}:" | $AWK -F: '{print $2}'` INI=`$ECHO ${TtoINI} | $SED 's/ /\n/g' | $GREP "^${T}:" | $AWK -F: '{print $2}'` BAS=`$ECHO ${TtoBAS} | $SED 's/ /\n/g' | $GREP "^${T}:" | $AWK -F: '{print $2}'`
Now you're ready to create the ISO to burn your patched Oracle installation CD.Code:cd .. jar cMf filegroup6.jar bin/* rm -rf bin
P.S. If you get a 'permission denied' when running runInstaller, create a new mountpoint for the cdrom, chmod it (777) and manually mount the cdrom.
Last edited by giulix; 23rd March 2006 at 02:40 PM.
Asus K55VD, i5 3230M - Productivity/Programming (F28)
Asus M32CD - i7-6700, Asus STRIX-GTX970-DC2OC-4GD, 1x8 GB Sk Hynix 2133 MHz DDR4 - Gaming (W10)
I got passed those issues last week. I am now running into issues trying to connect to tnsnames.ora and listener.ora. I don't remember the exact error message but it had something to do with not being able to resolve, connect etc.Originally Posted by giulix
================================================== =====================================
[oracle@localhost ~]$ lsnrctl start
LSNRCTL for Linux: Version 10.2.0.1.0 - Production on 05-APR-2006 00:05:10
Copyright (c) 1991, 2005, Oracle. All rights reserved.
Starting /u01/app/oracle/product/10.2.0/db_1/bin/tnslsnr: please wait...
TNSLSNR for Linux: Version 10.2.0.1.0 - Production
Log messages written to /u01/app/oracle/product/10.2.0/db_1/network/log/listener .log
TNS-01150: The address of the specified listener name is incorrect
TNS-01153: Failed to process string: (ADDRESS=(PROTOCOL=tcp)(HOST=)(PORT=1521))
Listener failed to start. See the error message(s) above...
================================================== =====================================
Last edited by aschreiber1; 5th April 2006 at 05:07 AM. Reason: Reinstalled 10g and posting exact error message for review
When I try and run "emctl start dbconsole" from a terminal window I get the following output:
TZ set to US/Eastern
OC4J Configuration issue. /u01/app/oracle/product/10.2.0/db_1/oc4j/j2ee/OC4J_DBC onsole_localhost.localdomain_TSH1 not found.
You need to specify a host IP address (or name) in there. Mind that I don't actually run any Oracle server installations on FC5 (yetOriginally Posted by aschreiber1
). My instructions are for the client, so that one can access an Oracle db from a FC5 box. In fact, Oracle is not supported on FC5 (not even the client). That said, I can confirm the Oracle precompilers are working (Pro*C), SQL*Plus, DBAStudio, Sqlloader and the NetInstaller from my FC5 machine (I am using it right now), are all working fine.
Anyway, despite the fact it is not officially supported, it is possible (even probable) that Oracle server 10.2 runs on FC5 just fine like it does on a (supported) RHEL server.
Last edited by giulix; 5th April 2006 at 10:00 AM.
Asus K55VD, i5 3230M - Productivity/Programming (F28)
Asus M32CD - i7-6700, Asus STRIX-GTX970-DC2OC-4GD, 1x8 GB Sk Hynix 2133 MHz DDR4 - Gaming (W10)