Thread: [SOLVED] A lot of duplicates in YUM
View Single Post
  #15  
Old 27th January 2014, 11:18 PM
Yatoom Offline
Registered User
 
Join Date: Apr 2012
Location: The Netherlands
Posts: 7
Re: A lot of duplicates in YUM

Thanks for making the list But I did this instead.
Code:
rpm --nodeps --noscripts -e libreport-gtk-2.1.10-1.fc20.x86_64 udisks2-2.1.2-1.fc20.x86_64 perl-libs-5.18.2-289.fc20.x86_64 accountsservice-libs-0.6.35-3.fc20.x86_64 bind-license-9.9.4-8.fc20.noarch audit-libs-2.3.3-1.fc20.x86_64 abrt-python-2.1.11-1.fc20.x86_64 abrt-retrace-client-2.1.11-1.fc20.x86_64 glusterfs-3.4.2-1.fc20.x86_64 abrt-libs-2.1.10-1.fc20.x86_64 dhcp-common-4.2.5-26.fc20.x86_64 kde-runtime-libs-4.11.4-1.fc20.x86_64 popt-1.16-2.fc20.x86_64 gnome-abrt-0.3.5-1.fc20.x86_64 nss-3.15.4-1.fc20.x86_64 kde-runtime-drkonqi-4.11.4-1.fc20.x86_64 kdepimlibs-kxmlrpcclient-4.11.4-1.fc20.x86_64 kdelibs-common-4.11.4-1.fc20.x86_64 abrt-2.1.10-1.fc20.x86_64 libreport-plugin-reportuploader-2.1.10-1.fc20.x86_64 initscripts-9.51-1.fc20.x86_64 perl-macros-5.18.2-289.fc20.x86_64 perl-5.18.2-289.fc20.x86_64 satyr-0.12-1.fc20.x86_64 coreutils-8.21-20.fc20.x86_64 kactivities-4.11.4-1.fc20.x86_64 php-common-5.5.7-1.fc20.x86_64 nepomuk-core-libs-4.11.5-1.fc20.x86_64 policycoreutils-2.2.4-5.fc20.x86_64 glusterfs-libs-3.4.1-3.fc20.x86_64 NetworkManager-glib-0.9.9.0-26.git20131003.fc20.x86_64 libreport-python-2.1.11-1.fc20.x86_64 perl-Module-CoreList-2.96-288.fc20.noarch gdk-pixbuf2-2.30.1-1.fc20.x86_64 mutter-3.10.3-1.fc20.x86_64 libreport-filesystem-2.1.10-1.fc20.x86_64 libreport-2.1.11-1.fc20.x86_64 dhcp-libs-4.2.5-26.fc20.x86_64 kde-runtime-flags-4.11.5-1.fc20.noarch abrt-gui-libs-2.1.11-1.fc20.x86_64 abrt-addon-ccpp-2.1.11-1.fc20.x86_64 oxygen-icon-theme-4.11.4-1.fc20.noarch kde-runtime-4.11.5-1.fc20.x86_64 p11-kit-0.20.2-1.fc20.x86_64 nss-sysinit-3.15.3.1-1.fc20.x86_64 kdelibs-4.11.4-1.fc20.x86_64 libreport-web-2.1.11-1.fc20.x86_64 gdb-7.6.50.20130731-19.fc20.x86_64 PackageKit-glib-0.8.16-1.fc20.x86_64 libreport-plugin-ureport-2.1.10-1.fc20.x86_64 control-center-filesystem-3.10.2-3.fc20.x86_64 nss-util-3.15.4-1.fc20.x86_64 accountsservice-0.6.35-4.fc20.x86_64 nss-softokn-freebl-3.15.3-1.fc20.x86_64 nss-softokn-3.15.3-1.fc20.x86_64 libreport-plugin-bugzilla-2.1.10-1.fc20.x86_64 ibus-libs-1.5.5-1.fc20.x86_64 nepomuk-core-4.11.5-1.fc20.x86_64
After that, I am able to yum update without errors.

Thank you!
Here is a funny text, because you helped me: link.

Quick summary of solution:
Store duplicate-list in a file.
# package-cleanup --dupes > duplicates.txt

Remove odd lines.
# awk 'NR%2==0' duplicates.txt > single-duplicates.txt

Replace new lines with spaces.
# awk '{ printf "%s ", $0 }' single-duplicates.txt > duplicates.txt

Copy-paste content of duplicates after command.
# rpm --nodeps --noscripts -e [paste here]
Reply With Quote