View Single Post
  #19  
Old 19th March 2011, 12:51 AM
vallimar Online
Registered User
 
Join Date: Jul 2008
Posts: 1,050
Re: changing fonts and icon theme in gnome-shell

Played around a little today, figured out how to change the icon theme, at least somewhat.
You need to install dconf-editor and gconf-editor. In dconf-editor, change the key
"org.gnome.desktop.interface.icon-theme" to the name of your theme. I chose "Faenza-Dark".
I changed it under gconf too to be safe "desktop.gnome.interface.icon-theme".

You can manually tweak the fonts as well. Have the latest F15 gnome-shell, 2.91.91-2 and
still no sign of any font config settings.

---------- Post added at 07:26 PM ---------- Previous post was at 07:17 PM ----------

Also, saw a tip on webupd8 before about how to get the minimize/maximize buttons back.
Change the key "desktop.gnome.shell.windows.button_layout".
I changed mine back to "menu:minimize,maximize,close".
I also had to logout and back in for it to take effect.

---------- Post added at 07:51 PM ---------- Previous post was at 07:26 PM ----------

Okay, last thing.. if you want to change the mouse cursor as well, in dconf
"org.gnome.desktop.interface.cursor-theme". And in gconf, also change
"desktop.gnome.peripherals.mouse.cursor-theme".

You can find out the name of the theme by looking at the "Name=" value inside the
index.theme file. Set both keys to the same value, should take effect immediately
if you have done it right if I recall, else try a relog. I went with "Protozoa-Blu".