View Single Post
  #9  
Old 2nd March 2010, 01:44 PM
madhavdiwan Offline
Registered User
 
Join Date: Jun 2009
Posts: 472
Well you definitely have at least one selinux issue. Xauth is being denied write access to "name"'s home directory


it probably has the incorrect selinux context:
Quote:
tcontext=unconfined_u:object_r:home_root_t:s0
typically a user's home directory has an selinux context of
Quote:
unconfined_u:object_r:user_home_dir_t:s0
to find a files selinux context use the Z option with the ls command
ls -lZ
ls -ldZ
ls -laZ

you can change the context using the chcon utility

man chcon

example

Code:
 chcon  unconfined_u:object_r:user_home_dir_t:s0 /home/name
to confirm this is a selinux issue only you might want to try a test by temporarily putting selinux into permissive mode on the remote host ,

as root please run /usr/sbin/getenforce ; /usr/sbin/setenforce 0 ; /usr/sbin/getenforce on the remote host ,

remove your Xauthority file on the remote host and try a fresh login invoking an X session.

Xauth should at that point write a new Xauthority file and enable your X11Forwarding socket on the loopback address of the remote host as well as set your DISPLAY variable.

You can set selinux back to enforcing after your test with

/usr/sbin/setenforce 1

if there are other issues , you will run into them after setting selinux to permissive.

Last edited by madhavdiwan; 2nd March 2010 at 01:50 PM.
Reply With Quote