View Single Post
  #4  
Old 7th September 2009, 01:03 AM
NoFate Offline
Registered User
 
Join Date: Jun 2006
Posts: 7
Hi all.
I wish to share my experience with F12 and nvidia.
In brief - yes it's possible to use nvidia driver in F12 but need some play:
1. Download latest beta driver (only this driver is able to work under new X server)
2. Download kernel source (i've downloaded it from koji.fedoraproject.org
3. Install it via rpm -ivh
4. Go to ~/rpmbuild/SOURCES and edit config-nodebug
Code:
CONFIG_SND_VERBOSE_PRINTK=y
CONFIG_SND_DEBUG=y
CONFIG_SND_PCM_XRUN_DEBUG=y
# CONFIG_DEBUG_MUTEXES is not set
# CONFIG_DEBUG_RT_MUTEXES is not set
# CONFIG_DEBUG_LOCK_ALLOC is not set
# CONFIG_PROVE_LOCKING is not set
# CONFIG_DEBUG_VM is not set
# CONFIG_DEBUG_SPINLOCK is not set
# CONFIG_FAULT_INJECTION is not set
# CONFIG_FAILSLAB is not set
# CONFIG_FAIL_PAGE_ALLOC is not set
# CONFIG_FAIL_MAKE_REQUEST is not set
# CONFIG_FAULT_INJECTION_DEBUG_FS is not set
# CONFIG_FAULT_INJECTION_STACKTRACE_FILTER is not set
# CONFIG_FAIL_IO_TIMEOUT is not set
# CONFIG_SLUB_DEBUG_ON is not set
# CONFIG_LOCK_STAT is not set
# CONFIG_DEBUG_STACK_USAGE is not set
# CONFIG_ACPI_DEBUG is not set
# CONFIG_DEBUG_SG is not set
# CONFIG_DEBUG_PAGEALLOC is not set
# CONFIG_DEBUG_WRITECOUNT is not set
# CONFIG_DEBUG_OBJECTS is not set
# CONFIG_DEBUG_OBJECTS_SELFTEST is not set
# CONFIG_DEBUG_OBJECTS_FREE is not set
# CONFIG_DEBUG_OBJECTS_TIMERS is not set
CONFIG_DEBUG_OBJECTS_ENABLE_DEFAULT=1
# CONFIG_X86_PTDUMP is not set
# CONFIG_CAN_DEBUG_DEVICES is not set
# CONFIG_MODULE_FORCE_UNLOAD is not set
# CONFIG_SYSCTL_SYSCALL_CHECK is not set
# CONFIG_DEBUG_NOTIFIERS is not set
# CONFIG_DMA_API_DEBUG is not set
# CONFIG_MMIOTRACE is not set
5. Build a kernel with following options
Code:
rpmbuild -bb --without debug --with baseonly kernel.spec
6. After finish to build a kernel install it from RPMS/<arch>
Code:
rpm -Uvh --force *.rpm
7. Edit xorg.conf (if it doesn't exist under /etc/X11/xorg.conf just create it manually) and add ignoreABI
Code:
Section "ServerFlags"
        Option      "ignoreABI" "true"
EndSection
8. Reboot the system and go to 3 level of boot
9. Log in to the system and install NVIDIA driver

The problem is because of kernel maintainer turn on GPL only mode (I mean that only modules under GPL are able to be used) by enable debugging.