View Single Post
  #3607  
Old 1st September 2009, 06:05 PM
a12ctic Offline
Registered User
 
Join Date: Jun 2005
Posts: 13
Quote:
Originally Posted by Canuck View Post
After a bit of messing around I was able to get Compiz to work without any cursor corruption. This is my work system so nothing fancy -- Radeon HD 2400 XT. I performed the manual install of the ATI driver / mkinitrd etc. With my first install / Xinerama on I did see corruption with Compiz...but this morning I blew away xorg.conf and performed the following:

1) mv xorg.conf xorg.conf.old
2) aticonfig --initial -f
3) aticonfig --set-pcs-str="DDX,EnableRandR12,FALSE"

The above should enable big desktop after logging out etc. I then setup my dual monitor config (through the ATI catalyst control center), logged out one more time, and enabled desktop effects. Worked without any problems and did not see any cursor corruption. I've had it running the past 12 hours without any freezes or issues.

Kernel: 2.6.29.6-217.2.8.fc11.x86_64

Xorg below:

Section "ServerLayout"
Identifier "aticonfig Layout"
Screen 0 "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Files"
EndSection

Section "Module"
EndSection

Section "ServerFlags"
Option "Xinerama" "off"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]-0"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]-0"
Driver "fglrx"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]-0"
Device "aticonfig-Device[0]-0"
Monitor "aticonfig-Monitor[0]-0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection
The third line fixed the issues I was having as well, allowing me to disable the software cursor.

Code:
aticonfig --set-pcs-str="DDX,EnableRandR12,FALSE"
Thank you.
Reply With Quote