View Single Post
  #3564  
Old 24th August 2009, 11:43 PM
Jeff72 Offline
Registered User
 
Join Date: Nov 2008
Posts: 164
* Updated October 12, 2009

Here are some notes on how I got the ATI Catalyst 9.8 and 9.9 driver working with Fedora 11 (32-bit) on my ATI 4850 graphics card:

ATI Catalyst driver install
I started with post #1 and did the PAE install since i'm running Fedora 11 32-bit: http://forums.fedoraforum.org/showpo...99&postcount=1
However, I had to do the following to resolve some issues.

Generate an ATI /etc/X11/xorg.conf file (xorg.conf issue):
I originally had an empty /etc/X11/xorg.conf file before installing the Catalyst packages. I noticed that /etc/X11/xorg.conf was still empty after installing the catalyst packages and rebooting.
The fix for this was to generate an ATI /etc/X11/xorg.conf file by running this as root:
Code:
# rename old /etc/X11/xorg.conf file
mv /etc/X11/xorg.conf /etc/X11/xorg.conf-old

# Single Monitor display
aticonfig --initial

# or, if you have two monitors configured:
# Two Monitor displays
aticonfig --initial=dual-head
Fix desktop locking up after login and while moving windows around:
After creating an initial xorg.conf file, I was able to get to the login screen. However, my screen would lockup whenever moving windows around.
There are 2 options you can do to fix this, as far as I am aware of:
NOTE: Pick only one of the two options below. If you want to do option 1 and you already have done option 2, then you will want to comment or remove the "Option "SWCursor" "true" line from your /etc/X11/xorg.conf file.

Disable RandR 1.2 support:
(Note, the below command adds "EnableRandR12=SFALSE" to the "[AMDPCSROOT/SYSTEM/DDX]" section in the /etc/ati/amdpcsdb file.)
(See also http://www.phoronix.com/scan.php?pag...item=927&num=1 for "A Newbie's Guide To RandR 1.2".)
Code:
# Run the following as root
aticonfig --set-pcs-str="DDX,EnableRandR12,FALSE"
REMOVE the following line from from your /etx/X11/xorg.conf file, if it is there:
Code:
Option "SWCursor" "true"
COMPIZ-FUSION (cube and other desktop affects)
I installed compiz-fusion using the official package instructions here:http://forums.fedoraforum.org/showpo...29&postcount=2
To run compiz-fusion, run: "Applications" - "System Tools" - "Compiz Fusion Icon"
Then right click the running Compiz Fusion Icon in the top right of your screen and select "Select Window Manager" and choose "Compiz".
Then right click the running Compiz Fusion Icon in the top right of your screen and select "Select Window Decorator" and choose "Emerald".
Then right click the running Compiz Fusion Icon in the top right of your screen and select "Emerald Theme Manager" and choose "SlateHorn_Blue" (or any one you like) and then click Quit.
Hold down CTRL+Alt keys and then left click on the top of a window and drag left or right to see the cube affect.


SELINUX fixes:
I got this error on bootup which is related to SELINUX:
Code:
# /etc/rc5.d/S97atieventsd start
Starting ATI External Events Daemon: atieventsd: error while loading shared libraries: /usr/lib/catalyst/libGL.so.1: cannot restore segment prot after reloc: Permission denied
                                                           [FAILED]
The fix for the above SELINUX error is to run this as root:
Code:
chcon -t textrel_shlib_t '/usr/lib/catalyst/libGL.so.1.2'
To make "glxgears" run without having SELINUX complain, run this as root:
Code:
chcon -t textrel_shlib_t '/usr/lib/catalyst/libatiadlxx.so'
To change screen display properties:
Run "Applications" - "System Tools" - "ATI Catalyst Control Center"

UPDATING YOUR SYSTEM (Added October 12, 2009)
If you update your system, and update the xorg catalyst packages (to version 9.9-2, for example):
xorg-x11-drv-catalyst
xorg-x11-drv-catalyst-libs
Then you will need to run the SELINUX fixes again. These will fix things so that Compiz Fusion Icon and also "glxgears" works again.
Run these as root userID:
Code:
chcon -t textrel_shlib_t '/usr/lib/catalyst/libGL.so.1.2'
chcon -t textrel_shlib_t '/usr/lib/catalyst/libatiadlxx.so'

Other options:
I am running fine with disabling RandR 1.2 support above. But, if you happen to have issues with disabling RandR 1.2 support above, you can try this instead:
Enable SWCursor:
(Note: Originally I tried this option. With SWCursor set to true, the system display does not lockup anymore. Although things work, I notice mouse cursor corruption if I enable compiz-fusion.)
Code:
# Add the following line to the "Device" section in the ATI created /etc/X11/xorg.conf file:
Option "SWCursor" "true"

Last edited by Jeff72; 13th October 2009 at 05:57 AM.
Reply With Quote