FedoraForum.org

FedoraForum.org (http://forums.fedoraforum.org/index.php)
-   Guides & Solutions (No Questions) (http://forums.fedoraforum.org/forumdisplay.php?f=12)
-   -   F16,F15 & F14 Nvidia driver guides (http://forums.fedoraforum.org/showthread.php?t=204752)

CarlosMosca 3rd December 2009 01:39 AM

I was reading and trying every single configuration change possible to try and get the nvidia driver working (installing wasn't an issue) the way it's supposed to when I came about this post:

http://forums.fedoraforum.org/showpo...0&postcount=36

And followed the instructions at the top of the page. Everything worked flawlessly and I'm now enjoying Fedora 12 KDE with enhanced window management as I type.

I thought perhaps posting this here will help somebody else as well. :p

Boricua 3rd December 2009 02:26 AM

Way to Recover Plymouth?
 
Hi, I followed early instructions when F12 was still beta that disabled plymouth in order to allow the nvidia driver to load. Now that F12 is more stable, I was wondering if I can bring back graphical plymouth, that is, deleting the parameters inserted in grub.conf. I have being checking this thread and others without success, so any guidance would be appreciated.

pablaasmo 3rd December 2009 08:59 AM

I upgraded from F11 to F12 yesterday using preupgrade. The upgrad went well, but i have a small chaning in the behavior of the wallpaper.

I Use nvidia 9500GT card in TwinView mode. In F11 the wallpaper covered both monitors. But in F12 I get the same picture on each monitor.

Anyone have an explanation for that?
What has changed? Is it Gnome, X11, Compiz or nVidia drivers?

Eos 3rd December 2009 09:33 PM

Quote:

Originally Posted by Hlingler (Post 1300379)
Correct: pushed to RPMFusion stable/updates (from *-testing).

Does that mean they can now be installed safely via "yum install kmod-nvidia", without any further system-adjustments? Because that's what I just did, but after the reboot X won't start anymore. The logs say something about another driver (probably nouveau)blocking the hardware

Hlingler 3rd December 2009 11:10 PM

Quote:

Does that mean they can now be installed safely via "yum install kmod-nvidia", without any further system-adjustments? Because that's what I just did...
Yes.
Quote:

...but after the reboot X won't start anymore. The logs say something about another driver (probably nouveau)blocking the hardware
Follow all of the instructions to suppress, and if necessary uninstall, nouveau.

V

miltbos 4th December 2009 12:05 AM

nvidia F12 issues continuing for me
 
I have been reading the posts on the nvidia issues for F12. Have had absolutely no success getting anything to allow me to use dual screen mode. If I try the automatically generated xorg.conf from the "settings-nvidia" app I get a message about the driver is not an nvidia driver the next time I try to access that app to get my second screen set up. All screen addresses and names appear correct.

Changed to latest released kernel yesterday with no success. Running the x86_64 variant.

File follows:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (mockbuild@builder.wilsonet.com) Sun Nov 22 21:42:15 EST 2009

# Xorg configuration created by livna-config-display

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
Screen 1 "Screen1" RightOf "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "1"
EndSection

Section "Files"
ModulePath "/usr/lib64/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib64/xorg/modules"
EndSection

Section "ServerFlags"
Option "AIGLX" "on"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "ViewSonic VX2035wm"
HorizSync 30.0 - 82.0
VertRefresh 50.0 - 75.0
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "Unknown"
ModelName "SHARP HDMI"
HorizSync 15.0 - 75.0
VertRefresh 55.0 - 76.0
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
Option "AddARGBGLXVisuals" "True"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 8400 GS"
BusID "PCI:3:0:0"
EndSection

Section "Device"
Identifier "Device1"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "nForce 750a SLI"
BusID "PCI:2:0:0"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Videocard0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Device1"
Monitor "Monitor1"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

I manually deleted this from the xorg.conf file to get KDE to run. If I do not remove the following pointer information, KDE locks soon after login.

Section "InputDevice"
# generated from data in "/etc/sysconfig/keyboard"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbLayout" "us"
Option "XkbModel" "pc105"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Have never had issues with configuring the dual screens before. What am I missing.

leigh123linux 4th December 2009 12:09 AM

Quote:

Originally Posted by miltbos (Post 1300951)
I have been reading the posts on the nvidia issues for F12. Have had absolutely no success getting anything to allow me to use dual screen mode. If I try the automatically generated xorg.conf from the "settings-nvidia" app I get a message about the driver is not an nvidia driver the next time I try to access that app to get my second screen set up. All screen addresses and names appear correct.

Changed to latest released kernel yesterday with no success. Running the x86_64 variant.

File follows:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (mockbuild@builder.wilsonet.com) Sun Nov 22 21:42:15 EST 2009

# Xorg configuration created by livna-config-display

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
Screen 1 "Screen1" RightOf "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "1"
EndSection

Section "Files"
ModulePath "/usr/lib64/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib64/xorg/modules"
EndSection

Section "ServerFlags"
Option "AIGLX" "on"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "ViewSonic VX2035wm"
HorizSync 30.0 - 82.0
VertRefresh 50.0 - 75.0
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "Unknown"
ModelName "SHARP HDMI"
HorizSync 15.0 - 75.0
VertRefresh 55.0 - 76.0
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
Option "AddARGBGLXVisuals" "True"
EndSection


Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 8400 GS"
BusID "PCI:3:0:0"
EndSection

Section "Device"
Identifier "Device1"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "nForce 750a SLI"
BusID "PCI:2:0:0"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Videocard0"
EndSection


Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Device1"
Monitor "Monitor1"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

I manually deleted this from the xorg.conf file to get KDE to run. If I do not remove the following pointer information, KDE locks soon after login.

Section "InputDevice"
# generated from data in "/etc/sysconfig/keyboard"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbLayout" "us"
Option "XkbModel" "pc105"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Have never had issues with configuring the dual screens before. What am I missing.


delete the red bits

CaptainH 4th December 2009 03:51 AM

The answer to this question may be obvious but after doing this step "setsebool -P allow_execstack on" if I wanted to undo it and put it back to how it was would I just run this "setsebool -P allow_execstack off" ? I had another computer were I omitted this step and it still worked fine so I wanted to try and undo it on a different one to see if it still worked. Thanks.

JohnnyLinux 4th December 2009 06:18 AM

Quote:

Originally Posted by Hlingler (Post 1300379)
EDIT: *At least: I think that's what you meant. If not: please clarify. We will, of course, always attempt to answer all (relevant) questions here, no matter how hard our teeth are grinding. :D

Yes, you answered my question. I have decided to reinstall and will use the nouveau drivers for now....

Thanks Hlingler

---------- Post added at 11:18 PM CST ---------- Previous post was at 09:38 PM CST ----------

Quote:

Originally Posted by weitjong (Post 1300195)
A suggestion on step 2.

When installing F12, I chosen to use LVM and I have a LV root partition. My grub entry has something like this:
kernel ........ root=/dev/mapper/vgXXX-lvRoot

Thus the "sed -i '/root=UUID/s|$| rdblacklist=nouveau|' /boot/grub/grub.conf" does not work for me. To make it more generic this would be better.

# sed -i '/root=/s|$| rdblacklist=nouveau|' /boot/grub/grub.conf

p.s. may be that is why nouveau refuses to die for some who follow the guide to the dot.

Thanks to this comment I decided to skip Step 2 since it would be redundant.

Nvidia akmod works on 64bit.

Thanks weitjong!

AdoNNeN 4th December 2009 09:18 AM

i have fedora 12 64 bit with the kernel 2.6.31.6-145.fc12.x86_64
nvidia driver starts normally, i can access nvidia settings without a problem, however, KDE won't start, it hangs by the startup. desktop effects in gnome also won't work, i receive the message that Accelerated 3D graphics is not available. interestingly that startkde command works from gnome and kde starts with 3d effects!!! what is going on in here?
i've followed all the installation points and also retried to reenable the nvidia-config-display , i get the following error :

adonnen]# nvidia-config-display disable
Traceback (most recent call last):
File "/usr/sbin/nvidia-config-display", line 146, in <module>
app = nvidiaConfigDisplay()
File "/usr/sbin/nvidia-config-display", line 52, in __init__
self.run()
File "/usr/sbin/nvidia-config-display", line 134, in run
self.disable()
File "/usr/sbin/nvidia-config-display", line 94, in disable
prevDriver = self.config.getOldDriver()
File "/usr/lib/python2.6/site-packages/livnaConfigDisplay/ConfigFile.py", line 112, in getOldDriver
return self.get('Configuration', 'OldDriver')
File "/usr/lib/python2.6/site-packages/livnaConfigDisplay/ConfigFile.py", line 76, in get
value = self.config.get(section, property)
File "/usr/lib64/python2.6/ConfigParser.py", line 540, in get
raise NoOptionError(option, section)
ConfigParser.NoOptionError: No option 'olddriver' in section: 'Configuration'


thanks for the reply in advance :)

leigh123linux 4th December 2009 10:34 AM

Quote:

Originally Posted by AdoNNeN (Post 1301137)
i have fedora 12 64 bit with the kernel 2.6.31.6-145.fc12.x86_64
nvidia driver starts normally, i can access nvidia settings without a problem, however, KDE won't start, it hangs by the startup. desktop effects in gnome also won't work, i receive the message that Accelerated 3D graphics is not available. interestingly that startkde command works from gnome and kde starts with 3d effects!!! what is going on in here?
i've followed all the installation points and also retried to reenable the nvidia-config-display , i get the following error :

adonnen]# nvidia-config-display disable
Traceback (most recent call last):
File "/usr/sbin/nvidia-config-display", line 146, in <module>
app = nvidiaConfigDisplay()
File "/usr/sbin/nvidia-config-display", line 52, in __init__
self.run()
File "/usr/sbin/nvidia-config-display", line 134, in run
self.disable()
File "/usr/sbin/nvidia-config-display", line 94, in disable
prevDriver = self.config.getOldDriver()
File "/usr/lib/python2.6/site-packages/livnaConfigDisplay/ConfigFile.py", line 112, in getOldDriver
return self.get('Configuration', 'OldDriver')
File "/usr/lib/python2.6/site-packages/livnaConfigDisplay/ConfigFile.py", line 76, in get
value = self.config.get(section, property)
File "/usr/lib64/python2.6/ConfigParser.py", line 540, in get
raise NoOptionError(option, section)
ConfigParser.NoOptionError: No option 'olddriver' in section: 'Configuration'


thanks for the reply in advance :)


nvidia-config-display is probably complaining because xorg.conf already exists


try

Code:

su
rm -f /etc/X11/xorg.conf
nvidia-config-display disable
nvidia-config-display enable


AdoNNeN 4th December 2009 01:05 PM

thanks, now I can open the desktop effects menu.
however, if I choose Compiz, the system hangs (just mouse is still working)..
and KDE still won't start

erroneus 4th December 2009 08:29 PM

I am not sure what I didn't do besides the initrd part (which I still haven't done) but I was unable to get it to work as documented. I initially followed some other instructions found elsewhere that did not include the initrd portion, but since the nuveau thing was blocked in the kernel line, I didn't see the point.

In any case, I was able to resolve my problem by removing the kmod packages and going with the akmod package. It worked after that. I haven't had time to read through this thread yet, but I will...

IrishBouzouki 4th December 2009 09:54 PM

tried it, worked (fc12 64-bit using akmods)
did both the grub.conf mod and the initramfs although some places (ie rpmfusion website) seem to indicate only one or the other is required
comments...
1. fc12 with nouveau had a new (ie different from fc10) splash screen during boot (fedora icon slowly changing blue->white bot-left to top-rt), with nvidia it is back to the old splash screen (3-color bar along the bottom progressing toward "Fedora 12" at right)
2. has it ever been resolved wether one can return to default SELinux level?
3. if I never use wine or 32-bit 3d stuff I can probably avoid instaling the 686 libs and all the stuff you have install with them (about 30 other packages)?
but meantime lsmod is clear of nouveau and my glxgears went from ~450fps to ~1800fps (but the way I instantly know the nvidia drivers are in is the fan noise went way down!)

miltbos 5th December 2009 12:45 AM

Tried deleting the red bits per your instructions. Doesn't help. Situation continues thusly - when the automatically generated xorg.conf from the nvidia-settings program is run, system locks up somewhere upon login or shortly thereafter. I have a default xorg.conf that is generated when it is deleted and everything is fine.

tux4me 5th December 2009 01:41 PM

miltBos :

I dont know if this will help you in any way, but since no one else is answering you i'll share my expirence.

I noticed that you are using a Sharp tv, with HDMI. ... so do i ...
I had the problem that my nvidia card couldent detect that TV properly, since the nvidia driver 1.81 (or so) .
I asked in here but never got any answer .....
It was detected as a CRT monitor (cathode ray tube) but should have been detected as a DFP monitor (Digital Flat Panel).
When i read the info from nvidia on the Linux driver, they say that you cant count on the driver to detect your monitor correctly.
therefore there is a few options to force your card to see the monitor as a DFP or a HD TV.

Please note, that im only a happy Fedora user, and in no way a qualified Fedora/Linux admin/developer/nvidia dude :cool:

You can use CRT, DFP or TV as display devices, according to what you have.

"They may be specified either in the Screen or Device sections of the X config file."
(i recommend the screen section, since nvidia settings delete the driver section if you change number of monitors)

"limits the display devices the NVIDIA X driver will consider for an X screen."
Code:

Option        "UseDisplayDevice" "DFP"
"Allows you to override what the NVIDIA kernel module detects is connected to your graphics card."
"It is generally recommended to not use this option, but instead use the "UseDisplayDevice" option."
tho i had to use it like this ;)
Code:

Option        "ConnectedMonitor" "DFP-0, DFP-1"
"reports the currently enabled display devices in the order "CRT, DFP, TV", can be used to override this order"
Code:

Option        "TwinViewXineramaInfoOrder" "DFP-0, DFP-1"
"Force Component output format, also called YPbPr for HD"
Code:

Option        "TVOutFormat" "COMPONENT"
Good luck m8 ;)

freekill 5th December 2009 03:40 PM

yum install kmod-nvidia xorg-x11-drv-nvidia-libs.i686 gave me
Code:

Loaded plugins: presto, refresh-packagekit
Setting up Install Process
No package kmod-nvidia available.
No package xorg-x11-drv-nvidia-libs.i686 available.
Nothing to do

any work around?

tux4me 5th December 2009 04:47 PM

Did you install the rpmfusion repo first ?

Code:

rpm -Uvh http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm

freekill 6th December 2009 12:28 AM

Quote:

Did you install the rpmfusion repo first ?
I did. Verified and checked for repo installation. Still no good though.

CarlosMosca 6th December 2009 01:10 AM

Quote:

Originally Posted by AdoNNeN (Post 1301189)
thanks, now I can open the desktop effects menu.
however, if I choose Compiz, the system hangs (just mouse is still working)..
and KDE still won't start

Have you tried replacing xorg-x11-server-Xorg-1.7.1-12.fc12 and xorg-x11-server-common-1.7.1-12.fc12 ??

I'm running Fedora 12 KDE PAE kernel thanks to this post on another thread:

http://forums.fedoraforum.org/showth...60#post1300260

Instructions are at the top of the page, and the two files to download can be found here:

http://koji.fedoraproject.org/koji/b...buildID=142860

It made my problem go away and I'm happily running the enhanced desktop features and my compy can now go to sleep and wake up without problems. :p

AdoNNeN 8th December 2009 09:53 AM

installed new kernel 2.6.31.6-162.fc12.x86_64 and updated the system, including nvidia-driver..
still fails to start Compiz and KDE.

IrishBouzouki 8th December 2009 02:36 PM

interestingly, have been running with the akmod nvidia package for a few days (including the new mainstream kernel update)... but just tried to enable compiz for the first time via desktop-effects (system>preferences>desktop effects)

system locked up for about 10-15 seconds, then returned to the standard non-compiz setting on its own.






edit... not sure this is the place to ask about compiz stuff anyhow, so started a thread under software...
http://forums.fedoraforum.org/showthread.php?p=1303153
...but if you know of the right place to ask about compiz let me know

AdoNNeN 8th December 2009 02:56 PM

Quote:

Originally Posted by IrishBouzouki (Post 1303138)
interestingly, have been running with the akmod nvidia package for a few days (including the new mainstream kernel update)... but just tried to enable compiz for the first time via desktop-effects (system>preferences>desktop effects)

system locked up for about 10-15 seconds, then returned to the standard non-compiz setting on its own.

yap, having the same problem..

leigh123linux 8th December 2009 03:09 PM

Compiz works OK here.


Code:

[leigh@localhost ~]$ uname -r
2.6.32-1.fc12.x86_64
[leigh@localhost ~]$ rpm -qa |grep nvidia
kmod-nvidia-2.6.31.6-153.fc12.x86_64-190.42-1.fc12.4.x86_64
xorg-x11-drv-nvidia-190.42-5.fc12.x86_64
xorg-x11-drv-nvidia-libs-190.42-5.fc12.i686
akmod-nvidia-190.42-1.fc12.4.x86_64
nvidia-settings-1.0-3.2.fc12.x86_64
nvidia-xconfig-1.0-1.fc12.x86_64
xorg-x11-drv-nvidia-libs-190.42-5.fc12.x86_64
kmod-nvidia-2.6.31.6-160.fc12.x86_64-190.42-1.fc12.4.x86_64
kmod-nvidia-2.6.32-1.fc12.x86_64-190.42-1.fc12.4.x86_64
[leigh@localhost ~]$ rpm -qa |grep compiz
compizconfig-backend-gconf-0.8.4-1.fc12.x86_64
compiz-devel-0.8.4-3.fc12.x86_64
compiz-fusion-0.8.4-2.fc12.x86_64
compiz-fusion-release-1-8.noarch
compiz-fusion-unsupported-0.8.4-1.fc12.x86_64
compizconfig-python-0.8.4-1.fc12.x86_64
compiz-fusion-gnome-0.8.4-2.fc12.x86_64
compiz-fusion-extras-0.8.4-1.fc12.x86_64
compiz-bcop-0.8.4-1.fc12.noarch
compiz-gnome-0.8.4-3.fc12.x86_64
libcompizconfig-0.8.4-1.fc12.x86_64
compiz-fusion-extras-gnome-0.8.4-1.fc12.x86_64
compiz-0.8.4-3.fc12.x86_64
[leigh@localhost ~]$


Have you checked for direct rendering?

IrishBouzouki 8th December 2009 04:36 PM

Yep, here ya go...
Code:

$ uname -r
2.6.31.6-162.fc12.x86_64
$ rpm -qa |grep nvidia
xorg-x11-drv-nvidia-190.42-5.fc12.x86_64
nvidia-xconfig-1.0-1.fc12.x86_64
kmod-nvidia-2.6.31.6-162.fc12.x86_64-190.42-1.fc12.4.x86_64
xorg-x11-drv-nvidia-libs-190.42-5.fc12.x86_64
nvidia-settings-1.0-3.2.fc12.x86_64
kmod-nvidia-2.6.31.6-145.fc12.x86_64-190.42-1.fc12.6.x86_64
akmod-nvidia-190.42-1.fc12.4.x86_64
$ rpm -qa |grep compiz
compiz-0.8.2-19.fc12.x86_64
compiz-gnome-0.8.2-19.fc12.x86_64
$ glxinfo |grep direct
direct rendering: Yes

...but compiz does not work when I try to enable it using the menu GUI at system>preferences>desktop effects. locks up 10-15 secs then thankfully sets itself back to standard mode.

Is there something else I need? Never done the compiz thing before so all brand spanking new to me.

Quote:

Originally Posted by leigh123linux (Post 1303155)
Compiz works OK here.
Code:

$ uname -r
2.6.32-1.fc12.x86_64
$ rpm -qa |grep nvidia
kmod-nvidia-2.6.31.6-153.fc12.x86_64-190.42-1.fc12.4.x86_64
xorg-x11-drv-nvidia-190.42-5.fc12.x86_64
xorg-x11-drv-nvidia-libs-190.42-5.fc12.i686
akmod-nvidia-190.42-1.fc12.4.x86_64
nvidia-settings-1.0-3.2.fc12.x86_64
nvidia-xconfig-1.0-1.fc12.x86_64
xorg-x11-drv-nvidia-libs-190.42-5.fc12.x86_64
kmod-nvidia-2.6.31.6-160.fc12.x86_64-190.42-1.fc12.4.x86_64
kmod-nvidia-2.6.32-1.fc12.x86_64-190.42-1.fc12.4.x86_64
$ rpm -qa |grep compiz
compizconfig-backend-gconf-0.8.4-1.fc12.x86_64
compiz-devel-0.8.4-3.fc12.x86_64
compiz-fusion-0.8.4-2.fc12.x86_64
compiz-fusion-release-1-8.noarch
compiz-fusion-unsupported-0.8.4-1.fc12.x86_64
compizconfig-python-0.8.4-1.fc12.x86_64
compiz-fusion-gnome-0.8.4-2.fc12.x86_64
compiz-fusion-extras-0.8.4-1.fc12.x86_64
compiz-bcop-0.8.4-1.fc12.noarch
compiz-gnome-0.8.4-3.fc12.x86_64
libcompizconfig-0.8.4-1.fc12.x86_64
compiz-fusion-extras-gnome-0.8.4-1.fc12.x86_64
compiz-0.8.4-3.fc12.x86_64

Have you checked for direct rendering?


Hlingler 8th December 2009 04:49 PM

Quote:

$ glxinfo |grep direct
direct rendering: Yes
Insufficient output - where's the OpenGL renderer string ? Post:
glxinfo | grep render
Quote:

$ rpm -qa |grep compiz
compiz-0.8.2-19.fc12.x86_64
compiz-gnome-0.8.2-19.fc12.x86_64
Where's the rest of the pile ?? Your list is somewhat shorter than a full suite:
Code:

compizconfig-backend-gconf-0.8.4-1.fc12.x86_64
compiz-devel-0.8.4-3.fc12.x86_64
compiz-fusion-0.8.4-2.fc12.x86_64
compiz-fusion-release-1-8.noarch
compiz-fusion-unsupported-0.8.4-1.fc12.x86_64
compizconfig-python-0.8.4-1.fc12.x86_64
compiz-fusion-gnome-0.8.4-2.fc12.x86_64
compiz-fusion-extras-0.8.4-1.fc12.x86_64
compiz-bcop-0.8.4-1.fc12.noarch
compiz-gnome-0.8.4-3.fc12.x86_64
libcompizconfig-0.8.4-1.fc12.x86_64
compiz-fusion-extras-gnome-0.8.4-1.fc12.x86_64
compiz-0.8.4-3.fc12.x86_64

Quote:

but compiz does not work when I try to enable it using the menu GUI at system>preferences>desktop effects.
That's not Compiz - that's GNOME's built-in compositing effects. EDIT: OOPS! Strike that - it appears that I'm in error.

V

IrishBouzouki 8th December 2009 05:03 PM

Code:

$ glxinfo | grep render
direct rendering: Yes
OpenGL renderer string: GeForce 9600 GT/PCI/SSE2

as stated, know very little about compiz or compiz-fusion, what else do I need to do to run compiz?
thanks.

Quote:

Originally Posted by Hlingler (Post 1303204)
Insufficient output - where's the OpenGL renderer string ? Post:
glxinfo | grep renderWhere's the rest of the pile ?? Your list is somewhat shorter than a full suite:
Code:

compizconfig-backend-gconf-0.8.4-1.fc12.x86_64
compiz-devel-0.8.4-3.fc12.x86_64
compiz-fusion-0.8.4-2.fc12.x86_64
compiz-fusion-release-1-8.noarch
compiz-fusion-unsupported-0.8.4-1.fc12.x86_64
compizconfig-python-0.8.4-1.fc12.x86_64
compiz-fusion-gnome-0.8.4-2.fc12.x86_64
compiz-fusion-extras-0.8.4-1.fc12.x86_64
compiz-bcop-0.8.4-1.fc12.noarch
compiz-gnome-0.8.4-3.fc12.x86_64
libcompizconfig-0.8.4-1.fc12.x86_64
compiz-fusion-extras-gnome-0.8.4-1.fc12.x86_64
compiz-0.8.4-3.fc12.x86_64

That's not Compiz - that's GNOME's built-in compositing effects.


leigh123linux 8th December 2009 05:06 PM

Quote:

Originally Posted by Hlingler (Post 1303204)
Insufficient output - where's the OpenGL renderer string ? Post:
glxinfo | grep renderWhere's the rest of the pile ?? Your list is somewhat shorter than a full suite:
Code:

compizconfig-backend-gconf-0.8.4-1.fc12.x86_64
compiz-devel-0.8.4-3.fc12.x86_64
compiz-fusion-0.8.4-2.fc12.x86_64
compiz-fusion-release-1-8.noarch
compiz-fusion-unsupported-0.8.4-1.fc12.x86_64
compizconfig-python-0.8.4-1.fc12.x86_64
compiz-fusion-gnome-0.8.4-2.fc12.x86_64
compiz-fusion-extras-0.8.4-1.fc12.x86_64
compiz-bcop-0.8.4-1.fc12.noarch
compiz-gnome-0.8.4-3.fc12.x86_64
libcompizconfig-0.8.4-1.fc12.x86_64
compiz-fusion-extras-gnome-0.8.4-1.fc12.x86_64
compiz-0.8.4-3.fc12.x86_64

That's not Compiz - that's GNOME's built-in compositing effects.

V

Desktop-effects is compiz ;)

Hlingler 8th December 2009 05:07 PM

OK, well: the NVidia driver is working fine (as indicated by "OpenGL renderer string: GeForce 9600 GT/PCI/SSE2"). Suggest that you now go to Leigh's Compiz-Fusion tutorial and follow it: http://forums.fedoraforum.org/showthread.php?t=173317 EDIT: Or... you could follow along here since Leigh seems to be available. :)

V
Quote:

Desktop-effects is compiz
My bad (don't use GNOME) - last time I looked, both GNOME and KDE had built-in compositing effects, I assumed system>preferences>desktop effects would be GNOME built-in.

leigh123linux 8th December 2009 05:09 PM

Quote:

Originally Posted by IrishBouzouki (Post 1303209)
Code:

$ glxinfo | grep render
direct rendering: Yes
OpenGL renderer string: GeForce 9600 GT/PCI/SSE2

as stated, know very little about compiz or compiz-fusion, what else do I need to do to run compiz?
thanks.



Post


Code:

compiz --replace --sm-disable --ignore-desktop-hints gconf
and

Code:

cat /etc/X11/xorg.conf

IrishBouzouki 8th December 2009 05:21 PM

Quote:

Originally Posted by leigh123linux (Post 1303214)
Post
Code:

compiz --replace --sm-disable --ignore-desktop-hints gconf
and
Code:

cat /etc/X11/xorg.conf

$ compiz --replace --sm-disable --ignore-desktop-hints gconf
Code:

compiz (video) - Warn: No 8 bit GLX pixmap format, disabling YV12 image format
but... my desktop is acting differently... but had to close that hung terminal and the process was killed with it.

$ cat /etc/X11/xorg.conf
Code:

# Xorg configuration created by livna-config-display

Section "Files"
        ModulePath  "/usr/lib64/xorg/modules/extensions/nvidia"
        ModulePath  "/usr/lib64/xorg/modules"
EndSection

Section "ServerFlags"
        Option            "AIGLX" "on"
EndSection

Section "Device"
        Identifier  "Videocard0"
        Driver      "nvidia"
        Option            "AddARGBGLXVisuals" "True"
EndSection

Section "Extensions"
        Option            "Composite" "Enable"
EndSection


leigh123linux 8th December 2009 05:25 PM

Quote:

Originally Posted by IrishBouzouki (Post 1303225)
$ compiz --replace --sm-disable --ignore-desktop-hints gconf
Code:

compiz (video) - Warn: No 8 bit GLX pixmap format, disabling YV12 image format
but... my desktop is acting differently... but had to close that hung terminal and the process was killed with it.

$ cat /etc/X11/xorg.conf
Code:

# Xorg configuration created by livna-config-display

Section "Files"
    ModulePath  "/usr/lib64/xorg/modules/extensions/nvidia"
    ModulePath  "/usr/lib64/xorg/modules"
EndSection

Section "ServerFlags"
    Option        "AIGLX" "on"
EndSection

Section "Device"
    Identifier  "Videocard0"
    Driver      "nvidia"
    Option        "AddARGBGLXVisuals" "True"
EndSection

Section "Extensions"
    Option        "Composite" "Enable"
EndSection



It wasn't hung, the command shouldn't close.


Quote:

my desktop is acting differently.
That's compiz ;)

IrishBouzouki 8th December 2009 05:33 PM

Quote:

Originally Posted by leigh123linux (Post 1303228)
It wasn't hung, the command shouldn't close.

that's what I expected was the case, sorry for the misuse of the term

Quote:

Originally Posted by leigh123linux (Post 1303228)
That's compiz ;)

thought it might be, at least part of it, oddly it seems there are still residual parts of it, maybe even all of it, running that did not shut down when the terminal closing killed the process - could that be?

does that mean this is a permanent feature of mine now or do I need to actually change some other setting? and system preferences desktop-effects still shows standard if that means anything

leigh123linux 8th December 2009 05:45 PM

Quote:

Originally Posted by IrishBouzouki (Post 1303232)
that's what I expected was the case, sorry for the misuse of the term


thought it might be, at least part of it, oddly it seems there are still residual parts of it, maybe even all of it, running that did not shut down when the terminal closing killed the process - could that be?

does that mean this is a permanent feature of mine now
or do I need to actually change some other setting? and system preferences desktop-effects still shows standard if that means anything


Yes it could, try the compiz guide in my sig.
No it isn't permanent.

you could run

Code:

compiz --replace --sm-disable --ignore-desktop-hints gconf &
to restart it.

IrishBouzouki 8th December 2009 06:01 PM

Quote:

Originally Posted by leigh123linux (Post 1303236)
try the compiz guide in my sig.

I'm going to move my hopefully-short line of questioning over to that thread then if its okay, might be out of scope here. Many thanks though.

duke11235 9th December 2009 04:43 AM

Nvidia Driver issues
 
I followed all 4 steps in the Fedora 12 section of the sticky. However, when Fedora boots up, the login screen appears and I see the little warning sign in the bottom right hand corner. I click on it and discover that nvidia.so(Or something like that) is not found for the current kernel and that the nvidia driver will not be enabled until it is. How can I fix that?

leigh123linux 9th December 2009 05:31 AM

Quote:

Originally Posted by duke11235 (Post 1303501)
I followed all 4 steps in the Fedora 12 section of the sticky. However, when Fedora boots up, the login screen appears and I see the little warning sign in the bottom right hand corner. I click on it and discover that nvidia.so(Or something like that) is not found for the current kernel and that the nvidia driver will not be enabled until it is. How can I fix that?


Try posting some info

Code:

rpm -qa |grep nvidia
Code:

lspci |grep VGA
and

Code:

uname -r

duke11235 9th December 2009 06:40 AM

Thanks
 
The problem corrected itself. The command that edited the ramdisk changed the kernel somehow. A yum update set it to a new kernel, and the subsequent modules were found. Thank you for the response

bakerboy26 9th December 2009 07:23 AM

Followed your steps, works perfectly, thanks.

Will I have to edit the grub.conf everytime I update the kernel?

Thanks in advance,

Gordy

Reticent 9th December 2009 04:01 PM

Hi,

I'm on Fedora 10. I have an app that requires Nvidia driver 195.17 or newer (NAMD with CUDA). I have not found an rpm for the current beta driver (195.22).

I have attempted to install from the Nvidia binary with 195.17 and 195.22. I have previously uninstalled 190.42 driver and kmod (the ATRPMS packaging) with yum. After rebooting and attempting to startx from init 3, X errors out attempting to load the old kmod (190.42). I can still load the nv driver and/or reinstall 190.42 just fine, but that doesn't really help of course.

Roughly 12 hours of googling have not pointed me to an effective resolution, or even anyone reporting the same problem, but I do know others appear to have this app working on F10.

I won't be back at the machine for about another 8 hours so I'll be delayed posting any diagnostic output or log files if needed.

Thanks,
John

srbdivb 9th December 2009 05:09 PM

I'm on Fedora 11, but I've stuck with using the Nvidia binary blobs directly from Nvidia. It's a little more work having to manually install the drivers after each kernel update... but I like having the control. I know in the past these are some of the things I've done:

- Uninstall the akmod and kmod packages for the nvidia driver
- Blacklist the nv and nouveau drivers
- run mkinitrd to make sure the nv and nouveau drivers aren't being loaded
- Install the nvidia driver using the .run file from Nvidia
- boot using the nomodeset kernel param.
- make sure your xorg.conf is using the nvidia driver. you might have to tweak this a bit by hand but I've had good luck with just letting the nvidia installer generate xorg.conf file for me.

BTW, nouveau in F12 looks pretty promising... once I upgrade I'll be anxious to try it out and see if I can get away from the nvidia blobs.

Reticent 9th December 2009 05:18 PM

Quote:

Originally Posted by srbdivb (Post 1303776)
- Uninstall the akmod and kmod packages for the nvidia driver <--I've done this
- Blacklist the nv and nouveau drivers <--I don't think F10 came with nouveau (I haven't added it) and I haven't heard of nv causing the same issues, but I'll try this
- run mkinitrd to make sure the nv and nouveau drivers aren't being loaded <--see above
- Install the nvidia driver using the .run file from Nvidia <--have done this
- boot using the nomodeset kernel param. <---I will try this
- make sure your xorg.conf is using the nvidia driver. you might have to tweak this a bit by hand but I've had good luck with just letting the nvidia installer generate xorg.conf file for me. <---xorg.conf is definitely pointing at the nvidia driver (except when I manually edit it back to nv so I can get X up to browse for a fix)

BTW, nouveau in F12 looks pretty promising... once I upgrade I'll be anxious to try it out and see if I can get away from the nvidia blobs.

I'd love to try nouveau at some point, but I'd guess that CUDA is going to require Nvidia proprietary for a long long time.

Thank you very much for the reply!

AdoNNeN 10th December 2009 01:43 PM

so, i reinstalled compiz as it is described in this forum. turning it on in the menu still won't work..
also, i've seen some of the files with .ko and .so extensions were "empty" and were not updated somehow.. maybe that is the problem?
the cmd command compiz --replace --sm-disable --ignore-desktop-hints gconf & works great, compiz turns on but doesn't stay after reboot or even logout. furthermore main frame of the window (with CLose, Maximize and Hide Buttons) are not seen after turning compiz on.

iloxos 12th December 2009 01:40 AM

Hi everyone!!!
I 've installed the nvidia drivers in my new F12 installation and the KDE is very very slow...

is there any solution?

uname -r
2.6.31.6-166.fc12.x86_64

uname -r
2.6.31.6-166.fc12.x86_64
[root@geo-pc grub]# rpm -qa |grep nvidia
xorg-x11-drv-nvidia-libs-190.42-5.fc12.i686
kmod-nvidia-2.6.31.6-166.fc12.x86_64-190.42-1.fc12.8.x86_64
nvidia-settings-1.0-3.2.fc12.x86_64
kmod-nvidia-190.42-1.fc12.8.x86_64
xorg-x11-drv-nvidia-190.42-5.fc12.x86_64
nvidia-xconfig-1.0-1.fc12.x86_64
xorg-x11-drv-nvidia-libs-190.42-5.fc12.x86_64

and my xorg.conf

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (mockbuild@builder.wilsonet.com) Sun Nov 22 21:42:15 EST 2009

# Xorg configuration created by livna-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
Option "Xinerama" "0"
EndSection

Section "Files"
ModulePath "/usr/lib64/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib64/xorg/modules"
EndSection

Section "ServerFlags"
Option "AIGLX" "on"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# keyboard added by system-config-display
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105+inet"
Option "XkbLayout" "us"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Samsung SyncMaster"
HorizSync 30.0 - 81.0
VertRefresh 56.0 - 75.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
Option "AddARGBGLXVisuals" "True"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 8800 GT"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "1680x1050_60 +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

ozjd 12th December 2009 03:56 AM

Quote:

Originally Posted by iloxos (Post 1305006)
Hi everyone!!!
I 've installed the nvidia drivers in my new F12 installation and the KDE is very very slow...

is there any solution?

It is a known problem see http://forums.fedoraforum.org/showthread.php?t=234227 for a detailed discussion and solution.

leigh123linux 12th December 2009 10:16 AM

Quote:

Originally Posted by ozjd (Post 1305042)
It is a known problem see http://forums.fedoraforum.org/showthread.php?t=234227 for a detailed discussion and solution.


There maybe a fixed driver on the horizon ,

Quote:

Disabled the UseEvents option for GeForce 8 series and higher GPUs due to a problem that causes occasional short hangs. It will be re-enabled when that bug has been tracked down and fixed.

http://www.nvnews.net/vbulletin/show....php?p=2141387


Have you tried ?
Code:

Option        "UseEvents" "False"

iloxos 12th December 2009 05:04 PM

Quote:

Originally Posted by ozjd (Post 1305042)
It is a known problem see http://forums.fedoraforum.org/showthread.php?t=234227 for a detailed discussion and solution.

thanks for the answer!!!


Quote:

Originally Posted by leigh123linux (Post 1305135)
There maybe a fixed driver on the horizon ,

http://www.nvnews.net/vbulletin/show....php?p=2141387

Have you tried ?
Code:

Option        "UseEvents" "False"

thanks also!!!

i will read the discussion and try the code. hope it will work :)

leone1 13th December 2009 02:59 AM

I'm having problems with Fedora 12 for GEForce 6,7,8,9, & 200 series. I used the "yum install akmod-nvidia xorg-x11-drv-nvidia-libs.i686". The Linux kernel I installed it under is 2.6.31.6-166.fc12.i686.PAE. I used all the lines for blacklisting the nouveau as well as adding the vmalloc=256m and the selinux part. When I rebooted it gave me the loading bar and when it finished I got a flashing screen. So I rebooted again and pressed alt i to see the info scrolling by and there are two things that failed.

Files needed for building modules against kernel 2.6.31.6-166.fc12.i686.PAE could not be found as the following directories are missing
/usr/src/kernels/2.6.31.6-166.fc12.i686.PAE/
/lib/modules/2.6.31.6-166.fc12.i686.PAE/ Failed

Checking for module nvidia.ko Failed

I do not know how to get to a prompt so cannot post any outputs at the moment. Any help would be appreciated as I do not wish to reinstall Fedora 12 again today this is the third install.

GoinEasy9 13th December 2009 03:06 AM

@leone1
Do you have kernel-PAE-devel installed?
yum install kernel-PAE-devel

leone1 13th December 2009 03:13 AM

I have no idea I do not know how to get to a prompt to check. It resolved all dependices when it installed the package from rpmfusion.

GoinEasy9 13th December 2009 03:18 AM

For some reason kernel-PAE-devel is not listed as a dependency. It has to be installed before using the akmods. Can you add a 3 to the boot line and boot into runlevel 3. At least you could fix the problem from there.

leone1 13th December 2009 03:40 AM

Add a 3 to which part of the boot command and do I add any arguments?

---------- Post added at 09:33 PM CST ---------- Previous post was at 09:30 PM CST ----------

Ok thanks I found it press a at grub and add a 3 thank you.

---------- Post added at 09:40 PM CST ---------- Previous post was at 09:33 PM CST ----------

That worked like a charm installing the kernel-PAE-devel. Thank you GoinEasy9

GoinEasy9 13th December 2009 04:04 AM

np, glad you got in working.

Lokoci 13th December 2009 02:16 PM

Quote:

Originally Posted by leigh123linux (Post 1303214)
Post


Code:

compiz --replace --sm-disable --ignore-desktop-hints gconf
and

Code:

cat /etc/X11/xorg.conf

I've the same problem. I got an nvidia gt220, trying to enable desktop effects from gnome menu it gives an error after 10-15 seconds of lookup. With that command it works.

leigh123linux 13th December 2009 02:26 PM

Quote:

Originally Posted by Lokoci (Post 1305514)
I've the same problem. I got an nvidia gt220, trying to enable desktop effects from gnome menu it gives an error after 10-15 seconds of lookup. With that command it works.


Post

Code:

glxinfo | grep texture_from_pixmap -c

Lokoci 13th December 2009 02:29 PM

Quote:

Originally Posted by leigh123linux (Post 1305518)
Post

Code:

glxinfo | grep texture_from_pixmap -c

$ glxinfo | grep texture_from_pixmap -c
3
$

leigh123linux 13th December 2009 02:47 PM

Quote:

Originally Posted by Lokoci (Post 1305519)
$ glxinfo | grep texture_from_pixmap -c
3
$

Weird, the desktop-effects menu entry should work.


Try


Code:

su -
gedit  /usr/bin/compiz-gtk


and change


Code:

#!/bin/bash

function runCompiz() {
    gtk-window-decorator &
    exec compiz --ignore-desktop-hints glib gconf gnomecompat $@
}

ISSW=`glxinfo | grep "Software Rasterizer" -c`

# Try with direct rendering
HAVETFP=`glxinfo | grep texture_from_pixmap -c`

if ( [ $ISSW == 0 ] && [ $HAVETFP -gt 2 ] ); then
    runCompiz $@
fi

# Try again with indirect rendering
export LIBGL_ALWAYS_INDIRECT=1

HAVETFP=`glxinfo | grep texture_from_pixmap -c`

if ( [ $ISSW == 0 ] && [ $HAVETFP -gt 2 ] ); then
    runCompiz $@
fi

# Fall back to metacity
exec metacity $@


to

Code:

#!/bin/bash

function runCompiz() {
    gtk-window-decorator &
    exec compiz --replace  --ignore-desktop-hints glib gconf gnomecompat $@
}

ISSW=`glxinfo | grep "Software Rasterizer" -c`

# Try with direct rendering
HAVETFP=`glxinfo | grep texture_from_pixmap -c`

if ( [ $ISSW == 0 ] && [ $HAVETFP -gt 2 ] ); then
    runCompiz $@
fi

# Try again with indirect rendering
export LIBGL_ALWAYS_INDIRECT=1

HAVETFP=`glxinfo | grep texture_from_pixmap -c`

if ( [ $ISSW == 0 ] && [ $HAVETFP -gt 2 ] ); then
    runCompiz $@
fi

# Fall back to metacity
exec metacity $@


Lokoci 13th December 2009 02:57 PM

The same :-(

Anyway I put more attention and I saw something weird, when it gives the error "Failed to start compiz" during that I see the trasparency of various windows and after clicking OK it returns to the standard windowing
(This with and without --replace)
Then I tried: "compiz --replace --ignore-desktop-hints glib gconf gnomecompat" in the console and it gives no error !
:-(

leigh123linux 13th December 2009 03:00 PM

Quote:

Originally Posted by Lokoci (Post 1305531)
The same :-(

Anyway I put more attention and I saw something weird, when it gives the error "Failed to start compiz" during that I see the trasparency of various windows and after clicking OK it returns to the standard windowing
(This with and without --replace)
Then I tried: "compiz --replace --ignore-desktop-hints glib gconf gnomecompat" in the console and it gives no error !
:-(


OK run this as non-root

Code:

/usr/bin/compiz-gtk

Lokoci 13th December 2009 03:19 PM

Quote:

Originally Posted by leigh123linux (Post 1305535)
OK run this as non-root

Code:

/usr/bin/compiz-gtk

Without --replace:

$ /usr/bin/compiz-gtk
gtk-window-decorator: Screen 0 on display ":0.0" already has a decoration manager; try using the --replace option to replace the current decoration manager.
compiz (core) - Error: Screen 0 on display ":0.0" already has a window manager; try using the --replace option to replace the current window manager.
compiz (core) - Fatal: No manageable screens found on display :0.0

and it doesn't work

With --replace:
$ /usr/bin/compiz-gtk
gtk-window-decorator: Screen 0 on display ":0.0" already has a decoration manager; try using the --replace option to replace the current decoration manager.
compiz (video) - Warn: No 8 bit GLX pixmap format, disabling YV12 image format

It works, and I added --replace to gtk-widnow-decorator. The first warning is gone away.

$ /usr/bin/compiz-gtk
compiz (video) - Warn: No 8 bit GLX pixmap format, disabling YV12 image format
$

Instead when I run it from the gnome menu, it fails (but compiz run for some seconds!)

Vector 14th December 2009 07:29 AM

Thanks leigh. I took your advice, in reverse, and had good effects, other than a compiz crash (i finally moved from 10 to 12). I never edited grub, nor did i set the se bool:

Code:

[root@hate ~]# yum remove xorg-x11-drv-nouveau
[root@hate ~]# mv  /lib/modules/$(uname -r)/kernel/drivers/gpu/drm/nouveau/nouveau.ko /lib/modules/$(uname -r)/kernel/drivers/gpu/drm/nouveau/nouveau.txt
[root@hate ~]# mv /boot/initramfs-$(uname -r).img /boot/initramfs-$(uname -r)-nouveau.img
[root@hate ~]# dracut /boot/initramfs-$(uname -r).img $(uname -r)
[root@hate ~]# yum -y install xorg-x11-drv-nvidia
[root@hate ~]# shutdown -r now

Code:

compiz[2013]: segfault at 7fd183198820 ip 00007fd183198820 sp 00007fffe9e30948 error 14 in libglib-2.0.so.0.2200.3[7fd183a20000+e4000]
compiz[2133]: segfault at 7f4430238428 ip 00007f44308bb0ec sp 00007fff87bbfb30 error 4 in libglib-2.0.so.0.2200.3[7f443087f000+e4000]

Also, i always use compiz-manager and ccsm for starting and managing compiz (instead of the "System > Preferences > Desktop Effects > Enable Desktop Effects" options):
Code:

yum -y install compiz-manager ccsm
and then go to System > Preferences > Startup Applications > Add
then Name: Compiz Manager
Command: compiz-manager

then [ctrl]+[alt]+[backspace]

Also, if any of you made the mistake of installing nvidia without removing nouveau (or whatever the heck it is) and got a weird login screen, and lost the ability to [ctrl]+[alt]+[F2-7] into a terminal, then you can put your install disk in, and go into rescue mode, and do:
Code:

chroot /mnt/sysimage
and then
Code:

rm /etc/xorg.conf
then reboot, and in the screwed up login screen you can [ctrl]+[alt]+[F2-7] into a terminal, and then
Code:

yum remove xorg-x11-drv-nvidia
then reboot, into the install DVD/CD again, into rescue mode, and redo the steps to remove the xorg.conf AGAIN (because it gets rewritten when you remove the nvidia drivers), and then reboot again. Then you are back at the default generic driver and a working xorg. Then you can follow leigh's steps, or my backwards steps, if they work for you...

Hope this helps someone....... It worked for me ;)

sperk99 15th December 2009 12:13 AM

I had the 3D accelerator issue with a Geoforce 2 MX/MX 400 card and your guide resolved the issue. Thanks!

Reticent 15th December 2009 09:26 PM

Quote:

Originally Posted by Reticent (Post 1303747)
Hi,

I'm on Fedora 10. I have an app that requires Nvidia driver 195.17 or newer (NAMD with CUDA). I have not found an rpm for the current beta driver (195.22).

I have attempted to install from the Nvidia binary with 195.17 and 195.22. I have previously uninstalled 190.42 driver and kmod (the ATRPMS packaging) with yum. After rebooting and attempting to startx from init 3, X errors out attempting to load the old kmod (190.42). I can still load the nv driver and/or reinstall 190.42 just fine, but that doesn't really help of course.

Roughly 12 hours of googling have not pointed me to an effective resolution, or even anyone reporting the same problem, but I do know others appear to have this app working on F10.

I won't be back at the machine for about another 8 hours so I'll be delayed posting any diagnostic output or log files if needed.

Thanks,
John

Whatever the underlying issue was here, installing on a fresh kernel with no previous proprietary Nvidia drivers worked around the problem nicely.

Simen 15th December 2009 11:22 PM

Hi, I've got a pretty big problem with the new Fedora 12 and Nvidia drivers. I used F9 and F11 on the same laptop, with no other issues than a "yum install kmod-nvidia", and it worked out of the box. It's an Acer Aspire notebook with Nvidia GeForce 8600M GS. This time however, there has been trouble. I've had three tries so far (a try counts as when I've got to the point where I haven't been able to save the system, and did a reinstall):

Try 1, yesterday evening: Tried the akmod and kmod drivers. Every time I installed a driver, there would be a problem with this virtualization package, and I would get no picture.

Try 2, today's morning: Reinstall without virtualization package. This time I installed a normal kernel, instead of a PAE one. Installed only the kmod driver. After many failed attempts, I managed to screw up the xorg.conf file so bad I weren't able to boot with a picture anymore.

Try 3, now: After a reinstall, I followed Leigh's guide to the exact. PAE kernel, kmod. Now I don't get past the bootloader, only thing showing up is a blinking line at the top left corner of the screen, and the operating system never loads. :/

I'm pretty clueless on these things, and would love some tips from you guys. Pretty tired of reinstalling by now. :P I will do a couple of runs more thought, before eventually falling back to good ol' Fedora 11.
Thankful for any help/hints!

kelxso 17th December 2009 12:02 AM

i've noticed that f12 has some sort of display driver that automatically runs the graphics, and when you install the nvidia driver they conflict.

The very indirect solution I found is to download the actual install media for f12 NOT the live versions. and when it first shows up to boot, select the second option. it says something along the lines of "run without display drivers". (i used the f12 dvd 86_64 disc but im assuming the boot options are the same on all f12 install media versions)

then install the rpmfusion repos and the kernel-devel and the kmod-nvidia

if your like me and you messed everything up so much just trying to get the nvidia drivers to work, you wont mind a reinstall

JeremyLeonard 17th December 2009 02:07 PM

leigh123linux -- Great guide thank you.

I do have a question that I'm hoping somebody can help me with. I just installed F12, have an nvidia geforce 4, and a Dell p1130 monitor. The highest resolution that I am able to set (via menu ->System->Preferences->Display) is 1280 x 1024. I would like to be able to get a resolution of 1600 x 1200.

I know instructions are probably listed somewhere, but I haven't had luck finding them. If it helps I found the specs for the monitor at: http://support.dell.com/support/edoc...g_ug/specs.htm.

Thanks in advance.

leigh123linux 17th December 2009 02:13 PM

Quote:

Originally Posted by JeremyLeonard (Post 1307038)
leigh123linux -- Great guide thank you.

I do have a question that I'm hoping somebody can help me with. I just installed F12, have an nvidia geforce 4, and a Dell p1130 monitor. The highest resolution that I am able to set (via menu ->System->Preferences->Display) is 1280 x 1024. I would like to be able to get a resolution of 1600 x 1200.

I know instructions are probably listed somewhere, but I haven't had luck finding them. If it helps I found the specs for the monitor at: http://support.dell.com/support/edoc...g_ug/specs.htm.

Thanks in advance.


Try
Code:

# Xorg configuration created by livna-config-display

Section "ServerLayout"
    Identifier    "Layout0"
    Screen      0  "Screen0" 0 0
    Option        "Xinerama" "0"
EndSection

Section "Files"
    ModulePath  "/usr/lib/xorg/modules/extensions/nvidia"
    ModulePath  "/usr/lib/xorg/modules"
EndSection

Section "ServerFlags"
    Option        "AIGLX" "on"
EndSection

Section "Monitor"
    Identifier  "Monitor0"
    VendorName  "Unknown"
    ModelName    "Dell 1130"
    HorizSync    30.0 - 130.0
    VertRefresh  48.0 - 170.0
    Option        "DPMS"
EndSection

Section "Device"
    Identifier  "Device0"
    Driver      "nvidia"
    VendorName  "NVIDIA Corporation"
    BoardName  "GeForce 4"
    Option        "AddARGBGLXVisuals" "True"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device    "Device0"
    Monitor    "Monitor0"
    DefaultDepth    24
    Option        "TwinView" "0"
    Option        "metamodes" "1600x1200_85 +0+0; nvidia-auto-select +0+0"
    SubSection "Display"
        Depth    24
    EndSubSection
EndSection

Section "Extensions"
    Option        "Composite" "Enable"
EndSection


JeremyLeonard 17th December 2009 02:52 PM

Quote:

Originally Posted by leigh123linux (Post 1307041)
Try
Code:

# Xorg configuration created by livna-config-display

Section "ServerLayout"
    Identifier    "Layout0"
    Screen      0  "Screen0" 0 0
    Option        "Xinerama" "0"
EndSection

Section "Files"
    ModulePath  "/usr/lib/xorg/modules/extensions/nvidia"
    ModulePath  "/usr/lib/xorg/modules"
EndSection

Section "ServerFlags"
    Option        "AIGLX" "on"
EndSection

Section "Monitor"
    Identifier  "Monitor0"
    VendorName  "Unknown"
    ModelName    "Dell 1130"
    HorizSync    30.0 - 130.0
    VertRefresh  48.0 - 170.0
    Option        "DPMS"
EndSection

Section "Device"
    Identifier  "Device0"
    Driver      "nvidia"
    VendorName  "NVIDIA Corporation"
    BoardName  "GeForce 4"
    Option        "AddARGBGLXVisuals" "True"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device    "Device0"
    Monitor    "Monitor0"
    DefaultDepth    24
    Option        "TwinView" "0"
    Option        "metamodes" "1600x1200_85 +0+0; nvidia-auto-select +0+0"
    SubSection "Display"
        Depth    24
    EndSubSection
EndSection

Section "Extensions"
    Option        "Composite" "Enable"
EndSection


Thank you. That worked perfectly.:)

Simen 17th December 2009 08:01 PM

Quote:

Originally Posted by Simen (Post 1306396)
Hi, I've got a pretty big problem with the new Fedora 12 and Nvidia drivers. I used F9 and F11 on the same laptop, with no other issues than a "yum install kmod-nvidia", and it worked out of the box. It's an Acer Aspire notebook with Nvidia GeForce 8600M GS. This time however, there has been trouble. I've had three tries so far (a try counts as when I've got to the point where I haven't been able to save the system, and did a reinstall):

Try 1, yesterday evening: Tried the akmod and kmod drivers. Every time I installed a driver, there would be a problem with this virtualization package, and I would get no picture.

Try 2, today's morning: Reinstall without virtualization package. This time I installed a normal kernel, instead of a PAE one. Installed only the kmod driver. After many failed attempts, I managed to screw up the xorg.conf file so bad I weren't able to boot with a picture anymore.

Try 3, now: After a reinstall, I followed Leigh's guide to the exact. PAE kernel, kmod. Now I don't get past the bootloader, only thing showing up is a blinking line at the top left corner of the screen, and the operating system never loads. :/

I'm pretty clueless on these things, and would love some tips from you guys. Pretty tired of reinstalling by now. :P I will do a couple of runs more thought, before eventually falling back to good ol' Fedora 11.
Thankful for any help/hints!

Continuation:

Try 4, yesterday: Another reinstall. The driver works perfectly now after following this guide. :)

leigh123linux 17th December 2009 08:11 PM

Quote:

Originally Posted by Simen (Post 1307198)
Continuation:

Try 4, yesterday: Another reinstall. The driver works perfectly now after following this guide. :)

That guide is exactly the same as this one!

teancum144 17th December 2009 08:23 PM

Warning When Installing F12 Nvidia driver
 
Hi,

I have a Toshiba Tecra laptop. I followed your guide exactly. However, when attempting to install the kernel, I got two warnings as follows:
Code:

# yum install kmod-nvidia xorg-x11-drv-nvidia-libs.i686
...
Running Transaction
  Installing    : nvidia-settings-1.0-3.2.fc12.i686                        1/9
  Installing    : nvidia-xconfig-1.0-1.fc12.i686                          2/9
  Installing    : kernel-2.6.31.6-166.fc12.i686                            3/9
W: Possible missing firmware ql8100_fw.bin for module qla2xxx.ko
W: Possible missing firmware aic94xx-seq.fw for module aic94xx.ko

  Installing    : system-config-display-2.2-1.fc12.i686                    4/9
  Installing    : livna-config-display-0.0.23-1.fc11.noarch                5/9
  Installing    : kmod-nvidia-2.6.31.6-166.fc12.i686-190.42-1.fc12.8.i68  6/9
  Installing    : kmod-nvidia-190.42-1.fc12.8.i686                        7/9
  Installing    : xorg-x11-drv-nvidia-190.42-5.fc12.i686                  8/9
  Installing    : xorg-x11-drv-nvidia-libs-190.42-5.fc12.i686              9/9

Installed:
  kmod-nvidia.i686 0:190.42-1.fc12.8                                           
  xorg-x11-drv-nvidia-libs.i686 0:190.42-5.fc12                               

Dependency Installed:
  kernel.i686 0:2.6.31.6-166.fc12                                             
  kmod-nvidia-2.6.31.6-166.fc12.i686.i686 0:190.42-1.fc12.8                   
  livna-config-display.noarch 0:0.0.23-1.fc11                                 
  nvidia-settings.i686 0:1.0-3.2.fc12                                         
  nvidia-xconfig.i686 0:1.0-1.fc12                                             
  system-config-display.i686 0:2.2-1.fc12                                     
  xorg-x11-drv-nvidia.i686 0:190.42-5.fc12                                     

Complete!

Here is my kernel version:
Code:

2.6.31.6-166.fc12.i686.PAE
Here is my video chipset info:
Code:

01:00.0 VGA compatible controller: nVidia Corporation NV43 [Geforce Go 6600TE/6200TE] (rev a2) (prog-if 00 [VGA controller])
Here is the rest of my install process (note the warnings here as well):
Code:

# su -
# sed -i '/root=/s|$| rdblacklist=nouveau|' /boot/grub/grub.conf
# mv /boot/initramfs-$(uname -r).img /boot/initramfs-$(uname -r)-nouveau.img
# dracut /boot/initramfs-$(uname -r).img $(uname -r)
W: Possible missing firmware ql8100_fw.bin for module qla2xxx.ko
W: Possible missing firmware aic94xx-seq.fw for module aic94xx.ko

# sed -i '/root=/s|$| vmalloc=256m|' /boot/grub/grub.conf
# setsebool -P allow_execstack on

Is the problem related to the following bug?
https://bugzilla.redhat.com/show_bug.cgi?id=523365

leigh123linux 17th December 2009 08:53 PM

Quote:

Originally Posted by smconvey (Post 1307217)
Hi,

I have a Toshiba Tecra laptop. I followed your guide exactly. However, when attempting to install the kernel, I got two warnings as follows:
Code:

# yum install kmod-nvidia xorg-x11-drv-nvidia-libs.i686
...
Running Transaction
  Installing    : nvidia-settings-1.0-3.2.fc12.i686                        1/9
  Installing    : nvidia-xconfig-1.0-1.fc12.i686                          2/9
  Installing    : kernel-2.6.31.6-166.fc12.i686                            3/9
W: Possible missing firmware ql8100_fw.bin for module qla2xxx.ko
W: Possible missing firmware aic94xx-seq.fw for module aic94xx.ko

  Installing    : system-config-display-2.2-1.fc12.i686                    4/9
  Installing    : livna-config-display-0.0.23-1.fc11.noarch                5/9
  Installing    : kmod-nvidia-2.6.31.6-166.fc12.i686-190.42-1.fc12.8.i68  6/9
  Installing    : kmod-nvidia-190.42-1.fc12.8.i686                        7/9
  Installing    : xorg-x11-drv-nvidia-190.42-5.fc12.i686                  8/9
  Installing    : xorg-x11-drv-nvidia-libs-190.42-5.fc12.i686              9/9

Installed:
  kmod-nvidia.i686 0:190.42-1.fc12.8                                           
  xorg-x11-drv-nvidia-libs.i686 0:190.42-5.fc12                               

Dependency Installed:
  kernel.i686 0:2.6.31.6-166.fc12                                             
  kmod-nvidia-2.6.31.6-166.fc12.i686.i686 0:190.42-1.fc12.8                   
  livna-config-display.noarch 0:0.0.23-1.fc11                                 
  nvidia-settings.i686 0:1.0-3.2.fc12                                         
  nvidia-xconfig.i686 0:1.0-1.fc12                                             
  system-config-display.i686 0:2.2-1.fc12                                     
  xorg-x11-drv-nvidia.i686 0:190.42-5.fc12                                     

Complete!

Here is my kernel version:
Code:

2.6.31.6-166.fc12.i686.PAE
Here is my video chipset info:
Code:

01:00.0 VGA compatible controller: nVidia Corporation NV43 [Geforce Go 6600TE/6200TE] (rev a2) (prog-if 00 [VGA controller])
Here is the rest of my install process (note the warnings here as well):
Code:

# su -
# sed -i '/root=/s|$| rdblacklist=nouveau|' /boot/grub/grub.conf
# mv /boot/initramfs-$(uname -r).img /boot/initramfs-$(uname -r)-nouveau.img
# dracut /boot/initramfs-$(uname -r).img $(uname -r)
W: Possible missing firmware ql8100_fw.bin for module qla2xxx.ko
W: Possible missing firmware aic94xx-seq.fw for module aic94xx.ko

# sed -i '/root=/s|$| vmalloc=256m|' /boot/grub/grub.conf
# setsebool -P allow_execstack on

Is the problem related to the following bug?
https://bugzilla.redhat.com/show_bug.cgi?id=523365


The warning is safe to ignore.

Simen 17th December 2009 11:35 PM

Quote:

Originally Posted by leigh123linux (Post 1307208)
That guide is exactly the same as this one!

Yeah, I think I made a mistake and messed up the grub.conf file on try 3 there.

michaelr7177 19th December 2009 09:10 AM

I love you so much.....I should read this post first in this forum...

marcrblevins 23rd December 2009 01:40 AM

Hey Leigh,
Was using a Creative Labs GeForce 2 Ultra 64 Megs AGP 4X for 8 or 9 years.

Just bought an Asus N7600GS for $38 on eBay. Yeah its a GeForce BLUE card.

Ran your four steps for 'GeForce 7' stuff.

Did a glxgears before and after, shown to be a workhorse!

Great job Leigh!

Partial of glxinfo:
Code:

OpenGL vendor string: NVIDIA Corporation                                     
OpenGL renderer string: GeForce 7600 GS/AGP/SSE2                             
OpenGL version string: 2.1.2 NVIDIA 190.42                                   
OpenGL shading language version string: 1.20 NVIDIA via Cg compiler

The only negative thing is my Asus P4T board runs AGP 4X, but its working anyway!
Now I got to figure out what to do with 3Ds.

Cheers

---------- Post added at 03:05 PM CST ---------- Previous post was at 03:04 PM CST ----------

Going to buy a DVI cable for it now. Bye bye VGA cable!

---------- Post added at 04:40 PM CST ---------- Previous post was at 03:05 PM CST ----------

Geez, $24 for a 6.5 feet Dynex DVI cable at BestBuy. Came home and noticed in the back, it says:

Quote:

Supports single link connections - resolution up to 2.75 megapixels at 60Hz.
Now I better look up at my video card and monitor specs if I need better than 60Hz.

Think I better return the cable.

leigh123linux 23rd December 2009 05:02 PM

Here's a quick guide to build you own 190.53 & 195.30 rpm's

http://forums.fedoraforum.org/showthread.php?t=237118

mwette 24th December 2009 06:09 PM

Any ideas ?

Code:

[root@bluefin ~]# yum install kmod-nvidia xorg-x11-drv-nvidia-libs.i686
Loaded plugins: presto, refresh-packagekit
Setting up Install Process
No package kmod-nvidia available.
No package xorg-x11-drv-nvidia-libs.i686 available.
Nothing to do
[root@bluefin ~]# uname -r
2.6.31.6-166.fc12.x86_64
[root@bluefin ~]# cat /etc/system-release
Fedora release 12 (Constantine)


leigh123linux 24th December 2009 07:26 PM

Quote:

Originally Posted by mwette (Post 1310181)
Any ideas ?

Code:

[root@bluefin ~]# yum install kmod-nvidia xorg-x11-drv-nvidia-libs.i686
Loaded plugins: presto, refresh-packagekit
Setting up Install Process
No package kmod-nvidia available.
No package xorg-x11-drv-nvidia-libs.i686 available.
Nothing to do
[root@bluefin ~]# uname -r
2.6.31.6-166.fc12.x86_64
[root@bluefin ~]# cat /etc/system-release
Fedora release 12 (Constantine)


It looks like you haven't installed both rpmfusion release rpm's.

mwette 24th December 2009 11:29 PM

Quote:

Originally Posted by leigh123linux (Post 1310212)
It looks like you haven't installed both rpmfusion release rpm's.

Ahh. That was it. Thanks.

leigh123linux 26th December 2009 09:15 AM

Rpmfusion haven't released any new kmods for the new kernel.

Please don't bother posting here to whine about it as I'm on holiday. :p


To workaround this install the matching akmod package for your driver ( see post # 1 or 2 )


All times are GMT +1. The time now is 10:21 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.