FedoraForum.org

FedoraForum.org (http://forums.fedoraforum.org/index.php)
-   Installation, Upgrades and Live Media (http://forums.fedoraforum.org/forumdisplay.php?f=6)
-   -   Globus Toolkit (http://forums.fedoraforum.org/showthread.php?t=181045)

Curtor 13th February 2008 09:10 PM

Globus Toolkit
 
Hi!
<Insert apology for being new at Fedora>
Alright, that's out of the way.
So, I'm in the process of trying to install the Globus Toolkit. I'm following the instructions from:
http://www.globus.org/toolkit/docs/4...uickstart.html
I've just finished exporting the environment variables, but I get warning when running the configure:
Code:

[globus local]$ export JAVA_HOME=/usr/java/j2sdk1.4.2_16/
[globus local]$ export ANT_HOME=/usr/local/apache-ant-1.7.0
[globus local]$ export PATH=/usr/local/apache-ant-1.7.0/bin:/usr/java/j2sdk1.4.2_16/bin:$PATH
[globus local]$ cd /home/globus/Desktop/gt4.0.6-x86_fc_4-installer
[globus gt4.0.6-x86_fc_4-installer]$ ./configure --prefix=/usr/local/globus-4.0.1/ \
> --with-iodbc=/usr/lib
checking for javac... /usr/java/j2sdk1.4.2_16/bin/javac
configure: WARNING: the javac in your path is not from your $JAVA_HOME environment
checking for ant... /usr/local/apache-ant-1.7.0/bin/ant
configure: creating ./config.status
config.status: creating Makefile
[globus gt4.0.6-x86_fc_4-installer]$

Everything prior to this went smoothly. Should I heed this warning, or ignore it and continue?
Secondly, how do I keep those new variables in the path after each session or reboot? After I restart the computer, all of my variables I had set will no longer be there.
Thanks.

fnmblot 13th February 2008 09:21 PM

to keep the paths, add them to the .bash_profile in your home directory.
the warning is just a warning... if you ever update java to a newer version, then it wouldn't work anymore. I'd say go ahead and finish the compilation

bulgalien 13th February 2008 09:33 PM

System wide vs. user's bash profile
 
Hi, Curtor. I'm new to Fedora forum, but not so new to Fedora/Linux. However, I'm not what I would call an expert, either. So, now that that's out of the way, I can tell you this much.

The PATH environment variable is the list of directories where the shell (/bin/bash, most likely) looks to fine executable commands. If an executable program appears in more than one directory, then the shell uses the first one it finds in the PATH. So, you probably have javac in more than one location, possibly in /usr/bin. You can check this by typing

$which javac
/usr/bin/javac

The configure script is probably telling you that it found javac in /usr/bin.

If you want to have these environment variables defined permanently you can edit the file /etc/profile. In it you'll see stuff like this

>>cat /etc/profile
# /etc/profile

# System wide environment and startup programs
# Functions and aliases go in /etc/bashrc

PATH="/opt/schily/bin:$PATH:/usr/X11R6/bin:/etc/rc.d/init.d:/usr/local/bin:/opt/schily/bin:/root:/usr/local/mozilla"

ulimit -S -c 1000000 > /dev/null 2>&1
if [ `id -gn` = `id -un` -a `id -u` -gt 14 ]; then
umask 002
else
umask 022
fi

LOGIN_SHELL=true
USER=`id -un`
LOGNAME=$USER
MAIL="/var/spool/mail/$USER"

HOSTNAME=`/bin/hostname`
HISTSIZE=1000
MAILCHECK=60

if [ -z "$INPUTRC" -a ! -f "$HOME/.inputrc" ]; then
INPUTRC=/etc/inputrc
fi

export PATH USER LOGNAME MAIL HOSTNAME HISTSIZE INPUTRC

for i in /etc/profile.d/*.sh ; do
if [ -x $i ]; then
. $i
fi
done

unset i

. /etc/bashrc

You can see the PATH is set near the top of the file. You can just add whatever you like to it there. Other environment variables (like MAILCHECK, and HISTSIZE) are defined further down. They are exported with the 'export' command. So, just add what you want there, and have it exported in the same way.

I think that should do it.

--bulgalien

P.S. The file /etc/profile is the system-wide profile. That is any user who starts a command terminal that runs the bash shell will have the settings given there. However, there is a file in each user's home directory called .bash_profile (notice the leading . ) which is also read by bash when it starts. The settings in that file will override the system-wide settings.

Curtor 13th February 2008 09:51 PM

Alright, looks good, thanks a lot!

Curtor 13th February 2008 09:57 PM

Hmm .. so my path seems to state the following:
/usr/local/apache-ant-1.7.0/bin:/usr/java/j2sdk1.4.2_16/bin:/usr/kerberos/bin:/usr/lib/ccache:/usr/local/bin:/usr/bin:/bin:/usr/X11R6/bin:/home/globus/bin

Where would the second javac location be?

bulgalien 13th February 2008 10:06 PM

locate and find commands...
 
You could try typing

$which javac

This will show the first (if there is more than one) javac found in the path. That is, the shell looks in the directories given in the PATH environment variable in the order that they're listed. The first one found would be the one that gets executed if you were to type

$javac

at the command prompt.

From your post it looks like you have /usr/java/j2sdk1.4.2_16/bin before /usr/bin, etc. So, that would be the first one found. If you want to find out if there is another javac around you could try running this command

$locate javac | grep bin

or,

$find /usr -name javac

or, you could use the find files/folders gui.

P.S. The locate and find commands will give a list of all the places where javac appears. You'd have to look through the list for javac in, say /usr/bin, or some other 'bin' directory. That's why I added the ' | grep bin ' to the locate command above in order to reduce the amount of stuff it returns. On my machine I get this

$locate javac | grep bin
/usr/bin/javac
/usr/lib/jvm/java-1.5.0-gcj-1.5.0.0/bin/javac
/usr/lib/jvm/java-1.7.0-icedtea-1.7.0.0/bin/javac

I have three of them! (I don't know anything about why, exactly. D'oh!)

Curtor 14th February 2008 02:44 PM

Alright, looks good. I guess, in other words, there is no 'huge' issue with having more than one java installed, it's just that the computer will use the first one it finds in the path, from what I understand from this.

So, I continued installing the toolkit, and then got to the certificates part.

Though, when I tried to sign it, I got the following error :
Code:

[globus@GRID9 ~]$  grid-ca-sign -in /etc/grid-security/hostcert_request.pem -out hostsigned.pem

ERROR: The file: /etc/grid-security/hostcert_request.pem is not readable

I also noticed that when I tried to get a hostcert for the machine, it said that it was written to
/root/.globus/userkey.pem
instead of
/etc/grid-security/hostkey.pem
Lastly, why does it say that "GRID9: command not found" when I try to use it as an argument for the hostname?

The output previous is as follows:

Code:

[root@GRID9 etc]# export GLOBUS_LOCATION=/usr/local/globus-4.0.1
[root@GRID9 etc]# /usr/local/globus-4.0.1/setup/globus_simple_ca_cfd1c845_setup/setup-gsi -default
Subroutine Compress::Zlib::gzFile::gzseek redefined at /usr/lib/perl5/vendor_perl/5.8.8/Compress/Zlib.pm line 214.
setup-gsi: Configuring GSI security
Installing /etc/grid-security/certificates//grid-security.conf.cfd1c845...
Running grid-security-config...
Installing Globus CA certificate into trusted CA certificate directory...
Installing Globus CA signing policy into trusted CA certificate directory...
setup-gsi: Complete
[root@GRID9 etc]# ls /etc/grid-security/
certificates  globus-host-ssl.conf  globus-user-ssl.conf  grid-security.conf
[root@GRID9 etc]# ls /etc/grid-security/certificates/
cfd1c845.0                    globus-user-ssl.conf.cfd1c845
cfd1c845.signing_policy        grid-security.conf.cfd1c845
globus-host-ssl.conf.cfd1c845
[root@GRID9 etc]# source $GLOBUS_LOCATION/etc/globus-user-env.sh
[root@GRID9 etc]# grid-cert-request -host `GRID9`
bash: GRID9: command not found
Generating a 1024 bit RSA private key
...........++++++
........++++++
writing new private key to '/root/.globus/userkey.pem'
-----
You are about to be asked to enter information that will be incorporated
into your certificate request.
What you are about to enter is what is called a Distinguished Name or a DN.
There are quite a few fields but you can leave some blank
For some fields there will be a default value,
If you enter '.', the field will be left blank.
-----
Level 0 Organization [Grid]:Level 0 Organizational Unit [GlobusTest]:Level 1 Organizational Unit [simpleCA-grid9]:Level 2 Organizational Unit []:Name (e.g., John M. Smith) []:

A private key and a certificate request has been generated with the subject:

/O=Grid/OU=GlobusTest/OU=simpleCA-grid9/CN=root

If the CN=root is not appropriate, rerun this
script with the -force -cn "Common Name" options.

Your private key is stored in /root/.globus/userkey.pem
Your request is stored in /root/.globus/usercert_request.pem

Please e-mail the request to the Globus Simple CA grid_9@GRID9
You may use a command similar to the following:

  cat /root/.globus/usercert_request.pem | mail grid_9@GRID9

Only use the above if this machine can send AND receive e-mail. if not, please
mail using some other method.

Your certificate will be mailed to you within two working days.
If you receive no response, contact Globus Simple CA at grid_9@GRID9

[globus@GRID9 gt4.0.6-x86_fc_4-installer]$ cd ..
[globus@GRID9 Desktop]$ cd ..
[globus@GRID9 ~]$  grid-ca-sign -in /etc/grid-security/hostcert_request.pem -out hostsigned.pem

ERROR: The file: /etc/grid-security/hostcert_request.pem is not readable


Curtor 15th February 2008 08:01 PM

Hello again
I managed to solve the last problem.
My newest problem is when I try to run the following:
Code:

[grid_9@GRID9 etc]$ source /usr/local/globus-4.0.1/etc/globus-user-env.csh
bash: /usr/local/globus-4.0.1/etc/globus-user-env.csh: line 132: syntax error: unexpected end of file

This file came with the installation. What exactly does this mean? Did I do something wrong here?

aligod 29th March 2008 05:19 PM

globus
 
you are not in the tcsh shell
you run : source /usr/local/globus-4.0.1/etc/globus-user-env.sh (not .csh just .sh)

arindamchoudhur 3rd February 2009 02:18 PM

I'm having this problem...please help


QUOTE=Curtor;962771]Alright, looks good. I guess, in other words, there is no 'huge' issue with having more than one java installed, it's just that the computer will use the first one it finds in the path, from what I understand from this.

So, I continued installing the toolkit, and then got to the certificates part.

Though, when I tried to sign it, I got the following error :
Code:

[globus@GRID9 ~]$  grid-ca-sign -in /etc/grid-security/hostcert_request.pem -out hostsigned.pem

ERROR: The file: /etc/grid-security/hostcert_request.pem is not readable

I also noticed that when I tried to get a hostcert for the machine, it said that it was written to
/root/.globus/userkey.pem
instead of
/etc/grid-security/hostkey.pem
Lastly, why does it say that "GRID9: command not found" when I try to use it as an argument for the hostname?

The output previous is as follows:

Code:

[root@GRID9 etc]# export GLOBUS_LOCATION=/usr/local/globus-4.0.1
[root@GRID9 etc]# /usr/local/globus-4.0.1/setup/globus_simple_ca_cfd1c845_setup/setup-gsi -default
Subroutine Compress::Zlib::gzFile::gzseek redefined at /usr/lib/perl5/vendor_perl/5.8.8/Compress/Zlib.pm line 214.
setup-gsi: Configuring GSI security
Installing /etc/grid-security/certificates//grid-security.conf.cfd1c845...
Running grid-security-config...
Installing Globus CA certificate into trusted CA certificate directory...
Installing Globus CA signing policy into trusted CA certificate directory...
setup-gsi: Complete
[root@GRID9 etc]# ls /etc/grid-security/
certificates  globus-host-ssl.conf  globus-user-ssl.conf  grid-security.conf
[root@GRID9 etc]# ls /etc/grid-security/certificates/
cfd1c845.0                    globus-user-ssl.conf.cfd1c845
cfd1c845.signing_policy        grid-security.conf.cfd1c845
globus-host-ssl.conf.cfd1c845
[root@GRID9 etc]# source $GLOBUS_LOCATION/etc/globus-user-env.sh
[root@GRID9 etc]# grid-cert-request -host `GRID9`
bash: GRID9: command not found
Generating a 1024 bit RSA private key
...........++++++
........++++++
writing new private key to '/root/.globus/userkey.pem'
-----
You are about to be asked to enter information that will be incorporated
into your certificate request.
What you are about to enter is what is called a Distinguished Name or a DN.
There are quite a few fields but you can leave some blank
For some fields there will be a default value,
If you enter '.', the field will be left blank.
-----
Level 0 Organization [Grid]:Level 0 Organizational Unit [GlobusTest]:Level 1 Organizational Unit [simpleCA-grid9]:Level 2 Organizational Unit []:Name (e.g., John M. Smith) []:

A private key and a certificate request has been generated with the subject:

/O=Grid/OU=GlobusTest/OU=simpleCA-grid9/CN=root

If the CN=root is not appropriate, rerun this
script with the -force -cn "Common Name" options.

Your private key is stored in /root/.globus/userkey.pem
Your request is stored in /root/.globus/usercert_request.pem

Please e-mail the request to the Globus Simple CA grid_9@GRID9
You may use a command similar to the following:

  cat /root/.globus/usercert_request.pem | mail grid_9@GRID9

Only use the above if this machine can send AND receive e-mail. if not, please
mail using some other method.

Your certificate will be mailed to you within two working days.
If you receive no response, contact Globus Simple CA at grid_9@GRID9

[globus@GRID9 gt4.0.6-x86_fc_4-installer]$ cd ..
[globus@GRID9 Desktop]$ cd ..
[globus@GRID9 ~]$  grid-ca-sign -in /etc/grid-security/hostcert_request.pem -out hostsigned.pem

ERROR: The file: /etc/grid-security/hostcert_request.pem is not readable

[/QUOTE]

:confused:


All times are GMT +1. The time now is 10:26 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.