FedoraForum.org

FedoraForum.org (http://forums.fedoraforum.org/index.php)
-   Guides & Solutions (No Questions) (http://forums.fedoraforum.org/forumdisplay.php?f=12)
-   -   Howto for fglrx / catalyst (Ati driver) (http://forums.fedoraforum.org/showthread.php?t=155503)

Ravnos 14th November 2008 07:51 PM

wow, rpmfusion is fast indeed, only now I got the kernel 2.6.27.5-37 through yum, let me try the new version now. Glad to know rpmfusion is doing a great job :)

LBCoder 14th November 2008 08:05 PM

Quote:

Originally Posted by leigh123@linux (Post 1110492)
So it works OK if you do this ?

rm -f /usr/lib/dri/fglrx_dri.so
ln -s /usr/lib64/dri/fglrx_dri.so /usr/lib/dri/fglrx_dri.so

I will change post #1 as soon as rpmfusion releases 8.11 .

Yes. That will do it.

LBCoder 14th November 2008 08:09 PM

For anybody wondering... the main driver download page at ati.amd.com shows that its good for xorg 7.3, however, it actually supports 7.4/xserver1.5 as stated in the release notes. Whoever it is who manages that web page is just prone to oversights -- up until 8.10, the page title showed something like 8.5, so this is nothing new. 8.11 does indeed support 7.4/1.5.

Ravnos 14th November 2008 09:08 PM

It works ! Of course it needs a hack :p (at least in my case)

what I did (worked here, do it at your own risk, works on x64):

yum clean all
yum --enablerepo=updates-testing-newkey update kernel*
yum remove *fglrx*
# I'm using x64, so I installed the extra i386 libs package in an attempt to make opengl work with wine, might not be needed
yum install akmod-fglrx kmod-fglrx xorg-x11-drv-fglrx-libs.i386
reboot
# Now if you are using the x64 version you will notice you have no glx at all, that's because it is looking for the driver in the wrong place, maybe because I've installed the i386 package, in that case:
mv /usr/lib/dri/fglrx_dri.so /usr/lib/dri/fglrx_dri.so.backup
cp /usr/lib64/dri/fglrx_dri.so /usr/lib/dri/fglrx_dri.so

Now compiz is working fine again ! :)

I will try removing the i386 package to see if it looks for the driver in the right place.

Ravnos 14th November 2008 09:14 PM

Oh, and my tremulous is dog slow ...

Minase 14th November 2008 09:28 PM

hy there i have an ATI RADEON HD3850 from HIS on AGP 512DDR3 but i cant figure out how to install drivers for my video card,im still new to linux
tryed some guides i got error to start x server,i did restore my old xorg.conf and it works normally but i would be gladly if my video card will be installed.thank you

here it is the trouble maker xorg.conf

Code:


# Xorg configuration created by system-config-display

Section "ServerLayout"
        Identifier    "single head configuration"
        Screen      0  "aticonfig-Screen[0]-0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
EndSection

Section "Module"
EndSection

Section "InputDevice"

# keyboard added by rhpxl
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option            "XkbModel" "pc105"
        Option            "XkbLayout" "us"
EndSection

Section "Monitor"
        Identifier  "Monitor0"
        ModelName    "LCD Panel 1680x1050"
        HorizSync    31.5 - 65.5
        VertRefresh  56.0 - 65.0
        Option            "dpms"
EndSection

Section "Monitor"
        Identifier  "aticonfig-Monitor[0]-0"
        Option            "VendorName" "ATI Proprietary Driver"
        Option            "ModelName" "Generic Autodetecting Monitor"
        Option            "DPMS" "true"
EndSection

Section "Device"
        Identifier  "Videocard0"
        Driver      "vesa"
EndSection

Section "Device"
        Identifier  "aticonfig-Device[0]-0"
        Driver      "fglrx"
        BusID      "PCI:1:0:0"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device    "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth    24
        SubSection "Display"
                Viewport  0 0
                Depth    24
        EndSubSection
EndSection

Section "Screen"
        Identifier "aticonfig-Screen[0]-0"
        Device    "aticonfig-Device[0]-0"
        Monitor    "aticonfig-Monitor[0]-0"
        DefaultDepth    24
        SubSection "Display"
                Viewport  0 0
                Depth    24
        EndSubSection
EndSection

thanks

Ravnos 14th November 2008 09:30 PM

Quote:

Originally Posted by Ravnos (Post 1110971)
Oh, and my tremulous is dog slow ...

Just removed the i386 package, now it is running fine, if I find some bugs I'll post here.

Ravnos 14th November 2008 09:36 PM

Minase, do you have two video cards ? You have many duplicated Sections, I would try commenting out those duplicated Sections not related to the ATI card

here is my xorg.conf in case it might help:

Code:

Section "ServerLayout"
        Identifier    "Default Layout"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Synaptics Touchpad"
EndSection

Section "Files"
        ModulePath  "/usr/lib64/xorg/modules/extensions/fglrx"
        ModulePath  "/usr/lib64/xorg/modules"
EndSection

Section "Module"
        Load  "glx"
        Load  "dri"
        Load  "extmod"
EndSection

Section "ServerFlags"
        Option            "AIGLX" "on"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option            "XkbModel" "abnt2"
        Option            "XkbLayout" "br"
EndSection

Section "InputDevice"
        Identifier  "Synaptics Touchpad"
        Driver      "synaptics"
        Option            "SendCoreEvents" "true"
        Option            "Device" "/dev/psaux"
        Option            "Protocol" "auto-dev"
        Option            "HorizEdgeScroll" "0"
EndSection

Section "Device"

#        Option      "XAANoOffscreenPixmaps" "true"
        Identifier  "Videocard0"
        Driver      "fglrx"
        Option            "OpenGLOverlay" "off"
        Option            "VideoOverlay" "on"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device    "Videocard0"
        DefaultDepth    24
        SubSection "Display"
                Viewport  0 0
                Depth    24
        EndSubSection
EndSection

Section "DRI"
        Mode        0666
EndSection

Section "Extensions"
        Option            "Composite" "Enable"
EndSection


Minase 14th November 2008 09:39 PM

what you mean im a bit confused about your post :|
all replys from previous topic did not work :(

Ravnos 14th November 2008 09:41 PM

Minase, check my xorg.conf, just edited my previous post to add it hehe

Minase 14th November 2008 09:44 PM

i dont have 2 video cards and my ati driver is not installed =/
just the control panel when i start CP it's saying that driver is not installed

Ravnos 14th November 2008 09:56 PM

To get your ATI driver working you should:

# 1 - install the rpmfusion repo:
http://rpmfusion.org/Configuration
# 2 - update your kernel (as root):
yum clean all
yum --enablerepo=updates-testing-newkey update kernel*
# 3 - install the ATI drivers (as root):
yum install akmod-fglrx kmod-fglrx
# 4 - reboot

If it still not works you shoud check your xorg.conf

Frila 14th November 2008 10:36 PM

Quote:

Originally Posted by leigh123@linux (Post 1110519)
Code:

nano /etc/X11/xorg.conf

I removed my xorg.conf file and then I could start F10 with GUI. This was my non-working xorg.conf file. What is wrong?

Code:

# Xorg configuration created by livna-config-display

Section "Files"
        ModulePath  "/usr/lib/xorg/modules/extensions/fglrx"
        ModulePath  "/usr/lib/xorg/modules"
EndSection

Section "ServerFlags"
        Option            "AIGLX" "on"
EndSection

Section "Device"
        Identifier  "Videocard0"
        Driver      "fglrx"
        Option            "OpenGLOverlay" "off"
        Option            "VideoOverlay" "on"
EndSection

Section "Extensions"
        Option            "Composite" "Enable"
EndSection

Got some advise to install akmod-fglrx. What is the difference? Worth a try? Or will I have the type of problems?

Minase 14th November 2008 10:43 PM

tryed that it return just an trembling image
everything is blury
i did look at hardware and it did not recognize my video card it was "unknow video card"
thank for reply ;)
other solutions?

Ravnos 14th November 2008 10:59 PM

You can try the aticonfig command, "aticonfig --initial" should create a minimum working config file


All times are GMT +1. The time now is 05:09 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.