PDA

View Full Version : Dual Display / Matrox G450 not working


SeaM
10th October 2005, 05:08 PM
hallo,

i'm new to linux. i'm trying to get two displays to work on FC4 / Gnome, using a Matrix G450 dual head graphics card. I've a seen a similar post (which wasn't solved) which is exactly what I experience: when configuring using the system settings display panel, i can check dual head and setup the second monitor, but i cannot safe the configuration (unchecking dual head allows me to save again). i have edited /etc/X11/Xorg.conf manually, using some of the templates posted. I ended up with this:


Section "ServerLayout"
Identifier "dual head configuration"
Screen 0 "Screen0" LeftOf "Screen1"
Screen 1 "Screen1" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
Option "Xinerama" "on"
Option "Clone" "off"
EndSection

[...]

Section "Monitor"
Identifier "Monitor0"
VendorName "Acer"
ModelName "AL2021ms"
DisplaySize 340 270
HorizSync 31.5 - 90.0
VertRefresh 60.0 - 60.0
Option "dpms"
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "Monitor Vendor"
ModelName "AL2021ms"
DisplaySize 340 270
HorizSync 31.5 - 90.0
VertRefresh 60.0 - 60.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "mga"
VendorName "Matrox"
BoardName "Matrox Millennium G450"
# BusID "PCI:1:0:0"
# Screen 0
EndSection

#Section "Device"
# Identifier "Videocard1"
# Driver "mga"
# VendorName "Matrox"
# BoardName "Matrox Millennium G450"
# BusID "PCI:1:0:0"
# Screen 1
#EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 16
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1600x1200" "1400x1050" "1280x960" "1280x800" "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
# Device "Videocard1"
Device "Videocard0"
Monitor "Monitor1"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1600x1200" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1600x1200" "1400x1050" "1280x960" "1280x800" "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection



I thought I was successfull with the uncommented config, i.e. defining a "second videocard" and assigning it to screen 1. In fact for the first time, when Fedora was launching, it showed two independant screens, the left one having the big computer icon (splash screen), the right one being black (but i could move the mouse to the other screen). But when the loader jumps to the login display, both displays go out, no sync, that's it. When I comment out the second videocard section, I can boot normally, but there is only one screen (even though i defined two). The monitors we use (two Acer AL2021) support up to 1600x1200 and i use this resolution in the single display mode, so it cannot be a monitor sync issue.

The matrox help file is not very usefull, they describe the procedure for Xfree86, only saying that one should add that "Xinerama" option and that's it. Also I'm a bit confused Fedora was identifying a G400 card when it was installed, although it's actually a G450. (I've run the matrox binary installers anyways). I've corrected the name in xorg.conf file.

I don't care if i have dual head or big desktop or twin view or whatever it's called, i only need to be able to display application windows on both displays. thanks for help!

best, hanns holger rutz

s.motycka
21st December 2005, 09:53 AM
Hello

right Parameters for the monitor 'Acer AL2021' are:

DisplaySize 408 306
HorizSync 31.0 - 81.0
VertRefresh 56.0 - 75.0

regards
S.M.

see you -> acer AL2021 (http://www.acer.de/acereuro/page9.do?dau34.oid=9486&UserCtxParam=0&GroupCtxParam=0&dctx1=9&CountryISOCtxParam=DE&LanguageISOCtxParam=de&crc=2445040633)

Creek Side - Stockholm-Arlanda Airport (ARN) Travel Photos on Instagram - Marina of Koper Travel Photos - Te Whiti Park Instagram Photos - Texas State Fair Photos on Instagram