PDA

View Full Version : "Segmentation Fault" error preventing boot


UED77
15th September 2005, 08:17 PM
Hello.

I installed Fedora Core 4 from CD onto an empty hard disk, with it as the only hard disk connected. Since this is the second time I'm doing this, I knew by trial and error to start the install by "linux ide=nodma noprobe skiddc", as this seemed to be the only combination that would work. After the install, I tried to boot Fedora, but it gave me an error.


/etc/rc.d/rc.sysinit: line 165: 919 Segmentation Fault modprobe $1 >/dev/null 2>&1 network


Then nothing... Fedora just doesn't want to progress beyond that, even if I add "noprobe skipddc" as arguments before booting. I am a Linux-newbie, so the Rescue mode or the Rescue CD doesn't help me at all.

If you need any system specs, or additional info, I'll try to find out as much as I can, but please help me overcome this annoying problem.

By the way, my computer is a retail Compaq, about two years old, but the hard disk in question has been known to work before, and it's a Seagate. The Motherboard is from an unidentified manufacturer.... but the whole computer has run WinXP in the past (and still runs it, with a different HD).

Thank you,

UED77

razi
16th September 2005, 10:05 PM
First of all, I think either you copied the error message incorrectly, or there is a bug in the rc.sysinit (which I highly doubt :) )

If you look at the line:

modprobe $1 >/dev/null 2>&1 network


may be I'm wrong, but that does not seem like a correct syntax to call modprobe ( an essential program to load your hardware modules /drivers)

the "2>&1" means roughly "output any error messages to screen". The command should end here, I don't know what "network" is doing there.


Then nothing... Fedora just doesn't want to progress beyond that, even if I add "noprobe skipddc" as arguments before booting. I am a Linux-newbie, so the Rescue mode or the Rescue CD doesn't help me at all.


Just a wild guess, I suggest you boot to a lower "init level":

1. quickly press escape while grub is waiting to boot, so you get the option of what to do with grub. Read the on-screen instruction
2. if you happen to give a password for grub during installation, enter 'p', and give your password
3. now you can edit the line (with "e", I think) that has something like:


kernel /vmlinuz-2.6....._FC4 ro root=/dev/...... rhgb quiet


substitute "rhgb quiet" with "1" , this forces fedora to boot to level 1 (sort of safe-mode) enter and see if you can boot up to the login prompt.

UED77
20th September 2005, 11:26 PM
Well, thanks for the help... but...

Substituting "rhgb quiet" with "1" didn't help at all. The only change is that instead of "919 Segmentation Fault", I get "904 Segmentation Fault"...

I will try experimenting with other options.

UED77

razi
22nd September 2005, 08:24 PM
Substituting "rhgb quiet" with "1" didn't help at all. The only change is that instead of "919 Segmentation Fault", I get "904 Segmentation Fault"...
UED77

How about booting from the CD (#1) ?