PDA

View Full Version : problems running Eclipse on x86_64


Mudhoney
20th July 2005, 06:57 AM
I get an error telling me to look in the log. The log says this (below). The libswt so file is in one of the jar files that installed with eclipse, so I don't know what the problem is.

!SESSION 2005-07-20 12:09:22.732 -----------------------------------------------eclipse.buildId=I20050401-1645
java.version=1.5.0_04
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Command-line arguments: -os linux -ws gtk -arch x86_64 -data /root/workspace

!ENTRY org.eclipse.osgi 2005-07-20 12:09:22.733
!MESSAGE Application error
!STACK 1
java.lang.UnsatisfiedLinkError: /usr/share/eclipse/configuration/org.eclipse.osgi/bundles/75/1/.cp/os/linux/x86_64/libswt-pi-gtk-3128.so: /usr/share/eclipse/configuration/org.eclipse.osgi/bundles/75/1/.cp/os/linux/x86_64/libswt-pi-gtk-3128.so: cannot open shared object file: No such file or directory
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(Unknown Source)
at java.lang.ClassLoader.loadLibrary(Unknown Source)
at java.lang.Runtime.loadLibrary0(Unknown Source)
at java.lang.System.loadLibrary(Unknown Source)
at org.eclipse.swt.internal.Library.loadLibrary(Libra ry.java:123)
at org.eclipse.swt.internal.gtk.OS.<clinit>(OS.java:19)
at org.eclipse.swt.internal.Converter.wcsToMbcs(Conve rter.java:63)
at org.eclipse.swt.internal.Converter.wcsToMbcs(Conve rter.java:54)
at org.eclipse.swt.widgets.Display.<clinit>(Display.java:122)
at org.eclipse.ui.internal.Workbench.createDisplay(Wo rkbench.java:320)
at org.eclipse.ui.PlatformUI.createDisplay(PlatformUI .java:155)
at org.eclipse.ui.internal.ide.IDEApplication.createD isplay(IDEApplication.java:128)
at org.eclipse.ui.internal.ide.IDEApplication.run(IDE Application.java:79)
at org.eclipse.core.internal.runtime.PlatformActivato r$1.run(PlatformActivator.java:228)
at org.eclipse.core.runtime.adaptor.EclipseStarter.ru n(EclipseStarter.java:344)
at org.eclipse.core.runtime.adaptor.EclipseStarter.ru n(EclipseStarter.java:156)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknow n Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Un known Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.core.launcher.Main.invokeFramework(Mai n.java:315)
at org.eclipse.core.launcher.Main.basicRun(Main.java: 268)
at org.eclipse.core.launcher.Main.run(Main.java:942)
at org.eclipse.core.launcher.Main.main(Main.java:926)

Oetzi
20th July 2005, 01:53 PM
If I remember right I got the same error some time ago.

You should check if you use a 64Bit Eclipse with a 64Bit virtual machine.
I don't know exactly how I solved this, but if I remember right, the problem was an incompatiblity between 32 and 64bit versions of Eclipse and the Java VM.

Mudhoney
20th July 2005, 11:33 PM
Hm thanks. I am definitely using 64 bit eclipse but I think I might have installed the 32 bit Java because of problems with the 64 bit version. I might try again.