PDA

View Full Version : ZSNES, Staticy Sound, FC4 Final


jlacroix
15th June 2005, 04:51 AM
Hello everyone, I am desperately trying to figure this out, I never had this problem with any other Fedora version, or any Linux distro for that matter. I am using FC4 final, and ZSNES has really staticy sound, its very annoying. I use Gnome, don't know if that has anything to do with it. Any ideas?

hlfmanhlfamzng
17th June 2005, 08:26 PM
I was experiencing the old sound delay problem with zsnes in FC4, this thread might help you out.

http://forums.fedoraforum.org/forum/showthread.php?t=18916&highlight=zsnes+delay

*EDIT* I get staticy sound too if logged in as a user. As root things sound normal. This happens in both gnome and kde.

*EDIT2* Ah hah.... Use this forum thread

http://www.fedoraforum.org/forum/showthread.php?t=18522

You'll need to create an .asoundrc file for your specific sound chip.(in my case, I have an nvidia nforce2) This isn't a perfect fix, as I can still hear static but chances are I just need to refine the asoundrc file. It also could be because I have my computer hooked up to my yamaha reciever and sounds are very pronounced. On pc speakers you might not notice it. Just a thought....................

The ALSA howto here http://fedoranews.org/contributors/andre_costa/alsa/ should be a big help to you, as will be ALSA's own website.

When you first implement your asoundrc file you will need to fully reboot your machine otherwise sound will not work for that user/profile.

Hopefully somebody else will have input when it comes to asoundrc tuning.

Good luck

hlfmanhlfamzng
17th June 2005, 10:34 PM
.asoundrc file is the key. Once you have your asoundrc file in place and you have rebooted your machine you need to find out the sampling rate at which your soundcard will accept.

I still haven't figured out the relationship between root and user logins yet. zsnes works fine at 48000khz under root, yet I can't get it to work any further than 32000 under user. I find 32000 acceptable, if you don't feel free to research it further, or somebody else might have more knowledge than I.

Anyways, here's what I did.

pcm.nforce-hw {
type hw
card 0
}
pcm.!default {
type plug
slave.pcm "nforce"
}
pcm.nforce {
type dmix
ipc_key 1234
slave {
pcm "hw:0,0"
period_time 0
period_size 1024
buffer_size 8192
rate 32000
}
bindings {
0 0
1 1
}
}
ctl.nforce-hw {
type hw
card 0
}

That's my .asoundrc file. If you'll note the "rate 32000" command in the middle, all I did was start at 48000khz while in the user account and work my way down with the corresponding numbers in zsnes. What I mean is this...... Setting my asoundrc and zsnes at 48000khz sounded HORRIBLE. Setting both at 44100 wasn't all that bad.(see post 2) Going to 32000 in both made it crystal clear. Mixing the numbers didn't seem to affect anything.

Hope that helps, please let us know if it solved the problem or if you need more assistance.

-Half

jlacroix
18th June 2005, 07:52 AM
This is the best darn message board in the world! The asound thing really helped, you guys saved my experience with FC4. Aside from one other minor glitch (whole other topic) everything rocks now!!!

samwyse
18th June 2005, 08:29 PM
I get this problem too in several games since I upgraded from FC3 to FC4. This looks like something Fedora should fix :confused:

jlacroix
18th June 2005, 08:43 PM
I agree. FC4 is a big dissapointment so far. There are an extreme amount of bugs in it. I am suprised they consider this stable.

I learned my lesson by reporting bugs, as the folks on Bugzilla just say everything isn't a Fedora problem when it is.

hlfmanhlfamzng
19th June 2005, 12:17 AM
jlacroix, glad I(we :p ) could help you out.

Samwyse.......

Honestly, I was disappointed at first with FC4 mainly because of the early boot "feature".(I created a post, if you care to see what I mean.) Other than that, I've found it to be mainly a great upgrade from 3. Everything seems more smooth, KDE(which is what I use) does load faster, and games are faster because of the updated DRI drivers for my firegl8800.

As far as multimedia goes, I wouldn't have high hopes whenever a new version is released. Maybe it's just me, but I have to fix something MM related every time I upgrade my comp to the latest FC. But that's coming from a linux user who hasn't used many other distros. I honestly don't mind it. I fix the bugs and move on. Or file a bug report and move on.

I'm curious sam.... did you try to implement an .asoundrc file on your computer....... if yes, did it change/help at all?

samwyse
19th June 2005, 12:40 AM
I'm curious sam.... did you try to implement an .asoundrc file on your computer....... if yes, did it change/help at all?
I'm not exactly sure what to do. The model of my card is ES1371 [AudioPCI-97] and the module is snd-ens1371 (system-config-soundcard). Should I replace all nforce with the module name, or? :confused: This is the only real problem I've had with FC4 so I wouldn't call it a big dissapointment.

hlfmanhlfamzng
22nd June 2005, 03:11 PM
Sam....

This guy has the same sound card as you, his asoundrc might help.
http://www.rockhopper.dk/linux/hardware/workstation.html

pcm.!default {
type plug
slave.pcm "dmixer"
}

pcm.dsp0 {
type plug
slave.pcm "dmixer"
}

pcm.dmixer {
type dmix
ipc_key 1024
slave {
pcm "hw:0,0"
period_time 0
period_size 1024
buffer_size 8192
#periods 128
rate 44100
}
bindings {
0 0
1 1
}
}

ctl.mixer0 {
type hw
card 0
}

The alsa page for your card.
http://www.alsa-project.org/alsa-doc/doc-php/template.php?company=Ensoniq&card=.&chip=ES1371%2C+ES1372%2C+ES1373%2C+CT5880+%28ES137 3%29&module=ens1371

samwyse
4th July 2005, 02:47 PM
^ Thanks, that worked perfectly.

Kharagpur Travel Photos on Instagram - Lilienthal - Martina Franca Photos