View Full Version : yum udate problem

4th May 2005, 12:19 PM
When in the process of dowloading during a yum update the following error shows up and stops my download.
Downloading Packages:
warning: rpmts_HdrFromFdno: Header V3 DSA signature: NOKEY, key ID 30c9ecf8
public key not available for desktop-backgrounds-basic-2.0-29.noarch.rpm

4th May 2005, 12:23 PM
Download the yum.conf from here (http://www.fedorafaq.org) and then do as stated here (http://www.fedorafaq.org/#gpgsig). That should resolve your problem. :)

4th May 2005, 12:36 PM
Download the yum.conf from here (http://www.fedorafaq.org) and then do as stated here (http://www.fedorafaq.org/#gpgsig). That should resolve your problem. :)

This won't work for FC4.

4th May 2005, 12:43 PM
And to boot watch which Repositories you use as well

4th May 2005, 12:46 PM
Well does someone have a fix for this?

4th May 2005, 12:54 PM
have you tried up2date first ?
what is in your yum.conf ? with out having FC4 I can't tell you what should be in there
if the system is "Stock" meaning you haven't messed with yum config files at all you should be fine
you can import the local key
look in /usr/share/doc/fedora-release or fedora-test4 for RPM-GPG-KEY*

once you locate it
rpm --import PATH_TO_KEY_/RPM-GPG-KEY*

4th May 2005, 01:16 PM
error: /usr/share/doc/fedora-release-3.91/rpm-gpg-key*: import read failed(-1).
[root@lx20 fedora-release-3.91]#

4th May 2005, 01:18 PM
you just install FC4 Test2 ?
do you do it as root ? Gues so

This is a mailing list of test users

4th May 2005, 01:22 PM
in that folder where you found your key is there a
RPM-GPG-KEY-fedora-test ?

if so try importing that one

4th May 2005, 01:56 PM
now we have a new error after importing:

Downloading Packages:
unsigned package kudzu-1.1.116-1.i386.rpm
[root@lx20 fedora-release-3.91]#

4th May 2005, 02:07 PM
try this
rpm --import http://download.fedora.redhat.com/pub/fedora/linux/core/test/3.91/i386/os/RPM-GPG-KEY

4th May 2005, 02:16 PM
No, lack of a key is not the problem. The problem is that sometimes in the development repo, packages are not signed at all. Depending on what yum is configured to do about that, it can error out as it is with you.

edit /etc/yum.conf and set gpgcheck=0

if that doesn't work (IIRC it is enough... but) then find your fedora development repo settings (likely in something like /etc/yum.repos.d/fedora-development.repo) and set gpgcheck=0 in there too.

Then retry your yum job.

4th May 2005, 02:23 PM
did what you said and this is what I get
Install 8 Package(s)
Update 318 Package(s)
Remove 0 Package(s)
Total download size: 533 M
Is this ok [y/N]: y
Downloading Packages:
unsigned package kudzu-1.1.116-1.i386.rpm
[root@lx20 carneyc]#

at this point the show stops

4th May 2005, 02:35 PM
Did you find the development repo settings too and change to gpgcheck=0 there too?

4th May 2005, 03:33 PM
Sorry Andy I was working another angle before I read your post. I changed the value to 0, it now appears to be updating. I will keep youposted when it finishes. :)
Thanks Chris

4th May 2005, 05:24 PM
Just a quick note to all that helped, Thank you, the system is now fully updated and running. Andy, changing the first value for yum.conf to = 0 did the trick
again thanks to all